ΒΟΗΘΕΙΑ - ATI RADEON DRIVERS

tom1972 | Τρί, 03/06/2012 - 13:24 | 1' | 74

Μόλις εγκατέστησα opensuse 12.1
Δεν μπορώ να εγκαταστήσω ati drivers radeon hd 6670. Για σύστημα 64 bit.
Η αλήθεια είναι ότι εγκατέστησα "κάτι" (AMD CATALIST), αλλά δεν μπορώ να ενεργοποιήσω τους drivers.
Κάποιος μπορεί να μου πει τι να κάνω;
Στο laptop έχω nvidia και το είχα καταφέρει εύκολα.
Τώτα από ati, έχω πελαγώσει. Ευχαριστώ εκ των προτέρων !!!

Φόρουμ
Δώσε αστέρια!

MO: 1 (ψήφοι: 1)

Σχόλια

Αν είσαι σε gnome να ξέρεις οτί θα έχεις πρόβλημα με ATI γιατί δεν υποστηρίζονται ακόμα! Σε KDE ή Unity δεν θα έχεις πρόβλημα!

ΤΙι εννοεις φιλε gasdim ? Εχουν σχεση οι drivers της ΑΤΙ (ή της nvidia) με τα DE ?

     τα  64-bit  ,  κατά  τη γνώμη  μου , έχουν  τεράστιο  πρόβλημα στο  θέμα  linux-video-driver ,  τόσο  για  NVIDIA   όσο  &  για  AMD. Aυτός είναι  & ο λόγος  που  ΟΛΕΣ  οι  διανομές  που  έχω  είναι   στα  32-bit  ( αν και  έχω  AMD  64μπιτη  CPU  &  4  GB RAM ).  H  λύση  είναι  ΜΙΑ. Ξανά  εγκατάσταση  με  την  32-bit  version , για να  μην  υπάρχει  πρόβλημα.

Αλλά πριν το διαγράψεις , δοκίμασε να εγκαταστήσεις πρώτα τα πακέτα kernel-devel , kernel-source , kernel-syms και patch. Είναι προαπαιτούμενα για να δουλέψει σωστά ο catalyst , ακόμα καί ο NVIDIA. Πάντως αυτό σίγουρα ισχύει στα 32-bit , οπότε λογικά & για τα 64-bit θα είναι το ίδιο.
Και τώρα ένα ωραίο τέστ για να δείς αν ο driver δουλεύει σωστά. Δώσε ένα
fgl_glxgears

και περίμενε να δείς έναν κύβο με γρανάζια να περιστρέφονται σε όλες τις επιφάνειές του. Αν ΔΕΝ τον δείς , να ξέρεις , ο driver απέτυχε να δουλέψει.
Πάντα να κάνεις το ίδιο τέστ , κάθε φορά που είσαι σε σύστημα με AMD graphics.

# zypper in kernel-devel kernel-source kernel-syms patch

θα δώσεις , για να αποκτήσεις τα πακέτα για το σύστημά σου , ουρανοκατέβατα. & ΔΕΝ πιστεύω να ΜΗΝ κατεβάζεις & αναβαθμίζεις τα ΠΑΝΤΑ μέσω τερματικού ? ! !
Αλλί , αλλί & ...τρισαλλί , αλλοιώς.

& τώρα , μπορώ να γράψω... ποιός έχει ...εντρυφήσει πεισσότερο στον ΤUX από εμένα ? ? ? Φέρτε μου ..διπλώματα , φέρτε και ..παπλώματα , πιστοποιήσεις , τίτλους & σπουδές , όλες οι ''Δόξες'' ΔΕΝ μου είναι .......αρκετές ! ! ! ! ! ! ! ! !

( μια διασκευή του σύγχρονου Dr.Faust , στην εποχή του Linux.)

όταν κατεβάσεις τον catalyst driver με τον τρόπο που ξέρεις , υποθέτω με ένα
# zypper in amd-catalyst amdcccle ή κάτι τέτοιο τέλος πάντων , μετά δίνεις υποχρεωτικά

# aticonfig --initial , για να δημιουργηθεί το αρχείο /etc/X11/xorg.conf & κατόπιν δίνεις

# init 6 ( δλδ , # reboot )

( στο δικό μου openSuse 12.1 32-bit με LXDE , τρέχω τον official AMD 12.1 (8.93) linux-video-driver , από το site της AMD κατεβασμένο).

τέλος , πρόσθεσε και την παράμετρο nomodeset στο boot entry για το SUSE , δλδ , διόρθωσε στο αρχείο /boot/grub/menu.lst τη γραμμή για τον kernel /boot/kernel-3.1.9-1.4 root=/dev/sdX ro nomodeset splash=verbose vga=0x31a

Περίμενα από σενα φιλε να με βοηθήσεις !! Δυστυχώς δεν δουλεψαν τα παραπάνω.
Παρόλο που έχω κάτι σαν amd-catalist εγκατεστημένο, το aticonfig --initial, μου έδωσε τα παρακάτω

Found fglrx primary device section
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-5

Δεν ξέρω αν το έχω εγκαταστήσει καλά. Αυτό που κατέβασα είναι : "amd-driver-installer-12-1-x86.x86_64.run"
Το έτρεξα κατευθείαν από την κονσόλα, και έγινε εγκατάσταση.
Τι λες παίχτη, τι χαζομάρα έκανα;

μάλλον έγιναν όλα έτσι όπως έπρεπε να γίνουν. Δυστυχώς όμως , θεωρώ σχεδόν ΒΕΒΑΙΟ πως ο amd-driver-installer-12.1 ΔΕΝ μπορεί να δουλέψει στα 64-bit. ΜΗΝ απογοητευτείς όμως καθόλου , γιατί ΕΓΓΥΗΜΕΝΑ ούτε & ο αντίστοιχος 64-bitος NVIDIA driver μπορεί να δουλέψει στο Linux. Είχα κάνει τίς άπειρες δοκιμές να το πετύχω για τα 64-bit όταν είχα στο σύστημα NVIDIA , που πλέον είμαι απόλυτα βέβαιος πως ΔΕΝ γίνεται να δουλέψει. Αν το ήξερα ότι θα το επιχειρούσες κάτι τέτοιο , θα σε απέτρεπα αλλά μου λείπει μια ...γυάλινη σφαίρα ! !
Τέσπα , νομίζω πως το τέστ fgl_glxgears δουλεύει μόνο στα 32-bit & αυτό είναι απόδειξη ότι με τα 64-bit υπάρχει ακόμα ΤΕΡΑΣΤΙΟ πρόβλημα. Το μήνυμα που έδωσες από τερματικό είναι ολόσωστο & αναμενόμενο , ΔΕΝ φταίει κάτι , ούτε & ο driver , απλά φταίνε τα 64-bit.
Περισσότερο δεν μπορώ να φανώ χρήσιμος στο πρόβλημα , καθώς για οτιδήποτε ποστάρω αναφέρομαι ΠΑΝΤΑ για τα 32-bit.
Σίγουρα κάνε απεγκατάσταση του driver & reboot , δλδ

# amd-driver-installer-12-1-x86.x86_64.run --uninstall

& επιχείρησε να εγκαταστήσεις τον amd-catalyst driver από την ίδια την διανομή.

Υ.Γ.- έλεγξε πρώτα ότι έχεις & τα πακέτα gcc & make , δλδ
~ gcc --version και
~ make --version πριν απεγκαταστήσεις οριστικά τον amd-driver-12.1 & ότι κατέβασες τα προαπαιτούμενα πακέτα.

& Δοκίμασε με την 32-bit version.

Φίλε με το
"επιχείρησε να εγκαταστήσεις τον amd-catalyst driver από την ίδια την διανομή"
τι εννοείς;
Και κάτι αλλο φταιει το 64 bit linux, ή ο 64 bit catalyst;

Αδελφέ σου γράφω από το laptop.
Μετά από την απεγκατάσταση του πακέτου "amd-driver-installer-12-1-x86.x86_64.run --uninstall", με reboot, με έβγαλε σε κονσόλα, και πάπαλα το gui... στο desktop

Μάλλον πάω για σβήσιμο. Να ξέρεις φιλε ότι ευχαριστώ για το χρόνο σου και για τη διάθεση να με βοηθήσεις !!!
Μάλλον θα φταίει το 64bit. Mε εκτίμηση tomkat !!!

zenwalk05]& τώρα , μπορώ να γράψω... ποιός έχει ...εντρυφήσει πεισσότερο στον ΤUX από εμένα ? ? ? Φέρτε μου ..διπλώματα , φέρτε και ..παπλώματα , πιστοποιήσεις , τίτλους & σπουδές , όλες οι ''Δόξες'' ΔΕΝ μου είναι .......αρκετές ! ! ! ! ! ! ! ! !
( μια διασκευή του σύγχρονου Dr.Faust , στην εποχή του Linux.)





εγώ ψηφίζω zenwalk ....τέλος ....
είναι η ανερχόμενη δύναμη ....
φίλε σε παραδέχομαι για κουράγιο σου να ασχολείσαι με το αντικείμενο .... 

Έκανα ένα μαγικό (από την κονσόλα εγκατέστησα ξανά αυτό που είχα απεγκαταστήσει και ξαναμπήκα στο σύστημα).
Πριν το πάθω αυτό είχα σκοπό να γράψω στο zenwalk, ότι το αρχειο "amd-ati-fglx64.ymp", που μου συνέστησες dsyrmalis, το είχα εγκαταστήσει πιο πριν (είχα κάνει πολλά τρελά....), αλλά δεν έκανε τίποτε !!!!

Μάλιστα για να εγκατασταθεί έκανε κανα 15-20 λεπτο ....
Πίστεψα ότι τα είχα καταφέρει αλλά δεν απέδωσε !!!

Έκανες προηγουμένως αυτά;

Before trying to install the fglrx package disable free radeon driver.

  • On the boot line add : radeon.modeset=0 blacklist=radeon 3
  • You will boot without xorg launched.
  • Recreate an initrd without the radeon loaded. Simply launch as
    root mkinitrd when it is done then proceed with one of the two method
    GUI or command line.

Πάντως αν δεν παίζεις παιχνίδια, δεν υπάρχει λόγος να βάλεις τον κλειστό Driver. Χρησιμοποιώ εδώ και χρόνα 64 bit εκδόσεις και ποτέ δεν είχα πρόβλημα. Επίσης, πάντα πρέπει να χρησιμοποιούμε τους πακεταρισμένους drivers της διανομής μας και όχι αυτούς απο το site της εταιρείας. Αυτά τα πακέτα θα πρέπει να είναι η τελευταία μας λύση και αν θυμάμαι καλά η εγκατάσταση τους γίνεται μόνο χωρίς Χ και φυσικά σε γραμμή εντολών. (Συνήθως βγαίνεις με Control Alt F3.)
 

Η εγκατάσταση γίνεται το ίδιο καλά & από το GUI & ειδικά για τον κλειστό AMD driver , αλλά ΠΑΝΤΑ μιλώντας για τα 32-bit . Για τα 64 ΞΕΧΑΣΕ ΤΟ ! ! ποτέ ΜΗΝ το επιχειρήσεις.
Για τον NVIDIA δινεις

# sh nvidia-linux-driver-295.20.x86.run --no-x-check

για να μην έχεις πρόβλημα , όταν είσαι στο GUI , ενώ κανονικά θα έπρεπε να είμαστε σε κονσόλα στο runlevel 3 , αν θέλαμε να είμαστε ακόμα πιό σωστοί.
Κατόπιν , δίνεις
# nvidia-xconfig & μετά reboot τον X server.

& τον ΝVIDIA driver ποτέ στα 64-bit , γιατί ΔΕΝ θα δουλέψει , μόνο στα 32 λειτουργεί & αυτός σωστά.

Πάντως , κριτήριο για το αν δουλεύει ο AMD catalyst driver είναι να μπορεί να εκτελέσει την εντολή
fgl_glxgears. Για τα 64-bit προσωπικά ΔΕΝ πιστεύω ότι αυτό είναι εφικτό να γίνει. Αν κάποιος το έχει πετύχει να μας γράψει κάτι.

Αν ΔΕΝ μείνεις ευχαριστημένος με τον driver , η λύση είναι τα 32-bit & τα συνιστώ ΑΝΕΠΙΦΥΛΑΚΤΑ.
Μπράβο για την εξυπνη ιδέα να ξαναεγκαταστήσεις τον driver από terminal για να ξαναμπείς στο GUI.
Δεσμεύομαι να σε κάνω γνώστη κάθε μου ''μικρής'' δεξιότητας πάνω στο openSuse & γενικότερα στο LINUX. To βρίσκω πάρα πολύ διασκεδαστικό σε σύντομο διάστημα & μέσα από τα σχόλια αυτού του φόρουμ , να ΜΗΝ έχω να σου γράψω πιά τίποτε το καινούριο. ! ! ! :-)

ένα nomodeset στο grub boot entry αρκεί για να φορτωθεί ο σωστός driver (& oxi o free radeon driver) , αλλά πάντα για τα 32-bit μιλώντας , αδερφέ μου Τομκάτ , τα 64 έχουν ένα ''μυστήριο'' γύρω από το θέμα video-driver. Σίγουρα φταίει ο X server που ακόμα είναι βασισμένος πάνω στην 32-μπιτη αρχιτεκτονική. Χρειάζεται γράψιμο από την αρχή & όλοι οι developers μάλλον συμφωνούν σε αυτό.

@zenwalk
Ναι χάρηκα πολύ που κατάφερα να ξαναμπώ στο gui. Ηταν μια φλασιά που είχα. Δέχομαι να το φορμάρω, αλλά όχι και ταπεινωμένος (εκτός gui). Ευχαριστώ για τις προσπάθειες να γίνω εξπερ του opensuse....

@dsyrmalis
Θα προσπαθήσω αργότερα για να ακολουθήσω αυστηρά τα βήματα που μου είπες,...
Αν δε τα καταφέρω... θα δω. Πάντως θα το παλέψω !!!
Δεν γνώριζα για τη διαφορά των κλειστών και ανοικτών drivers.
Προτιμώ τη χρήση αυτων της διανομής.

@ και  στους 2
Ευχαριστώ για την βοήθεια. Ασχολούμουν 3 μήνες με το opensuse. Έχω πολύ δρόμο ακόμη.

@ dsyrmalis
Αλήθεια τώρα που κάνω αυτά που είπες, το πρώτο το έκανα
Τα άλλα 2 μου φαίνονται σαν ακαταλαβίστικα....
δηλ αυτά...

  • You will boot without xorg launched.(Αυτό πως γίνεται;)
  • Recreate an initrd without the radeon loaded. Simply launch as

    root mkinitrd when it is done then proceed with one of the two method

    GUI or command line.
    (Kι aυτό πάλι;)

Είμαι άσχετος από τις λεπτομέριες αυτές.......

      Aν επιμείνεις στα  64  ΔΕΝ  θα καταφέρεις να έχεις τον catalyst σε λειτουργία ,  γιατί  απλά ΔΕΝ θα  λειτουργεί το  ίδιο καλά  όσο με τα 32-bit.  Απόδειξη  το fgl_glxgears.
       Τα  ερωτήματα  που  θέτεις παραπάνω ,  είναι  &  δικά  μου & αδυνατώ  να  εννοήσω..
  Όμως  , η  λύση  είναι πολύ απλή.. χωρίς  σωστά ρυθμισμένο video driver  , ΔΕΝ  υπάρχει λόγος να  τρέχεις τα 64 ,  για  χρήση  home computing . &  είναι μάλλον ΑΔΥΝΑΤΟΝ   να  τρέχεις τα 64  με  τον  video-driver   άψογα  σεταρισμένο , όπως με τα 32.

   Όταν  γυρίσεις στα 32 , τότε  μάλλον  θα τα  καταφέρεις καλύτερα  με  τον κλειστό AMD  όπως  δουλεύω & γώ  σε  ΟΛΕΣ  τις  διανομές &  ΠΟΤΕ ΔΕΝ  είχα πρόβλημα.

  Επιμένω στη  λύση  του  κλειστού driver της  ΑΜD  από το site , όπως  το  ίδιο έκανα &  με τον  αντίστοιχο κλειστό  driver  της  NVIDIA ,  γιατί  έχει   standard  καλύτερη  απόδοση , είναι πάντα ο  πιό ενημερωμένος  &  η  εγκατάστασή  του  από  τερματικό  είναι πολύ  απλή  &  γρήγορη  ,  ενώ  η  ''αίσθηση''   που  σου  δίνει  η όλη  διαδικασία είναι ίδια  με  αυτή  του  ''σκληροπυρηνικού''  λινουξά ,  που  ΔΕΝ  συμβιβάζεται  με  την  ''έτοιμη'' λύση   του  ''αποθετηρίου'' ,  που  θυμίζει  ..παράθυρα.Cool
   Άκουσέ  με  & δεν θα  πέσεις έξω.

Προσπαθούσα να το παλέψω (μαχητής σαν το JACKIE CHAN βλέπεις). Αλλά σε μισή ώρα κατεβαίνει το 32μπιτο.
Όσο για τους κλειστούς, έχω κακή εμπειρία από το ubuntu.
Κάθε φορά που τον εγκαθιστούσα χειροκίνητα, με το που έκανα update από synaptic, στο reboot, με άφηνε έξω από το gui......
Tην εποχή εκείνη ήμουν τελείως αρχάριος και δεν μου έρχονταν φλασιές όπως πριν. Πάθαινα σοκ!! Πήγαινα κατευθείαν για φορμάτ !
Ευχαριστώ για τις συμβουλές.....

μια χαρά συμπεριφέρεται & το ubuntu & οι υπόλοιπες διανομές ( εκτός από Arch-based που θέλουν υποχρεωτικά τον catalyst της ίδιας της διανομής).
Το μυστικό για ΟΛΕΣ τις διανομές , είναι όταν έχουμε τους κλειστούς drivers της AMD ή της NVIDIA να έχουμε ΠΑΝΤΑ την παράμετρο nomodeset στο grub boot entry , ΥΠΟΧΡΕΩΤΙΚΩΣ , αλλοιώς στο επόμενο reboot θα μένεις χωρίς το GUI.. & φαντάσου τώρα τί γνώμη θα σχηματίσει ο ..αρχάριος για το Linux..Αυτή η γνώση θα έπρεπε να υπάρχει σε κάθε τεύχος του περιοδικού , σαν οδηγίες , αλλά άντε να μάθεις στον αρχάριο πώς να διορθώνει το grub.cfg ή το menu.lst με τον nano..
Πάντα τον κλειστό driver έχω σε όλες τις διανομές & μάλλιστα της AMD από το site , αλλά τρέχω μόνο στα 32-bit. & αν σε μια διανομή δεν το καταφέρνω , δεν ασχολούμαι ξανά. Εξαίρεση το Nosonja-Arch , στο οποίο αναγκαστικά έχω τον catalyst από το αποθετήριο του ARCH & δουλεύει τέλεια. Σε όλα τα υπόλοιπα αξίζει να δοκιμάσεις πρώτα με τον κλειστό original AMD driver.

Σκέψου τι σοκ πήρα σαν αρχάριος την πρώτη φορά, όταν βγήκα από το gui !!
Θα σου εκμνηστηρευτώ, ότι όταν πρωτογνώρισα το ubuntu, επειδή περίμενα να έχει τη φιλοσοφία των windows, το είχα απεγκαταστήσει 5 φορές (αν θυμάμαι) ορκισμένος να μην το ξαναβάλω ποτέ, και τα επόμενα δεπτερόλεπτα, το ξανάβαζα, αρνούμενος να το βάλω κάτω, αλλά και αποφασισμένος να γλυτώσω από την κατάρα του φρικιαστικού malware που κυκλοφορεί στο internet (με τις ευλογίες της microsoft).
Γι'αυτό και είμαι υπομονετικός με δύσπιστους αρχάριους, πράγμα που με ανάγκασε να γράψω και το
ΟΔΗΓΙΕΣ ΓΙΑ ΑΡΧΑΡΙΟΥΣ
ΣΤΟ LINUX

Τώρα εγκαθιστώ το 32bit-ιτο. Θα μάθεις για την πρόοδό μου δάσκαλε !!!! 

  μερικές απλές  συμβουλές είναι για να  μπορέσεις να  δουλέψεις σωστά με το Linux.
   Μη  ξεχάσεις  όλα τα  προαπαιτούμενα πακέτα  kernel-devel , source κτλ &  τα  gcc  & make .
   &  το nomodeset  στο grub entry , αφού  πρώτα  εγκαταστήσεις τον  κλειστό  driver, δλδ   αφού δώσεις 
   #  aticonfig --initial   ,  αμέσως  μετά  διορθώνεις το  /boot/grub/menu.lst      και  ύστερα  δίνεις  # reboot.

tomkat]@ dsyrmalis
Αλήθεια τώρα που κάνω αυτά που είπες, το πρώτο το έκανα
Τα άλλα 2 μου φαίνονται σαν ακαταλαβίστικα....
δηλ αυτά...

  • You will boot without xorg launched.(Αυτό πως γίνεται;)
  • Recreate an initrd without the radeon loaded. Simply launch as

    root mkinitrd when it is done then proceed with one of the two method

    GUI or command line.
    (Kι aυτό πάλι;)

Είμαι άσχετος από τις λεπτομέριες αυτές.......



Το πρώτο στο γράφει ήδη ο Διονύσης στο #20 <<Συνήθως βγαίνεις με Control Alt F3>>. Για το δεύτερο ερώτημα  το γράφει στην ίδια παράγραφο <<Simply launch as root mkinitrd>>. Για καλό και για κακό περίμενε και απάντηση από το Διονύση γιατί ίσως χρειαστεί να προσθέσεις κάποια παραμετρο.

      όταν   πετύχει  η  όλη  διαδικασία  δώσε   &  ένα   fgl_glxgears  ,  για  να  σιγουρευτείς  ότι  όλα  είναι  OK  από  θέμα  catalyst  video-driver.  Μερικές  άλλες  εντολές σχετικές  είναι  &  οι   fglrxinfo   και 

      lspci -knn | grep  VGA -A3

Επειδή υπάρχει έλλειψη χρόνου, λίγο υπομονή. Με κάνατε, ειδικά ο zenwalk :) να εγκαταστήσω το OpenSUSE. Αν και είναι εξαιρετική διανομή, ειλικρινά για άλλη μια φορά χαίρομαι που προτιμώ απλές διανομές τύπου Slackware, Salix, Arch, Debian κλπ. Έπεσα κάποιο σε bug που προκύπτει μόνο αν γίνει εγκατάσταση απο το Live CD και άντε τώρα να ανακαλύψω γιατί δεν αναβαθμίζει το Zypper και να καταλάβω αν το πρόβλημα οφείλεται:

  • Στο Zypper
  • Στο Packagekit
  • Στο Yast
  • Όπου αλλού...

Προς το παρόν κάνω kill μέσα απο το τερματικό τη διεργασία Package Kit γιατί μέσα απο το Gui δεν γίνεται... Μέχρι και το IPV6 έκανα disable αλλά τίποτα... Τα updates απο το Yast κατεβαίνουν με ρυθμούς χελώνας και κάθε τόσο θέλει retry...
 

       για  τον  original AMD 8.93 (12.1)  driver ,  όταν  μας  βγάζει  στο dialog box  του   amd-panel  ,  επιλέγουμε

      1-  install  8.93 catalyst  driver  on  Xorg 6.9 or  above  ( δλδ , όχι την  επιλογή   ...for  specific  distribution )

      2-Choose mode of installation   διαλέγουμε   Automatic (Recommended) &  όχι  expert.

Παιδιά έκανα ότι είπατε με σύστημα 32 bit, αλλά τίποτε .....

@ zenwalk
Δεν παρέλειψα τίποτε από αυτά που μου είπες
nomodeset, τα extra πακέτα που μου είπες (patch, ....), aticonfig --initial, τίποτε, τίποτε, ....
Κοντεύω να κλάψω....

@dsyrmalis
δοκίμασα με τη σειρά όλες τις μεθόδους από τη σελίδα που μου είπες.
Καμία δε λειτούργησε.

Μήπως φταίει οτι η κάρτα μου είναι τύπου HD 6670

Στο laptop έχω nvidia, ήταν εύκολη υπόθεση τότε, κι επειδή δεν μου είχε ξανατύχει τόση ευκολία κόλησα με το opensuse.
Καμιά συμβουλή; ίσως να είμαι πολύ γκαντέμης

    η  κάρτα  HD 6670  είναι  ιδανική  ,  ΔΕΝ  φταίει σε τίποτα. Η δική  μου ,  μια HD 4350 με  512 MB  που  είναι  &  πιό  παλιά  & χαμηλότερων  επιδόσεων  δεν βγάζει  πρόβλημα. Απ  '  ό, τι  φαίνεται .  όλα  έγιναν  όπως  θα  έπρεπε , δεν  παρέλειψες  τίποτα ,  όμως  το  πρόβλημα  ποιό  ακριβώς  είναι ?  Πάλι έμεινες  χωρίς  GUI ?
      Δοκίμασες  πρώτα  τις  δικές  μου  οδηγίες &  δεν  το  πέτυχες  ή  ανακάτεψες  οδηγίες  &  από  τους  ''δύο''  διαφορετικούς  τρόπους  εγκατάστασης &  έγινε  τώρα  στο  σύστημά  σου  ένα  ...ψιλομπέρδεμα ?
      Αν  κάνεις  απεγκατάσταση  του  AMD  driver & reboot  ,  ξαναμπαίνεις  στο  GUI ?  Για  ...διαφώτισέ  μας  λίγο ...

Σαν τελευταία κινηση κατέβασα τον driver απο το site της ατι, τον εγκατέστησα χωρίς gui (ctrl-alt-f3), έβαλα το nomodeset, και δεν boot-αρει καν. Νομίζω ότι είμαι μάγκας, και πείραξα το menu.lst με λάθος τρόπο, xvr;iw na krat;hsv αντίγραφο. Βλακείες δηλαδή...
Ξαναφορμάρω και θα δω....

Απλά όταν πνίγεσαι κάνεις κινήσεις φλασιές.
ή πετυχαίνουν ή γίνονται πατάτα. Για μένα μιλάω......

   ο   amd    γίνεται  εγκατάσταση  κανονικότατα  &  από  το  GUI.     Αν  δεν  σε  βγάζει  ούτε  στο  boot  menu  του  grub   ,  πώς  να  εκκινήσεις  άραγε ?  Κάτι  πήγε  στραβά . Με  τον  nano  ,  αφού  διορθώσεις το menu.lst  ,  δίνεις  Ctrl + O  &  μετά  enter  για  αποθήκευση  ,  και  ύστερα  βγαίνεις  με  Ctrl + X. Αυτό το  γνώριζες αδερφέ μου Τομκάτ  , έτσι δεν  είναι ?   Μην  απελπίζεσαι , θα  τη  βρείς  τη  λύση ,  είναι  σίγουρο.

Πάντως dsyrmalis, είπες ότι εγκατέστησες κι εσύ opensuse.....
Αν καταφέρεις κάτι chief, διαφώτισέ μας....
Στην νέα προσπάθεια που κάνω θα εφαρμόσω αυτά που μου έγραψε ο zenwalk (ξανά...).
Έχω γονατίσει όλο το site, και σας έχω όλους στο πόδι. Λυπάμαι .... που σας έχω πρήξει (έπρεπε να παραγγείλω ati...)

Λάθος τα παραπάνω. Είμαι σαστισμένος Δεν έπρεπε να παραγγείλω amd-ati κάρτα γραφικών...

     εφάρμοσε  κατά  γράμμα  τις  οδηγίες  &  θα   παίξει ο  driver.  Στην  χειρότερη  περίπτωση  θα  τα..παίξει Laughing!  !
 
  Αστειεύομαι , θα  πετύχει  σίγουρα ,  μόνο  μην ανακατέψεις τίποτε άλλο εκτός  από  ό,τι έγραψα.

Πρίν ξαναδοκιμάω αυτά που είπες είπα να δοκιμάσω ξανα αυτά που είπε ο dsyrmalis...
Εγκατέστησα πάλι από κονσόλα (εκτός gui) τον driver (με nomodeset), και ξανά δεν μπούταρε... Το περίμενα.
Αλλά η πονηρή αλεπού που είμαι ε'ιχα κρατήσει το menu.lst αντίγραφο και ναμαι στο σύστημα..... χεχε, λίγο για να γελάσω μετά από αυτά.....
Τώρα θα εφαρμόσω ότι ακριβώς μου είπες.. zenwalk....

     πρέπει  πρώτα  να  απεγκαταστήσεις ό,τι σχετικό  τον  fglrx driver από το repo  &  μετά  να  προχωρήσεις με  τις  δικές  μου  οδηγίες...  Πρίν  λίγο  μπήκα  στο  δικό μου  openSuse 12.1 LXDE  ,  για  να  πειραματιστώ  λίγο.
      Απεγκατέστησα  τον  AMD 8.93  driver  ,  έκανα  reboot  &  όλα  ΟΚ ,  μπήκα  κανονικά  στο GUI  , αλλά  δεν  είχα    3D  επιτάχυνση  γραφικών.  Ξανα  εγκατάσταση  τον  driver  , reboot  &  είχα  πάλι    3D rendering. Απόδειξη  ότι  οι  οδηγίες  μου  είναι  σωστές. Το  nomodeset  ανακάλυψα πως  ειδικά  στο  openSuse  ΔΕΝ  παίζει  κάποιο  ιδιαίτερο  ρόλο , είτε  υπάρχει ,  είτε  όχι, δλδ , ΔΕΝ επηρεάζει το σύστημα  στο θέμα  GUI , οπότε  μπορείς  να  το  αποφύγεις.
      Αν  ΔΕΝ  τα  καταφέρεις ,  είναι γιατί  έμπλεξαν  οι  2  οδηγίες μαζί  &  γίνεται  conflict.  Φορμάτ  &  3η  εγκατάσταση  ,  αλλά  αυτή  τη  φορά  μόνο  με  τις  οδηγίες  του  ...μπάρμπα-ζένγουωκ Cool !
      

Aπέτυχα και να τι έκανα.....


1.Πρώτα εγκατέστησα
# zypper in kernel-devel kernel-source kernel-syms patch

2.drag-drop στο konsole τον driver (επίσημος) a.run (του άλλαξα όνομα...)
Έκανα τις κινήσεις από το gui...

3. Αυτό ακριβώς που έγραψες...

   για  τον  original AMD 8.93 (12.1)  driver ,  όταν  μας  βγάζει  στο dialog
box του   amd-panel  ,  επιλέγουμε

      α. install  8.93 catalyst  driver  on  Xorg 6.9 or  above  ( δλδ , όχι
την  επιλογή   ...for  specific  distribution )

      β. Choose mode of installation   διαλέγουμε   Automatic (Recommended) &
όχι  expert.

3.#aticonfig --initial

4. reboot

ΥΣΤΕΡΟΓΡΑΦΟ
Κοίτα που το τοποθέτησα το "ro nomodeset", είναι σωστό; Γιατί μετά δεν μπούταρε
καθόλου, και μετά έριξα το αντίγραφο menu.lst.
Να σου εξομολογήθώ ότι το "ro nomodeset", το έβαλα πρίν από τα παραπάνω
βήματα....
Που έκανα λάθος αδελφέ;

title openSUSE 12.1
    root (hd0,2)
    kernel /boot/vmlinuz-3.1.0-1.2-default
root=/dev/disk/by-id/ata-WDC_WD3200AAKS-00L9A0_WD-WCAV27485759-part3 ro
nomodeset splash=silent quiet showopts vga=0x345
    initrd /boot/initrd-3.1.0-1.2-default

Τώρα που κοιτάω τα τελευταία σου λόγια, πως θα απεγκαταστήσω τελείως τον fglrx...

Δες τα βήματά μου και πες μου τι βλακεία έκανα δάσκαλε.....;;;; Σ'ευχαριστώ για την υπομονή.....

Τώρα που βλέπω στο yast, το fglrx δεν το έχω καθόλου μέσα.
Αφού δεν έκανα εγκατάσταση με τη μέθοδο των έτοιμων πακέτων του opensuse.....
Παίζει ρόλο όμως που έκανα πρώτα την ίδια διαδικασία εγκατάστασης από cltl+alt+f3; Δηλ εκτός gui;

  • εκτός gui : Αυτό όμως απέτυχε.... Μου είπε ότι η εγκατάσταση έγινε με σφάλματα....
  • εντός gui : Πέτυχε η εγκατάσταση , αλλά όπως σου έγραψα παραπάνω, δεν ενεργοποιήθηκε o ραδεον...

.....

@Tomcat catalyst και fglrx ΔΕΝ μπορούν να παίξουν μαζί. Όπως είπε και ο Zen απεγκατάσταση ό,τι σχετικό  με τον  fglrx driver και στη συνέχεια κάνε την διαδικασία που σου έχει περιγράψει.
Το βήμα 2 με το drag-drop προσωπικά δεν το κατάλαβα.

Εκανα grag-drop τον επίσημο catalyst-driver .run, εντος του παραθύρου του konsole..... και enter.
To έκανα για να τρέξω την εγκατάσταση του driver..., για να μη πληκτρολογώ.
Πάντως τώρα ξαναφορμάρω......

bat12]@Tomcat catalyst και fglrx ΔΕΝ μπορούν να παίξουν μαζί. Όπως είπε και ο Zen απεγκατάσταση ό,τι σχετικό  με τον  fglrx driver και στη συνέχεια κάνε την διαδικασία που σου έχει περιγράψει.
Το βήμα 2 με το drag-drop προσωπικά δεν το κατάλαβα.


 
Το τελευταίο μου ποστ δεν έχει νοηματική συνέχεια με το τελευταιο δικο σου γιατί έγραφα απαντώντας στα προηγούμενα ενώ είχες ήδη ποστάρει.
Το λοιπόν, από που εγκατέστησες πακέτα εφόσον δεν έκανες εγκατάσταση με τη μέθοδο των έτοιμων πακέτων του opensuse.. δηλ. όχι από τα αποθετήρια απ'ότι κατάλαβα;

Τώρα πάντως κατάλαβα αυτό που μου είπες, δεν το ήξερα......
"catalyst και fglrx ΔΕΝ μπορούν να παίξουν μαζί"

Στις πρώτες μου προσπάθειες είχα εγκαταστήσει από τα αποθετήρια.
Μετά σε αλλο φορματ αποτον επίσημο driver catalist, που είχα κατεβάσει....
Τώρα θα ξανακάνω καθαρά αυτά που μου είπε ο zenwalk