ΒΟΗΘΕΙΑ - ATI RADEON DRIVERS

tom1972 | Τρί, 03/06/2012 - 13:24 | 1' | 74

Μόλις εγκατέστησα opensuse 12.1
Δεν μπορώ να εγκαταστήσω ati drivers radeon hd 6670. Για σύστημα 64 bit.
Η αλήθεια είναι ότι εγκατέστησα "κάτι" (AMD CATALIST), αλλά δεν μπορώ να ενεργοποιήσω τους drivers.
Κάποιος μπορεί να μου πει τι να κάνω;
Στο laptop έχω nvidia και το είχα καταφέρει εύκολα.
Τώτα από ati, έχω πελαγώσει. Ευχαριστώ εκ των προτέρων !!!

Φόρουμ
Δώσε αστέρια!

MO: 1 (ψήφοι: 1)

Σχόλια

tomkat]Τώρα πάντως κατάλαβα αυτό που μου είπες, δεν το ήξερα......
"catalyst και fglrx ΔΕΝ μπορούν να παίξουν μαζί"


Στο λέει και ο zen πιο πάνω <<απεγκατάσταση ότι έχει σχέση με  fglrx>>. Πρώτα αυτό.
Το μόνο σίγουρο είναι ότι δεν φταίει η κάρτα σου. Απλώς ηρέμησε λίγο και ξεκαθάρισε κάποιες έννοιες (catalyst, fglrx) και μετά εφάρμοσε αυτά που λένε πιο πάνω. Πρόσεξε άλλη διαδικασία προτείνει ο zenwalk κι άλλη ο Διονύσης.

Και κάτι άλλο μετάαπόφορματ έχει προεγκατεστημενο τον driver: "xorg-x11-driver-video-nouveau".
Μήπως πρέπει να απεγκατασταθεί πρώτα και αυτός πριν εγκαταστήσω τον catalyst ;

Με καθαρό σύστημα (ΑΠΌ ΦΟΡΜΆΤ) έκανα τα ίδια βήματα και τζίφος
Ξαναλέω τα βήματα που έκανα.... του zenwalk μόνο, για να μην σασ μπερδεύω .....

1.Πρώτα εγκατέστησα

# zypper in kernel-devel kernel-source kernel-syms patch

2.Εκανα grag-drop τον επίσημο catalyst-driver .run, εντος του παραθύρου του konsole..... και enter.
To έκανα για να τρέξω την εγκατάσταση του driver..., για να μη πληκτρολογώ.
Έκανα τις κινήσεις από το gui...

3. Αυτό ακριβώς που έγραψες ο zenwalk, το έκανα με τα ίδια βήματα α., β.

   για  τον  original AMD 8.93 (12.1)  driver ,  όταν  μας  βγάζει  στο dialog
box του   amd-panel  ,  επιλέγουμε

      α. install  8.93 catalyst  driver  on  Xorg 6.9 or  above  ( δλδ , όχι
την  επιλογή   ...for  specific  distribution )

      β. Choose mode of installation   διαλέγουμε   Automatic (Recommended) &
όχι  expert.

3.#aticonfig --initial

4. reboot

ΤΙ ΛΑΘΟΣ ΚΑΝΩ ΒΡΕ ΠΑΙΔΙΑ...??????????????????????

Καλού κακού απεγκατέστησα και τον ενσωματωμένο: "xorg-x11-driver-video-nouveau" (άσχετο με τα βήματα του zenwalk)

Μετά την παραπάνω εγκατάσταση που σας είπα, κοίταξα και το αρχείο
"/usr/share/ati/fglrx-install.log", και φαίνεται ότι δεν τα έκανα καλά.....
Αλλά τι;;;;;;

/usr/share/ati/fglrx-install.log

Uninstalling any previously installed drivers.
Unloading radeon module...
ERROR: Module radeon is in use
Unloading drm module...
ERROR: Module drm is in use by radeon,ttm,drm_kms_helper
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : Kernel module build environment not found - please consult readme.
[Reboot] Kernel Module : mkinitrd

Κάνω πραγματικές προσπάθειες, αλλά το opensuse δε με θέλει, αλλά εγώ το ΘΕΛΩ....

      αδερφέ  μου , να  τι  κάνεις λάθος.. ΔΕΝ  έκανες πρώτα  από  όλα  το  update  της  διανομής  , πράγμα  βασικότατο..
        ΜΗΝ  ξανακάνεις ΦΟΡΜΑΤ , έλεος , θα σε γράψουν στο Γκίνες...
 
   Δώσε  # zypper ref                 και  μετά 

              # zypper up        & όλα  θα πάνε ρολόι

   αφού  είσαι ακόμα με τον παλιό  3.1.0-1.2 kernel. Αναβαθμίσου πρώτα στον 3.1.9-1.4.

  ΔΕΝ  το  φαντάστηκα  ότι ΔΕΝ θα έκανες upgrade της  διανομής , αδερφέ μου Τομκάτ..

    Το αρχείο /usr/share/ati/fglrx-install.log   δεν έχει τίποτα να  ''κοιτάξεις'' μέσα. Παράτα το.

το 
xorg-x11-driver-video-nouveau  είναι για  NVdia κάρτα. Αρα , δεν χρησιμεύει σε τίποτα.

   Μην τα παρατάς , είσαι μιά ''ανάσα´ από τον ...θρίαμβο ! ! !

ΑΡΧΟΝΤΑ zenwalk, θα το εφαρμόσω, σε κανα μισάωρο. Τα αποτελέσματα θα τα μάθεις αύριο...!!!
Ευχαριστώ, τώρα βλεπω μια ταινια zombie με τη γυναίκα μου στο opensuse του laptop.
......!!!!!!

     ξανά  απεγκατάσταση  του driver &  μετά ,  ξανά  εγκατάσταση  από το  GUI.
 Όταν  από τερματικό  βγάζει μήνυμα λάθους , να ξέρεις , αποκλείεται να πετύχεις.
  Και βγήκε error ,  γιατί  είχες  τον  ''παλιό'' kernel  , μαζί  με  τις  ενημερωμένες εκδόσεις  για τα πακέτα  kernel-devel  ,   source  κτλ .  Δλδ ,  έγινε  της ...κακομοίρας  μέσα  στο  σύστημα.
    Πάλι  καλά  που  ΔΕΝ  βγήκε  από μέσα  κανένας  ...TUX  να   τα  κάνει  γυαλιά-καρφιά..! ! !Laughing

Τελικά το θέμα αυτό με τις τόσες ερωτ-απαντήσεις θα πάει για γκίνες....(εγώ είμαι για γκίν-ι-ες, λόγω γκίνιας...).
4ο φορμάτ και ΑAAAΠΕΤΥΧΕ !!!
Πρώτα έκανα σε καθαρό φορμαρισμένο τα:
# zypper ref
# zypper up

1.Πρώτα εγκατέστησα

# zypper in kernel-devel kernel-source kernel-syms patch

2.Εκανα grag-drop τον επίσημο catalyst-driver .run, εντος του παραθύρου του konsole..... και enter.
To έκανα για να τρέξω την εγκατάσταση του driver..., για να μη πληκτρολογώ.
Έκανα τις κινήσεις από το gui...

3. Αυτό ακριβώς που έγραψες zenwalk, το έκανα με τα ίδια βήματα α., β.

   για  τον  original AMD 8.93 (12.1)  driver ,  όταν  μας  βγάζει  στο dialog
box του   amd-panel  ,  επιλέγουμε

      α. install  8.93 catalyst  driver  on  Xorg 6.9 or  above  ( δλδ , όχι
την  επιλογή   ...for  specific  distribution )

      β. Choose mode of installation   διαλέγουμε   Automatic (Recommended) &
όχι  expert.

3.#aticonfig --initial

4. reboot

Να σημειώσω 2 παρατηρησεις:
1. ο επίσημος driver, είναι και για 32 και για 64, δεν έχει ξεχωριστους....
2. με καθαρό σύστημα τα παράθυρα κινούνται οκ...., με τον official driver πάνε καρέ-καρέ....
ΟΚ είμαι ΤΕΛΕΙΩΣ ΑΣΧΕΤΟΣ, αλλά μήπως να φταίει κάτι άλλο ..... λόγω του kde ίσως;;;;

Τι στα παραπάνω δεν έκανα......;;;;;;;;

     Είσαι  σίγουρος ότι  έχεις  &  το  πακέτο gcc ????????

   # zypper in gcc make           έδωσες ???????

   Είσαι ΟΚ από λειτουργικό.. ΜΗΝ ξαναφορμάρεις. Απεγκατάσταση  του  8.93 catalyst ,  reboot  ,  ξανά  εγκατάσταση  , aticonfig --intial .  reboot  &  είσαι  εντάξει.

ΜΙΑ ΤΕΛΕΥΤΑΙΑ ΚΙΝΗΣΗ !!!!

Κατέβασα, τον official catalyst, αλλά όχι της σειράς HD6xxxx, ΑΛΛΑ ΤΟΝ HD4xxxx, ο οποίος μετά την εγκατάσταση που ανέφερε errors, αλλά στην εντολή fgl_glxgears, μου εμφάνιζε τα γραναζια, σε windowed mode.
Χάρηκα εκείνη τη στιγμή (πέταξα από τη χαρά μου....), αλλά με reboot, δεν ξαναεμφάνισε τα γρανάζια.
Η κάρτα μου είναι HD6670, να θυμήσω.....

Μάλλον θα δουλεύω μονο από το opensuse του laptop (με nvidia).
Αν και όταν κάποιος θελήσει να δοκιμάσει OPENSUSE 12.1 KDE, με ati drivers, έτσι από περιέργεια, ..... δεν ξέρω, ίσως να κάνω λάθος εγώ, ίσως να υπάρχει bug.... πάντως είμαι άσχετος....
Να σημειώσω ότι αυτο που εγκατέστησα, ήταν το live kde cd.
To dvd το κατέβασα, αλλά μου κάηκαν 2 dvds (μάλλον δεν κατέβηκε σωστά, και δεν είχα υπομονη να το ξανακατεβάσω....)

Πάντως ευχαριστώ για την υπομονή όλων..... Δεν θα ξεχάσω τις προσπάθειες όλων να με βοηθήσουν
Ειδικά στους zenwalk, dsyrmalis, bat12, και στους υπόλοιπους που δεν μπορώ να θυμηθώ τα ονόματά τους....

      Αφού  το  έγραψα  ότι  χρειάζεται  οπωσδήποτε  το  gcc ,  πώς  να  παίξει ο driver χωρίς το  πακέτο ??

    Το παράθυρο πάει καρέ-καρέ όταν  ΔΕΝ  γίνει  σωστή  εγκατάσταση & τότε  έχεις  χειρότερα  γραφικά  &  από τον  radeon-free-driver.

   Θα  δώσεις  &  ένα  fgl_glxgears   για  να  είσαι σίγουρος ότι όλα είναι ΟΚ.

   Το  KDE το είχα  εγκαταστήσει παλιότερα &  ήταν εντάξει από θέμα catalyst driver.  Με  το  GNOME 3  υπάρχει κάποιο πρόβλημα , αλλοιώσεις   χρωμάτων στα  παράθυρα  κτλ ,λόγω  bug  στo  Gnome 3.


 
    O  driver  είναι  ο  ίδιος  &  για τα  64-bit ,  μόνο  που ΔΕΝ παίζει , λόγω  του Xorg server , που  χρειάζεται  γράψιμο από την  αρχή γιατί  βασίζεται  στην  32μπιτη αρχιτεκτονική  ακόμα.

       Κάνε  καλύτερα  copy-paste  τον   amd-linux-driver-12.1  από  το  ίδιο 
το  περιβάλλον  της  κονσόλας ,  για  να  μην  τον  πληκτολογείς  ξανά ,  ''μαρκάροντας'' με  αριστερό  κλίκ  όλο  το  όνομα  του  driver  &  στη  συνέχεια με  δεξί  κλίκ  κάνε  πρώτα copy  &  μετά  paste , μέσα  στο  τερματικό.


  

Τώρα είδα τι έγραψες, έγραφα πριν λίγο
δεν ήταν εγκατεστημένα αυτά που μου είπες...
Τώρα δοκιμάζω.....

   απεγκατάσταση  τον driver  της  σειράς  4XXXX  &  προσπάθησε ξανά  τον  4XXXX

   Τί  έκανες με  το  πακέτο gcc ???    δεν  έγραψες  αν  όλα είναι  εντάξει..

    Τί  δίνει  το  gcc --version    και  το  make --version  από  τερματικό ?

   αδερφέ  μου  Τομκάτ ,  χρειάζεσαι  ...σανίδα  βρεγμένη  ! ! !Laughing

   Αφού  τα  έγραψα  όλα  αυτά  !  !  !  !

ΕΠΙΤΥΧΙΑ !!!       ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!      ΕΠΙΤΥΧΙΑ !!!
ΕΥΧΑΡΙΣΤΩ !!!       ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!      ΕΥΧΑΡΙΣΤΩ !!!

       Ποιός  ξέρει  καλυτερα  το  LINUX   εδώ μέσα ?????????????????


    O  μπαρμπα-ζένγουωκ !  !  ! Cool    

YOU ARE THE MASTER !!!!!!

Για πληροφοριακούς λόγους, αυτό με το nomodeset, είπες δεν παίζει ρόλο στο opensuse ;;;;;;

Αλήθεια για άλλη διανομή στον kernel το τοποθέτησα ok ??? Ή είναι σε λάθος θέση ?????
Κοίτα αν βρίσκεται στη σωστή θέση..... (γενικά λέω όχι για τώρα..... ΤΩΡΑ ΔΕΝ ΤΟ ΑΛΛΑΞΑ.....)

title openSUSE 12.1
    root (hd0,2)
    kernel /boot/vmlinuz-3.1.0-1.2-default
root=/dev/disk/by-id/ata-WDC_WD3200AAKS-00L9A0_WD-WCAV27485759-part3 ro
nomodeset splash=silent quiet showopts vga=0x345
    initrd /boot/initrd-3.1.0-1.2-default

      Είναι  σωστά το  nomodeset. Θα  μπορούσε  να  είναι & ανάμεσα στο silent & quiet  , ή  μετά  το  showopts ή  μετά  το  vga=0x345 ,  είναι ακριβώς το  ίδιο , γιατί  πρόκειται  για  μιά  παράμετρο &  δεν  έχει  σημασία η  θέση της μέσα  στην πρόταση . Αρκεί  να  είναι  κάπου  μετά το root=/dev/disk ... κτλ ,  δλδ , στη  γραμμή  για  τον  kenrel  &  όχι  στη  γραμμή  για  το  initrd /boot/... κτλ.

   Στο  openSuse  είναι η  μοναδική  εξαίρεση  που  ΔΕΝ  είναι απαραίτητο το  nomodeset , αλλά  μιάς  και  το  πρόσθεσες κράτα το , κακό δεν κάνει. Σε  άλλες  διανομές ,  ΟΠΩΣΔΗΠΟΤΕ    πρέπει να  υπάρχει  ΠΑΝΤΑ.

   Αλήθεια , ακόμα  με τον  3.1.0-1.2   kernel είσαι ? Μάλλον αδύνατο . Copy-paste θα έκανες από προηγούμενο post. Δώσε το  αποτέλεσμα

   uname -a     να  δούμε  τον πυρήνα.

   Πολύ  χάρηκα πάντως  που επιτέλους ο driver έπαιξε &  δεν τα...παιξε ! ! !Laughing

    fgl_glxgears    , για  να τεστάρεις τον  catalyst ,  πάντα ! ! !


uname -a

Linux linux-fo2r 3.1.9-1.4-default #1 SMP Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux

Μπράβο tomkat για την υπομονή σου και την επιμονή σου. Υπάρχουν πολλοί που στη θέση σου θα είχαν εγκαταλείψει την προσπάθεια. Τα προβλήματα στο linux δεν λύνονται με format αλλά με ηρεμία, διάβασμα και τερματικό.Wink

@ bat12

Σ'ευχαριστώ για τις ευχές σου φίλε. Δουλεύω και στο τερματικό, όποτε δε βαριέμαι, ή δε βιάζομαι....
Γενικά μου αρέσει να ψάχνω το κάθε τι σε διάφορα sites....