Δεν φορτώνουν τα Windows μετά από αναβάθμιση των Ubuntu

Jivan Ashu | Δευ, 05/17/2010 - 21:07 | 2' | 13

Καλησπέρα,

από την προηγούμενη εβδομάδα αντιμετωπίζω διάφορα προβλήματα σε σχέση με τα λειτουργικά μου συστήματα. Μετά από μια αναβάθμιση που ξεκίνησα να κάνω στη έκδοση 9.10, αρχικά δεν μπορούσε να φορτώσει ο grub, τελικά αποφάσισα να κατεβάσω την έκδοση 10.04 και να κάνω από την αρχή format και εγκατάσταση. Τώρα η partition Uduntu λειτουργεί θαυμάσια, αλλά δεν μπορώ να φορτώσω τα windows. Μήπως κάποιος μπορεί να με βοηθήσει πιο αναλυτικά. Υπάρχουν διάφοροι τρόποι μέσω του terminal από όσο έχω καταλάβει, αλλά δεν θέλω να κάνω καμιά βλακεία και να πρέπει να ξανακάνω εγκατάσταση.

Παραθέτω παρακάτω τα αποτελέσματα μετά από την εντολή sudo fdisk -l,

Disk /dev/sda: 160.O GB

...

...

Device Boot       Start           End        Blocks               Id        System

/dev/sda1 *          1             14023       112639716        7        HPFS/NTFS

/dev/sda2          18691         19457         6160927+       7        HPFS/NTFS

/dev/sda3          14024         180180      33391102+      83       Linux

/dev/sda4          180181         18690        4096575        83       Linux swap/ Solaris

partition table entries are not in disk order

Disk /dev/sdb: 160.0 GB

...

...

Device Boot          Start        End            Blocks         Id             System

/dev/sdb                1            19457       156288321      7           HPFS/NTFS

Ελπίζω κάποιος να μπορεί να με βοηθήσει...

Ευχαριστώ και συγνώμη αν το παραφόρτωσα με λεπτομέρειες

Φόρουμ
Δώσε αστέρια!
Σχόλια

Όταν γίνεται για 1η φορά εγκατάσταση, δεν βάζει τα Windows στο μενού εκκίνησης.

τρέξε τις εντολές

 

sudo grub-install /dev/sda

sudo update-grub

 

και θα διορθωθεί το πρόβλημά σου.

 

 

Αν θέλεις να κατανοήσεις καλύτερα πως δουλεύει ο Grub 2, διάβασε το ακόλουθο tutorial

 

http://www.dedoimedo.com/computers/grub-2.html

 

 

 

 

 

 

 

Ευχαριστώ για την απάντηση. Το δοκίμασα αλλά δεν δούλεψε. Ίσως να μην ήμουν πολύ ξεκάθαρη. Μου εμφανίζει στο  grub την επιλογή των windows αλλά όταν το επιλέγω, μου βγάζει μαύρη οθόνη και μένει εκεί. Το ίδιο συμβαίνει με το recovery partition των windows. 'Εριξα και μια ματιά στο σύνδεσμο που μου έστειλες. Είναι πολύ διαφωτιστικό. Ευχαριστώ για το ενδιαφέρον.

Jivan Ashu]

Ευχαριστώ για την απάντηση. Το δοκίμασα αλλά δεν δούλεψε. Ίσως να μην ήμουν πολύ ξεκάθαρη. Μου εμφανίζει στο  grub την επιλογή των windows αλλά όταν το επιλέγω, μου βγάζει μαύρη οθόνη και μένει εκεί. Το ίδιο συμβαίνει με το recovery partition των windows. 'Εριξα και μια ματιά στο σύνδεσμο που μου έστειλες. Είναι πολύ διαφωτιστικό. Ευχαριστώ για το ενδιαφέρον.

 

Όταν έτρεξες την εντολή

sudo grub-install /dev/sda

σου έβγαλε σφάλμα;

Αν η απάντηση είναι ναι 

 

τρέξε διαφορετικά την εντολή  (ακόμα κι αν δεν έβγαλε σφάλμα)

sudo grub-install /dev/sda -recheck /dev/sda

και ξανά την εντολή 

sudo update-grub

 

 

Τα Windows σε ποιό δίσκο είναι; στο πρώτο δίσκο (sda)  ή στο δεύτερο (sdb);

 

Δοκίμασε και πες μου.

 

Μη φοβάσαι, μπορούμε να το διορθώσουμε. Αν δεν πετύχει, θα το κάνουμε διαφορετικά.

 

Όταν το έκανα για πρώτη φορά, δεν μου έβγαλε σφάλμα και μόλις  δοκίμασα την εντολή με το recheck. Τα windows είναι στον πρώτο δίσκο sda όπως και τα linux. Δεν λειτούργησε ούτε με την δεύτερη προσπάθεια. Υπάρχει περίπτωση να έχει πρόβλημα η partition με τα windows και να μην τα φορτώνει? Ευχαριστώ πάρα πολύ για την βοήθεια.

 

Jivan Ashu]

Όταν το έκανα για πρώτη φορά, δεν μου έβγαλε σφάλμα και μόλις  δοκίμασα την εντολή με το recheck. Τα windows είναι στον πρώτο δίσκο sda όπως και τα linux. Δεν λειτούργησε ούτε με την δεύτερη προσπάθεια. Υπάρχει περίπτωση να έχει πρόβλημα η partition με τα windows και να μην τα φορτώνει? Ευχαριστώ πάρα πολύ για την βοήθεια.

 

 

Ξέχασα να σε ρωτήσω, ποιά windows έχεις;

 

Πάντως κατέβασε το Super Grub Disk από εδώ    

Κάψτο σε ένα δισκάκι, και μπούταρε απο το δισκάκι.

 

Όταν φανεί το μενού, επέλεξε τη 2η επιλογή   Detect any OS

θα σου βγάλει μια λίστα με αποτελέσματα, βρες την επιλογή για τα Windows και πάτα Enter.

 

Πες μου αν μπήκες στα Windows ή όχι. 

 

 

 

 

 

 

 

Γεια χαρα,

συγνωμη που αργησα να απαντησω. Δεν ειχα πολυ χρονο. Μολις δοκιμασα με το super grub. Δεν ειχα καποιο προβλημα, ολα εμφανιζονται οπως τα περιγραφεις επανω, αλλα και παλι τα windows δεν φορτωνουν, ουτε τα recovery windows. Η εκδοση που εχω ειναι τα vista home edition,  αν δεν κανω λαθος. Υπαρχει καποια αλλη λυση?  Ευχαριστω παρα πολυ για ολα

Πήγαινε στις ακόλουθες διευθύνσεις, και διάβασε τις οδηγίες

 

http://www.lancelhoff.com/how-to-fix-vista-mbr-repair-broken-vista/

 

http://www.planetmy.com/blog/how-to-fixmbr-using-windows-vista-bootable…

 

Αλλά να ξέρεις ότι θα χάσεις το Grub 2, (διορθώνεται εύκολα)

 

Αφού τα καταφέρεις και μπεις στα windows, κάνε επανεκκίνηση και χρησιμοποίησε το Super Grub Disk πάρε τη 2η επιλογή και μπες στο Linux.

και τρέξε τις εντολές στο τερματικό

 

sudo grub-install /dev/sda

sudo update-grub
 

 

 

Γεια χαρα, δοκίμασα την τελευταια μεθοδο που μου εγραψες, αλλα δεν τα καταφερα. Το recovery mode που εχω στα  dvd δεν εμφανιζει την επιλογη repair your computer. To περιβαλλον ειναι διαφορετικο, δηλαδη η interface και οι επιλογες που μου δινει ειναι για recovery system, που κανει format στο συστημα μου και η αλλη επιλογη ειναι η επαναφορα σε προηγουμενη ημερομηνια, το οποιο το δοκιμασα αλλα δεν δουλευε. Το μονο που εγινε με αυτο ηταν να χαθει ο grub που τον ξαναπερασα. Λες να υπαρχει καποιος τροπος να μπορω να κατεβασω τα windows και να τα καψω σε cd? Η απλα να κανω φορματ στα windows και να ξαναπερασω τα προγραμματα μου?

Ευχαριστω πολυ και συγνωμη που συνεχιζω να σε ενοχλω. Φιλια

Δεν μπορείς να βρεις το δισκάκι απο κάποια φίλη; 

 

Μπορείς να το κατεβάσεις και από εδώ

Κατέβα στο κάτω μέρος της ιστοσελίδας και επέλεξε τη 32bit έκδοση

 

Αλλά πρέπει να έχεις MSN Hotmail ή MSN Messenger λογαριασμό.

 

 

Καλησμπέρα. Έχω το ίδιο πρόβλημα. Μετά το update των ubuntu, όταν πάω να κάνω boot απο τα win7 μου βγάζει μαύρη οθώνη και μια παύλα (-) να αναβοσβήνει. Βρήκες λύση τελικά? Κσερει κάποις τι πρόβλημα υπαρχει? Αλλού διάβασα ότι είναι πρόβλημα του Grub αλλά δεν ξέρω πως λύνεται.

Στις περισσότερες περιπτώσεις αν δώσεις μέσω τερματικού sudo update-grub.... Διορθώνεται...

Amd Shop Επίσημοι AMD Specialists με ειδίκευση στους Opteron. Υποστηρικτές Linux Ubuntu www.amdshop.gr Δικτυακή πύλη τεχνολογίας

 

Σε απάντηση του από amdshop

Καλημέρα σας!

Το ίδιο πρόβλημα και γω μετά από αναβάθμιση.Με μια διαφορα.Οταν φτιάχνω το πρόβλημα  με εντολές από terminal η από ένα boot repair του ubuntu φορτώνει κανονικά τα windows όσες φορές θελω.Οταν κάποια στιγμή επιλεξω το linux και πάω να ξαναμπώ windows μου εμφανίζει κανονικά και τα δύο λειτουργικά αλλά όταν επιλέγω windows δεν μπορώ να τα φορτώσω.Ποιες επιλογές έχω?

Ευχαριστώ προκαταβολικά!

Καλημέρα!

Κατ'αρχάς άνοιξε ένα νέο thread γιατί αυτή η συζήτηση είναι πολύ παλιά (9 ετών!) και αφορά πολύ παλιές εκδόσεις Windows και Linux.

Στο νέο post, γράψε τι Windows εχεις, τι διανομή Linux εχεις και ποια έκδοση, και τι εντολές δίνεις (αυτές που λες ότι σου διορθώνουν το πρόβλημα αλλά μόνο προσωρινά).

Φιλικά,

Δημήτρης