sxolinux: προβλήματα

Ανώνυμος (χωρίς επαλήθευση) | Πέμ, 09/10/2009 - 01:26 | 1' | 68

Σε αυτό το thread λύνουμε προβλήματα  για το sxolinux.

Το sxolinux ή σχολινουξ αν προτιμάτε είναι μια διανομή για μαθητές Α' Γυμνασίου με εκπαιδευτικές εφαρμογές.

Επομένως, αυτό το thread αφορά κυρίως μαθητές αλλά και όσους γενικά βλέπουν κάτι από την σκοπιά του χρήστη.

 

 

Φόρουμ
Tags
Δώσε αστέρια!
Σχόλια

Σχετικά με το νέο project που ακούει στο όνομα Sxolinux. 8)
Το εγκατέστησα στον μαθητικό φορητό της κόρης μου (HP mini 110-1160ev) που έχει Windows XP Home και Ubuntu 9.04 και παρατήρησα το εξής:
Παρόλο που το Ubuntu 9.04 βλέπει κανονικά τις συνδέσεις του φορητού (ενσύρματη & ασύρματη), το Sxolinux δεν βλέπει καμία τους. :?
Να υποθέσω ότι φταίει η διαφορά των διανομών μεταξύ τους;  (π.χ. το ένα είναι 8.10 και το άλλο 9.04) ;   :roll:
Μπορώ να κάνω κάτι ή να περιμένω κάποια ενημερωμένη έκδοση του Sxolinux; :(

vmanolis, θα ακουστεί απόλυτο αυτό που θα γράψω αλλά δεν νομίζω ότι υπάρχει περίπτωση να συμβαίνει αυτό που αναφέρεις! :)

Το Sxolinux _είναι_ το Ubuntu 9.04 με άλλα λογότυπα και έξτρα λογισμικό. Εάν υπάρχει ένας driver/firmware στο Ubuntu υπάρχει και στο Sxolinux. Δεν έχουμε αφαιρέσει τίποτε.

Υποθέτω δηλαδή ότι μάλλον κάνεις κάτι λάθος...

Υπάρχει κανείς άλλος που μπορεί να επιβεβαιωσει κάποιο τέτοιο πρόβλημα;

 

Υπάρχει περίπτωση να φταίει το ότι αφού ξεκίνησε το γραφικό περιβάλλον του Sxolinux σαν Live-dvd, μετά επέλεξα το εικονίδιο install για την εγκατάσταση;

Να δοκιμάσω απ' ευθείας εγκατάσταση; (επιλογή Install του Live-dvd)    

το ubuntu, ήταν προεγκατεστημένο ή το εγκατέστησες εσύ?

(μήπως είναι κάποιος driver πού δεν είναι στον πυρήνα ή στο firmware καί έχει προστεθεί μετά την εγκατάσταση?)

====

the hamster's is out there

http://alfistigr.blogspot.com/

Το Ubuntu είναι αυτό που προϋπήρχε στον φορητό με την αγορά του. Το Sxolinux το εγκατέστησα εγώ σε ξεχωριστά partition (swap και / ).    

Λες να είχαν τοποθετήσει τους drivers στο Ubuntu από πριν;  

Σαφώς.

Θα τούς βρείς στον φάκελο /lib/firmware.

(άνοιξε τον φάκελο /lib/firmware τού ubuntu κ΄ τον αντίστοιχο τού sxolinux. Ή βρες τα επιπλέον αρχεία καί κάντα copy-paste στο sxolinux, ή αντέγραψε-αντικατέστησε όλον τον φάκελο. (κράτα πρώτα backup τον φάκελο πού θα πειράξεις, αν κ θα τον έχεις στο dvd.) πρέπει να το κάνεις με δικαιώματα root.)

====

the hamster's is out there

http://alfistigr.blogspot.com/

Λοιπόν. Αφού αντέγραψα τον φάκελλο /lib/firmware μπήκα στο Sxolinux σαν root και έκανα επικόλληση-αντικατάσταση όλα τα περιεχόμενά του.

Έκανα επανεκκίνηση αλλά καμία διαφορά. Δεν δείχνει σαν διαθέσιμη ενσύρματη ή ασύρματη διασύνδεση ώστε να της αλλάξω π.χ. την ΙΡ και να παίξει με το τοπικό μου δίκτυο, όπως κάνω με το Ubuntu, ακόμα κι αν έχω συνδεδεμένο το καλώδιο δικτύου.

 

Παρατήρηση: Πηγαίνοντας στο "Διαχείρηση συστήματος" -> "Εργαλεία δικτύου", βλέπει διαθέσιμες τις εξής συνδέσεις:

- Διεπαφή Loopback (lo)

- Διεπαφή Ethernet (eth0)

- Άγνωστη Διεπαφή (pan0)

Επιλέγοντας την eth0 γράφει χαμηλά στην καρτέλα για μια "Διεύθυνση υλικού" του τύπου xx:xx:xx:xx:xx:xx (φυσιολογικά εννοεί την MAC).

Κάνοντας όμως δεξί κλικ στο εικονίδιο του δικτύου στην άνω μπάρα και επιλέγοντας "Επεξεργασία συνδέσεων", δεν υπάρχει διαθέσιμη καμία ενσύρματη ή ασύρματη διασύνδεση. 

Επιπλέον, παρόλο που δεν έχει διαθέσιμη ούτε ενσύρματη ούτε ασύρματη δικτύωση, κάνοντας κλικ στο εικονίδιο του δικτύου στην άνω μπάρα, βγαίνει ένα παραθυράκι με 3-4 ασύρματα δίκτυα τα οποία λογικά εντόπισε εντός εμβέλειας. 

Τι στο καλό συμβαίνει;

sorry αλλά ... με κούφανες  :)

(ίσως φταίει πως άλλα έχεις συνηθίσει στα win).

αν βλέπεις 4 ασύρματα δίκτυα, τι άλλο θες?

ένα από όλα είναι το δικό σου.

το επιλέγεις με αριστερό κλικ καί θα σού ζητήσει κωδικό (τον κωδικό πού έχεις γιά να κλειδώσεις το δίκτυο -αν το έχεις κλειδωμένο).

Δίνεις τον κωδικό καί ... τέρμα. Αυτό είναι.

ΜΗΝ αρχίσεις να πειράζεις τίποτα από ip καί mac γιατί θα μπλέξεις καί θα χαλάσεις καί τις συνδέσεις.

 

====

the hamster's is out there

http://alfistigr.blogspot.com/

Ας υποθέσουμε λοιπόν ότι η ασύρματη κάρτα δουλεύει αφού ανιχνεύει ασύρματα δίκτυα.

Ρυθμίσεις όπως διεύθυνση ΙΡ, μάσκα, κλπ πως θα βάλω αφού δεν την βλέπει για να μπω στις ιδιότητές της;

Με την ενσύρματη που δεν την βλέπει, επίσης πως θα ρυθμίσω ΙΡ, μάσκα, κλπ ώστε να συνδεθεί με το υποδίκτυό μου;

 

Μα τα χίλια netbook.  

μα αυτό λέω εκτός αν κάτι δεν ξέρω ή αν έχεις κάτι άλλο.

δεν χρειάζεται να βάλεις τίποτα.

Μόνο τον κωδικό κλειδώματος τού δικτύου.

Ούτε στην ethernet. Απλά... ενώνεις το καλώδιο καί συνδέεσαι.

Καλώς ήλθες στον κόσμο τού linux.

====

the hamster's is out there

http://alfistigr.blogspot.com/

alfisti]

μα αυτό λέω εκτός αν κάτι δεν ξέρω ή αν έχεις κάτι άλλο.

δεν χρειάζεται να βάλεις τίποτα.

Μόνο τον κωδικό κλειδώματος τού δικτύου.

Ούτε στην ethernet. Απλά... ενώνεις το καλώδιο καί συνδέεσαι.

Καλώς ήλθες στον κόσμο τού linux.

 

Χωρίς ρυθμίσεις δικτύου θα συνδεθεί;  Ελπίζω μην νομίζεις ότι παίζει DHCP στο δίκτυό μου.

Στο Ubuntu που έχει εγκατεστημένο ο υπολογιστής, αφού βάλω ρυθμίσεις δικτύου, μου βγάζει μήνυμα κάτω από το εικονιδιάκι δικτύου ότι συνδέθηκε. Πριν από τις ρυθμίσεις το εικονιδιάκι δικτύου έχει κόκκινο Χ.

Εγώ έχω ενα άλλο "πρόβλημα". Θέλω από το iso του sxolinux να κανω ένα bootable live usb disk 8gb, αλλά ενώ το dvd που

έγραψα από το ίδιο iso δουλεύει άψογα, το usb, όποιο πρόγραμμα και να χρησιμοποιήσω για να το δημιουργήσω, δουλεύει

καλά την πρώτη φορά που το συνδέω αλλά μόλις κάνω τερματισμό ή επανεκκίνηση μου βγάζει καμιά πενηνταριά disk error

και μετα δεν ξανανοίγει από αυτό. Δοκίμασα να κάνω το usb και από την εσωτερική εντολή "Create Bootable USB Disk" με

τα ίδια αποτελέσματα. Όταν δοκίμασα να κάνω το usb με το UNetbootin, δούλεψε κανονικά (ήταν και η μοναδική φορά) αλλά

η γλώσσα είχε γυρίσει αυτόματα στα Αγγλικά και δεν μπορούσα να την ξαναγυρίσω στα Ελληνικά ότι και να έκανα. Επίσης

ξεκινούσε με το UNetbootin και δεν μου έδινε πλέον την επιλογή να διαλέξω πως θα ξεκινήσω εγώ (Live χωρίς αλλαγή των

αρχείων μου, εγκατάσταση, έλεγχο κ.ο.κ.) όπως κάνει το dvd. Επειδή η γνώση μου από Ubuntu είναι περιορισμένη αναρωτιέμαι

μήπως κάνω κάτι λάθος ή μήπως αυτό που θέλω δεν γίνεται καθόλου;

 

Μήπως μπορείτε να με βοηθήσετε;

 

Ευχαριστώ εκ των προτέρων.

@vmanolis :  τώρα δείρε με! εσύ έγραψες παραπάνω γιά τοπικό δίκτυο καί γω τόση ώρα μιλάω γιά "διαδίκτυο".

αλλά από δίκτυα, μαύρα μεσάνυχτα.

====

the hamster's is out there

http://alfistigr.blogspot.com/

@zaxanoulis.

γίνεται ακριβώς με τούς τρόπους πού ανέφερες. με το ενσωματωμένο προγραμματάκι το έχω κάνει καί εγώ καί όλα δουλεύουν.

αν θες, δοκίμασε καί σε κάποιο άλλο usb αν έχεις διαθέσιμο (έχουν παρουσιατεί προβληματάκια σε κάποια usb 8 gb, καί ιδιαίτερα σε corsair).

αν έχεις internet, δοκίμασε καί αυτό εδώ αν θες:

http://alfistigr.blogspot.com/2009/10/ubuntu.html

====

the hamster's is out there

http://alfistigr.blogspot.com/

Ευχαριστώ για την γρήγορη ανταπόκριση. Το usb που χρησιμοποιώ έιναι Kingston Data Traveler 101.

Θα δοκιμάσω σε άλλο usb (μικρότερο μάλλον αυτή την φορά) και θα σου πω αν πέτυχε.

 

alfisti]

@vmanolis :  τώρα δείρε με! εσύ έγραψες παραπάνω γιά τοπικό δίκτυο καί γω τόση ώρα μιλάω γιά "διαδίκτυο".

αλλά από δίκτυα, μαύρα μεσάνυχτα.

 

Μμμμμμμμμ.   Καλά.  Δεν πειράζει, αρκεί η προσπάθεια. 

Όλο και κάποιος γνώστης περί ρυθμίσεων τοπικών δικτύων θα υπάρχει εδώ μέσα.

Θα περιμένω (αν μπορώ, ας κάνω κι αλλιώς).  

Πηγαίνεις

Σύστημα -> Προτιμίσεις -> Συνδέσεις δικτύου (ή ψάξε παρόμοιες καταχωρήσεις, δεν ξέρω
αν το Ubuntu προσαρμόζει με δικιές του μεταφράσεις τις διάφορες ενδείξεις των μενού)

Θα δεις κάτι τέτοιο

 

Εκεί φτιάξε ότι θες. 

φίλε vmanolis

αφού βλέπει τα ασύρματα δίκτυα έχει ρυθμισμένη την κάρτα ασύρματου δικτύου.

Αλλιώς δεν θα έβλεπε τίποτα.

Όσον αφορά το ip και το subnet mask, είναι προφανές ότι τα πέρνει αυτόματα από

κάθε δίκτυο. Αυτή την δουλειά κάνει ο dhcp server των ασύρματων ρούτερ. Μοιράζει ip

διευθύνσεις ακόμη και σε λαπτοπ που δεν πρόκειται να συνδεθούν.

Κανονικά θα πρέπει να συνδέεσαι με ένα απλό κλικ στο ασύρματο δίκτυό σου.

Εάν βλέπεις το ασύρματο δίκτυό σου και δεν μπορείς να δεις κάποια σελίδα τότε

θα φταίει το ασύρματο (adsl;) ρούτερ. Kάνε μια επανεκκίνηση του ρούτερ.

 Μήπως λείπει κάτι τέτοιο ??? (δεν θυμάμαι αν έχει προστεθεί στο sxolinux)

 " sudo apt-get install wpasupplicant " 

vmanolis]

 

Χωρίς ρυθμίσεις δικτύου θα συνδεθεί;  Ελπίζω μην νομίζεις ότι παίζει DHCP στο δίκτυό μου.

Στο Ubuntu που έχει εγκατεστημένο ο υπολογιστής, αφού βάλω ρυθμίσεις δικτύου, μου βγάζει μήνυμα κάτω από το εικονιδιάκι δικτύου ότι συνδέθηκε. Πριν από τις ρυθμίσεις το εικονιδιάκι δικτύου έχει κόκκινο Χ.

 

Καταρχήν, φίλε vmanolis, ζητώ συγνώμη - δεν είχα καταλάβει ότι στο λαπτοπ σου είχες ήδη Ubuntu. O alfi μπορεί να έχει δίκιο, δηλαδή  ο κατασκευαστής να έχει προσθέσει τους drivers. Μπορεί όμως απλώς να περιμένεις να δεις κάτι παρόμοιο με τα Windows, το λέω γιατί δεν έχω καταλάβει ακριβώς τι είναι το πρόβλημα.

Οπότε, για να αποκλείσουμε το ενδεχόμενο να κάνεις κάτι λάθος, σου παραθέτω στιγμιότυπα με τη διαδικασία ρύθμισης της ενσύρματης κάρτας μέσω στατικής διεύθυνσης IP μαζί με εξηγήσεις. Ελπίζω να σε βοηθήσουν. Τη διαδικασία αυτήν την έκανα σε εγκατεστημένο Sxolinux, όπως κι εσύ.

Όπως θα δεις ΠΟΥΘΕΝΑ δεν εμφανίζεται κάτι που να γράφει "κάρτα δικτύου τάδε". Αντίθετα, η λογική εδώ είναι ότι ορίζεις συνδέσεις.  Αναγνωρίζω ότι σε κάποια σημεία δεν είναι και τόσο διαισθητικά σωστό, αλλά μια συνηθεια είναι όλα :)

 

1. Ξεκινάμε. Δεξί κλικ στο εικονιδιο Δικτύωσης στον πάνω πίνακα και κλικ στο Επεξεργασία Συνδέσεων. Θα πρέπει στο μικό διάλογο που θα εμφανιστεί να είναι τσεκαρισμένο το "Ενεργοποίηση δικτύωσης"

 

 

2.  Εμφανίζεται ο νέος διάλογος Συνδέσεις Δικτύου. Οι δυο πρώτες καρτέλες σε αφορούν εσένα (Ενσύρματη και Ασύρματη). Εδώ θα σου δείξω πως ρυθμίζεις την Ενσύρματη συνδεση με στατική διεύυθυνση (αλλά παρόμοια είναι και για Ασύρματη). Λοιπόν, κάνεις κλικ στην σύνδεση Auto Eth0  και μετά κλικ στο κουμπί Edit. Αν δεν υπάρχει τέτοια εγγραφή σύνδεσης Auto Eth0, δημιουργείς μία με Προσθήκη.

 

3. Δίνεις τον κωδικό σου:

 

 

 

4. Στο νέο διάλογο υπάρχουν 3 καρτέλες. Στην πρώτη βλέπεις την MAC address της κάρτας. Δεν μας ενδιαφέρουν. Κάνε κλικ στην τρίτη καρτέλα "Ρυθμίσεις IPv4"

 

 

5.  Εδώ γίνονται οι ρυθμίσεις.  Πρώτα επιλεγεις από το μενου "Μέθοδος" την επιλογή "Χειροκίνητα" (εφόσον είπες ότι δεν έχεις DHCP server στο τοπικό σου δίκτυο).

 

 

 

6. Μετά κάνεις κλικ στο κουμπί Προσθήκη και σου δίνει τη δυνατότητα να εισάγεις την διεύθυνση IP που θέλεις να έχει το laptop σου στο τοπικό δίκτυο.

 

 

7. Μόλις βάλεις την διεύθυνση IP, μετά κάνε κλικ δίπλα της (στο κενό κάτω από το "Μάσκα Δικτύου") και γράψε το subnet mask. Όμοια, μόλις τελειώσεις και μ' αυτό, κάνεις κλικ κάτω από το Πύλη και εισάγεις την διευθυνση του router σου (συνήθως 192.168.1.1 ή 192.168.254).

 

 

8. Είμαστε στο τέλος, αλλά εδώ δώσε βάση!!! Αν γνωρίζεις τους DNS servers του παρόχου σου, τους γράφεις στο "Εξυπηρετητές DNS". Αν δεν τους γνωρίζεις, τότε συμβουλέψου τη λίστα που έχουμε ΕΔΩ. Ενα κλασικό πρόβλημα νέων χρηστών Linux είναι ότι είναι συνδεδεμένοι στο Διαδίκτυο, αλλά δεν βλέπουν ιστοσελίδες επειδή δεν έχει ρυθμιστεί σωστά η σύνδεση τους με τους σωστούς DNS servers...

 

Αυτό είναι όλο.  Mετά πατάς Εφαρμογή και τελείωσε το πανηγύρι (εύχομαι...)

 

Παρόμοια είναι η διαδικασία όταν θες να βάλεις στατική IP σε ασύρματη κάρτα.

 

Ελπίζω να σε βοηθήσουν αυτά. Και ....καλωσήλθες στο σχολίνουξ! :)

 

lebronJ]

φίλε vmanolis

αφού βλέπει τα ασύρματα δίκτυα έχει ρυθμισμένη την κάρτα ασύρματου δικτύου.

Αλλιώς δεν θα έβλεπε τίποτα.

Όσον αφορά το ip και το subnet mask, είναι προφανές ότι τα πέρνει αυτόματα από

κάθε δίκτυο. Αυτή την δουλειά κάνει ο dhcp server των ασύρματων ρούτερ. Μοιράζει ip

διευθύνσεις ακόμη και σε λαπτοπ που δεν πρόκειται να συνδεθούν.

Κανονικά θα πρέπει να συνδέεσαι με ένα απλό κλικ στο ασύρματο δίκτυό σου.

lebronJ]

Εάν βλέπεις το ασύρματο δίκτυό σου και δεν μπορείς να δεις κάποια σελίδα τότε

θα φταίει το ασύρματο (adsl;) ρούτερ. Kάνε μια επανεκκίνηση του ρούτερ.

Επαναλαμβάνω ότι δεν έχω ασύρματο δίκτυο ή ασύρματο modem-router εντός του σπιτιού μου. 

Έχω ενσύρματο τοπικό δίκτυο και μάλιστα με στατικές διευθύνσεις ΙΡ, όχι DHCP.   

Το μόνο ασύρματο δίκτυο που έχω σχέση βρίσκεται εκτός σπιτιού, όπου λόγω και της ενασχόλησής μου με το AWMN, έχω ένα PC με 5 ασύρματες κάρτες για router στην ταράτσα και ένα Linksys NAS200 στο υπόγειο για server με δύο σκληρούς των 1ΤB σε διάταξη mirroring για ασφάλεια.

Στο σπίτι έχω έναν desktop, τρία laptop, ένα Playstation 3 και ένα Wii.

Όλα αυτά στο τοπικό μου δίκτυο.  Ελπίζω να μην σας... ζάλισα.

 

Στις ρυθμίσεις τώρα:

dimitris]

1. Ξεκινάμε. Δεξί κλικ στο εικονιδιο Δικτύωσης στον πάνω πίνακα και κλικ στο Επεξεργασία Συνδέσεων. Θα πρέπει στο μικό διάλογο που θα εμφανιστεί να είναι τσεκαρισμένο το "Ενεργοποίηση δικτύωσης"

 

 

2.  Εμφανίζεται ο νέος διάλογος Συνδέσεις Δικτύου. Οι δυο πρώτες καρτέλες σε αφορούν εσένα (Ενσύρματη και Ασύρματη). Εδώ θα σου δείξω πως ρυθμίζεις την Ενσύρματη συνδεση με στατική διεύυθυνση (αλλά παρόμοια είναι και για Ασύρματη). Λοιπόν, κάνεις κλικ στην σύνδεση Auto Eth0  και μετά κλικ στο κουμπί Edit. Αν δεν υπάρχει τέτοια εγγραφή σύνδεσης Auto Eth0, δημιουργείς μία με Προσθήκη.

 

Στο βήμα 1, η "Ενεργοποίηση δικτύωσης" και η "Ενεργοποίηση ασύρματης δικτύωσης" ήταν από την αρχή τικαρισμένες.

Στο βήμα 2, αναφέρεις ότι "κάνεις κλικ στην σύνδεση Auto Eth0  και μετά κλικ στο κουμπί Edit. Αν δεν υπάρχει τέτοια εγγραφή σύνδεσης Auto Eth0, δημιουργείς μία με Προσθήκη."

Εμένα όντως δεν αναγράφει ούτε κάποια ενσύρματη ούτε κάποια ασύρματη διασύνδεση. Επέλεξα το "Προσθήκη" που αναφέρεις (αφού δεν υπάρχει ήδη κάποια). Παρότι όμως που δημιούργησα μία διασύνδεση εντούτοις αφενός το εικονίδιο παρέμενε με κόκκινο Χ, αφετέρου όντως δεν συνδεόταν στο δίκτυο παρότι έβαλα τις κατάλληλες ρυθμίσεις.

 

dimitris]

4. Στο νέο διάλογο υπάρχουν 3 καρτέλες. Στην πρώτη βλέπεις την MAC address της κάρτας. Δεν μας ενδιαφέρουν. Κάνε κλικ στην τρίτη καρτέλα "Ρυθμίσεις IPv4"

 

 

Σε εμένα παρεπιπτόντως δεν ανέφερε καθόλου MAC address.   

vmanolis]

Σε εμένα παρεπιπτόντως δεν ανέφερε καθόλου MAC address.   

 

Αν δεν απατώμαι αυτό σημαίνει ότι το Sxolinux δεν διαθέτει drivers για την Ethernet κάρτα σου.  Μπορείς:

α) να αντιγράψεις όλα τα firmware όπως σου είπε ο alfi

β) στο Σχολίνουξ, να ανοίξεις ένα τερματικό (από το μενού Εφαρμογές > Βοηθήματα) και να δώσεις την εντολή:

lspci -v | grep Ethernet

Θα σου πει ποια είναι η κάρτα σου. Οπότε μετά ξεκινάμε το Googling μήπως βρούμε λύση  :P

Σε εμένα π.χ. γράφει

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B ...

που υποστηρίζεται.

 

 

dimitris]. . . . .

β) στο Σχολίνουξ, να ανοίξεις ένα τερματικό (από το μενού Εφαρμογές > Βοηθήματα) και να δώσεις την εντολή:

lspci -v | grep Ethernet

Θα σου πει ποια είναι η κάρτα σου. Οπότε μετά ξεκινάμε το Googling μήπως βρούμε λύση  :P

Σε εμένα π.χ. γράφει

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B ...

που υποστηρίζεται.

Λοιπόν, έγραψα lspci -v | grep Ethernet και πήρα το εξής:

02:00.0 Ethernet controller: Attansic Technology Corp. Device 1062 (rev c0)

 

Αλήθεια, από τον φάκελλο /lib/firmware δεν μπορούμε να εντοπίσουμε το ανάλογο αρχείο του driver και να το φορτώσουμε "manual" στο Sxolinux;  

η οποία κάρτα αν κατάλαβα καλά στο google, έχει chip Atheros.

δες τε (καί οί δύο μιά καί ... δεν είναι ειδικότητά μου) εδώ

http://ubuntuforums.org/showthread.php?t=1244898

στο 6 σχόλιο, είναι καί η λύση.

(vmanolis, λογικά στο ubuntu, στο /lib/firmware πρέπει να υπάρχει driver -κάτι σαν AR813)

====

the hamster's is out there

http://alfistigr.blogspot.com/

alfisti]

η οποία κάρτα αν κατάλαβα καλά στο google, έχει chip Atheros.

δες τε (καί οί δύο μιά καί ... δεν είναι ειδικότητά μου) εδώ

http://ubuntuforums.org/showthread.php?t=1244898

στο 6 σχόλιο, είναι καί η λύση.

(vmanolis, λογικά στο ubuntu, στο /lib/firmware πρέπει να υπάρχει driver -κάτι σαν AR813)

Λοιπόν...

Πήγα στο http://ubuntuforums.org/showthread.php?t=1244898 όπως είπες.

Εκεί αναφέρει τα εξής:

 

Finally I found my way out following this thread,
http://ubuntuforums.org/showthread.p...ht=D250&page=2

SOLUTION:

Download AR81Family-linux-v1.0.0.10.tar.gz from
http://partner.atheros.com/Drivers.aspx
Put it in a directory

Code:
$ gunzip AR81Family-linux-v1.0.0.10.tar.gz
$ tar xvf AR81Family-linux-v1.0.0.10.tar
$ cd src
$ make
$ sudo make install
$ cd /lib/modules/2.6.28-11-generic/kernel/drivers/net/atl1e/
$ sudo insmod ./atl1e.ko

Thus the driver is installed and the eth0 deviced can be detected and configured. Problem solved.

 

Κατέβασα το αρχείο AR81Family-linux-v1.0.0.10.tar.gz με τον φορητό μου και το μετέφερα με USB stick στον φορητό με το Sxolinux.

Έκανα αυτά που αναφέρει στην κονσόλα και ...

Code:
[email protected]:~$ gunzip AR81Family-linux-v1.0.0.10.tar.gz
gzip: AR81Family-linux-v1.0.0.10.tar.gz: decompression OK, trailing garbage ignored
[email protected]:~$ tar xvf AR81Family-linux-v1.0.0.10.tar
atl1e.7
at_osdep.h
copying
ldistrib.txt
readme
release_note.txt
src/
src/atl1c.h
src/atl1c_ethtool.c
src/atl1c_hw.c
src/atl1c_hw.h
src/atl1c_main.c
src/atl1c_param.c
src/atl1e.h
src/atl1e_ethtool.c
src/atl1e_hw.c
src/atl1e_hw.h
src/atl1e_main.c
src/atl1e_param.c
src/at_common.h
src/at_common_main.c
src/at_osdep.h
src/kcompat.c
src/kcompat.h
src/kcompat_ethtool.c
src/Makefile
src/Module.symvers
src/modules.order
[email protected]:~$ cd src
[email protected]:~/src$ make
Makefile:118: *** Compiler not found.  Stop.
[email protected]:~/src$

 

Τώρα δηλαδή τι θέλει;  

 

(εκτός του... "Καλώς ήλθες στο Sxolinux"  )

ΟΚ, τώρα έχεις δημιουργήσει ένα φακελο src/.

Μπαίνεις μέσα σε αυτόν:

cd src

και γράφεις

sudo apt-get install build-essential make

για να εγκαταστήσεις πακέτα όπως το make.

Και μετά τρέχεις την εντολή:

make

για να κάνεις μεταγλώττιση του driver.  Όταν τελειώσει γράφεις

sudo make install

Τώρα το μόνο που μένει είναι να μπεις στον φάκελο όπου υπάρχει το module που μόλις εφτιαξες και να φορτώσεις τον driver:

cd /lib/modules/`uname -r`/kernel/drivers/net/atl1e

εκεί γράφεις

sudo insmod ./atl1e.ko

 

Λογικά είσαι έτοιμος. Τσεκάρεις αν έχεις σύνδεση... :)

 

 

dimitris]

ΟΚ, τώρα έχεις δημιουργήσει ένα φακελο src/.

Μπαίνεις μέσα σε αυτόν:

cd src

και γράφεις

sudo apt-get install build-essential make

για να εγκαταστήσεις πακέτα όπως το make.

. . . . .

Λοιπόν, το δοκίμασα και...

Code:
[email protected]:~$ cd src
[email protected]:~/src$ sudo apt-get install build-essential make
[sudo] password for aggeliki: 
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Το πακέτο build-essential δεν είναι διαθέσιμο, αλλά υπάρχει αναφορά για αυτό από άλλο πακέτο.
Αυτό σημαίνει ότι το πακέτο αυτό λείπει, είναι παλαιωμένο, ή είναι διαθέσιμο από άλλη πηγή
E: Το πακέτο build-essential δεν είναι υποψήφιο για εγκατάσταση
[email protected]:~/src$

Να υποθέσω ότι απλά δεν μπορεί να βρει το πακέτο λόγω απουσίας σύνδεσης στο internet;

Αν ναι, πως μπορώ να το βρω από αλλού ή π.χ. να το κατεβάσω με άλλον υπολογιστή και να τα μεταφέρω με USB stick στον φορητό με το Sxolinux;

Sorry που δεν σκαμπάζω από τέτοιες custom-ιές.  

ουπς! εδώ μας έπιασες. vmanolis, θα έπρεπε να έχουμε προσθέσει και το build-essential στο Σχολίνουξ, διαφορετικά δεν γίνεται δουλειά σε τέτοιες περιπτώσεις...Συγνώμη για την ταλαιπωρία, στην επόμενη έκδοση 2009.1 θα είναι μέσα τα πακέτα αυτά :(

Μέχρι τότε δοκίμασε να κατεβάσεις τα πακέτα από εδώ:

http://gr.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.3/libstdc++6-4.3-…
http://gr.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.3/g++-4.3_4.3.3-5…
http://gr.archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/g++_4.3.3-…
http://gr.archive.ubuntu.com/ubuntu/pool/main/m/make-dfsg/make_3.81-5_i…
http://gr.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.14.24ub…
http://gr.archive.ubuntu.com/ubuntu/pool/main/b/build-essential/build-e…
 

Μπορείς να κατεβάσεις απευθείας τα πακέτα ακόμα και στα Windows και να τα μεταφέρεις μέ κάποιο usb stick στο sxolinux.

Αντέγραψε τα αρχεία χύμα στο Home του Σχολίνουξ και μετά άνοιξε ένα Τερματικό. Γράψε:

cd /home/aggeliki

για να μπεις στο home της Aggelikis και μετά

sudo dpkg -i *.deb

για να γίνει η εγκατάσταση

Μετά πήγαινε στο φάκελο όπου έχεις αφήσει τους drivers (νομίζω src) και συνέχισε στις παραπάνω οδηγίες, από την εντολή make και κάτω.

Το βλέπω χλωμό, αλλά ίσως είσαι τυχερός και να μην χρειάζεσαι τα υπόλοιπα πακέτα του build-essential για να compiλάρεις τους drivers σου. Διαφορετικά, αν δεις μηνύματα λάθους πρέπει να εγκαταστήσεις τα πακέτα του build-essential

 

 

Προσπαθειών... συνέχεια.

Code:
[email protected]:~$ ls
AR81Family-linux-v1.0.0.10.tar              make_3.81-5_i386.deb
atl1e.7                                     readme
at_osdep.h                                  release_note.txt
build-essential_11.4_i386.deb               src
copying                                     Βίντεο
Desktop                                     Δημόσιο
dpkg-dev_1.14.24ubuntu1_all.deb             Έγγραφα
g++_4.3.3-1ubuntu1_i386.deb                 Εικόνες
g++-4.3_4.3.3-5ubuntu4_i386.deb             Μουσική
ldistrib.txt                                Πρότυπα
libstdc++6-4.3-dev_4.3.3-5ubuntu4_i386.deb
[email protected]:~$ sudo -i *.deb
[sudo] password for aggeliki: 
-bash: build-essential_11.4_i386.deb: No such file or directory
[email protected]:~$

Από τα λίγα που καταλαβαίνω, παρόλο που αντέγραψα όλα τα αρχεία στον φάκελο και φαίνεται με το ls ότι υπάρχει όντως το πακέτο build-essential_11.4_i386.deb , εντούτοις δεν το βλέπει; 

Πότε βγαίνει η έκδοση 2009.1 είπαμε; 

vmanolis]

Προσπαθειών... συνέχεια.

Code:
[email protected]:~$ ls
AR81Family-linux-v1.0.0.10.tar              make_3.81-5_i386.deb
atl1e.7                                     readme
at_osdep.h                                  release_note.txt
build-essential_11.4_i386.deb               src
copying                                     Βίντεο
Desktop                                     Δημόσιο
dpkg-dev_1.14.24ubuntu1_all.deb             Έγγραφα
g++_4.3.3-1ubuntu1_i386.deb                 Εικόνες
g++-4.3_4.3.3-5ubuntu4_i386.deb             Μουσική
ldistrib.txt                                Πρότυπα
libstdc++6-4.3-dev_4.3.3-5ubuntu4_i386.deb
[email protected]:~$ sudo -i *.deb
[sudo] password for aggeliki: 
-bash: build-essential_11.4_i386.deb: No such file or directory
[email protected]:~$

Από τα λίγα που καταλαβαίνω, παρόλο που αντέγραψα όλα τα αρχεία στον φάκελο και φαίνεται με το ls ότι υπάρχει όντως το πακέτο build-essential_11.4_i386.deb , εντούτοις δεν το βλέπει; 

Πότε βγαίνει η έκδοση 2009.1 είπαμε; 

Ξέχασες να βάλεις στην εντολή το dpkg, πληκτρολόγησες sudo -i *.deb. Το σωστό είναι sudo dpkg -i *.deb.

************************

www.postokano.gr

Εγω προσωπικα παιδευτηκα σαν το χριστο 2 μερες και 2 νυχτες για να φτιαξω την ενσυρματη καρτα δικτυου-με chipset atheros- που δεν την εβλεπε καν κανενα ubuntu-sxolinux στο netbook..αφου ειδα και αποειδα παιρνω το netbook παραμασχαλα ,πηγαινω κοντα σε ενα ασυρματο δικτυο -εχοντας καλου κακου μαζι και ενα usb -wireless rt73- συνδεθηκα ασυρματα,ριχνω μια γενναια αναβαθμιση dist-upgrade ,μπουταρω με τον νεο πυρηνα 2.6.28-15 και ολα μια χαρα,νατην μπροστα μου η ενσυρματη καρτα δικτυου.Υ.Γ. ολα αυτα στο acer D250 με το καταραμενο chipset afheros

vriareos]

Εγω προσωπικα παιδευτηκα σαν το χριστο 2 μερες και 2 νυχτες για να φτιαξω την ενσυρματη καρτα δικτυου-με chipset atheros- που δεν την εβλεπε καν κανενα ubuntu-sxolinux στο netbook..αφου ειδα και αποειδα παιρνω το netbook παραμασχαλα ,πηγαινω κοντα σε ενα ασυρματο δικτυο -εχοντας καλου κακου μαζι και ενα usb -wireless rt73- συνδεθηκα ασυρματα,ριχνω μια γενναια αναβαθμιση dist-upgrade ,μπουταρω με τον νεο πυρηνα 2.6.28-15 και ολα μια χαρα,νατην μπροστα μου η ενσυρματη καρτα δικτυου.Υ.Γ. ολα αυτα στο acer D250 με το καταραμενο chipset afheros

Σορυ για την ταλαιπωρία αν είναι από το Σχολίνουξ, αλλά απ' ότι φαίνεται το «πρόβλημα» προέρχεται από τον πηρύνα και λύνεται μόνο έτσι όπως έπραξες, οπότε εμείς στο Σχολίνουξ δύσκολα μπορούμε να κάνουμε κάτι. Λογικά όμως στην επόμενη έκδοση δεν θα υπάρχουν τέτοια προβλήματα...

 

 

Δεν παραπονιεμαι,το προβλημα το εχει ο πυρηνας 2.6.28-11 δηλαδη ο πυρηνας που υπαρχει στο αρχικο cd του ubuntu και επομενως  και ο πυρηνας του sxolinux....παρεπιπτοντως ουτε το fedora-leonidas την βλεπει.....εγραψα με λιγο χιουμορ γιατι απ οτι βλεπω πολλα netbook εχουν το συγκεκριμενο chipset και επομενως πολλοι θα αντιμετωπισουν το ιδιο προβλημα και να ξερουν τιφταιει  και τι να κανουν....dimitris δεν μας σταματα τιποτα..παμε γερα παμε δυνατα...και ΣΥΓΧΑΡΗΤΗΡΙΑ δημοσια ,καλο κουραγιο ,διοτι εχεις επωμισθει το μεγαλυτερο βαρος..και κανω ΕΚΚΛΗΣΗ  ΣΕ ΟΛΑ ΤΑ ΜΕΛΗ ΤΟΥ FORUM  για ακομα μεγαλυτερη ενεργο συμμετοχη να βοηθησει ο καθενας οπως και οσο μπορει....

jvarkas]Ξέχασες να βάλεις στην εντολή το dpkg, πληκτρολόγησες sudo -i *.deb. Το σωστό είναι sudo dpkg -i *.deb.

Βασικά, ότι είδα έκανα.  Το δοκιμάζω κι αυτό. Έχουμε και λέμε λοιπόν:

Code:
[email protected]:~$ sudo dpkg -i *.deb
[sudo] password for aggeliki: 
Επιλογή προηγούμενου απεπιλεγμένου πακέτου build-essential.
(Ανάγνωση βάσης δεδομένων ... προς το παρόν εγκαταστάθηκαν 174848 αρχεία και κατάλογοι.)
Γίνεται αποσυμπίεση build-essential (από build-essential_11.4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου dpkg-dev.
Γίνεται αποσυμπίεση dpkg-dev (από dpkg-dev_1.14.24ubuntu1_all.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++.
Γίνεται αποσυμπίεση g++ (από g++_4.3.3-1ubuntu1_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++-4.3.
Γίνεται αποσυμπίεση g++-4.3 (από g++-4.3_4.3.3-5ubuntu4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου libstdc++6-4.3-dev.
Γίνεται αποσυμπίεση libstdc++6-4.3-dev (από libstdc++6-4.3-dev_4.3.3-5ubuntu4_i386.deb) ...
Προετοιμασία για αντικατάσταση make 3.81-5 (χρησιμοποιώντας το make_3.81-5_i386.deb) ...
Αποσυμπίεση του αντικαταστάτη make ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του dpkg-dev:
dpkg-dev εξαρτάται από patch (>= 2.2-1). Ωστόσο:
Το πακέτο patch δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του dpkg-dev (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του g++:
g++ εξαρτάται από gcc (>= 4:4.3.3-1ubuntu1). Ωστόσο:
Το πακέτο gcc δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του g++ (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση make (3.81-5) ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του build-essential:
build-essential εξαρτάται από g++ (>= 4:4.3.1). Ωστόσο:
Το πακέτο g++ δεν έχει ρυθμιστεί ακόμη.
build-essential εξαρτάται από dpkg-dev (>= 1.13.5). Ωστόσο:
Το πακέτο dpkg-dev δεν έχει ρυθμιστεί ακόμη.
dpkg: σφάλμα στην επεξεργασία του build-essential (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση g++-4.3 (4.3.3-5ubuntu4) ...
Επεξεργασία των trigger για man-db ...
Γίνεται εγκατάσταση libstdc++6-4.3-dev (4.3.3-5ubuntu4) ...
Προέκυψαν σφάλματα κατά την επεξεργασία του:
dpkg-dev
g++
build-essential
[email protected]:~$

Του λείπει πάλι κάτι ή μου φαίνεται;    

 

dimitris]Σορυ για την ταλαιπωρία αν είναι από το Σχολίνουξ, αλλά απ' ότι φαίνεται το «πρόβλημα» προέρχεται από τον πηρύνα και λύνεται μόνο έτσι όπως έπραξες, οπότε εμείς στο Σχολίνουξ δύσκολα μπορούμε να κάνουμε κάτι.

Λογικά όμως στην επόμενη έκδοση δεν θα υπάρχουν τέτοια προβλήματα... 

Την περιμένουμε πως και πως λοιπόν.   

vmanolis]

jvarkas]Ξέχασες να βάλεις στην εντολή το dpkg, πληκτρολόγησες sudo -i *.deb. Το σωστό είναι sudo dpkg -i *.deb.

Βασικά, ότι είδα έκανα.  Το δοκιμάζω κι αυτό. Έχουμε και λέμε λοιπόν:

Code:
[email protected]:~$ sudo dpkg -i *.deb
[sudo] password for aggeliki: 
Επιλογή προηγούμενου απεπιλεγμένου πακέτου build-essential.
(Ανάγνωση βάσης δεδομένων ... προς το παρόν εγκαταστάθηκαν 174848 αρχεία και κατάλογοι.)
Γίνεται αποσυμπίεση build-essential (από build-essential_11.4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου dpkg-dev.
Γίνεται αποσυμπίεση dpkg-dev (από dpkg-dev_1.14.24ubuntu1_all.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++.
Γίνεται αποσυμπίεση g++ (από g++_4.3.3-1ubuntu1_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++-4.3.
Γίνεται αποσυμπίεση g++-4.3 (από g++-4.3_4.3.3-5ubuntu4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου libstdc++6-4.3-dev.
Γίνεται αποσυμπίεση libstdc++6-4.3-dev (από libstdc++6-4.3-dev_4.3.3-5ubuntu4_i386.deb) ...
Προετοιμασία για αντικατάσταση make 3.81-5 (χρησιμοποιώντας το make_3.81-5_i386.deb) ...
Αποσυμπίεση του αντικαταστάτη make ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του dpkg-dev:
dpkg-dev εξαρτάται από patch (>= 2.2-1). Ωστόσο:
Το πακέτο patch δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του dpkg-dev (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του g++:
g++ εξαρτάται από gcc (>= 4:4.3.3-1ubuntu1). Ωστόσο:
Το πακέτο gcc δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του g++ (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση make (3.81-5) ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του build-essential:
build-essential εξαρτάται από g++ (>= 4:4.3.1). Ωστόσο:
Το πακέτο g++ δεν έχει ρυθμιστεί ακόμη.
build-essential εξαρτάται από dpkg-dev (>= 1.13.5). Ωστόσο:
Το πακέτο dpkg-dev δεν έχει ρυθμιστεί ακόμη.
dpkg: σφάλμα στην επεξεργασία του build-essential (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση g++-4.3 (4.3.3-5ubuntu4) ...
Επεξεργασία των trigger για man-db ...
Γίνεται εγκατάσταση libstdc++6-4.3-dev (4.3.3-5ubuntu4) ...
Προέκυψαν σφάλματα κατά την επεξεργασία του:
dpkg-dev
g++
build-essential
[email protected]:~$

Του λείπει πάλι κάτι ή μου φαίνεται;    

 

Καταρχάς αν προσέξεις καλά το ποστ του dimitri θα δεις ότι έχει γράψει σωστά την εντολή sudo dpkg -i *.deb.

Λοιπόν, απ'ότι βλέπω χρειάζεται να εγκατασταθεί και το πακέτο patch (έκδοση >=2.2-1) από το οποίο εξαρτάται το πακέτο dpkg-dev. Επίσης φαίνεται ότι χρειάζεται η εγκατάσταση του gcc compiler στην έκδοση 4.3.3-1ubuntu1 ή ανώτερη (λογικά υπάρχει εγκατεστημένο το πακέτο αλλά σε παλαιότερη έκδοση). Από τον gcc compiler εξαρτάται η εγκατάσταση του πακέτου g++. Από κει και πέρα το πακέτο build-essential δεν εγκαταστάθηκε διότι εξαρτάται από τα δύο προηγούμενα πακέτα που προανέφερα, dpkg-dev & g++. Στο τέλος φαίνεται ότι τρία πακέτα δεν εγκαταστάθηκαν (build-essential, g++, dpkg-dev), τα υπόλοιπα εγκαταστάθηκαν κανονικά.

Οπότε, κάνε μια προσπάθεια να εγκαταστήσεις τα πακέτα patch και gcc στις εκδόσεις που αναφέρω παραπάνω. Δεν έχω μπροστά μου sxolinux για να δω τι γίνεται με αυτά τα πακέτα, μόλις μπορέσω θα στείλω περισσότερες οδηγίες. Μην απογοητεύεσαι, θα βρεθεί η λύση, είσαι πολύ κοντά!

************************

www.postokano.gr

jvarkas]

Λοιπόν, απ'ότι βλέπω χρειάζεται να εγκατασταθεί και το πακέτο patch (έκδοση >=2.2-1) από το οποίο εξαρτάται το πακέτο dpkg-dev. Επίσης φαίνεται ότι χρειάζεται η εγκατάσταση του gcc compiler στην έκδοση 4.3.3-1ubuntu1 ή ανώτερη (λογικά υπάρχει εγκατεστημένο το πακέτο αλλά σε παλαιότερη έκδοση). Από τον gcc compiler εξαρτάται η εγκατάσταση του πακέτου g++. Από κει και πέρα το πακέτο build-essential δεν εγκαταστάθηκε διότι εξαρτάται από τα δύο προηγούμενα πακέτα που προανέφερα, dpkg-dev & g++. Στο τέλος φαίνεται ότι τρία πακέτα δεν εγκαταστάθηκαν (build-essential, g++, dpkg-dev), τα υπόλοιπα εγκαταστάθηκαν κανονικά.

Οπότε, κάνε μια προσπάθεια να εγκαταστήσεις τα πακέτα patch και gcc στις εκδόσεις που αναφέρω παραπάνω. Δεν έχω μπροστά μου sxolinux για να δω τι γίνεται με αυτά τα πακέτα, μόλις μπορέσω θα στείλω περισσότερες οδηγίες. Μην απογοητεύεσαι, θα βρεθεί η λύση, είσαι πολύ κοντά!

Δηλαδή, τι, πως και από που θα τα κατεβάσω;  

vmanolis]

Βασικά, ότι είδα έκανα.  Το δοκιμάζω κι αυτό. Έχουμε και λέμε λοιπόν:

Code:
[email protected]:~$ sudo dpkg -i *.deb
[sudo] password for aggeliki: 
Επιλογή προηγούμενου απεπιλεγμένου πακέτου build-essential.
(Ανάγνωση βάσης δεδομένων ... προς το παρόν εγκαταστάθηκαν 174848 αρχεία και κατάλογοι.)
Γίνεται αποσυμπίεση build-essential (από build-essential_11.4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου dpkg-dev.
Γίνεται αποσυμπίεση dpkg-dev (από dpkg-dev_1.14.24ubuntu1_all.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++.
Γίνεται αποσυμπίεση g++ (από g++_4.3.3-1ubuntu1_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου g++-4.3.
Γίνεται αποσυμπίεση g++-4.3 (από g++-4.3_4.3.3-5ubuntu4_i386.deb) ...
Επιλογή προηγούμενου απεπιλεγμένου πακέτου libstdc++6-4.3-dev.
Γίνεται αποσυμπίεση libstdc++6-4.3-dev (από libstdc++6-4.3-dev_4.3.3-5ubuntu4_i386.deb) ...
Προετοιμασία για αντικατάσταση make 3.81-5 (χρησιμοποιώντας το make_3.81-5_i386.deb) ...
Αποσυμπίεση του αντικαταστάτη make ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του dpkg-dev:
dpkg-dev εξαρτάται από patch (>= 2.2-1). Ωστόσο:
Το πακέτο patch δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του dpkg-dev (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του g++:
g++ εξαρτάται από gcc (>= 4:4.3.3-1ubuntu1). Ωστόσο:
Το πακέτο gcc δεν είναι εγκατεστημένο.
dpkg: σφάλμα στην επεξεργασία του g++ (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση make (3.81-5) ...
dpkg: προβλήματα εξαρτήσεων εμποδίζουν τη ρύθμιση του build-essential:
build-essential εξαρτάται από g++ (>= 4:4.3.1). Ωστόσο:
Το πακέτο g++ δεν έχει ρυθμιστεί ακόμη.
build-essential εξαρτάται από dpkg-dev (>= 1.13.5). Ωστόσο:
Το πακέτο dpkg-dev δεν έχει ρυθμιστεί ακόμη.
dpkg: σφάλμα στην επεξεργασία του build-essential (--install):
προβλήματα εξάρτησης - αφήνεται μη ρυθμισμένο
Γίνεται εγκατάσταση g++-4.3 (4.3.3-5ubuntu4) ...
Επεξεργασία των trigger για man-db ...
Γίνεται εγκατάσταση libstdc++6-4.3-dev (4.3.3-5ubuntu4) ...
Προέκυψαν σφάλματα κατά την επεξεργασία του:
dpkg-dev
g++
build-essential
[email protected]:~$

Του λείπει πάλι κάτι ή μου φαίνεται;    

 

Ναι, το λάθος είναι ολότελα δικό μου. Εκανα τη δοκιμή σε εγκατεστημένο Sxolinux στο οποίο ήδη είχα προσθέσει τα gcc και dpkg-dev, γι' αυτό δεν ανέφερα στη λίστα αυτά τα δύο πακέτα. Τώρα ξαναδοκιμάζοντας από το LiveDVD είδα ότι τα πακέτα του build-essential (δηλαδή τα gcc, g++, libsdtc++, κλπ) υπάρχουν ήδη στο DVD, οπότε μπορείς να εγκαταστήσεις το πακέτο build-essentials απευθείας από το Synaptic (Σύστημα > Διαχείριση). Δοκίμασα ακριβώς αυτό στο liveDVD του Sxolinux και η εγκατάσταση των πακέτων (και του gcc) έγινε με επιτυχία. Δοκίμασε κι εσύ και μετά ξαναδοκίμασε τις εντολές μεταγλώττισης.

 

 

dimitris]Τώρα ξαναδοκιμάζοντας από το LiveDVD είδα ότι τα πακέτα του build-essential (δηλαδή τα gcc, g++, libsdtc++, κλπ) υπάρχουν ήδη στο DVD, οπότε μπορείς να εγκαταστήσεις το πακέτο build-essentials απευθείας από το Synaptic (Σύστημα > Διαχείριση). Δοκίμασα ακριβώς αυτό στο liveDVD του Sxolinux και η εγκατάσταση των πακέτων (και του gcc) έγινε με επιτυχία. Δοκίμασε κι εσύ και μετά ξαναδοκίμασε τις εντολές μεταγλώττισης.

 

Μμμμμμμμ...

Το liveDVD όντως δεν σκέφτηκα να το τσεκέρω.   

Δηλαδή από το Synaptic (Σύστημα > Διαχείριση) θα βάλω να ψάξει για "build-essentials" ;   

vmanolis]

dimitris]Τώρα ξαναδοκιμάζοντας από το LiveDVD είδα ότι τα πακέτα του build-essential (δηλαδή τα gcc, g++, libsdtc++, κλπ) υπάρχουν ήδη στο DVD, οπότε μπορείς να εγκαταστήσεις το πακέτο build-essentials απευθείας από το Synaptic (Σύστημα > Διαχείριση). Δοκίμασα ακριβώς αυτό στο liveDVD του Sxolinux και η εγκατάσταση των πακέτων (και του gcc) έγινε με επιτυχία. Δοκίμασε κι εσύ και μετά ξαναδοκίμασε τις εντολές μεταγλώττισης.

 

Μμμμμμμμ...

Το liveDVD όντως δεν σκέφτηκα να το τσεκέρω.   

Δηλαδή από το Synaptic (Σύστημα > Διαχείριση) θα βάλω να ψάξει για "build-essentials" ;   

Ψάχνοντας για τα πακέτα μέσα από το Synaptic (Σύστημα > Διαχείριση), μου έβγαλε ένα μήνυμα ότι υπάρχουν δύο κατεστραμμένα πακέτα στο σύστημα. 

Κοιτάζοντας ανάμεσα στα πακέτα βρήκα τα dpkg-dev και g++-4.3 με κόκκινο τεράγωνο στα αριστερά τους.   

(Με δεξί κλικ υπήρχαν διαθέσιμες μόνο οι επιλογές απομάκρυνση και οριστική απομάκρυνση).

Ιδέες ;    

Εγκατεστησα ολο το εκαιδευτικο λογισμικο για το γυμνασιο ...με το metapackage dymnasio εγκαθιστανται ολα τα λογισμικα πλην της γεωφραφιας την οποια και εγκατεστησα ξεχωριστα απο τον synaptic...για την γεωγραφια δεν υπαρχει εκκινητης πουθενα ουτε μπορεσα να τον βρω με το κυριως μενου-alacarte...προφανως ειναι προβλημα του συγκεκριμενου πακετου και οχι του συστηματος  .....ανοιγονας τη χημεια διαπιστωσα οτι το προγραμμα απαιτει wmp..ως εδω καλα διοτι υπαρχουν στον prism-firefox τα ενσωματωμενα plugins για τα πολυμεσα...Ομως μερικα video απαιτουν shockwave player και τα πραγματα δυσκολευουν δεδομενου οτι δεν υπαρχει τετοιο ενθετ για linux....λιγο που εψαξα βρηκα οτι ισως λυνεται με την ταυτοχρονη εγκατασταση firefox.exe και shockwave.exe μεσω wine και εκτελεση  του video απο εκει...καμμια ιδεα???

Επισης για τη χημεια απαιτουνται τα chemical/x-mdl-modfile και application/x-spt ,application/x-director για τα ποιοα δεν βρηκα λυση...

Τελικά, επειδή είδα ότι τραβάει μακριά το θέμα, έβαλα στον φορητό μου (Evo n410c) ένα USB WiFi adapter της Zyxel το οποίο έβαλα σε Access Point mode. Έτσι, σύνδεσα ασύρματα το HP mini με το internet και έκανα update ότι έβγαζε διαθέσιμο μέσα στο Sxolinux.

Μετά την ενημέρωση, όλα δούλευαν άψογα.   

Πάντως, το προσπαθήσαμε.  Ευχαριστώ για τις συμβουλές και δοκιμές που "κάναμε μαζί".

Ελπίζω όντως η επόμενη έκδοση του Sxolinux να μην έχει κανένα πρόβλημα σε κανένα επίπεδο. 

Keep walking

Βρηκα λυση για το προβλημα της χημειας -γεωγραφιας ...που χρειαζονται ενθετα που δεν υπαρχουν σε linux.εγκαθιστουμε firefox, flasfh,shockwave και μερικα αλλα plugins που υπαρχουν στους φακελλους των προγραμματων στη διαδρομη /usr/share/gym*** με το wine Τo μονο που χρειαζεται πλεον ειναι να ανοιχτει το αντιστοιχο html αρχειο με τον firefox του wine και το μαθημα δουλευει πληρως..αναλυτικοτερα.το βραδυ αν μπορεσω.Με μια συντομευση στην επιφανεια εργασιας του html που μας ενδιαφερει ολα γινονται απλα....

vriareos] Βρηκα λυση για το προβλημα της χημειας -γεωγραφιας ...που χρειαζονται ενθετα που δεν υπαρχουν σε linux.εγκαθιστουμε firefox, flasfh,shockwave και μερικα αλλα plugins που υπαρχουν στους φακελλους των προγραμματων στη διαδρομη /usr/share/gym*** με το wine Τo μονο που χρειαζεται πλεον ειναι να ανοιχτει το αντιστοιχο html αρχειο με τον firefox του wine και το μαθημα δουλευει πληρως..αναλυτικοτερα.το βραδυ αν μπορεσω.

Περιμένουμε αναλυτικότερα λοιπόν τι και πως.  

Κατ αρχην να πω οτι αναγκαστηκα να στραφω στο wine γιατι οπως προανεφερα η μεν χημεια δουλευει κατα το ημισυ η δε γεωγραφια δεν εμφανιζεται στο μενου και δουλευει ημιτελως..... Δευτερον η εμπειρια μου στο wine ειναι μικρη.. τωρα το μαθαινω....εχουμε και λεμε....πρωτα βαζουμε στον φακελλο fonts του κρυφου φακελλου .wine που βρισκεται στον /home/user,τα fontsαπο μια εγκατεστημενη εκδοση των win.....μετα εγκατεσησα κατα σειρα με το wine τα εξης...Firefox Setup 3.5.3.exe  install_flash_player_10.exe  Shockwave_Installer_Full.exe AdbeRdr910_en_US.exe που κατεβασα απο το διαδικτυο και τα MDLChimeSP5.exe   Shockwave.exe απο το φακελλο /usr/share/gym-chimeia-b-c/chemistry/plugins  και  psetup.exe απο το φακελλο /usr/share/gym-geografia-a-b/plugin...κατα την εγκατασταση του MDL Chime επιλεγουμε χειροκινητα τον browser......Ακολουθως ανοιγουμε τον firefox του wine  απο την συντομευση που μας εχει βαλει το wine στην επιφανεια εργασιας η απο την μπαρα wine-programs-mozillafirefox-firefox..απο τον firefox  πηγαινουμε αρχειο-ανοιγμα αρχειου και απο εκει επιλεγουμε /usr/share/gym-chimeia-b-c/chemistry/index.htm για τη χημεια η /usr/share/gym-geografia-a-b/begin.htm  για τη γεωγραφια...τελος --αποθηκευση ιστοσελιδας-- για καθε μια απο τισ δυο ιστοσελιδες που ανοιξαμε..Υ.Γ. εκτος απο ενα εικονιδιο στην χημεια και αν θυμαμαι καλα ενα εικονιδιο στη γεωγραφια τα υπολοιπα δουλευουν καλα...μολις βρω χρονο θα προσπαθησω να ελεγξω εξαντλητικα τα προγραμματα Υ.Γ.2. παρακαλουνται οι γκουρου του wine να δωσουν τα φωτα τους για παραπανω

Βρισκομαι σε μια διαδικασια μετακομισης σε αλλη πολη & δυστυχως δε μπορω να συνεισφερω πια πολλα.

Ομως επειδη τωρα ειδα το θεμα εδω...

Να σας πω, οτι το sxoolinux, το χρησιμοποιυν 2 φιλες εκπαιδευτικοι, σ' επαρχιακο σχολειο που εργαζονται. Καπου καποιος φιλος ΠΟΛΥ ΣΩΣΤΑ ανεφερε τα εγχειριδια της 5ης-6ης δημοτικου, που καλιστα μπορουν να χρησιμοποιηθουν & στην Α' Γυμνασιου.

Το σχετικο προβλημα που αναφερεται εδω, το ελυσα κανοντας την διαδικασια αυτη applikation με το Prism.

Απο εκει & περα μπορει να τρεξει απλα μ' ενα κλικ...

Το προβλημα που εχουν εισπαξει κατα κορον ειναι πως στα δοθεντα απο το κρατος notebook, δε βγαζουν ακρη για το πως θα κανουν την εγκατατσταση.

Μια χαρα η εγκατασταση σε usb, που το κανανε μερικα, με με τιποτε, λενε, δε καταφερνουν ν'αποθηκευουν δεδομενα....

 

Διαβαζουν το φορουμ & αρα οτι γραφετε βοηθαει, ελπιζω αμεσα να εχουμε & απο πρωτο χερι τα οποια προβληματα & οχι μονο...

 

Υ.Γ: Εχω την αισθηση, πως τα παραπανω μπορουν να μετατραπουν σε pdf, οποτε θα ειναι & πιο απλα τα πραγματα μετα...

 

 

Π.Σ.Π.Α

 

 

Πολύ καλή προσπάθεια. Μπράβο στους δημιουργούς. αλλά έχω μερικές ερωτήσεις για το sxolinux - Ubuntu 9.04.

Τι θα συμβεί στο sxolinux όταν με το καλό θα γεννηθεί το 9.10 (Karma); Θα γίνει αυτόματα αναβάθμισή του σε 9.10;

Επίσεις με το σύστημα ext4 τί παιζει διότι το 9.04 το υποστηρίζει βέβαια αλλά δεν το προτίνει ενώ το 9.10 το έχει σαν προεπιλογή.

 

Ευχαριστώ εκ των προτέρων.