saa7134 (sound - nosound) -x32 or x64

mpoyk2005 | Τρί, 10/06/2009 - 20:34 | 1' | 3

Siduxφιλοι, γειά σας. Την βοήθειά σας παρακαλώ, γιατί είχα απογοητευθεί τόσο πολύ ώστε έσβησα τα Sidux και γύρισα στα Windows

καθόσον εδώ και καιρό δεν είχα ήχο απο την κάρτα μου  ASUSTek  με  chip saa7134 philips. Μετά θυμήθηκα ότι όταν είχα τα Sidux 

32διάμπιτα,  όλα δούλευαν ρολόϊ.  Μόλις όμως έκανα dist-upgrade,  σε 64μπιτ,τέρμα ο ήχος.  Μήπως γνωρίζει κάποιος που μπορώ να βρώ

τους 64μπιτους drivers για την κάρτα μου.

 

 

 

 

Δώσε αστέρια!
Σχόλια

Απο οτι ξέρω εδω και χρόνια οι drivers για το συγκεκριμένο chip βρίσκονται στον πυρήνα.  Όντας κάτοχος τέτοιας κάρτας μου δούλευε κανονικά, σε 64-βιτ σύστημα. Οπότε προτείνω τα εξής: Πέρνα ή αναβάθμισε τα πακετάκια σχετικά με το v4l (video 4 linux) μήπως διορθωθεί απο εκεί. Αν συνεχίζει να μην δουλεύει δώσε σαν root την εντολή lsmod | grep SAA και δες αν φορτώνονται σωστά τα modules (δώσε και σε εμάς την έξοδο να το δούμε). Αν τρέχουν τα απαραίτητα modules τότε ψάξε στο pulseaudio (αν δουλευεις με αυτό).

Εικόνα έχεις κανονικά απο την κάρτα?

Επίσης υποθέτω οτι έχεις κάνει  προσπάθειες να δουλέψει, όπως και εδώ: http://www.linuxinsider.gr/forum/pci-%CE%BA%CE%AC%CF%81%CF%84%CE%B1-%CF…

 

 

  

Φίλε Teddy, έκανα όπως μου γράφεις και στο lsmod |grep SAA δεν μου δίνει τπτ, ενώ στο dmesg | grep SAA* μου δίνει το παρακάτω με τις δύο τελευταίες γραμμές να είναι

disabled.

dmesg | grep SAA*
ACPI: PCI Interrupt Link [LSA0] (IRQs 20 21 22 23) *11
ACPI: PCI Interrupt Link [LSA1] (IRQs 20 21 22 23) *5
ACPI: PCI Interrupt Link [LSA2] (IRQs 20 21 22 23) *0, disabled.
fb0: VESA VGA frame buffer device
ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 20
sata_nv 0000:00:05.0: PCI INT A -> Link[LSA0] -> GSI 20 (level, low) -> IRQ 20
ata3: SATA max UDMA/133 cmd 0xd800 ctl 0xd480 bmdma 0xd000 irq 20
ata4: SATA max UDMA/133 cmd 0xd400 ctl 0xd080 bmdma 0xd008 irq 20
ACPI: PCI Interrupt Link [LSA1] enabled at IRQ 23
sata_nv 0000:00:05.1: PCI INT B -> Link[LSA1] -> GSI 23 (level, low) -> IRQ 23
ata5: SATA max UDMA/133 cmd 0xcc00 ctl 0xc880 bmdma 0xc400 irq 23
ata6: SATA max UDMA/133 cmd 0xc800 ctl 0xc480 bmdma 0xc408 irq 23
ata5: SATA link down (SStatus 0 SControl 300)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata6: SATA link down (SStatus 0 SControl 300)
IRQ 19/saa7133[0]: IRQF_DISABLED is not guaranteed on shared IRQs
saa7134 ALSA driver for DMA sound loaded
IRQ 19/saa7133[0]: IRQF_DISABLED is not guaranteed on shared IRQs

Αντιμετωπίζω δε το εξής παράδοξο.  Με LiveCD Sidux έχω ήχο στον player, απο την στιγμή όμως που θα κάνω εγκατάσταση, παύει να υπάρχει ήχος. Απο το εικονίδιο του ήχου, πατώντας

mixer,  σβύνω τα check που ήταν mute,  αλλά και πάλι δεν έχω ήχο.  Τέλος απο το System ..System Settings.....multimedia ....όταν δίνω να κάνει test πχ το Jack Audio Connection Κιτ, μου

επιστρέφει μήνυμα σφάλματος (the audio playback device Jack Audio Connection does not work,  fall back to HDA (ALc883Analog).

Οταν πάλι δίνω lspci μου επιστρέφει το παρακάτω.

 lspci
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
06:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GT] (rev a1)

Δεν γνωρίζω τι πρέπει να κάνω ή να διορθώσω.

Για δοκίμασε τον mplayer όπως περιγράφω εδώ. Υπάρχει και άλλη λύση για  να έχεις ήχο stereo με αυτή την κάρτα με το sox, αλλά δεν θυμάμαι την εντολή...Θα το ψάξω...

Επίσης κοίτα εδώ και εδώ. Στο πρώτο link υπάρχουν γενικές οδηγίες για το σετάρισμα ενώ στο δεύτερο υπάρχει μια λίστα καρτών με αυτό το chip, και σε μερικές υπάρχουν και επιμέρους οδηγίες.