Βοήθεια για εκγατάσταση package.

Ανώνυμος (χωρίς επαλήθευση) | Κυρ, 01/13/2008 - 23:23 | 1' | 12

Κατέβασα το dvdshrink από internet. Κατέβηκε τo εξής package :

dvdshrink-2.6.1-10mdk.tar.gz
dvdshrink-2.6.1-10mdk.src.rpm
dvdshrink-2.6.1-10mdk.noarch.rpm.

Μήπως μπορείτε να μου δώσετε οδηγίες, για το πως θα στήσω το dvdshrink στο OPENSUSE 10.2

Σας ευχαριστώ πολύ.

Φόρουμ
Δώσε αστέρια!
Σχόλια

Και με δεξί κλικ πάνω του και > Install... μπορείς να το εγκαταστήσεις, αν θυμάμαι καλά...

Φίλε constantine έκανα δεξί κλικ πάνω του και > Install... και το μύνημα που παίρνω είναι το εξής :

Unresolved dependencies:
Installing dvdshrink-2.6.1-10mdk.noarch[Local packages]
There are no installable providers of perl(Gtk2::Gdk::Keysyms) for dvdshrink-2.6.1-10mdk.noarch[Local packages].

Σου λειπουν καποι πακετακια γι΄αυτο & δε μπορεις να το εγκαταστησεις ετσι.
Υποθετωντας οτι οι οι γνωσεις σου στο LINUX βρισκονται ακομη στο αρχικο σταδιο, θα σου προτεινα σα καλυτερη λυση να εγκαθιστας οτι πακετο (εφαρμογη) θελεις με τον εγκαταστατη πακετων της διανομης σου, ο οποιος βρισκεται στο Yast.
Δοκιμασε το ετσι καλυτερα & για ολα τα αλλα υπαρχει το forum & το περιοδικο.
Γενικα μην αποθαρρυνεσαι, πολυ συντομα θα δεις & θα καταλαβεις οτι αυτα που σου φαινονται δυσκολα &... παραξενα τωρα, θα παψουν να ειναι!!

constantinos2007-8-29 19:12:29


constantinos] Σου λειπουν καποι πακετακια γι΄αυτο & δε μπορεις να το εγκαταστησεις ετσι.
Υποθετωντας οτι οι οι γνωσεις σου στο LINUX βρισκονται ακομη στο αρχικο σταδιο, θα σου προτεινα σα καλυτερη λυση να εγκαθιστας οτι πακετο (εφαρμογη) θελεις με τον εγκαταστατη πακετων της διανομης σου, ο οποιος βρισκεται στο Yast.
Δοκιμασε το ετσι καλυτερα & για ολα τα αλλα υπαρχει το forum & το περιοδικο.
Γενικα μην αποθαρρυνεσαι, πολυ συντομα θα δεις & θα καταλαβεις οτι αυτα που σου φαινονται δυσκολα &... παραξενα τωρα, θα παψουν να ειναι!!


Φίλε constantine πάλι σε ενοχλώ.


Με όσα μου λες παραπάνω εννοείς ότι τα πακέτα αυτά θα τα βρω στο Yast? Αν όχι μήπως μπορείς να μου πεις που θα τα βρω?

amka1968, από το Yast > Instal Software, βρες και εγκατέστησε ότι σχετικό υπάρχει με την Perl και development αρχεία. H γλώσσα Perl σου λείπει και παραπονιέται το rpm :)


dimitris]amka1968, από το Yast > Instal Software, βρες και εγκατέστησε ότι σχετικό υπάρχει με την Perl και development αρχεία. H γλώσσα Perl σου λείπει και παραπονιέται το rpm :)


Ευχαριστώ dimitri.

amka19682007-8-30 20:50:53

Αντι να κάθεσαι να ψάχνεις στα διάφορα sites για rpms, μπορείς να βάλεις κάποια repositories (πηγές εγκατάστασης πακέτων) στο YaST.
Έτσι θα μπορείς να κάνεις πολύ εύκολα εγκατάσταση/απεγκατάσταση πακέτων ,αλλά και επίσης ενημέρωση των πακέτων που έχεις με ενότερες εκδόσεις.
Οδηγίες για το πώς θα το κάνεις θα βρείς εδώ. Επίσης σου δίνω τη λίστα με τα official και τα additional repos. Θα σου πρότεινα να μην τα βάλεις όλα τα additional, γιατί κάθε φορά που ανοίγεις το YaST ,κάνει ενημέρωση του κάθε repository (που σημαίνει οτι θα καθυστερεί λιγάκι).

Καλησπέρα!Αντιμετωπίζω και εγώ το ίδιο πρόβλημα σχετικα με αυτό το θαυμάσιο μήνυμα "There are no installable providers blah...blah..." απο την στιγμή που εγκατέστησα το opensuse 10.2.Ασφαλώς και εφαρμοσα τις οδηγίες του Δημήτρη σχετικά με το Perl αλλά και πάλι πήρα ως ανταμοιβή το ίδιο μήνυμα.Εγκατέστησα και αρκετά repos (αυτά τουλάχιστον που θεώρησα απαραίτητα),αλλά....μάλλον θα πρέπει να αποδεχτώ πως θα γεράσω παρέα με αυτό το εκνευριστικό κιτρινοκόκκινο μήνυμα!Θα μπορούσε κάποιος να βοηθήσει;Ευχαριστώ προκαταβολικά!
Σημείωση:Είμαι νέα χρήστρια στο linux και οι γνώσεις μου (ακόμα) δεν είναι οι καλύτερες.Όπως ανέφερα παραπάνω επέλεξα το opensuse μετά από αρκετά test drive σε άλλες διανομές.Δυστυχώς η δική μου "ανήσυχη φύση" (ψάξιμο και "πειραγμα" του λειτουργικού) δεν απέδωσε καρπούς,οπότε τα φώτα σας θα ήταν πολύτιμα!

Ειναι μια απο αυτες τις  φορες, που βρισκομαι στο διλλημα:
-Να πω κατι που ισως δουλεψει? & αν ναι πως?
Με γραφικο περιβαλλον η με κονσολα??
Na δωσω & καλοιο/καποια link,ισως??
-Να κανω προταση για καποια αλλη διανομη που αυτα, τεσπα, θα δουλευουν με τη πρωτη??
Μιλωντας παντα για νεο χρηστη, που οσκοπος ειναι να μη παρει μια πλασματικη & ασχημη εντυπωση για το Linux, καθ΄οτι μονο ετσι δεν ειναι...
Sicily, ειμαι βεβαιος οτι   δοκιμασες ολες η εστω αρκετες απο τις.. tredy διανομες. (ανησυχη φυση,γαρ!)
Το θεμα στη προκειμενη περιπτωση ειναι οτι λειπουν κατι πακετακια.
Μα.... αν θες για να μην απογοητευεσαι (& μη γερασεις με κιτρινομαυρα μηνυματα, απο απαισιες οθονες ) & για να μπορεσεις να χρησιμοποιησεις πια το linux στο pc σου, αμεσως, θες να ριξεις μια ματια στο PCLOS?
Τρεξτο, απλα live σε πρωτη φαση...
ΠΡΟΣΕΞΕ: Οχι πως λεω οτι το μεν υπερτερει του δε.
Απλα, στη προκειμενη περιπτωση θα σου δουλεψει αμεσως & ευκολα θα το χειριστεις.

Είναι πραγματικά αξιοπρόσεκτη η ταχύτητα της ανταπόκρισης στην έκκλησή μου!
Κωνσταντίνε,κατάφερες πάρα πολύ εύκολα να με πείσεις (φαντάσου πόσο σπασμένα είναι τα νεύρα μου!) σχετικά με το PClinuxOS.Θα κάνω μία τελευταία απελπισμένη προσπάθεια με αυτό που προτείνεις.Βλέπεις δεν θα ήθελα να πέσω σε διανομές όπως το Ubuntu (όχι πως το κατακρίνω,απλά σε εμένα δεν ικανοποιεί εκείνη την "ανησυχη φύση" που λέγαμε...-ασε που με το lap μου,δεν μπορεί να κάνει μια καλή "σχέση"), οπότε ακολουθώ την συμβουλή σου με κλειστά μάτια (το ένα μάτι ίσως γιατί κάποιος πρέπει να κάνει την όλη διαδικασία....).Το μόνο που με θλίβει είναι οι ατέλειωτες ώρες downloading repos-ψαξίματος στο νετ-διαβάσματος του περιοδικού και ρύθμισης του opensuse.Ελπίζω τουλάχιστον ότι εχω μάθει μέχρι στιγμής να μπορέσω να τα αξιοποιήσω στο PCLos και ασφαλώς να μη με απογοητεύσει και αυτό και με ρίξει στα... σκληρά ναρκωτικά (aka windows)!
Σε ευχαριστώ που ανταποκρίθηκες και είμαι σίγουρη πως θα τα ξαναπούμε (βλέπεις οι απορίες δεν τελειώνουν ποτέ όταν κάποιος είναι ακόμα ...στραβάδι).

Ειμαι σχεδον βεβαιος, πως ο χρονος που σπαταλησες για το Suse & ολα τα αλλα, μονο χρησιμος θα ειναι.
Σιγουρα κατι παραπανω εμαθες & καταλαβες.
Ελπιζω λοιπον η ανησυχες φυσεις τοσο του Linux, οσο & της Sicily να ταιριαξουν, παααρα πολυ & να εχουν μια αψογη... συμβιωση.
Θα χαρουμε να δουμε ενα ολοκληρο forum, γεματο αποριες, ωστε να μη ξανακυλησει καποιος στα... "σκληρα"!

pc:Προσωπικα ακομα στραβαδι, νοιωθω...