''ξυλωμα'' πακετου

ulver | Σάβ, 05/29/2010 - 00:36 | 1' | 6

python-epsilon

το παραπανω πακετακι με εχει πεθανει..

ποιο συξκεκριμενα εγκατεστησα το moovida  και καποιο πακετο δειχνει να ειναι σπασμενο.προσπαθω να το βγαλω αλλα ....

μεσα απο το synaptic βλεπω οτ τα πακετα που δεν βγαζει ειναι τα moovida-plugins-good & python-moovida.

το error που παιρνω ειναι  

  E: /var/cache/apt/archives/python-epsilon_0.6.0-1ubuntu1_all.deb: trying to overwrite '/usr/share/pyshared/epsilon/_

_init__.py', which is also in package python-efl-epsilon 0
 

δεν με αφηνει για update και συνεχεια μου δειχνει οτι εχω σπασμενο πακετο.καμια προταση?

 

Φόρουμ
Tags
Δώσε αστέρια!
Σχόλια

Εκτελεσε

sudo apt-get -f install

sudo apt-get update

και αν δεν εχεις αποτελεσμα εκτελεσε

sudo dpkg --configure -a

sudo apt-get update

και λογικα θα φτιαξει!

τα ειχα δοκιμασει και τα 2....τιποτα

και ποιο αναλυτικα

[email protected]-desktop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  python-epsilon
The following NEW packages will be installed:
  python-epsilon
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
Need to get 0B/92.6kB of archives.
After this operation, 582kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 198007 files and directories currently installed.)
Unpacking python-epsilon (from .../python-epsilon_0.6.0-1ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-epsilon_0.6.0-1ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/epsilon/__init__.py', which is also in package python-efl-epsilon 0:0.3.1+svn20090507.20-1~ppa2~lucid0
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/python-epsilon_0.6.0-1ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]-desktop:~$

και

[email protected]-desktop:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of python-axiom:
 python-axiom depends on python-epsilon (>= 0.5.11); however:
  Package python-epsilon is not installed.
dpkg: error processing python-axiom (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-coherence:
 python-coherence depends on python-axiom; however:
  Package python-axiom is not configured yet.
dpkg: error processing python-coherence (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-axiom
 python-coherence
[email protected]-desktop:~$

 

 

 

 

I'm never gonna work another day in my life
The gods told me to relax

Όσες φορές είχα τέτοια πρόβλημα, κατέβαζα το προβληματικό πακέτο ή κάποια άλλη έκδοσή του χειροκίνητα (π.χ. από το Launchpad ή αλλού) και το εγκατθιστούσα. Συνήθως το πρόβλημα διορθωνόταν.

--------------------------------------------------------------------

LawyersVoice.grLawyersVoice.gr - To forum των νέων δικηγόρων

Ναι ειναι ενας τροπος και αυτος.....

αλλα υπαρχει και καλυτερος πιστευω, οπου θα σου εμφανισει και πιο ειναι ακριβως το προβλημα, και θα φτιαξει κιολας!

sudo dpkg --force-overwrite -i  /var/cache/apt/archives/ονομασια_του_προβληματικου_αρχειου.deb

Όλες αυτές οι εντολές, θεωρούν ως δεδομένη την ακεραιότητα του πακέτου και πιστεύουν ότι το πρόβλημα εντοπίζεται στην διαδικασία της εγκατάστασης, οπότε όσες φορές και να τις τρέξεις δεν θα κάνεις κάτι.

Το πρόβλημα εδώ εντοπίζεται στο γεγονός ότι στο αποθετήριο το πακέτο είναι προβληματικό. Εάν αλλάξεις πηγές (αποθετήρια) σε κάποια άλλη χώρα μπορεί να εγκατασταθεί άμεσα! Άρα το force-overwrite ενός προβληματκού πακέτου, όπως καταλαβαίνετε, πρόβλημα θα δημιουργήσει παρά λύση θα δώσει...

--------------------------------------------------------------------

LawyersVoice.grLawyersVoice.gr - To forum των νέων δικηγόρων