OpenGL 4.0 and fglrx

mitsaras77 | Πέμ, 03/25/2010 - 22:13 | 1' | 6

Σήμερα η ATI έδωσε στην κυκλοφορία μια ανεπίσημη έκδοση του fglrx (βασιμένο στην έκδοση 10.3, επομένως χωρίς υποστίριξη για xserver-1.7) ο οποίος υποστιρίζει OpenGL 3.3/4.0 στις κάρτες HD5000 και άνω. Οποιος έχει τέτοια κάρτα και linux μπορεί να το δοκιμάσει και να πει τη γνώμη του (ενδιαφέρομαι για αγορα...), και ίσως να κάνει και κανένα benchmark με την ολοκαίνουργια 3d μηχανή της Unigine, η οποία στην κυριολεξία τα σπάει...

ΥΣ.Αλήθεια, γιατί δεν χρησιμοποίησαν την έκδοση που έδωσαν στο Ubuntu, που υποστιρίζει xserver-1.7???

Φόρουμ
Δώσε αστέρια!
Σχόλια

Που να την δοκιμάσουμε βρε Μήτσο; Έχω εδώ και καιρό περάσει σε xserver-1.7.. Να κάτσω να κάνω εγκαταστάσεις για κάτι που δεν θα κρατήσω; (οι ανοιχτοί drivers δουλεύουν μια χαρά)

Παρεπιπτόντως, η έκδοση υποστηρίζει OpenGL 3.3 για τις HD2000 και άνω, ενώ OpenGL 4.0 στις κάρτες HD5000.Οπότε (αν θυμάμαι καλά την κάρτα σου) μπορείς να τους δοκιμάσεις.

 

Λέω τώρα, μήπως υπάρχει κανένας χρηστιανός... Και γω έχω xserver-1.7 οπότε δεν μπορώ τα το δοκιμάσω. Αν και από προχθές χρησιμοποιώ την έκδοση του Ubuntu που μπήκε και στα αποθετήρια του Debian Sid και παίζει μια χαρά με τον xserver-1.7. (ασχετο, δοκίμασα την 3δ μηχανή της Unigine αλλά δεν παίζει με τον fglrx του Ubuntu..)

Y.Σ  Και γω με τους open source ήμουν μέχρι πριν 3-4 μέρες, κανένα παράπονο, αλλά το wine με παιχνίδια δεν τσουλάει...

Ναι, με τους ανοιχτούς πού να τσουλήσει... Καλοί, χρυσοί, αλλά το wine δεν το κατέχουν..  Πολύ φοβάμαι οτι θα καταλήξουμε να έχουμε dual-boot όχι win-linux αλλά Linux-Linux, την μια εγκατάσταση για παιχνίδια με fglrx, την άλλη για την καθημερινή μας χρήση με τους ανοιχτούς...

Teddy]

Ναι, με τους ανοιχτούς πού να τσουλήσει... Καλοί, χρυσοί, αλλά το wine δεν το κατέχουν..  Πολύ φοβάμαι οτι θα καταλήξουμε να έχουμε dual-boot όχι win-linux αλλά Linux-Linux, την μια εγκατάσταση για παιχνίδια με fglrx, την άλλη για την καθημερινή μας χρήση με τους ανοιχτούς...

Ένα παρόμοιο σκηνικό έχω στο πισι μου. Καθότι η κάρτα μου είναι παλιά (ΑΤΙ Radeon X1600) ο fglrx παίζει καλά σε debian stable λόγω παλαιότερου xorg, αλλά σε opensuse με νεότερο xorg χρησιμοποιώ τους ανοιχτούς. Βέβαια τα effects του KWin κάνουν νερά και τα έχω απενεργοποιήσει (ναι ακόμα δεν έχω κάνει δοκιμές να δω πώς μπορούν να παίξουν...).

Πάντως γενικότερα είναι ένα θέμα αυτό, καθώς στο απώτερο μέλλον θα χρειαστεί να παίζω παιχνίδια με τον μικρό (ακόμα είναι 11 μηνών βέβαια οπότε έχουμε χρόνο) και πρέπει το λίνουξ να έχει λύσει το πρόβλημα αυτό...

************************

www.postokano.gr

Παράξενο αυτό που αναφέρεις. Η κάρτα σου έπρεπε να παίζει με τη μία χωρίς κολπάκια από τους opensource drivers εδώ και πολύ καιρό, σύμφωνα με αυτά που έχω διαβάσει. Η όλη φασαρία γίνεται πια για τις R600 και άνω ( αν και πρέπει να σου πώ ότι είμαι λίιιγο.. απαιτητικός από τις κάρτες γραφικών μου και ίσως να μην ανταποκρίνομαι στον μέσο χρήστη... Συνέχεια τα ανακατεύω...)

Δοκίμασε κάποια beta της νέας φουρνιάς διανομών, θα βελτιωθεί πολύ η κατάσταση. Το 11.2 έχει σχετικά παλιά πακέτα και το θέμα έχει προχωρήσει πολύ απο τότε.