Nosonja Linux 32-bit ( Arch-live )

zenwalk05 | Πέμ, 03/01/2012 - 23:51 | 4' | 36

       κατέβασμα από εδώ

    https://sourceforge.net/projects/nosonja/files/latest/download?source=d…

    Το site  εδώ  https://plus.google.com/102479162698978916755/posts

   ένα  ARCH-live με  XFCE4  ,  που  του  λείπουν  μόνο  τα πακέτα  make  &  linux-headers. Επίσης  αντί για  firefox  έχει  Chromium , αλλά πολύ  εύκολα  αυτό διορθώνεται.
    Τέλος , είναι το μοναδικό arch-live-cd  που  έχει  τον  Compiz ( ccsm  & fusion-icon )  & παίζει τόσο σε  AMD όσο & NVidia .


[[email protected] zen]# pacman -Sy
warning: database file for 'nosonja-stable' does not exist
warning: database file for 'core' does not exist
warning: database file for 'extra' does not exist
warning: database file for 'community' does not exist
warning: database file for 'archlinuxfr' does not exist
:: Synchronizing package databases...
 nosonja-stable                                                        11.8 KiB  78.7K/s 00:00 [########################################################] 100%
 core                                                                 105.2 KiB   117K/s 00:01 [########################################################] 100%
 extra                                                               1391.3 KiB  59.9K/s 00:23 [########################################################] 100%
 community                                                           1539.7 KiB   101K/s 00:15 [########################################################] 100%
 archlinuxfr                                                           29.6 KiB   129K/s 00:00 [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (3): libarchive-3.0.3-5  linux-3.2.8-1  qt-4.8.0-5

Total Download Size:    60.47 MiB
Total Installed Size:   148.39 MiB
Net Upgrade Size:       0.00 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 libarchive-3.0.3-5-i686                                              608.2 KiB  71.1K/s 00:09 [########################################################] 100%
 linux-3.2.8-1-i686                                                    39.5 MiB  88.8K/s 07:35 [########################################################] 100%
:: Retrieving packages from extra...
 qt-4.8.0-5-i686                                                       20.4 MiB  83.8K/s 04:10 [########################################################] 100%
(3/3) checking package integrity                                                               [########################################################] 100%
(3/3) loading package files                                                                    [########################################################] 100%
(3/3) checking for file conflicts                                                              [########################################################] 100%
(3/3) checking available disk space                                                            [########################################################] 100%
(1/3) upgrading libarchive                                                                     [########################################################] 100%
(2/3) upgrading linux                                                                          [########################################################] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio.  Please wait...
==> Building image from preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.2.8-1-ARCH
  -> Parsing hook: [base]
  -> Parsing hook: [fbsplash]
  -> Parsing hook: [udev]
  -> Parsing hook: [autodetect]
  -> Parsing hook: [pata]
  -> Parsing hook: [scsi]
  -> Parsing hook: [sata]
  -> Parsing hook: [filesystems]
  -> Parsing hook: [usbinput]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.2.8-1-ARCH
  -> Parsing hook: [base]
  -> Parsing hook: [fbsplash]
  -> Parsing hook: [udev]
  -> Parsing hook: [pata]
  -> Parsing hook: [scsi]
  -> Parsing hook: [sata]
  -> Parsing hook: [filesystems]
  -> Parsing hook: [usbinput]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
(3/3) upgrading qt                                                                             [########################################################] 100%
[[email protected] zen]# cd /var/cache/pacman/pkg;ls
libarchive-3.0.3-5-i686.pkg.tar.xz  linux-3.2.8-1-i686.pkg.tar.xz  qt-4.8.0-5-i686.pkg.tar.xz
[[email protected] pkg]# cd -
/home/zen
[[email protected] zen]#

Δώσε αστέρια!
Σχόλια

    Εδώ κατεβάζουμε τα πακέτα make &  linux-headers  που  λείπουν &  είναι απολύτως απαραίτητα να  υπάρχουν , όπως και ο  firefox

[[email protected] zen]# pacman -S linux-headers
resolving dependencies...
looking for inter-conflicts...

Targets (1): linux-headers-3.2.8-1

Total Download Size:    4.63 MiB
Total Installed Size:   44.54 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 linux-headers-3.2.8-1-i686                                             4.6 MiB  80.7K/s 00:59 [########################################################] 100%
(1/1) checking package integrity                                                               [########################################################] 100%
(1/1) loading package files                                                                    [########################################################] 100%
(1/1) checking for file conflicts                                                              [########################################################] 100%
(1/1) checking available disk space                                                            [########################################################] 100%
(1/1) installing linux-headers                                                                 [########################################################] 100%
[[email protected] zen]# cd /var/cache/pacman/pkg;ls
libarchive-3.0.3-5-i686.pkg.tar.xz  linux-3.2.8-1-i686.pkg.tar.xz  linux-headers-3.2.8-1-i686.pkg.tar.xz  qt-4.8.0-5-i686.pkg.tar.xz
[[email protected] zen]#

                                 ###################

[[email protected] zen]# pacman -S make
resolving dependencies...
looking for inter-conflicts...

Targets (1): make-3.82-4

Total Download Size:    0.34 MiB
Total Installed Size:   1.29 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 make-3.82-4-i686                                                     345.9 KiB  94.6K/s 00:04 [########################################################] 100%
(1/1) checking package integrity                                                               [########################################################] 100%
(1/1) loading package files                                                                    [########################################################] 100%
(1/1) checking for file conflicts                                                              [########################################################] 100%
(1/1) checking available disk space                                                            [########################################################] 100%
(1/1) installing make                                                                          [########################################################] 100%
[[email protected] zen]# make --version
GNU Make 3.82
Built for i686-pc-linux-gnu
Copyright (C) 2010  Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html&gt;
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
[[email protected] ~]$

                    ###########################

[[email protected] zen]# pacman -S firefox
resolving dependencies...
looking for inter-conflicts...

Targets (2): mime-types-8-1  firefox-10.0.2-1

Total Download Size:    13.23 MiB
Total Installed Size:   22.16 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from extra...
 mime-types-8-1-any                                                    11.2 KiB  1990K/s 00:00 [########################################################] 100%
 firefox-10.0.2-1-i686                                                 13.2 MiB   154K/s 01:28 [########################################################] 100%
(2/2) checking package integrity                                                               [########################################################] 100%
(2/2) loading package files                                                                    [########################################################] 100%
(2/2) checking for file conflicts                                                              [########################################################] 100%
(2/2) checking available disk space                                                            [########################################################] 100%
(1/2) installing mime-types                                                                    [########################################################] 100%
(2/2) installing firefox                                                                       [########################################################] 100%
[[email protected] zen]#

     για  εγκατάσταση  του  AMD Catalyst driver ,  οδηγίες από  εδώ

   https://wiki.archlinux.org/index.php/ATI_Catalyst#Installing_from_AUR

   κατέβασα τον driver με  τον  τρόπο που δείχνει το section

Unofficial repositories,  δλδ

 

To use it you need:

1.) Edit /etc/pacman.conf and add those lines above all other repositories (so also above [core] and [extra]):

[catalyst]
Server = http://catalyst.apocalypsus.net/repo/catalyst/$arch

2.) Update with:

# pacman -Syu

3.) Install catalyst:

# pacman -S catalyst catalyst-utils

4.) Don't forget to prepare your /etc/X11/xorg.conf for catalyst! Use aticonfig --initial if it doesn't exist.

5.) Reboot.

Μόνο τα παραπάνω χρειάζονται , για κάρτες AMD , υποχρεωτικά aticonfig --initial & reboot, ΤΙΠΟΤΑ ΕΠΙΠΛΕΟΝ!!!

    εδώ  φαίνονται όλα τα βήματα & πώς ξεπεράστηκαν τα προβλήματα  στο τερματικό.


[[email protected] zen]# pacman -S catalyst catalyst-utils
resolving dependencies...
looking for inter-conflicts...
:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N] y
:: catalyst and xf86-video-ati are in conflict. Remove xf86-video-ati? [y/N] y
:: catalyst and ati-dri are in conflict. Remove ati-dri? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: intel-dri: requires libgl=7.11.2
:: mach64-dri: requires libgl=7.11.2
:: mga-dri: requires libgl=7.11.2
:: r128-dri: requires libgl=7.11.2
:: savage-dri: requires libgl=7.11.2
:: sis-dri: requires libgl=7.11.2
:: tdfx-dri: requires libgl=7.11.2
[[email protected] zen]#

  

  Νά  πώς ξεπεράστηκαν τα εμπόδια.

[[email protected] zen]# pacman -R xf86-video-intel
checking dependencies...

Targets (1): xf86-video-intel-2.17.0-2

Total Removed Size:     0.78 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-intel                                                                [########################################################] 100%
[[email protected] zen]# pacman -R intel-dri
checking dependencies...

Targets (1): intel-dri-7.11.2-1

Total Removed Size:     1.49 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing intel-dri                                                                       [########################################################] 100%
[[email protected] zen]# pacman -R xf86-video-mach64
checking dependencies...

Targets (1): xf86-video-mach64-6.9.0-2

Total Removed Size:     0.20 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-mach64                                                               [########################################################] 100%
[[email protected] zen]# pacman -R mach64-dri
checking dependencies...

Targets (1): mach64-dri-7.11.2-1

Total Removed Size:     0.32 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing mach64-dri                                                                      [########################################################] 100%
[[email protected] zen]# pacman -R xf86-video-mga
checking dependencies...

Targets (1): xf86-video-mga-1.4.13-4

Total Removed Size:     0.18 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-mga                                                                  [########################################################] 100%
[[email protected] zen]# pacman -R mga-dri
checking dependencies...

Targets (1): mga-dri-7.11.2-1

Total Removed Size:     0.36 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing mga-dri                                                                         [########################################################] 100%
[[email protected] zen]#          κτλ  ,  τώρα καταλάβατε τη λογική , το ίδιο κάνουμε  &  με τα υπόλοιπα πακέτα


   Προχωράμε λοιπόν

[[email protected] zen]# pacman -S catalyst catalyst-utils
resolving dependencies...
looking for inter-conflicts...
:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N] y
:: catalyst and xf86-video-ati are in conflict. Remove xf86-video-ati? [y/N] y
:: catalyst and ati-dri are in conflict. Remove ati-dri? [y/N] y

Targets (7): ati-dri-7.11.2-1 [removal]  libgl-7.11.2-1 [removal]  netkit-bsd-finger-0.17-7  xf86-video-ati-6.14.3-1 [removal]  xinetd-2.3.14-8
             catalyst-12.1-2  catalyst-utils-12.1-1

Total Download Size:    29.56 MiB
Total Installed Size:   116.92 MiB
Net Upgrade Size:       72.98 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 xinetd-2.3.14-8-i686                                                  84.2 KiB   126K/s 00:01 [########################################################] 100%
:: Retrieving packages from extra...
 netkit-bsd-finger-0.17-7-i686                                         17.6 KiB  2.10M/s 00:00 [########################################################] 100%
:: Retrieving packages from catalyst...
 catalyst-utils-12.1-1-i686                                            28.6 MiB   241K/s 02:01 [########################################################] 100%
 catalyst-12.1-2-i686                                                 875.3 KiB   294K/s 00:03 [########################################################] 100%
(4/4) checking package integrity                                                               [########################################################] 100%
(4/4) loading package files                                                                    [########################################################] 100%
(4/4) checking for file conflicts                                                              [########################################################] 100%
(7/7) checking available disk space                                                            [########################################################] 100%
(1/3) removing libgl                                                                           [########################################################] 100%
(2/3) removing xf86-video-ati                                                                  [########################################################] 100%
(3/3) removing ati-dri                                                                         [########################################################] 100%
(1/4) installing xinetd                                                                        [########################################################] 100%
Optional dependencies for xinetd
    perl: for xconv.pl script
(2/4) installing netkit-bsd-finger                                                             [########################################################] 100%
(3/4) installing catalyst-utils                                                                [########################################################] 100%
----------------------------------------------------------------
PLEASE NOTE:
For these drivers to work, you must install kernel modules.
Depending on your kernel, these module packages are named
catalyst-$kernel and stock kernel module is catalyst

OR simply use packages that provides auto re-compilation:
catalyst-hook or catalyst-daemon

OR use catalyst-generator package to generate catalyst-{kernver}
packages
----------------------------------------------------------------
You can use the tool 'aticonfig' to generate an xorg.conf file.
--------------------- ^^^^^^^^^ --------------------------------
Add nomodeset to your kernel line in /boot/grub/menu.lst , ie.:
kernel /boot/vmlinuz-linux root=/dev/sda1 ro nomodeset
----------------------------------------------------------------
For more info and troubleshooting visit:
http://wiki.archlinux.org/index.php/ATI_Catalyst
----------------------------------------------------------------
Optional dependencies for catalyst-utils
    qt: to run ATi Catalyst Control Center (amdcccle)
    libxxf86vm: to run ATi Catalyst Control Center (amdcccle)
    opencl-headers: headers necessary for OpenCL development
(4/4) installing catalyst                                                                      [########################################################] 100%
----------------------------------------------------------------
For more info and more troubleshooting visit:
http://wiki.archlinux.org/index.php/ATI_Catalyst
----------------------------------------------------------------

--------------------------- == * == ----------------------------
catalyst package has been splited between:
- catalyst (module for stock kernel)
- catalyst-utils (libs and stuff)

and optional:
- catalyst-hook (auto rebuilding script and source files)
- catalyst-daemon (auto rebuilding script and source files)
- catalyst-generator (generator of catalyst-{kernver} packages)
----------------------------------------------------------------
[[email protected] zen]#

      ΔΕΝ  χρειαζόμαστε κανένα άλλο πακέτο , δλδ catalyst-hook   κτλ ,είμαστε ΟΚ !

      δίνουμε  aticonfig --initial  &  μετά  reboot
 

   &   μερικές  τελευταίες  γραμμές που  δείχνουν  ότι ΟΛΑ λειτουργούν τέλεια.

[[email protected] ~]$ uname -a
Linux Nosonja 3.2.8-1-ARCH #1 SMP PREEMPT Mon Feb 27 22:13:59 UTC 2012 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux
[[email protected] ~]$ df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs           32G  3.5G   27G  12% /
/dev            1.6G     0  1.6G   0% /dev
/run            1.7G  584K  1.7G   1% /run
/dev/sda14       32G  3.5G   27G  12% /
shm             1.7G     0  1.7G   0% /dev/shm
tmpfs           1.7G   52K  1.7G   1% /tmp
[[email protected] ~]$ free -m
             total       used       free     shared    buffers     cached
Mem:          3280        737       2542          0         29        304
-/+ buffers/cache:        403       2876
Swap:         3071          0       3071
[[email protected] ~]$  glxinfo | grep "direct rendering"
direct rendering: Yes
[[email protected] ~]$ lspci -knn |grep VGA -A3
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4350] [1002:954f]
    Subsystem: PC Partner Limited Device [174b:e990]
    Kernel driver in use: fglrx_pci
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series] [1002:aa38]
[[email protected] ~]$ fgl_glxgears
Using GLX_SGIX_pbuffer
2967 frames in 5.0 seconds = 593.400 FPS
3098 frames in 5.0 seconds = 619.600 FPS
3088 frames in 5.0 seconds = 617.600 FPS
3089 frames in 5.0 seconds = 617.800 FPS
3100 frames in 5.0 seconds = 620.000 FPS
3089 frames in 5.0 seconds = 617.800 FPS
3086 frames in 5.0 seconds = 617.200 FPS
3095 frames in 5.0 seconds = 619.000 FPS
3100 frames in 5.0 seconds = 620.000 FPS
3090 frames in 5.0 seconds = 618.000 FPS
3088 frames in 5.0 seconds = 617.600 FPS
3101 frames in 5.0 seconds = 620.200 FPS
3094 frames in 5.0 seconds = 618.800 FPS
3084 frames in 5.0 seconds = 616.800 FPS
3093 frames in 5.0 seconds = 618.600 FPS
3099 frames in 5.0 seconds = 619.800 FPS
[[email protected] ~]$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4300/4500 Series      
OpenGL version string: 3.3.11399 Compatibility Profile Context

[[email protected] ~]$ date
Thu Mar  1 22:24:06 EET 2012
[[email protected] ~]$ compiz --version
compiz 0.8.8
[[email protected] ~]$ ccsm --version
Info: No sexy-python package found, don't worry it's optional.
CCSM 0.8.4
[[email protected] ~]$

   
    ασφαλώς , το περιβάλλον είναι full 3D Compiz-Fusion.

    Ποιός  ξέρει καλύτερα  το Linux εδώ μέσα ??? Tongue out   Είπατε τίποτα  ???  HAL9000??? 

      2   παρατηρήσεις  πολύ  χρήσιμες

  1ον-  Το πακέτο linux-headers είναι απαραίτητο μόνο όταν  θέλουμε να κάνουμε εγκατάσταση  τον κλειστό driver  για  NVIDIA  ή  AMD  , όπως αυτός  διατίθεται  ελεύθερα  για  κατέβασμα  από τα  επίσημα sites  των  2  κατασκευαστών. Ο  NVIDIA  driver  δεν  έχει κανένα πρόβλημα κατά  την  εγκατάστασή  του στο ARCH , όπως &  σε όλες τις  άλλες διανομές. Με  τον  κλειστό  AMD  driver  υπάρχει πρόβλημα  στο  ARCH  &  η  σωστή εγκατάσταση  είναι ακόμα  ΑΔΥΝΑΤΗ. Για το  λόγο αυτό ,  αναγκαστικά   κατεβάζουμε τον  catalyst  από τα  repos  του  ARCH  &   όλα  λειτουργούν  τέλεια ( full 3D Compiz-Fusion περιβάλλον ). Το πρόβλημα  αυτό  αναμένεται  να  ''διορθωθεί''  σε  νεώτερη  έκδοση.
            Ο  catalyst    driver   του  ARCH    ΔΕΝ   χρειάζεται   το   πακέτο  linux-headers ,  όπως   ΔΕΝ   χρειάζεται  &  για  τον  NVidia  driver  που  υπάρχει στα  repos  της  διανομής  (  για  όσους  ενδιαφέρονται ,  η  εγκατάστασή  του  γίνεται  με ένα  απλό 
       # pacman -S  nvidia   ,   από  τερματικό  &  ύστερα  reboot του  X  server).



   2ον-  Όσοι έχουν  στο  σύστημά  τους  κάρτα  AMD  ή  NVIDIA  ,  μετά  την  εγκατάσταση  των  ''κλειστών''  drivers  χρειάζεται  απαραιτήτως  να  προσθέσουν  την  παράμετρο  nomodeset   στη   γραμμή  για  τον  linux  kernel ,  διορθώνοντας  το  αρχείο  grub.cfg  αν  εκκινούν  με τον  grub2   ή  το  αρχείο  menu.lst  αν  εκκινούν  με  τον  grub-legacy . H  διόρθωση  γίνεται  με  τον  nano  από  τερματικό  ,  στη  διαδρομή  /boot/grub/     και   αυτό  προ-υποθέτει  ότι  ο  user  έχει  τις  στοιχειώδεις  γνώσεις  για  να  το  κάνει επιτυχώς. Αν  ΔΕΝ  κάνει  την  παραπάνω  διόρθωση , απλά  θα  είναι  ΑΔΥΝΑΤΟΝ  να  συνδεθεί  με  το  γραφικό περιβάλλον   αλλά  ούτε  και σε  περιβάλλον  κονσόλας. ( Μια  λύση  σε  αυτή  τη  δύσκολη  περίπτωση  είναι να  εκκινήσει το  linux  με  την  παράμετρο  single  στη  γραμμή  του  linux  kernel ,  για να συνδεθεί  σε  περιβάλλον  CLI  ,  στο  runlevel S ).

      εδώ  φαίνονται όλα τα  βήματα για  να απεγκαταστήσουμε τους  περιττούς  video  drivers   ώστε  να  προχωρήσει  κανονικά  η  εγκατάσταση  του  catalyst  AMD  driver  από  το  repository  του  ARCH.


[[email protected] zen]# pacman -S catalyst catalyst-utils
resolving dependencies...
looking for inter-conflicts...
:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N] y
:: catalyst and xf86-video-ati are in conflict. Remove xf86-video-ati? [y/N] y
:: catalyst and ati-dri are in conflict. Remove ati-dri? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: intel-dri: requires libgl=7.11.2
:: mach64-dri: requires libgl=7.11.2
:: mga-dri: requires libgl=7.11.2
:: r128-dri: requires libgl=7.11.2
:: savage-dri: requires libgl=7.11.2
:: sis-dri: requires libgl=7.11.2
:: tdfx-dri: requires libgl=7.11.2
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-intel
checking dependencies...

Targets (1): xf86-video-intel-2.17.0-2

Total Removed Size:     0.78 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-intel                                                                [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R intel-dri
checking dependencies...

Targets (1): intel-dri-7.11.2-1

Total Removed Size:     1.49 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing intel-dri                                                                       [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-mach64
checking dependencies...

Targets (1): xf86-video-mach64-6.9.0-2

Total Removed Size:     0.20 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-mach64                                                               [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R mach64-dri
checking dependencies...

Targets (1): mach64-dri-7.11.2-1

Total Removed Size:     0.32 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing mach64-dri                                                                      [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-mga
checking dependencies...

Targets (1): xf86-video-mga-1.4.13-4

Total Removed Size:     0.18 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-mga                                                                  [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R mga-dri
checking dependencies...

Targets (1): mga-dri-7.11.2-1

Total Removed Size:     0.36 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing mga-dri                                                                         [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-r128
checking dependencies...

Targets (1): xf86-video-r128-6.8.1-7

Total Removed Size:     0.12 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-r128                                                                 [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R r128-dri
checking dependencies...

Targets (1): r128-dri-7.11.2-1

Total Removed Size:     0.25 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing r128-dri                                                                        [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-savage
checking dependencies...

Targets (1): xf86-video-savage-2.3.3-1

Total Removed Size:     0.15 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-savage                                                               [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R savage-dri
checking dependencies...

Targets (1): savage-dri-7.11.2-1

Total Removed Size:     0.29 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing savage-dri                                                                      [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-sis
checking dependencies...

Targets (1): xf86-video-sis-0.10.3-5

Total Removed Size:     0.58 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-sis                                                                  [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R sis-dri
checking dependencies...

Targets (1): sis-dri-7.11.2-1

Total Removed Size:     0.32 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing sis-dri                                                                         [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R xf86-video-tdfx
checking dependencies...

Targets (1): xf86-video-tdfx-1.4.3-7

Total Removed Size:     0.07 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-tdfx                                                                 [########################################################] 100%
[[email protected] catalyst-12.1-2]# pacman -R tdfx-dri
checking dependencies...

Targets (1): tdfx-dri-7.11.2-1

Total Removed Size:     0.30 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing tdfx-dri                                                                        [########################################################] 100%
[[email protected] catalyst-12.1-2]#




     &  προχωράμε κανονικά

[[email protected] zen]# pacman -S catalyst catalyst-utils
resolving dependencies...
looking for inter-conflicts...
:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N] y
:: catalyst and xf86-video-ati are in conflict. Remove xf86-video-ati? [y/N] y
:: catalyst and ati-dri are in conflict. Remove ati-dri? [y/N] y

Targets (7): ati-dri-7.11.2-1
[removal]  libgl-7.11.2-1 [removal]  netkit-bsd-finger-0.17-7 
xf86-video-ati-6.14.3-1 [removal]  xinetd-2.3.14-8

             catalyst-12.1-2  catalyst-utils-12.1-1

Total Download Size:    29.56 MiB
Total Installed Size:   116.92 MiB
Net Upgrade Size:       72.98 MiB

Proceed with installation? [Y/n] Y

       *****     etc     ****

zenwalk05]  Με  τον  κλειστό  AMD  driver  υπάρχει πρόβλημα  στο  ARCH  &  η  σωστή εγκατάσταση  είναι ακόμα  ΑΔΥΝΑΤΗ. Για το  λόγο αυτό ,  αναγκαστικά   κατεβάζουμε τον  catalyst  από τα  repos  του  ARCH  &   όλα  λειτουργούν  τέλεια ( full 3D Compiz-Fusion περιβάλλον ).



Εφόσον ο catalyst είναι ο κλειστός και <<όλα  λειτουργούν  τέλεια ( full 3D Compiz-Fusion περιβάλλον ) >> πιο είναι το πρόβλημα; 
Επίσης ο catalyst βρίσκεται στο ΑUR (https://wiki.archlinux.org/index.php/AUR) και σε ανεπίσημα αποθετήρια όπως το http://catalyst.apocalypsus.net/repo/catalyst/$arch

      το  πρόβλημα  είναι μόνο  με  τον  επίσημο  driver  της  AMD  από  το  site  της , δλδ   τον  12.1 ( 8.93 ) . Στις  υπόλοιπες  διανομές ( ubuntu , openSuse , Fedora ,Mageia , Mandriva ) δεν  υπάρχει πρόβλημα κατά την  εγκατάσταση.

     Το πακέτο  catalyst  από το repo του  ARCH  είναι  μεν  κλειστός  driver  αλλά  παίζει  μόνο  για  το  ARCH LINUX , όπως  είναι αναμενόμενο. Οι  οδηγίες που  έγραψα  παραπάνω δείχνουν τον τρόπο  εγκατάστασης  από το unofficial repository  για  τον  catalyst  &  έχω  δώσει  ακριβώς  την ίδια  URL , δλδ , http://catalyst.apocalypsus.net/repo/catalyst/$arch

zenwalk05]      το  πρόβλημα  είναι μόνο  με  τον  επίσημο  driver  της  AMD  από  το  site  της , δλδ   τον  12.1 ( 8.93 ) . Στις  υπόλοιπες  διανομές ( ubuntu , openSuse , Fedora ,Mageia , Mandriva ) δεν  υπάρχει πρόβλημα κατά την  εγκατάσταση.

     Το πακέτο  catalyst  από το repo του  ARCH  είναι  μεν  κλειστός  driver  αλλά  παίζει  μόνο  για  το  ARCH LINUX , όπως  είναι αναμενόμενο. Οι  οδηγίες που  έγραψα  παραπάνω δείχνουν τον τρόπο  εγκατάστασης  από το unofficial repository  για  τον  catalyst  &  έχω  δώσει  ακριβώς  την ίδια  URL , δλδ , http://catalyst.apocalypsus.net/repo/catalyst/$arch



OK κατάλαβα τι εννοείς. Εντάξει δουλεύουν στις παραπάνω διανομές, αλλά είναι προβλεπόμενος τρόπος εγκατάστασης του κλειστού driver; Δεν ξέρω αν με καταλαβαίνεις...Θέλω να πω τον προτείνουν οι παραπάνω διανομές αυτόν τον τρόπο, εγκατάσταση εκτός package manager;

      ΔΕΝ  μπορώ  να  ξέρω άν  τον  προτείνουν οι  υπόλοιπες  διανομές  αυτό  τον  τρόπο εγκατάστασης  του κλειστού  AMD linux  driver .  Μπορώ  όμως  να  σε διαβεβαιώσω 1000% πως  τα  γραφικά  ''δουλεύουν''  περίφημα. Και  ότι  σε  κάθε  διανομή  που τρέχω , πάντα  με  τον  ίδιο ''τρόπο''  δουλεύω  το  θέμα του linux driver.
     Δλδ ,  και  παλαιότερα ( πριν 3 μήνες ) που  είχα  στο  PC  την NVIDIA κάρτα ( 8400 GS  256 MB )  , πάλι  με  τον  ίδιο  τρόπο   δούλευα ,  και ΔΕΝ  συνάντησα  ΠΟΤΈ   κανένα  πρόβλημα.
     Με  την   Radeon HD 4350  512  MB ,  με  τις  ARCH-based  διανομές  μου  έβγαινε  πρόβλημα  στον  X  server ,  κατά  την  επόμενη  αναβάθμιση  του  πυρήνα . Υπόψιν  ότι  η  όλη '' εμπειρία '' μου  με το  ARCH  είναι  μέσα  από  τα  derivatives  ARCHBANG ,  BRIDGE  &  τελευταία  με  το  NOSONJA LINUX ,  μετά  από  κανονική  εγκατάστασή  τους σε  μία  από  τις  πάμπολλες  κατατμήσεις  που  έχω  στη  διάθεσή   μου σε  3  δίσκους.
      Ενα πολύ  μικρότερο ''προβληματάκι''  υπάρχει  επίσης  &  με  το  Fedora 16  , αλλά  βρήκα  ένα  πάρα  πολύ  εύκολο  ''trick''  να  το  ξεπεράσω ,  μέσω  του  boot  prompt    του  bootloader  (  έχω  προσθέσει  την παράμετρο   single   στο  ''boot  entry''  του  Fedora  &   μετά  δίνω  init 3  &  τέλος  startx  για  να μπώ  στο  GUI  ).

      Θα  ήθελα  να  προσθέσω  ότι  αυτή  τη  στιγμή  το  Nosonja Linux  , με  full  3D  Compiz-Fusion  υποστήριξη  μέσα από το  live-cd ,    είναι  πραγματικά  ένα  διαμάντι  του  LINUX  &    θα έπρεπε  να  υπάρχει  σε  κάθε  linux  desktop  γιατί  είναι  σφαιράτο , πλήρες  &  πολύ  εύκολο  σε  όλα.  Οπωσδήποτε  κάθε  λινουξάς  οφείλει   να  το   εγκαταστήσει στο  δίσκο ,  το  θεωρώ  σαν  ...ξαδερφάκι  του   Fedora   αλλά  ακόμα  πιό  προχωρημένο  &  ''φορά''  & τον  πιό καινούριο   kernel 3.2.8-1.   (  το Fedora  είναι ακόμα  με τον 3.2.7-1)

    &  ύστερα πάλι ,  από  τη  στιγμή  που  κυκλοφορούν κατά διαστήματα &  οι  δύο  κάρτες ( AMD & NVidia )  τις  καινούριες  εκδόσεις  για τους linux drivers τους ,  πάει να πεί  πως  είναι αναμενόμενο  να  δουλεύουν σωστά  με τις διάφορες διανομές. Με  την  NVidia πάντως ΔΕΝ  θα έχουμε ποτέ  πρόβλημα  , παρά μόνο αν  το  σύστημα  γραφικών  είναι  ''hybrid''  ή  τεχνολογίας ''optimus''  , όπως με τα νέα laptops  με  Intel CPU  i3 , i5 & i7   second  generation.  Με  τα  αντίστοιχα  μοντέλα  πρώτης  γεννιάς  δεν  υπάρχει  πρόβλημα ,  γιατί  η  CPU  ΔΕΝ  έχει  ενσωματωμένα  γραφικά  μέσα.  Προαπαιτούμενα  είναι  να  έχουμε  στη  διανομή  τα  πακέτα  gcc  , make  &  linux-headers  για  το  ARCH ,    kernel-devel   για τα  Fedora Mageia , Mandriva , PCLinuxOS , CentOS , Scientific κτλ (  RPMs  διανομές )  ,  για τα  Ubuntus  τα linux-generic , linux-headers-generic & linux-image-generic  & τέλος  για το  openSuse  τα  πακέτα  kernel-devel , kernel-source , kernel-syms &  patch.
     Σε  όλες  τις  διανομές  απαραιτήτως  τα  gcc & make.

Πάντως και τα τρία (ARCHBANG ,  BRIDGE  & NOSONJA LINUX)  χρησιμοποιούν τα αποθετήρια του Arch.

     Πρόβλημα  με  την  αναβάθμιση  του  συστήματος. Το  pacman -Syu  ΔΕΝ αναβαθμίζει &
απ' ό,τι φαίνεται  το  πρόβλημα  οφείλεται  στον  catalyst. Στο αμέσως προηγούμενο  update 
όλα  έγιναν κανονικά. Καμιά  ιδέα για  το τί μπορεί  να  γίνει ?

[[email protected] ~]$ uname -a
Linux Nosonja 3.2.9-1-ARCH #1 SMP PREEMPT Thu Mar 1 09:10:44 UTC 2012 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux
[[email protected] ~]$ df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs           32G   12G   19G  40% /
/dev            1.6G     0  1.6G   0% /dev
/run            1.7G  588K  1.7G   1% /run
/dev/sda14       32G   12G   19G  40% /
shm             1.7G     0  1.7G   0% /dev/shm
tmpfs           1.7G   44K  1.7G   1% /tmp
[[email protected] ~]$ su
[[email protected] zen]# pacman -Sy
:: Synchronizing package databases...
 nosonja-stable                                                        15.2 KiB  47.6K/s 00:00 [########################################################] 100%
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
 catalyst is up to date
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils: requires xorg-server<1.12.0
[[email protected] zen]# date
Tue Mar 13 23:37:52 EET 2012
[[email protected] zen]#


  Δοκίμασα το πακέτο xorg-server. Τίποτα πάλι.


[[email protected] zen]# pacman -S xorg-server
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils: requires xorg-server<1.12.0
[[email protected] zen]#

Πολύ καλή διανομή και σε ευχαριστώ που μας την σύστησες φίλε μου.
Δεν αντιμετωπίζω παρόμοιο πρόβλημα γιατί έχω nvidia κάρτα γραφικών και οι αναβαθμίσεις γίνονται κανονικά.
Μερικά προβληματάκια που είχα (ένα από αυτά ήταν να μην βλέπει καμιά διανομή από της τρεις που έχω το swap) τα έλυσα πολύ εύκολα με λίγο ψάξιμο βεβαία.

Ο τωρινός catalyst δεν υποστηρίζει τον xorg-server 1.12 (όπου τώρα είναι στο extra repository και με το update που προσπαθείς να κάνεις πρόκειται να μπει) γι' αυτό το λόγο δεν μπορείς να κάνεις την αναβάθμιση.

Στη σελίδα του πακέτου στο AUR προτείνουν τη χρήση ενός repo[1] που περιέχει τον xorg-server 1.11

[1] https://wiki.archlinux.org/index.php/ATI_Catalyst#Xorg-server_repositor… (είναι το [xorg111] repo)

Μην ξεχάσεις να το βάλεις πάνω από τα άλλα repositories για να έχει προτεραιότητα.



   thanks  Thano , το πρόβλημα  λύθηκε , μόνο που  χρειάστηκε να  απεγκαταστήσω  από το  τερματικό  μια  σειρά  από  ατέλειωτους  ''άχρηστους''  video drivers  , που έρχονταν  σε  ''σύγκρουση''  με  τον  catalyst , όπως φαίνεται παρακάτω. Μάλλον θα ξαναβάλω  μια  NVIDIA  silent  520  στο  σύστημα  ,  γιατί  &  με  το  Fedora 16  είναι ακριβώς  το  ίδιο , μόνο που  ΔΕΝ  υπάρχει  λύση.


[[email protected] zen]# pacman -Sy
warning: database file for 'xorg111' does not exist
:: Synchronizing package databases...
 xorg111                                                               10.2 KiB  88.5K/s 00:00 [########################################################] 100%
 catalyst is up to date
 nosonja-stable                                                        15.2 KiB  45.2K/s 00:00 [########################################################] 100%
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-ark and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-ark and xorg-server are in conflict (xorg-server<1.11.99.902)
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-ark and xorg-server are in conflict. Remove xorg-server? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils: requires xorg-server>=1.7.0
:: catalyst-utils: requires xorg-server<1.12.0
:: lxdm-nosonja: requires xorg-server
[[email protected] zen]# pacman -R xf86-video-ark
checking dependencies...

Targets (1): xf86-video-ark-0.7.3-4

Total Removed Size:     0.02 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-ark                                                                  [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-ast and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-ast and xorg-server are in conflict (xorg-server<1.11.99.902)
[[email protected] zen]# pacman -R xf86-video-ast
checking dependencies...

Targets (1): xf86-video-ast-0.93.9-1

Total Removed Size:     0.08 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-ast                                                                  [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-chips and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-chips and xorg-server are in conflict (xorg-server<1.11.99.902)
[[email protected] zen]# pacman -R xf86-video-chips
checking dependencies...

Targets (1): xf86-video-chips-1.2.4-3

Total Removed Size:     0.15 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-chips                                                                [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-cirrus and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-cirrus and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-cirrus
checking dependencies...

Targets (1): xf86-video-cirrus-1.3.2-7

Total Removed Size:     0.09 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-cirrus                                                               [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-dummy and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-dummy and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-dummy
checking dependencies...

Targets (1): xf86-video-dummy-0.3.4-5

Total Removed Size:     0.02 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-dummy                                                                [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-glint and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-glint and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-glint
checking dependencies...

Targets (1): xf86-video-glint-1.2.6-1

Total Removed Size:     0.23 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-glint                                                                [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-i128 and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-i128 and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-i128
checking dependencies...

Targets (1): xf86-video-i128-1.3.4-4

Total Removed Size:     0.07 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-i128                                                                 [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-i740 and xorg-server are in conflict. Remove xorg-server? [y/N] ^N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-i740 and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-i740
checking dependencies...

Targets (1): xf86-video-i740-1.3.2-7

Total Removed Size:     0.05 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-i740                                                                 [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-neomagic and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-neomagic and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-neomagic
checking dependencies...

Targets (1): xf86-video-neomagic-1.2.5-5

Total Removed Size:     0.08 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-neomagic                                                             [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-nv and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-nv and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-nv
checking dependencies...

Targets (1): xf86-video-nv-2.1.18-4

Total Removed Size:     0.18 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-nv                                                                   [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-rendition and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-rendition and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-rendition
checking dependencies...

Targets (1): xf86-video-rendition-4.2.4-5

Total Removed Size:     0.11 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-rendition                                                            [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-s3 and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-s3 and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-s3
checking dependencies...

Targets (1): xf86-video-s3-0.6.3-6

Total Removed Size:     0.07 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-s3                                                                   [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-s3virge and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-s3virge and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-s3virge
checking dependencies...

Targets (1): xf86-video-s3virge-1.10.4-6

Total Removed Size:     0.08 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-s3virge                                                              [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-siliconmotion and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-siliconmotion and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-siliconmotion
checking dependencies...

Targets (1): xf86-video-siliconmotion-1.7.5-3

Total Removed Size:     0.12 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-siliconmotion                                                        [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-sisusb and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-sisusb and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-sisusb
checking dependencies...

Targets (1): xf86-video-sisusb-0.9.4-5

Total Removed Size:     0.08 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-sisusb                                                               [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-trident and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-trident and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-trident
checking dependencies...

Targets (1): xf86-video-trident-1.3.4-5

Total Removed Size:     0.16 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-trident                                                              [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-tseng and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-tseng and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-tseng
checking dependencies...

Targets (1): xf86-video-tseng-1.2.4-5

Total Removed Size:     0.06 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-tseng                                                                [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-v4l and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-v4l and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-v4l
checking dependencies...

Targets (1): xf86-video-v4l-0.2.0-9

Total Removed Size:     0.07 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-v4l                                                                  [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-vmware and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-vmware and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-vmware
checking dependencies...

Targets (1): xf86-video-vmware-11.1.0-1

Total Removed Size:     0.07 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-vmware                                                               [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-voodoo and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-voodoo and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-voodoo
checking dependencies...

Targets (1): xf86-video-voodoo-1.2.4-5

Total Removed Size:     0.04 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-voodoo                                                               [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xf86-video-xgixp and xorg-server are in conflict. Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-xgixp and xorg-server are in conflict (xorg-server<1.11.99.903)
[[email protected] zen]# pacman -R xf86-video-xgixp
checking dependencies...

Targets (1): xf86-video-xgixp-1.8.0-4

Total Removed Size:     0.14 MiB

Do you want to remove these packages? [Y/n] Y
(1/1) removing xf86-video-xgixp                                                                [########################################################] 100%
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (25): freetype2-2.4.9-1  glproto-1.4.15-1  grep-2.11-2  gstreamer0.10-0.10.36-1  gstreamer0.10-bad-0.10.23-1  gstreamer0.10-base-0.10.36-1
              gstreamer0.10-base-plugins-0.10.36-1  gstreamer0.10-good-0.10.31-1  imagemagick-6.7.6.0-1  inputproto-2.2-1  libglapi-8.0.1-2
              libpciaccess-0.13-1  libtiff-4.0.1-1  libx11-1.4.99.1-1  libxcb-1.8.1-1  libxft-2.3.0-2  libxi-1.6.0-1  libxt-1.1.2-2  man-pages-3.37-1
              mesa-8.0.1-2  mpfr-3.1.0.p7-1  poppler-0.18.4-1  thunar-1.2.3-5  xcb-proto-1.7-2  xf86-video-geode-2.11.13-1

Total Download Size:    22.84 MiB
Total Installed Size:   115.22 MiB
Net Upgrade Size:       18.50 MiB

Proceed with installation? [Y/n] Y
:: Retrieving packages from core...
 grep-2.11-2-i686                                                     170.4 KiB   151K/s 00:01 [########################################################] 100%
 man-pages-3.37-1-any                                                   4.4 MiB   750K/s 00:06 [########################################################] 100%
 mpfr-3.1.0.p7-1-i686                                                 365.2 KiB   159K/s 00:02 [########################################################] 100%
:: Retrieving packages from extra...
 freetype2-2.4.9-1-i686                                               570.0 KiB   179K/s 00:03 [########################################################] 100%
 glproto-1.4.15-1-any                                                  15.2 KiB  2030K/s 00:00 [########################################################] 100%
 gstreamer0.10-0.10.36-1-i686                                        1393.8 KiB   183K/s 00:08 [########################################################] 100%
 gstreamer0.10-base-0.10.36-1-i686                                   1264.9 KiB   457K/s 00:03 [########################################################] 100%
 gstreamer0.10-bad-0.10.23-1-i686                                    1017.2 KiB   844K/s 00:01 [########################################################] 100%
 gstreamer0.10-base-plugins-0.10.36-1-i686                            169.5 KiB   140K/s 00:01 [########################################################] 100%
 gstreamer0.10-good-0.10.31-1-i686                                    968.1 KiB   287K/s 00:03 [########################################################] 100%
 xcb-proto-1.7-2-any                                                   55.7 KiB  2.08M/s 00:00 [########################################################] 100%
 libxcb-1.8.1-1-i686                                                  327.9 KiB   694K/s 00:00 [########################################################] 100%
 libx11-1.4.99.1-1-i686                                                 2.0 MiB   151K/s 00:14 [########################################################] 100%
 libxt-1.1.2-2-i686                                                   533.2 KiB   328K/s 00:02 [########################################################] 100%
 imagemagick-6.7.6.0-1-i686                                          1920.6 KiB   260K/s 00:07 [########################################################] 100%
 inputproto-2.2-1-any                                                  73.3 KiB   306K/s 00:00 [########################################################] 100%
 libglapi-8.0.1-2-i686                                                 16.1 KiB  2.02M/s 00:00 [########################################################] 100%
 libpciaccess-0.13-1-i686                                              29.4 KiB  2.08M/s 00:00 [########################################################] 100%
 libtiff-4.0.1-1-i686                                                 835.1 KiB   174K/s 00:05 [########################################################] 100%
 libxft-2.3.0-2-i686                                                   42.0 KiB   185K/s 00:00 [########################################################] 100%
 libxi-1.6.0-1-i686                                                   135.3 KiB   290K/s 00:00 [########################################################] 100%
 mesa-8.0.1-2-i686                                                      3.4 MiB   205K/s 00:17 [########################################################] 100%
 poppler-0.18.4-1-i686                                                771.8 KiB   545K/s 00:01 [########################################################] 100%
 thunar-1.2.3-5-i686                                                    2.6 MiB   442K/s 00:06 [########################################################] 100%
 xf86-video-geode-2.11.13-1-i686                                      106.5 KiB   235K/s 00:00 [########################################################] 100%
(25/25) checking package integrity                                                             [########################################################] 100%
(25/25) loading package files                                                                  [########################################################] 100%
(25/25) checking for file conflicts                                                            [########################################################] 100%
(25/25) checking available disk space                                                          [########################################################] 100%
( 1/25) upgrading freetype2                                                                    [########################################################] 100%
( 2/25) upgrading glproto                                                                      [########################################################] 100%
( 3/25) upgrading grep                                                                         [########################################################] 100%
( 4/25) upgrading gstreamer0.10                                                                [########################################################] 100%
( 5/25) upgrading gstreamer0.10-base                                                           [########################################################] 100%
( 6/25) upgrading gstreamer0.10-bad                                                            [########################################################] 100%
( 7/25) upgrading gstreamer0.10-base-plugins                                                   [########################################################] 100%
( 8/25) upgrading gstreamer0.10-good                                                           [########################################################] 100%
( 9/25) upgrading xcb-proto                                                                    [########################################################] 100%
(10/25) upgrading libxcb                                                                       [########################################################] 100%
(11/25) upgrading libx11                                                                       [########################################################] 100%
(12/25) upgrading libxt                                                                        [########################################################] 100%
(13/25) upgrading imagemagick                                                                  [########################################################] 100%
(14/25) upgrading inputproto                                                                   [########################################################] 100%
(15/25) upgrading libglapi                                                                     [########################################################] 100%
(16/25) upgrading libpciaccess                                                                 [########################################################] 100%
(17/25) upgrading libtiff                                                                      [########################################################] 100%
(18/25) upgrading libxft                                                                       [########################################################] 100%
(19/25) upgrading libxi                                                                        [########################################################] 100%
(20/25) upgrading man-pages                                                                    [########################################################] 100%
(21/25) upgrading mesa                                                                         [########################################################] 100%
(22/25) upgrading mpfr                                                                         [########################################################] 100%
(23/25) upgrading poppler                                                                      [########################################################] 100%
(24/25) upgrading thunar                                                                       [########################################################] 100%
(25/25) upgrading xf86-video-geode                                                             [########################################################] 100%
[[email protected] zen]# uname -a
Linux Nosonja 3.2.9-1-ARCH #1 SMP PREEMPT Thu Mar 1 09:10:44 UTC 2012 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux
[[email protected] zen]# pacman -Sy
:: Synchronizing package databases...
 xorg111 is up to date
 catalyst is up to date
 nosonja-stable                                                        15.2 KiB  44.9K/s 00:00 [########################################################] 100%
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
[[email protected] zen]# pacman -Su
:: Starting full system upgrade...
 there is nothing to do
[[email protected] zen]# date
Wed Mar 14 12:39:51 EET 2012
[[email protected] zen]#

Πολυ καλο και επιτελους βρεθηκα κοντα στο arch .

 

Μερικες ερωτησεις μονο αν ειναι ευκολο να απαντηθουν ?

1.Χανει καπoιες φορες τα περιγραματα στα παραθυρα (κουμπια σμικρυνσης εξοδου απουσιαζουν τελειως)

με reload window manager απο το compiz fusion icon επανερχονται αλλα μηπως υπαρχει καμια ποιο αποδοτικη και μονιμη λυση (δεν με ενδιαφερουν κυβοι κουνηματα και αλλα κολπα οποτε αν χρειαζεται να αφαιρεθουν κανενα προβλημα)

2. Απο αυτο το σημειο και μετα (που ολα λειτουργουν ικανοποιητικα) μπορω να γυρισω σε καθαρο arch

και να κανω οτι αλαγες θελω μετα η υπαρχουν δεσμευσεις σε αρχεια που χρειαζεται να ανανεονται απο nosonja ?

2) Εκτός από το repo nosonja-stable που δεν γνωρίζω τι πακέτα έχει μέσα και κατά πόσο επηρεάζουν το σύστημα,μπορείς εύκολα να το γυρίσεις σε καθαρό arch.

Για σιγουριά από κονσόλα δώσε την εντολή:

pacman -Sl nosonja-stable

για να δούμε τα πακέτα του repo.

    Δεν έγραψες με  ποιά  κάρτα  έχεις το πρόβλημα  με τα ''περιγράμματα''  που  εξαφανίζονται  από τα  παράθυρα. NVIDIA  ή AMD  ?

    Τοποθέτησα  μια  NVIDIA GeForce GT 520  ASUS silent  με  1  GB SDDR3 RAM  , για  να  μην  έχω  πρόβλημα  με  τον  video driver  τόσο για  το Nososnja-Arch  όσο & με το Fedora 16 Lxde &  ΔΕΝ  εμφανίστηκε  ποτέ  το πρόβλημα αυτό. Αλλά  το  ίδιο , ποτέ δεν βγήκε  πρόβλημα όσο  είχα  την  AMD Radeon HD  4350 Sapphire  512 MB ,  σε  περιβάλλον  full 3D Compiz-Fusion πάντα. Έκανα ξανά  εγκατάσταση το  Nosonja-Arch  32bit  σε  ένα  άλλο partition  &  όλα  λειτουργούν  τέλεια.
    Έχω τον  original  NVIDIA-Linux-x86-295.20  driver  από το  official site  της  Nvidia  ,  ο  οποίος  για  να  εγκατασταθεί  χρειάζεται  ΟΠΩΣΔΗΠΟΤΕ  το  πακέτο  linux-headers , δλδ πρέπει  να δώσουμε  μετά   την  ολική  αναβάθμιση  της  διανομής από τερματικό

   # pacman -S linux-headers    


  παρακάτω  φαίνονται μερικές πληροφορίες για την καινούρια εγκατάσταση  του Nosonja


 [[email protected] ~]$ uname -a
Linux Nosonja 3.2.11-1-ARCH #1 SMP PREEMPT Thu Mar 15 09:16:03 UTC 2012 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux
[[email protected] ~]$ df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs           32G  3.5G   27G  12% /
/dev            1.6G     0  1.6G   0% /dev
run             1.6G  624K  1.6G   1% /run
/dev/sda6        32G  3.5G   27G  12% /
shm             1.6G     0  1.6G   0% /dev/shm
tmpfs           1.6G   52K  1.6G   1% /tmp
[[email protected] ~]$ free -m
             total       used       free     shared    buffers     cached
Mem:          3153        551       2601          0         26        245
-/+ buffers/cache:        279       2874
Swap:         3071          0       3071
[[email protected] ~]$ glxinfo | grep "direct rendering"
direct rendering: Yes
[[email protected] ~]$ glxgears
28635 frames in 5.0 seconds = 5726.839 FPS
29212 frames in 5.0 seconds = 5842.250 FPS
29208 frames in 5.0 seconds = 5841.523 FPS
29212 frames in 5.0 seconds = 5842.231 FPS
29212 frames in 5.0 seconds = 5842.264 FPS
29211 frames in 5.0 seconds = 5842.034 FPS
29206 frames in 5.0 seconds = 5840.978 FPS
29218 frames in 5.0 seconds = 5843.531 FPS
29216 frames in 5.0 seconds = 5843.152 FPS
29216 frames in 5.0 seconds = 5843.173 FPS
29202 frames in 5.0 seconds = 5840.399 FPS
29209 frames in 5.0 seconds = 5841.729 FPS
29215 frames in 5.0 seconds = 5842.952 FPS
29208 frames in 5.0 seconds = 5841.505 FPS
29214 frames in 5.0 seconds = 5842.749 FPS
29219 frames in 5.0 seconds = 5843.618 FPS
[[email protected] ~]$ glxinfo | grep renderer
OpenGL renderer string: GeForce GT 520/PCIe/SSE2/3DNOW!
[[email protected] ~]$ date
Sun Mar 18 15:52:19 EET 2012
[[email protected] ~]$ compiz --version
compiz 0.8.8
[[email protected] ~]$ ccsm --version
Info: No sexy-python package found, don't worry it's optional.
CCSM 0.8.4
[[email protected] ~]$

 

  Νά  και  τα  αποτελέσματα για  τα  περιεχόμενα του  repo nosonja-stable


 [[email protected] ~]$ pacman -Sl nosonja-stable
nosonja-stable alacarte-xfce 0.13.2-2 [installed]
nosonja-stable avant-window-navigator 0.4.0-12 [installed]
nosonja-stable awn-extras-applets 0.4.0-13 [installed]
nosonja-stable b43-firmware 5.100.138-1 [installed]
nosonja-stable chromium-stable-libpdf 17.0.963.79-1 [installed]
nosonja-stable downgrade 2.0.3-1 [installed]
nosonja-stable faenza-icon-theme 1.2-2 [installed]
nosonja-stable fbsplash 1.5.4.4-7 [installed]
nosonja-stable fbsplash-extras 3.0-1 [installed]
nosonja-stable fbsplash-theme-nosonja 2012.02-1 [installed]
nosonja-stable gdevilspie 0.5-1
nosonja-stable gnome-menus2 3.0.1-1 [installed]
nosonja-stable gtk-engine-unico 1.0.1-2 [installed]
nosonja-stable libdesktop-agnostic 0.3.92-3 [installed]
nosonja-stable libindicator 0.4.1-2 [installed]
nosonja-stable libreoffice-installer 0.6-1 [installed]
nosonja-stable lxdm-nosonja 0.4.1-7 [installed]
nosonja-stable mint-z-theme 1.1.4-1
nosonja-stable miscsplashutils 0.1.8-3 [installed]
nosonja-stable nosonja-mirrorlist 20120226-1 [installed]
nosonja-stable nosonja-skel-xfce 2012.02-1 [installed]
nosonja-stable nosonja-system 2012.02-1 [installed]
nosonja-stable nosonja-update 0.0.6-1 [installed]
nosonja-stable pacmanxg-bin 2.21-1
nosonja-stable pacmanxg4-bin 4.9.5-2 [installed]
nosonja-stable uget 1.8.0-1
nosonja-stable vcp 2.2-4 [installed]
nosonja-stable vlsub 0.6-1
nosonja-stable x11-keyboard-layout-switcher 1.0-1 [installed]
nosonja-stable xfce-theme-greybird 0.5-1 [installed]
nosonja-stable xfce-theme-nosonja 2012.02-2 [installed]
nosonja-stable yad 0.17.1.1-1 [installed]
nosonja-stable yapan 0.4.1-1 [installed]
[[email protected] ~]$

   Και μιά ακόμα  εντολή  για  την  κάρτα  γραφικών

[[email protected] ~]$ lspci -knn |grep VGA -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0de4] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:83d2]
    Kernel driver in use: nvidia
01:00.1 Audio device [0403]: NVIDIA Corporation GF108 High Definition Audio Controller [10de:0bea] (rev a1)
[[email protected] ~]$

  
   

    Το  Nosonja  είναι  ένα  πλήρες &  καθαρόαιμο  Arch  που  έρχεται  με  XFCE-4  σε  live-cd  &  η  εγκατάστασή  του  γίνεται  πολύ  γρήγορα  με  τον  installer , ενώ  είναι  ακόμα  πιό
εύκολο  στο  χειρισμό  και  από  Ubuntu. Μιά  διανομή  που  πρέπει  να  υπάρχει  σε  κάθε  linux desktop σύστημα.

     Το  μοναδικό  ''μειονέκτημα'' να  τρέχουμε  τον  original  NVIDIA-Linux-x86  driver  είναι  ότι  χρειάζεται  κάθε φορά  που  αναβαθμίζεται  ο  πυρήνας   της  διανομής  να  κάνουμε  απεγκατάστασή  του από  τερματικό  , reboot  &  ξανά  εγκατάστασή  του. Και αυτό  ισχύει &  για  κάθε  άλλη  διανομή.
 
  Μιά  πιό  εύκολη  λύση  είναι  να  χρησιμοποιούμε  το  έτοιμο  πακέτο για  τον  NVidia-driver  της  ίδιας  της  διανομής  δίνοντας  ένα  απλό

    #  pacman -S  nvidia

     Για  την  περίπτωση  που  θέλουμε να  τρέχουμε  το  έτοιμο  πακέτο  της  διανομής για  τον  NVidia video  driver  ,  ΔΕΝ  χρειαζόμαστε  το  πακέτο  linux-headers  ,  δλδ ,  ΔΕΝ  χρειάζεται  να  δώσουμε  την  εντολή

     #  pacman  -S  linux-headers    

     γιατί  ΔΕΝ  είναι  προαπαιτούμενο  για  τον  ''έτοιμο''  driver  της  διανομής.

Σε λαπτοπ toshiba το εχω βαλει και εχει τον controller της intel

 

 

 

[[email protected] ~]$ lspci -knn|grep VGA -A3

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)
Subsystem: Toshiba America Info Systems Device [1179:ff04]
Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 03)

Σχετικά με τα πακέτα,εκτός από τα

  • nosonja-stable lxdm-nosonja 0.4.1-7 [installed] --πρέπει να είναι το lxde από το community repo
  • nosonja-stable nosonja-mirrorlist 20120226-1 [installed] -- το πακέτο pacman-mirrorlist από το core repo
  • nosonja-stable nosonja-system 2012.02-1 [installed] -- πρέπει να είναι το πεκέτο filesystem από το core repo
  • nosonja-stable nosonja-update 0.0.6-1 [installed] --δεν έχω ιδέα ποιο πακέτο μπορεί να είναι :p


όλα τα υπόλοιπα υπάρχουν στο AUR.


Και αυτό nosonja-stable libreoffice-installer 0.6-1 [installed] δεν χρειάζεται.Αρκεί ένα

pacman -S libreoffice

για την εγκατάσταση.

      με  την  intel 915  κάρτα  του  laptop  ΔΕΝ  μπορείς  να  έχεις τα εφφέ  του  Compiz-Fusion  γιατί   χρειάζεται  να  υπάρχει  μιά  NVidia  ή  AMD.    &  χάνεται  το  ''περίγραμμα''  από  τα  παράθυρα  όταν  επιχειρείς  να ''τρέξεις''  το  3D  desktop   σε   μηχάνημα  που  απλά  είναι  ΑΔΥΝΑΤΟ  να  το  ''τρέξει''.  Οπότε  ΔΕΝ  ενεργοποιείς  το  3D  desktop  από  το  εικονίδιο  fusion-icon  &  είσαι  μιά  χαρά  σε  2D  desktop.

    Τα  πράγματα  ΔΕΝ  θα  ήταν  καλύτερα  για  σένα  αν   είχες   ένα  laptop  με  NVidia κάρτα  ανεξάρτητη  ,  αλλά  με  μια  CPU   Intel  i3  i5  i7    2ης  γεννιάς. Γιατί  πάλι  ο  NVidia  driver  ΔΕΝ   θα  μπορούσε  να  τρέξει ,  λόγω  integrated  graphics  μέσα   στην  ΚΑΤΑΡΑΜΕΝΗ    CPU  της   Intel. 

    ΔΕΝ  θα  είχες  πρόβλημα  μόνο  εάν  η  Intel  CPU  i3  i5  i7  ήταν    πρώτης  γεννιάς.

     Το  ξέρω   πολύ  καλά  αυτό  γιατί  έχω  ένα   laptop  με  NVidia 525 M   1GB  , αλλά  με  i3  δεύτερης  γεννιάς.

Καλημερα επανερχομαι με δυο ερωτησεις που πιθανον να εχετε και λυση.

 

!. Χρησιμοποιοντας το απλετ απο το xfce4 γιααλλαγη πληκτρολογιου δεν κραταει τις ρυθμισεις

2. Samba server ενω υπαρχει στους daemons και εχει ξεκινησει, τα share τα βλεπει το δικτυο μονο

αφου γινει ρεσταρτ του samba server

 

[[email protected] ~]$ testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Processing section "[public]"
WARNING: The security=share option is deprecated
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
server string = Samba Server
security = SHARE
guest account = root
log file = /var/log/samba/%m.log
max log size = 50
local master = No
domain master = No
dns proxy = No
idmap config * : backend = tdb
hosts allow = 192.168.0., 192.168.1., 127.

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
guest ok = Yes
printable = Yes
print ok = Yes
browseable = No

[public]
path = /home/gmouzo/Downloads
read only = No
guest ok = Yes

Γιαυτο το λογο, λεμε παντα οτι μια πακετοποιηση ενος χρηστη ΔΕΝ αποτελει διανομη. Ετσι και εδω - οπως και στο ανεκδιηγητο Bridge Linux - τα προβληματα που προκυπτουν θα επρεπε να απαντηθουν απο τον κατασκευαστη τους - ο οποιος ομως ουτε κοινοτητα εχει δημιουργησει, ουτε μπορει να ασχοληθει με τα προβληματα του καθενα απο εμας.

Αν θελει καποιος να "βιωσει" τη εμπειρια του Archlinux - αρκει να κατεβασει και να εγκαταστησει το επισημο cd της διανομης. Και οτι προβλημα αντιμετωπισει απο εκει και περα, υπαρχει και κοινοτητα (και Ελληνικη)  και Wiki για να αποτανθει.

Οσον αφορα φιλε gmouzo το θεμα των Ελληνικων - ισχυουν τα οσα αναφερονται σε διαφορα σημεια του Επισημου Wiki του Archlinux πχ

Switching_Between_Keyboard_Layouts

Ρυθμίσεις πληκτρολογίου





 

Εχεις δικιο φιλε herco

Αλλα σαν πρωτη επαφη με arch πιστευω οτι ειναι μια καλη προσπαθεια

που σε βαζει και κατευθειαν σε γραφικο περιβαλον

Τωρα απο εκει και περα ειναι στο χερι του καθενας μας αν θα προχωρησει μετα σε μια καθαρη εγκατασταση

arch

gmouzo]

Καλημερα επανερχομαι με δυο ερωτησεις που πιθανον να εχετε και λυση.

 

!. Χρησιμοποιοντας το απλετ απο το xfce4 γιααλλαγη πληκτρολογιου δεν κραταει τις ρυθμισεις



Αυτό είναι bug του xkb-plugin. Στο wiki του arch υπάρχει ένα workaround που ίσως σου λύσει τα χέρια. https://wiki.archlinux.org/index.php/Xfce#Xfce4-xkb-plugin_settings_issue
Αν και έχω κι εγώ το ίδιο πρόβλημα στο xfce4 δεν το έχω δοκιμάσει ακόμα γιατί δεν είναι το βασικό μου DE.

herco]Γιαυτο το λογο, λεμε παντα οτι μια πακετοποιηση ενος χρηστη ΔΕΝ αποτελει διανομη. Ετσι και εδω - οπως και στο ανεκδιηγητο Bridge Linux - τα προβληματα που προκυπτουν θα επρεπε να απαντηθουν απο τον κατασκευαστη τους - ο οποιος ομως ουτε κοινοτητα εχει δημιουργησει, ουτε μπορει να ασχοληθει με τα προβληματα του καθενα απο εμας.

Αν θελει καποιος να "βιωσει" τη εμπειρια του Archlinux - αρκει να κατεβασει και να εγκαταστησει το επισημο cd της διανομης. Και οτι προβλημα αντιμετωπισει απο εκει και περα, υπαρχει και κοινοτητα (και Ελληνικη)  και Wiki για να αποτανθει.



Από τη στιγμή που παραμένει ένα custom archlinux ενός χρήστη και δεν έχει ξεφύγει με τη χρήση δικών του εφαρμογών,ποιος ο λόγος να δημιουργήσει κοινότητα γι' αυτό ;; Τα ίδια προβλήματα θα έχει με τη βασική διανομή και τις απαντήσεις θα τις πάρει από την ίδια κοινότητα του arch.

Τώρα αν κάποιος έκανε ένα custom iso και το έδωσε στο λάο με κάποιους από αυτούς να ασχολήθηκαν με αυτό είναι άλλο θέμα.Π.χ μερικοί δεν θέλουν να μπλέξουν με την εγκατάσταση του arch.

@thanos

Μα δεν ισχυριστηκα οτι πρεπει να δημιουργησει κοινοτητα για εναν custom installer που εφτιαξε. Λεω το αυτονοητο οτι ο μονος που ξερει τι και πως το πακεταρε ειναι ο ιδιος και οτι προβλημα δημιουργηθει και παταει πανω στο customization του δεν μπορει να απαντηθει παραμονο απο τον ιδιο.

Επισης ξαναλεω οτι τετοιες προσπαθειες ναι μεν δειχνουν την ενασχοληση του κοσμου με το Archlinux - αλλα σε καμια περιπτωση δεν μπορουν να συγκριθουν με την ιδια τη διανομη. Ειδικα στη περιπτωση του Arch που αλλαζει μερα με τη μερα.

Σου θυμιζω σοβαροτερες προσπαθειες - οχι ενος χρηστη δηλαδη - οπως το ArchBang - που ΔΕΝ ειναι ενα Arch με Openbox οπως λανθασμενα αναφερεται ακομα και στο forum εδω. Ειναι χτισμενο διαφορετικα - δουλευει με HAL (που εχει "φυγει" απο το Arch εδω και 2 χρονια) και τα προβληματα που θα συναντησεις θα πρεπει να στα λυσουν πρωτιστως οι δημιουργοι του. Ακομα ακομα και το Parabola - που αναφερεται ως Archlinux με 100% free packages - ειναι τοσο διαφορετικο πλεον απο το Archlinux που καμια απορια σχετικα με αυτο δεν μπορει να απαντηθει στo Arch forum.

Γενικα ειμαι της κοινοτικης λογικης - δηλαδη πραγματικων διανομων με βαθος και ανθρωπους που ασχολουνται - και οχι μια προσπαθειας πακεταρισματος ενος φοιτητη απο την Κροατια που αυριο μεθαυριο δεν θα ασχοληθει ξανα με το δημουργημα του. Ως εκτουτου η αναφορα πχ του Nosonja ως μια Archlinux εμπειριας, με βρισκει αντιθετο. 

Απο και υστερα, δεν θα φαγωθουμε κιολας :-)

     Μπορεί  όμως  τα  ίδια  ''προβλήματα''  που  εμφανίζει  το  Nosonja  στους  ''δαίμονες'' &  τα  ''διαόλια''   του  samba  server  ,  όπως  &  στην  εναλλαγή  eng-greek  ,  να  υπάρχουν  αυτούσια  &  στο  ίδιο  το  ARCH.
       Όπως  &  να  χει , το  Nosonja  είναι  μια  προσπάθεια   που με  καλύπτει  100 %   και   θα  παρακολουθώ  κάθε  του  νέα  έκδοση  όπως  &  αντίστοιχες  άλλες  προσπάθειες  που  έρχονται  με ένα  desktop  environment   σε  μορφή  live-cd.

     Και   το   μεγάλο  ερώτημα  είναι. Γιατί  ΔΕΝ  κυκλοφορούν  οι  developers  &  ένα  arch-live-cd  με  xfce ?

zenwalk05]   Και   το   μεγάλο  ερώτημα  είναι. Γιατί  ΔΕΝ  κυκλοφορούν  οι  developers  &  ένα  arch-live-cd  με  xfce ?



Μα αυτη ειναι η βασικη αρχη του Archlinux - δεν ειναι GUI oriented - δεν κυκλοφορει με κανενα DE by default. Ακολουθει την KISS φιλοσοφια και οτι φερνει μαζι της αυτη.

Στο The Arch Way τα εξηγει ολα αυτα - ριξτου μια ματια για να εχεις μια ιδεα του τι αντιπροσωπευει η διανομη που χρησιμοποιεις.

Ευχαριστω τον bat12 για την πληροφορια (οντως αυτο ηταν και παρολο που στο ψαξιμο εβρισκα και αλλους με το ιδιο προβλημα δεν ειχα δει την απλη αυτη λυση αλλου) .

Επισης να πω οτι και οsamba server μετα απο μια χθεσινη αναβαθμιση εφτιαξε και αυτος χωρις καμια αλαγη (βασικα δεν ετρεχε απο την αρχη ο nmbd ).

 

gmouzo]

Ευχαριστω τον bat12 για την πληροφορια (οντως αυτο ηταν και παρολο που στο ψαξιμο εβρισκα και αλλους με το ιδιο προβλημα δεν ειχα δει την απλη αυτη λυση αλλου) .

Επισης να πω οτι και οsamba server μετα απο μια χθεσινη αναβαθμιση εφτιαξε και αυτος χωρις καμια αλαγη (βασικα δεν ετρεχε απο την αρχη ο nmbd ).

 



Το wiki του arch είναι μεγάλος βοηθός. Έχει τα πάντα και είναι σωτήριο να ανατρέχουμε πρώτα εκεί. Για περαιτέρω εδώ είμαστε να το συζητάμε.