Slackware greek fonts

slackware | Πέμ, 01/19/2012 - 20:15 | 1' | 9

Καλησπερα,

Περασα το slackware 13.37 και στην συνεχεια εκανα upgrade σε current.

Δεν μπορω να θυμηθω πως ρυθμιζω τα Ελληνικα ωστε να εμφανιζονται σωστα οι φακελοι και τα αρχεια που ειναι στα Ελληνικα.

Τα locale ειναι

LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=

και τα Ελληνικα fonts ειναι περασμενα.

Καποια ιδεα?

Δώσε αστέρια!
Σχόλια

Επειδή είναι testing και για να μη γίνει κάποιο μπέρδεμα δεν δίνεις για αρχή locale -a για να δεις αν υπάρχουν τα ελληνικά; Δοκίμασε με localesetup.

1. Στο αρχείο /etc/profile.d/lang.sh σαν διαχειριστής (root) άλλαξε τη γραμμή  export LANG=en_US.utf8 σε export LANG=el_GR.utf8

2. Για να αλλάζεις πληκτρολόγιο από ελληνικά σε αγγλικά με alt_shift, αν δεν υπάρχει δημιούργησε το αρχείο
/etc/X11/xorg.conf.d/10-keymap.conf με περιεχόμενα

Section "InputClass"
        Identifier      "Keyboard settings"
        MatchIsKeyboard "yes"
        Driver          "evdev"
        Option          "XkbLayout" "us,el"
        Option          "XkbVariant" ""
        Option          "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Και αν δεν υπάρχει ήδη εγκατεστημένο
3. εγκατέστησε για το KDE το πακέτο kde-l10n-el-4.5.5-noarch-3



Οι παραπάνω ρυθμίσεις είναι καλύτερα επειδή ισχύουν για όλο το σύστημα και γραφικό περιβάλλον.

Εννοείται ότι αν χρησιμοποιείς το KDE σαν περιβάλλον,  μπορείς να ρυθμίσεις τα ελληνικά από system-settings -> locale επιλέγεις χώρα Ελλάδα και system-settings -> συσκευές εισόδου ρυθμίζεις τα πάντα για το πληκτρολόγιο αλλαγή κλπ

Βγες από το KDE και ξαναμπές και εισαι οκ.

To πληκτρολογιο ειναι ρυθμισμενο αλλα δεν μπορω να διαβασω σωστα ειτε σε KDE ειτε σε terminal τα αρχεια που ειχαν απο πριν ελληνικα ονοματα.

Δοκιμασα να κανω export το LANG αλλα τα ιδια.....

Μήπως αναφέρεσαι σε αρχεία μέσω Wine ή σε κάποιο Windows Partition; Δεν μιλάμε για .srt έτσι;

Τότε αφού και στο KDE τα ελληνικά δεν διαβάζονται πάσχει το συστημά σου από ένα bag στο slackware current.
Σε ένα xterm σαν  root τρέξε το παρακάτω
ln -s /sbin/mount.ntfs-3g $startdir/pkg/sbin/mount.ntfs
ώστε να δημιουργηθεί ο σύνδεσμος (link) mount.ntfs που πιθανόν να μην υπάρχει. Κατόπιν κάνε umount και ξανα mount τα partition που έχεις ελληνικά αρχεία και μάλλον δεν θα έχεις πρόβλημα.
Κανονικά στο xterm θα πρέπει να βλέπεις σωστά τα ελληνικά αρχεία και φακέλλους.

Στη console (init 3) πιθανόν όχι. Eπειδή χρειάζεται να ορίσεις τη σωστή γραμματοσειρά στο αρχείο /usr/bin/unicode_start

djemos]Τότε αφού και στο KDE τα ελληνικά δεν διαβάζονται πάσχει το συστημά σου από ένα bag στο slackware current.
Σε ένα xterm σαν  root τρέξε το παρακάτω
ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs
ώστε να δημιουργηθεί ο σύνδεσμος (link) mount.ntfs που πιθανόν να μην υπάρχει. Κατόπιν κάνε umount και ξανα mount τα partition που έχεις ελληνικά αρχεία και μάλλον δεν θα έχεις πρόβλημα.
Κανονικά στο xterm θα πρέπει να βλέπεις σωστά τα ελληνικά αρχεία και φακέλλους.

Στη console (init 3) πιθανόν όχι. Eπειδή χρειάζεται να ορίσεις τη σωστή γραμματοσειρά στο αρχείο /usr/bin/unicode_start

Οχι δεν μιλάμε για wine .srt κλπ

Το ελυσα βαζοντας Slackel current , βεβαια με ξυνιζει λιγο που ειναι τα παντα στα Ελληνικα γιατι σε καποια σημεια η μεταφραση δεν ειναι και η καλυτερη αλλα μπορω και το δουλευω ανετα :)