Debian 6 Αδυναμια τερματισμου συστηματος

Souiters | Παρ, 05/20/2011 - 17:02 | 1' | 20

Καλημερα στην κοινοτητα

μετα απο νεα εγκατασταση Debian 6 και ενω ολα δειχνουν να δουλευουν κανονικα παω να κανω τερματισμο συστηματος και αντι να κλεσει ο υπολογιστης με βγαζει σε περιβαλλον login!

Μετα απο λιγο ψαξιμο βρηκα πολλες αναφορες με το ιδιο προβλημα και η λυση ειναι μαλλον στο

/etc

οπου πρεπει να αλλαξει ετσι

http://nopaste.debianforum.de/34161

Το προβλημα ειναι οτι δεν βλεπω στο /etc φακελο /PolicyKit/PolicyKit.conf ουτε στα κρυμμενα!

Οποια βοηθεια δεκτη.

Ευχαριστω.

Υ.Γ. Γιατι το λενε Stable οταν εχει τετοια bug και δεν μπορει ο χρηστης να σταματησει το συστημα;

 

Φόρουμ
Δώσε αστέρια!
Σχόλια

Φίλε μου Souiters, έχω κάνει 5 φορες installation το Debian 6 σε διαφορετικούς υπολογιστές, και αυτό που αναφέρεις δεν το συνάντησα...

Κάτι έκανες λάθος μάλλον στην διαδικασία εγκατάστασης...

Λογαριασμό απλού χρήστη έχεις φτιάξει;

Το λεω αυτο γιατί το Polkit κανονικά θα έπρεπε να σου ζητά τον κωδικό root για επανεκκίνηση ή για τερματισμό...

Οταν εκανα την εγκατασταση ειχα καποιο προβλημα με την εγκατασταση λογισμικου αλλα το τελικο μηνυμα ηταν οτι η εγκατασταση εγινε κανονικα. Ο λογαριασμος απλου χρηστη υπαρχει.Οταν με στελνει στο περιβαλλον login βλεπω τον λογαριασμο απλου χρηστη.
Μετα το σχετικο ψαξιμο βρηκα οτι το προβλημα πιθανως ξεκιναει απο το πακετο dbus Η εντολη $ ps -efH | grep dbus δειχνει οτι τρεχει ο dbus-daemon και το dbus-launch Παρακατω αναφερεται οτι με δικαιωματα χρηστη η εντολη $ dbus-send --system --print-reply --dest="org.freedesktop.Hal" \ /org/freedesktop/Hal/devices/computer \ org.freedesktop.Hal.Device.SystemPowerManagement.Shutdown τερματιζει το συστημα Σε μενα αυτη η λυση δεν δουλευει και δινει σαν αποτελεσμα Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files

Τι ακριβώς εγκατέστησες; Gnome; Απο minimal cd ή ολόκληρο iso; Αν ο login manager σου είναι ο gdm, δεν του κάνεις μια επανεγκατάσταση; Για αρχή και μέχρι να βρεις τη λύση, δίνε shutdown -h now για κλείσιμο ή shutdown -r now για επανεκκίνηση.  Και εγώ σε Debian Stable είμαι.

Συμφωνώ με nikolaosx1 και dsyrmalis, και πολύ φοβάμαι και εγώ, οτι έκανες minimal εγκατάσταση.

Καλύτερα το ολόκληρο iso setup. 

Αυτο εκανα εγκατασταση σε περιβαλλον Gnome debian-6.0.1a-i386-DVD-1.iso την εχω πατησει με network install και δεν το ξανακανω.Μονο DVD. dsyrmalis πως κανω επανεγκατάσταση gdm;
Με τα πολλα που δοκιμαζω απο διαφορα γερμανικα φορουμ σχετικα με το προβλημα μαλλον βρεθηκε η λυση αλλα δυστυχως δεν ξερω ποια ειναι! Μετα απο 4 διαδοχικες επανεκινησεις και τερματισμους δειχνει να δουλευει οπως πρεπει. Μια τελευταια ερωτηση σχετικα με τα Fonts.Eιμαι σε Iceweasel 4.01 και οι σελιδες που ανοιγω στο ιντερνετ ειναι καπως.... Σε Chromium 6.0.472.63 η κατασταση ειναι καπως καλυτερη αλλα δεν συγκρινεται σε καμμια περιπτωση με το Ουμπουντου. Το msttcorefonts ειναι το πρωτο πακετο που εγκατεστησα στην αρχη. Ευχαριστω.

και εγω παραξενευτηκα. πανω δεξια στο μενου δινει την επιλογη logout. αν θες δοκιμασε να  βαλεις στο πανελ   με δεξι κλικ πανω στηνμπαρα "add to panel"    και βάλε το κουμπι τεματισμός  (shutdown)  μου ειχε ξανατυχει σε αλλη διανομη.  ξερω και γω τι εγινε,
Σημειωωαη απο το dvd του περιοδικου το εβαλα

@hellaspc
το κολπο με το κουμπι τερματισμου στο πανελ μου ειναι γνωστο.Το δοκιμασα πριν ακομα ανοιξω το θεμα αλλα δεν πιανει.

@vagrale13
Η εντολη που προτεινεις μου ενια γνωστη και δεν κανει κατι

[email protected]:/home/souiters# sudo shutdown -P now
shutdown: -H and -P flags can only be used along with -h flag.
Usage:      shutdown [-akrhPHfFnc] [-t sec] time [warning message]
          -a:      use /etc/shutdown.allow
          -k:      don't really shutdown, only warn.
          -r:      reboot after shutdown.
          -h:      halt after shutdown.
          -P:      halt action is to turn off power.
          -H:      halt action is to just halt.
          -f:      do a 'fast' reboot (skip fsck).
          -F:      Force fsck on reboot.
          -n:      do not go through "init" but go down real fast.
          -c:      cancel a running shutdown.
          -t secs: delay between warning and kill signal.
          ** the "time" argument is mandatory! (try "now") **

Απο τα διαφορα πειραματα που εχω κανει βγαζω το συμπερασμα οτι το προβλημα υπαρχει εντονα οταν εχω πανω στο μηχανημα εξωτερικους σκληρους η στικακια usb.Μαλλον κατι δεν γινεται καλα με την αποπροσαρτηση δισκων.

Υπαρχουν σε ξενα φορουμ αναφορες σχετικες με το προβλημα  που μιλανε και για kernrl panic!

Μια ακομα πιθανοτητα ειναι να εχει προβλημα ο υπολογηστης με την διαχειρηση usb.

Κανε επανεκκινηση, και προσθεσε στον grub την παραμετρο

acpi=noacpi

μετα που θα μπεις, δοκιμασε παλι να δεις αν ειναι ενταξει!

Για τον τροπο που θα προσθεσεις την παραμετρο, δες εδω https://help.ubuntu.com/community/BootOptions#Change%20Boot%20Options%2…
αντικατεστησε το vga=771 με το παραπανω!

Μπαινω στο Bios, μαρκαρω οπως λεει ο οδηγος την γραμμη με τον kernel, παταω e και βγαινω σε διαφορετικο μενου απο αυτο που δειχνει ο οδηγος για το ουμπουντου.

Αν παω στην γραμμη που λεει

kernel /boot/vmlinuz root UUID και τα σχετικα, πατωντας e προσθετω απλα ενα e διπλα στα αριστερα του kernel

Ισως αν εχεις καποιο τροπο να το κανω απο το τερματικο με διαφορες εντολες;

Δεν ξερω αν σε βοηθαει καθολου αλλα η εντολη
# cat /proc/cmdline

δινει
BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-686 root=UUID=9e027892-9ab9-4de8-b807-682278869133 ro quiet
 
αν προσθεσω διπλα στο ro quiet το acpi=noacpi





Οχι, μην αλλαξεις το αρχειο!

Στο menu του grub πατησε το πληκτρο e
και θα σε βγαλει εδω

https://help.ubuntu.com/community/Grub2?action=AttachFile&do=get&target=grub2.menu.edit.png

και στο τελος, μετα το 2.6.31-9-generic
προσθεσε την παραπανω παραμετρο!
Μετα πατησε Ctrl+x και δες οταν μπεις αν μπορεσεις να κλεισεις τον Η/Υ σου!

Δες αναλυτικοτερα εδω https://help.ubuntu.com/community/Grub2#Editing%20Menus%20During%20Boot

τα καλα νεα πρωτα.Η επιμαχη γραμμη στο Bios ειναι τωρα ετσι

initrid /boot/initrid.img-2.6.32-5-686 ΚΕΝΟ acpi=noacpi

εκανα δυο φορες reboot και ολα δειχνουν ενταξει.

Τωρα θα δοκιμασω να κουμπωσω δυο εξωτερικους σκληρους και ενα στικακι

Επανερχομαι...

Αδερφε ξερω οτι στο εχουν πει χιλιαδες φορες αλλοι αυτοι οι αρχαριοι σαν εμενα που βοηθας ολα αυτα τα χρονια στα διαφορα φορουμ αλλα θα στο πω ακομα μια φορα.

ΕΙΣΑΙ ΘΕΟΣ!

Ενα πολυ μεγαλο ΕΥΧΑΡΙΣΤΩ για τον χρονο σου.

Υ.Γ.Εκανα τρεις φορες reboot με ολα τα παραφερναλια κουμπωμενα και παει σφαιρα!

Ωραια.
Αν εχω καταλαβει σωστα ομως, προσθετεις χειροκινητα την παραμετρο σε καθε εκκινηση του Η/Υ, σωστα?

Τωρα θα πρεπει να το κανεις μονιμο.

@sudo gedit /etc/default/[email protected]

και στο αρχειο που θα ανοιξει, βρισκεις τη γραμμη

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

και την κανεις ετσι

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noacpi"

πατας Αποθηκευση, κλεινεις το αρχειο και εκτελεις στο τερματικο

@sudo [email protected]

Αν βγαλει καποιο σφαλμα, μην κανεις επανεκκινηση, ποσταρε το εδω!
Αν ειναι οκ, κανεις επανεκκινηση, και το αφηνεις να κανει boot, και βλεπεις μετα αν ειναι ολα οκ!

Οχι μια φορα μονο εκανα την προσθηκη στο Bios.
Η εντολη


sudo gedit /etc/default/grub

δινει

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""


Δηλαδη εχω μονο quiet και οχι quiet splash

να ξανακανω απο την αρχη την προσθηκη στο Bios;



Αν ανοιγεις απλα τον Η/Υ σου, και δεν προσθετεις την παραμετρο,
και ειναι ολα οκ, μην πειραζεις τιποτα! Απλα αγνοησε το παραπανω μηνυμα! Smile

Επισης, η ονομασια BIOS δεν ειναι σωστη! Εκει που προσθεσες την παραμετρο,
ειναι το menu του grub! Απλα ενημερωτικα αυτο!Innocent