Επίλυση προβληματικής ώρας/ημερομηνίας

rpil | Σάβ, 01/09/2010 - 20:42 | 4'

Όλα καλά με τις εγκαταστάσεις μου, αλλά στις δύο από τις τρεις (εξαίρεση το Funtoo), μέρα και ώρα ήταν λάθος!  Είχαμε πει ότι κατά την διάρκεια της εγκατάστασης του Gentoo, πρέπει να ελέγξουμε την ημερομηνία με την εντολή "date".  Αυτό είχε γίνει μια χαρά, αλλά όταν εγκαταστάθηκε πλήρως το σύστημα, τα στοιχεία αυτά δεν ήταν σωστά.

Τι κάνουμε σε περίπτωση που μας συμβεί αυτό;

1. Κατεβάζουμε το πακέτο

net-misc/ntp

το οποίο είναι σύμφωνα με την περιγραφή:

     Network Time Protocol suite/programs 

 

2. Διαμορφώνουμε το αρχείο μας /etc/conf.d/clock, με τις παρακάτω ενδείξεις:

CLOCK="UTC"

TIMEZONE="Europe/Athens"

CLOCK_OPTS=""

CLOCK_SYSTOHC="no"

SRM="no"

ARC="no"

3. Διαμορφώνουμε και το αρχείο /etc/conf.d/ntp-client, ως εξής:

# Command to run to set the clock initially
# Most people should just leave this line alone ...
# however, if you know what you're doing, and you
# want to use ntpd to set the clock, change this to 'ntpd'
#NTPCLIENT_CMD="ntpdate"
NTPCLIENT_CMD="sntp"

# Options to pass to the above command
# This default setting should work fine but you should
# change the default 'pool.ntp.org' to something closer
# to your machine.  See http://www.pool.ntp.org/ or
# try running `netselect -s 3 pool.ntp.org`.
#NTPCLIENT_OPTS="-s -b -u \
# 0.gentoo.pool.ntp.org 1.gentoo.pool.ntp.org \
# 2.gentoo.pool.ntp.org 3.gentoo.pool.ntp.org"
NTPCLIENT_OPTS="-P no -r \
0.gentoo.pool.ntp.org 1.gentoo.pool.ntp.org \
2.gentoo.pool.ntp.org 3.gentoo.pool.ntp.org \
192.108.114.23 193.48.168.130"

4. Δίνουμε με τη σειρά:

# /etc/init.d/ntp-client start
 * Caching service dependencies ...                                                         [ ok ]
 * Setting clock via the NTP client 'sntp' ...                                              [ ok ]
 

# rc-update add ntp-client default
 * ntp-client added to runlevel default

και είμαστε έτοιμοι! ;)

Φόρουμ
Δώσε αστέρια!