OpenOffice 3: Fonts Invisible! [Λυμένο]

spatman | Πέμ, 12/11/2008 - 21:08 | 2' | 9

Λοιπόν. Δεν ήξερα αν έπρεπε να ρωτήσω εδώ αλλά μόνο στο Archlinux το εχω δει... Μετά από ένα μήνα διασκέδασης (με διαλλείματα) είχα ένα πλήρως λειτουργικό σύστημα και το OpenOffice λειτουργούσε αρκετά καλά. Χρησιμοποίησα οδηγίες από εδώ:

http://bbs.archlinux.org/viewtopic.php?id=56776

για την εμφάνιση του OpenOffice.
Μετά έκανα pacman -Syu... Μερικά προβλήματα με το X, απενεργοποίησα το hotplugin και όλα καλά. Εκτός από το OpenOffice.
Στην toolbar πάνω-πάνω τα εικονίδια εμφανίζονται μια χαρά (και στα μενού το ίδιο). Όμως αντί για γράμματα βλέπω κενά και παύλες ("-- "). Όταν χάνεται το focus από τα menu entries που προσπαθώ να διαβάσω τα γράμματα εμφανίζονται για δέκατα του δευτερολέπτου και μετα ξαναεξαφανίζονται. Τα ίδια και στα dialogs (πχ Save- Discard- Cancel) και στα παράθυρα που ανήγουν όπως το Options, οπου φυσικά δεν βλέπω τις επιλογές για τα fonts!... Καμιά βελτίωση και με το Raleigh GTK style...
Παρακαλώ λίγη βοήθεια...

Φόρουμ
Δώσε αστέρια!
Σχόλια

Βρήκα αυτό[1] που λέει μια λύση για το τι μπορείς να κάνεις...[1] ArchWiki

Απλά πρόσθεσε το

export OOO_FORCE_DESKTOP=gnome

στο ~/.bashrc στο home,κάνε ένα restart X και δες αν δουλεύει.Όλα αυτά αν έχεις KDE.btw μπορείς να ανεβάσεις μια εικόνα να καταλάβουμε καλύτερα για ποιο πράγμα μιλάς :).

--------------------
happy_linux_downloads

Ξέχασα να αναφέρω ότι χρησιμοποιώ kdemod και nvidia 6200.
Επίσης μόλις αντιλήφθηκα οτι και ο Amarok 1.4 έχει το ίδιο πρόβλημα.
Το export OOO_FORCE_DESKTOP=gnome το έχω στο ~/.bashrc αλλά δεν βοηθάει.
Πείραξα λίγο το xorg.conf και βγάζοντας την γραμμή
Option "AddARGBGLXVisuals" "True"
από το Device Section τα μενού επανέρχονται. Χάνεται όμως το compiz fusion, το οποίο τρέχει άλλα η KDE toolbar "ασπρίζει" και το emerald δεν φαίνεται να τρέχει.

Υ.Γ:Εικόνα θα ανέβαζα ευχαρίστως αλλά δεν ξέρω πώς... Αν γίνεται να μου πείτε?

Χμμμ σύμφωνα με αυτό το θέμα,προσπάθησε να το τρέξεις με:

OOO_FORCE_DESKTOP=gnome /opt/openoffice/program/soffice -writer

και αν δεν "παίξει" προσπάθησε και το παρακάτω:

OOO_FORCE_DESKTOP=gnome /usr/bin/soffice

:)

Τώρα όσο αφορά την εικόνα,αφού βγάλεις μία πήγαινε στο imageshack βάλε την εικόνα που θέλεις και πάτησε αποθήκευση...από τα λινκ που θα βγάλει κάνε paste το 2ο εδώ στο φόρουμ και είσαι έτοιμος

--------------------
happy_linux_downloads

Η πρώτη εντολή δίνει:

$ OOO_FORCE_DESKTOP=gnome /opt/openoffice/program/soffice -writer
(soffice:3460): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",
(soffice:3460): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
(soffice:3460): Gtk-WARNING **: GtkSpinButton: setting an adjustment witnon-zero page size is deprecated

είτε έχω AddARGBGLXVisuals σε true, είτε όχι, αλλά δεν πρέπει να είναι αυτό το πρόβλημα.
Ιδου κι ένα screenshot:

http://imageshack.gr/view.php?file=ol8eogpny2z54kkxi1go.jpg

Υ.Γ: merci για το imageshack.gr!

Restart X (ctrl+alt+backspace) έκανες αφού πρόσθεσες την πάνω γραμμή στο ~/.bashrc;;;

Αυτό έλεγε να κάνεις και στις οδηγίες στον pacman που έβγαλε μετά το upgrade,save της γραμμής
export OOO_FORCE_DESKTOP=gnome
στο ~/.bashrc ή στο /etc/profile :S.

Τώρα δεν ξέρω αν μπορεί να φταίει,αλλά έχεις το ελληνικό πακέτο openoffice-el;;;Δες αν το έχεις με:

pacman -Q | grep openoffice

και καλού κακού κάνε το μια εγκατάσταση με:

pacman -Sy openoffice-el

Ποτέ δεν ξέρεις...πάντως δεν πρόκειτε πρόβλημα με το xorg.conf

--------------------
happy_linux_downloads

Το openoffice-el το έχω εγκαταστήσει, και μάλιστα έκανα χτες uprgrade το openoffice-base. Τίποτα όμως...
Απ' ότι βλέπω πράγματι δεν φταίει tο xorg.conf: ακόμη και με Option "AddARGBGLXVisuals" "True" όλα τρέχουν σωστά μέχρι να ενεργοποιήσω τα Desktop Effects από τα System Settings ή μέχρι να τρέξω το fusion-icon. Πείραξα τα advanced options των Desktop Effects αλλά το μόνο που κατάφερα ήταν να κρασάρω το σύστημα και να μπω σε safe-mode για να το διορθώσω :-)
Ακόμη και με έναν καινούργιο χρήστη που έφτιαξα, το προβλημα επιμένει...
Αφού και ο amarok έχει ακριβώς το ίδιο πρόβλημα (ακόμη και το δεξί κλικ στο εικονίδιό του στο system-tray τα δείχνει παύλες-κενά) μάλλον το kdemod έχει το πρόβλημα. Απ'ότι έχω καταλάβει δεν τα πάει και πολύ καλά με τις nvidia κάρτες...
Έχω ακολουθήσει όλες τις οδηγίες για σωστή ρύθμιση που βρήκα αλλά τίποτα.
Μόνο το Option "BackingStore" "True" στο xorg δεν βάζω γιατί το σύστημα κολλάει μόλις κάνω login, και το
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1 στο startup, γιατί τότε όλα τα fonts φαίνονται..."άτσαλα".
(το GlyphCache=1 στην κονσόλα βγάζει "ERROR: Error parsing assignment 'GlyphCache=1' (Unrecognized attribute name).")
Καμιά ιδέα?

Τελικά ήταν μόνο ένα λάθος στη ρύθμιση της κάρτας γραφικών... Ήθελε απλά λίγο περισσότερο ψάξιμο...

Δεν την έγραψα επειδή ... απλά χρησιμοποιούσα λάθος nvidia drivers! :)