"XFree86-DRI" missing on display ":1.0".

hubman | Κυρ, 02/24/2008 - 17:55 | 1' | 3

Γεια σε ολους. Εχω ενα μικρο προβλημα χωρις να ειναι ενοχλητικο.

Στο Ubuntu 7.10 ενω ολα ειναι οκ εννοω ολα με το 3D desktop (Ati 9600pro se Agp) χθες εκανα ενα

ελεγχο fglrxinfo kai πηρα το παρακατω.

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 2.0.6473 (8.37.6)

Μεχρι εδω οκ Οταω ομως fgl_glxgears τοτε παιρνω

Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":1.0".
Error: couldn't get fbconfig

και φυσικα δεν δουλευει και το glxinfo | grep rendering

Καποια βοηθεια?

Ευχαριστω εκ των προτερων.

Φόρουμ
Δώσε αστέρια!
Σχόλια

Δεν έχεις πρόβλημα αν τρέχει το 3d desktop.Για πες μας αν οι ταινιές παίζουν σωστά και τέλος αν κάποιο 3d παιχνίδι όπως το neverball παίζει και αυτό σωστά.Να προσθέσω ότι σωστά χρησιμοποιείς τους open driver με την κάρτα σου που δουλεύουν άψογα σε αντίθεση με τους official.

chek2fire, δίκιο έχεις ότι σε τέτοιες κάρτες δουλεύει καλύτερα ο παλιότερος open source driver. Αλλά καταλαβαίνω κάτι λάθος; Από όσα γράφει και θέλει να κάνει, φαίνεται ότι χρησιμοποιεί τους κλειστούς drivers (8.37.6) - όχι τον open source ati driver.

--
Any fool knows a dog needs a home,
A shelter from pigs on the wing.

Κατ'αρχη ευχαριστω για τις απαντησεις, τωρα οσο αφορα τις ταινιες δεν εχει κανενα προβλημα, οσο αφορα τους drivers ειναι μαλλον κλειστου κωδικα αλλα απο οτι θυμαμαι ειχα το ιδιο προβλημα και με τους open αλλα αυτο που με εκανε να ψαχτω ηταν οτι με το παραμικρο δουλευει πολυ τον επεξεργαστη (AMD 3000+ ss2) συνηθως στο 100% και οι σελιδες στο ιντερνετ δειχνουν να κολανε στην γρηγορη μετακινηση της οθονης. Νομιζω οτι μαλλον το προβλημα ειναι οι Drivers. Δεν ξερω αν κατεβασω τους νεους εχω αυτο το μικρο προβλημα.

Και οσο για games δυστυχως η ευτυχως το λινουξ γενικα δεν το εχω για τετοιου ειδους δουλεια. Ισως το glxinfo βοηθησει.......

name of display: :1.0
Xlib: extension "XFree86-DRI" missing on display ":1.0".
display: :1 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:

GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3

client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture

GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 1.2 (2.0.6473 (8.37.6))
OpenGL extensions:
GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None

0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 Ncon

0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon

Και τελος οταν  DISPLAY=:0 gxlinfo τοτε

name of display: :0.0

display: :0  screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.2