Ubuntu 10.04 και Video Calls... και μία ακόμα απορρία

Myrrdin | Δευ, 08/02/2010 - 18:52 | 2' | 8

Καλησπέρα σε όλους. 

   Εδώ και μία εβδομάδα εγκατέστησα τα ubuntu LTS στο φορητό. Dell Vostro 1500. Ομολογώ έμεινα ενθουσιασμένος

από την ευχρηστία, την ταχύτητα και το όλο concept της διανομής. 

   Δυστυχώς γρήγορα ο ενθουσιασμός έφυγε... Λόγω δουλειά κάνω συχνά telcos οπότε το να μπορώ να χρησιμοποιώ την ενωματωμένη

κάμερα στο skype είναι κάτι επιθυμητό και αναγκαίο! Δυστυχώς με λίγο ψάξιμο σε forums διαπίστωσα ότι είναι από λίγο εώς πολύ

απίθανο να κάνω το skype να δει την κάμερά μου... Μήπως κάνω λάθος;

    Δε θέλω να προβώ ξανά σε format κτλ μόνο και μόνο για την έλλειψη ενός driver. Γνωρίζω το γιατί τίθεται τέτοια ζητήματα

και δε θέλω να εμβαθύνω σε αυτό. Ψάχνω απλά μία λύση ώστε να μπορώ να κάνω βιντεοκλήσεις. Υπάρχει λύση;

    

Ευχαριστώ πολύ!

 

Υ.Γ. Μία απλή απορρία που φαντάζομαι θα πάρω μπόλικες απαντήσεις. Στη δουλειά γράφω Java (eclipse) και Python. Υπάρχει κάποια

εφαρμογή όπου μπορώ να κάνω ένα σχεδιάγραμμα των κλάσεων μου με μεθόδους κτλ πριν να προχωρήσω στον προγραμματισμό

αυτό καθευτό;

Δώσε αστέρια!
Σχόλια

Καλως μας ηρθες καταρχας!

Myrrdin]Δυστυχώς γρήγορα ο ενθουσιασμός έφυγε... Λόγω δουλειά κάνω συχνά telcos οπότε το να μπορώ να χρησιμοποιώ την ενωματωμένη

κάμερα στο skype είναι κάτι επιθυμητό και αναγκαίο! Δυστυχώς με λίγο ψάξιμο σε forums διαπίστωσα ότι είναι από λίγο εώς πολύ

απίθανο να κάνω το skype να δει την κάμερά μου... Μήπως κάνω λάθος;

Δεν νομιζω να ισχυει αυτο που λες!

Μπορεις να μας δωσεις τα αποτελεσματα των 2 εντολων

lspci -nn

lsusb

Myrrdin]Δε θέλω να προβώ ξανά σε format κτλ μόνο και μόνο για την έλλειψη ενός driver. Γνωρίζω το γιατί τίθεται τέτοια ζητήματα

και δε θέλω να εμβαθύνω σε αυτό. Ψάχνω απλά μία λύση ώστε να μπορώ να κάνω βιντεοκλήσεις. Υπάρχει λύση;

Παντα, και για ολα υπαρχει λυση, αρκει τη βρισκουμε! Κανονικα θα επρεπε να λειτουργουν τα παντα, χωρις να κανεις τιποτα!

Αν εχεις λιγη υπομονη και ορεξη, στο τελος λογικα θα το κανουμε να δουλεψει!

Εγκατέστησε από το synaptic το xawtv και η κάμερα σου θα δουλέψει στο skype μια χαρά !!!!

 Καταρχήν ευχαριστώ για τη συμβουλή. Δυστυχώς τόσο από το synaptic όσο και από το ubuntu software center το xawtv δεν εγκαθίσταται... cannot fecth...

Ευχαριστώ για τη συμβουλή. Έχουμε και λέμε:

 

 

 

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 0c)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 02)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 02)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 02)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller [8086:2828] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1)
03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 12)
03:01.3 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
03:01.4 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev ff)
0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)

και με την άλλη εντολή έχουμε:

 

 Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 006 Device 002: ID 046d:c521 Logitech, Inc. MX620 Laser Cordless Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 0d49:7450 Maxtor 
Bus 002 Device 003: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

Λοιπόν γιατρέ? Γίνεται τίποτα?

 

Η camera που εχεις ειναι αυτη

Bus 002 Device 003: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

και μας ενδιαφερει το chip id που εχει, για να βρουμε την λυση, ή αν λειτουργει και κατι δεν εχουμε κανει σωστα,

αυτα ενημερωτικα!

Δοκιμασε να τρεξεις στο τερματικο τις δυο παρακατω εντολες,

sudo rmmod uvcvideo
sudo modprobe uvcvideo

και δοκιμασε μετα, να δεις αν ειναι ενταξει!

 To δοκίμασα και πάλι τζίφος... Τουλάχιστον τώρα όταν ανοίγω το Skype ανάβει το λαμπάκι της κάμερας αλλά μέχρι εκεί...Το test call δεν παίζει...

Για αρχή άνοιξε το synaptic κάνε μια ανανέωση,ψάξε για libv4l,και κάνε το εγκατάσταση. (αν δεν το βρεις δεν πειράζει,θα έχει ενσωματωθεί στον πυρήνα)

 

Μετά από μια κονσόλα για δοκίμασε:

env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

και δες αν θα έχεις κάμερα στο skype! :)

Hamsters !

Δοκιμασε και αυτο που σου λεει ο thanos, αλλα καλυτερα πρωτα να δοκιμασεις την camera σου με το cheese

εγκατεστησε το απο το Κεντρο λογισμικου Ubuntu,

και οχι με skype!

Μετα θα βρουμε τον τροπο, να το κανουμε να δουλεψει και με το skype, λογικα!