[ΛΥΘΗΚΕ] Πρόβλημα με την εμφάνιση υπότιτλων στον mplayer

jvarkas | Κυρ, 06/07/2009 - 23:31 | 3'

Καλησπέρα,

Γράφω αυτό το ποστ για να μοιραστώ μαζί σας μια λύση την οποία ανακάλυψα και είμαι πολύ χαρούμενος διότι το έψαχνα πολύ καιρό και μου τα είχε σπάσει λίγο...

Είχα ένα πρόβλημα στον mplayer όπου ενώ οι υπότιτλοι εμφανίζονταν κανονικά, μετά από κάποιο update (σε Debian Lenny) εμφανιζόντουσαν κάτι παύλες και ιερογλυφικά. Πάλευα με αλλαγή κωδικοποιήσεων, γραμματοσειρών τίποτα. Επανεγκατάσταση, απεγκατάσταση και ξανά μανά εγκατάσταση, πάλι τίποτα. Αλλαγές στο conf file στο home φάκελο και συγκεκριμένα στον κρυφό φάκελο .mplayer πάλι τίποτα. Τελικά, αφού έτρεξα σε τερματικό για να δω τι μηνύματα βγάζει, είδα ότι δε φαινόταν να βρίσκει τους χαρακτήρες της γραμματοσειράς. Έκανα ένα ψάξιμο στο google και βρήκα τη λύση...Στο αρχείο /etc/mplayer/mplayer.conf υπήρχαν οι εξής 3 γραμμές:

fontconfig = yes
font = "Sans"
subfont-text-scale = 3

Μόλις τις έκανα commented ο player δούλεψε μια χαρά...Το πρόβλημα εστιάζεται στο εξής:

"There are two ways to get TrueType fonts to work. The first is to pass the -font option to specify a TrueType font file on the command line. This option will be a good candidate to put in your configuration file (see the manual page for details). The second is to create a symlink called subfont.ttf to the font file of your choice. Either

 

ln -s /path/to/sample_font.ttf ~/.mplayer/subfont.ttf

for each user individually or a system-wide one:

 

 

ln -s /path/to/sample_font.ttf $PREFIX/share/mplayer/subfont.ttf

If MPlayer was compiled with fontconfig support, the above methods won't work, instead -font expects a fontconfig font name and defaults to the sans-serif font."

 

Πηγή

Ελπίζω η λύση αυτή να βοηθήσει και κάποιον άλλο κακόμοιρο που πιθανώς χτυπιέται ή θα χτυπηθεί με τον συγκεκριμένο player (που είναι φυσικά από τους καλύτερους, γι' αυτό και η επιμονή).

Δώσε αστέρια!