wicd & dsl router

dlinux | Παρ, 02/03/2012 - 23:40 | 1' | 13

Oταν μια διανομη εχει για διαχειριστη δικτυου τον wicd  (vector, salix κα) που δεν υποστηριζει pppoE κ δεν διαθετουμε ασυρματο ιντερνετ αλλα ενα dsl router connex πως μπορουμε να μπουμε στο ιντερνετ;Αν ξερει καποιος θα με υποχρεωσει γιατι το vector φυσαει

Φόρουμ
Δώσε αστέρια!
Σχόλια

Τι εννοείς dsl router connex; Συνδέεσαι ενσύρματα με καλώδιο δικτύου; Τότε τα πράγματα είναι απλά και το wicd υποστηρίζει τέτοιες συνδέσεις. Αν εννοείς usb μοντεμάκι θυμάμαι ότι παλιά συνδεόμουνα μέσω γραμμής εντολών αποθηκεύοντας ένα αρχείο με τις ρυθμίσεις και δίνοντας
pon otenet (για σύνδεση)
poff otenet (για αποσύνδεση)

otenet ήταν το όνομα του αρχείου με τις ρυθμίσεις.

συνδεση ethernet με το μοντεμ.Το βλεπω το μοντεμ  αλλα δεν μπορω να μπω ιντερντετ.Κ dns server δηλωνω κ την ip του μοντεμ βαζω αλλα τιποτα.Αν ξερει κανεις τι δηλωνουμε κ που

dlinux,
πιο modem/router έχεις και τι έχεις περάσει σε tcp/ip?

όπως σωστά είπε και ο shortmaniko,ο manager wicd υποστηρίζει τέτοιες συνδέσεις!
οπότε αν δεν σου ανοίγει το interface δοκίμασε με τερματικό π.χ

ping 192.168.0.1 -w4

να δούμε αν εποικινωνεί το pc με το router!


δυστυχως δεν εχω δυο pc ενα να κοιτω το φορουμ κ ενα να κανω τις πραξεις στο τερματικο.Το μοντεμ-ρουτερ είναι comtrend και με τον network manager εχω φτιαξει μια συνδεση connex.Oταν τρεχω το vector linux live cd βλεπω το ρουτερ κ αν στον firefox βαλω 192.168.1.1 μπαινω στο ρουτερ .Στον wicd εχω ενδειξη οτι εχει βρει δικτυο με ip 192.168.1.2 αλλα ιντερνετ δεν εχω .Σημειωση στο BIOS (κ στο vector) εχω ωρα δυο ωρες πισω απο την σωστη κ οσες φορες κ αν την διορθωσα με το εκκινουν τα ubuntu ξανα γυρνα παλι δυο ωρες πισω κ δεν ξερω αν αυτο παιζει ρολο

δοκιμασα να αλλαξω την ωρα κ δεν ειδα φως.Ο το wicd θελει καποια ρυθμιση κ αν καποιος την ξερει ας την γραψει ή το ρουτερ-μοντεμ πολυ αγαπά το λινουξ .Στις οδηγιες αναφερει συμβατοτητα μονο με τα παραθυρα

Το μόνο που μπορώ να σκεφτώ είναι κάποιο θέμα με το dns. Δοκίμασε να γράψεις πχ στον firefox
http://173.194.67.94/
Αν σε βγάλει στο google.gr τότε έχεις θέμα με το dns. Φρόντισε στα properties της σύνδεσης στο wicd να ΜΗΝ είναι επιλεγμένα τα use static ip και use static dns. Επίσης στα preferences του wicd να είναι τα external programs όλα στο automatic.

Σαν τελευταία λύση που μου έρχεται δοκίμασε (αν δε δεις φως με τα παραπάνω) στα properties να επιλέξεις use static dns βάζοντας τα ακόλουθα
208.67.222.222

208.67.220.220

και κάνε disconnect - connect για να χρησιμοποιεί αυτούς τους dns servers. Πρόκειται για τους dns servers του opendns.com

 

 

Δεν είδα φως.Νομιζω πως αν συνδεθεις σε ενα ρουτερ που ειναι στο ιντερνετ το φυσιολογικο ειναι να μπεις στο ιντερνετ.Ετσι δεν ειναι; Εγω λοιπον με το network manager το ubuntu φτιαχνω μια συνδεση connex που λειτουργει μια χαρα.Αν τωρα τρεξω το ubuntu σε live cd θα δω το ρουτερ θα παρω ωρα αλλα δεν θα μπαινω ιντερνετ κ θα πρεπει να ξαναφτιαξω την συνδεση.Κατι τρεχει στραβα εδω ετσι; Απο την αλλη αν κανω την εγκατασταση του ubuntu σε συνδεση στο ιντερνετ κατεβαζει πακετα (σε ρυθμο χελωνας) αλλα κατεβαζει οποτε μπαινει στο ιντερνετ.Προσπαθώντας να βαλω arch ειδε το ρουτερ πηρε ωρα αλλα με κανενα τροπο δεν εμπαινε στο ιντερνετ να κατεβασω πακετα! Αν ξερει καποιος απο ρυθμισεις στο περιβαλλον του ρουτερ θα βοηθουσε γιατι υποψιαζομαι οτι κατι τετοιο θελει ρυθμιση

Κάνε hard reset στο ρούτερ σου, περίμενε να συγχρονήσει και μετά σύνδεσέ το με τον υπολογιστή σου.
Πές μας αν είναι οκ κι αν όχι εδώ είμαστε για τα περαιτέρω. Το ρολόι σου δείχνει 2 ώρες πίσω γιατί η διανομή σου ρυθμίζει την ώρα σε UTC η οποία έχει 2 ώρες διαφορά με την local. Τι διανομή έχεις εγκατεστημένη; 

oχι δεν ειδα αποτελεσμα. εγκατεστημενη που λειτουργει μια χαρα ειναι ubuntu 11,10.Aυτη που εχει wicd κ θελω να  δοκιμαζω ειναι vector 7 live cd.Το ιδιο προβλημα ειχα παλιοτερα με το salix κ το εβγαλα

Οταν ενα ρουτερ ειναι συνδεδεμενο στο διαδικτυο ,το μονο που χρειαζεται εναι να συνδεθεις με το ρουτερ....η συνδεση pc-router γινεται με τους διαφορους network- managers πχ wicd ,gnome-network manager κλπ.....συνηθως το ρουτερ  δινει αυτοματα την ωρα που συνδεεται με το pc ,διευθυνση στο pc μας.....ολα αυτα δεν εχουν καμμια μα καμμια σχεση με το πως(ppoe κλπ) ειναι συνδεδεμμενο το ρουτερ στον σερβερ του παροχου isp ,δηλαδη πως ειναι παραμετροποιημενο να συνδεεται στο διαδικτυο....αυτο το κανουμε μια φορα και απαξ και ειναι συνδεδεμενο στο internet .ειναι και τελος....

με 192.168.1.1 μπαινω στο μοντεμ αλλα απο ιντερνετ τιποτα.με το ubuntu ολα δουλευουν μια χαρα

  • Αν δώσεις ping www.linuxinsider.gr και traceroute τι μήνυμα σου βγάζει;

 

  • Το /etc/network/interfaces τι γράφει μέσα; Κανονικά θα πρέπει να έχει μόνο αυτά:


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo  inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

  • Μήπως έχεις ταυτόχρονα εγκατεστημενο και τον network manager;
  • Το /var/log/wicd/wicd.log το κοίταξες μήπως έχει κάποιο ενδιαφέρον μήνυμα λάθους;

Επίσης δοκίμασε να ανοίξεις ένα τερματικό ως root
και δώσε
#ifconfig eth0 up
#dhclient
και δες αν έχεις internet