προβλημα με wi-fi realtek

promitheas | Κυρ, 05/04/2008 - 17:22 | 2' | 21

<!--
@page { size: 21cm 29.7cm; margin: 2cm }
P { margin-bottom: 0.21cm }
-->

χαίρετε προσφτατα
αγόρασα αυτό το laptop

Toshiba Satellite L40-16D,

CPU: Intel? Pentium? Dual-Core
Processor T2310 (1MB cache, 1.46 GHz, 533 MHz FSB)
RAM: 2GB
(1GB+1GB) , maximum expandability: 2 GB, technology: DDR2 RAM (667
MHz)
HD: 120 GB SATA
Optical Medium: DVD Super
Multi (Double Layer) drive
Monitor: 15,4" WXGA TFT
display, resolution 1,280 x 800
Graphic Card: Mobile Intel
965 Expres Chipset Family
Wireless Card: Realtek RT 8187B
Wireless LAN USB2.0 (802.11b/g)
Ethernet Card: Realtek 8139
10/100M
Audio: Intel 82801H
Modem: International
V.90 modem (V.92 ready)
Touch Pad: Synaptics Touchpad
Card
Slot: Express Card? slot, 2 memory slots
Extras: External
Wired Microsoft Optical Mouse USB2.0

λογο το οτι μου αρεσει
παρα πολυ το linux αποφασισα να εγκαταστισο
το ubuntu 7.10 δεν μου εχει αναγνωρισει την
καρτα wireless και την καρτα γραφικων. πως
μπορο να τα φτιάξω. θέλω να ενεργοποιήσω
και των κύβο.

υποψην είμαι αρχάριος
και δεν γνωρίζω πολλά με linux ευχαριστώ
εκ των προτέρων.

Φόρουμ
Δώσε αστέρια!

MO: (ψήφοι: 0)

Σχόλια

Promithea,
μπορείς να διευκρινήσεις τι ακριβώς κάρτα γραφικών έχεις (δηλ ποια intel ??)

αν είναι πάντως η Χ3100 υπάρχει αυτό το howto:
http://www.linuxinsider.gr/forum/intel-x3100-%CE%BA%CE%B1%CE%B9-compiz-…

Όσο για την κάρτα wifi ενώ φαίνεται να έχει driver ο kernel με λίγο googling είδα πως πολύς κόσμος δυσκολεύεται.
Άλλοι χρησιμοποίησαν Ndiswrapper με win driver και τους δούλεψε.

Είναι προτιμότερο πάντως να χρησιμοποιηθεί ο native driver του linux.
Δοκίμασε αρχικά να δώσεις σε κονσόλα τις εντολές:

$sudo modprobe r818x
και
$sudo modprobe r8187

και μετά για να δούμε τι κάναμε:

$sudo iwconfig

επίσης δώσε την εντολή:

$sudo lsusb

και postare εδώ το αποτέλεσμα (ή μόνο τη γραμμή που αναφέρεται στην wifi card του συτήματός σου)

Γεια σου promithea και καλως μας ήρθες :).

Με lsusb δεν θα δείξει την wifi κάρτα εκτός και αν είναι συνδεδεμένη σε usb (λίγο δύσκολο για λάπτοπ).Οπότε με lspci θα δεις το chipaki της κάρτας σου.

LOL κουφάθηκα πρώτη φορά το βλέπω αυτό σε λάπτοπ να έχει wifi κάρτα σε εσωτερική usb.(οτι να ναι).Δοκίμασε αυτό που έγραψε ο luckyb και αν δεν λειτουργήσει τότε πήγαινε σε ndiswrapper (πιθανόν).*

*Βρήκα και αυτό https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetw…

**Όπως επίσης και αυτό http://ubuntuforums.org/showpost.php?p=3945998&postcount=13

Έδωσα της εντολές και μου έβγαλε αυτά:

[email protected]:~$ sudo modprobe r818x
FATAL: Module r818x not found.
[email protected]:~$ sudo modprobe r8187
FATAL: Module r8187 not found.
[email protected]:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

[email protected]:~$ sudo lsusb
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0bda:8197 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 0000:0000
[email protected]:~$

Δεν δοκιμάζεις τον patchαρισμένο driver από εδώ:
http://www.datanorth.net/~cuervo/rtl8187b/
Σε πολλούς δούλεψε !!

Μην ξεχάσεις να διαβάσεις το FAQ και το readme.

Συνοπτικά:
1. Κατεβάζεις το αρχείο rtl8187b-modified-dist.tar.gz και το αποσυμπιέζεις με

tar xvfz rtl8187b-modified-dist.tar.gz

2. Πας στον υποκατάλογο που το αποσυμπίεσες:

cd rtl8187b-modified

3. Κάνεις compile τον driver (θα σου βγάλει πολλά λάθη)

sudo ./makedrv

4. Φορτώνεις τον driver:

sudo ./wlan0up

Λύση No.2:
Βάζεις μια σοβαρή κάρτα Wless :-p

Τα έκανα όλα αυτά ανάβει το λαμπάκι τις κάρτας μόλις γυρίζω το διακόπτη στο on αλλά δεν συνδέεται στο δίκτυο. Και μόλις κάνω επανεκκίνηση δεν αναγνωρίζει την κάρτα (το λαμπάκι δεν ανάβει μόλις βάζω τον διακόπτη στο on).

Μάλλον πρέπει να αλλάξω κάρτα. Πρότεινε μου κάποια?

Τα έκανα αυτά με την κάρτα γραφικών αλλά δεν παίζει video τώρα τι να κάνω?

Για το Wifi:
Τουλάχιστον κάτι έγινε (?)
Μπορείς να τσεκάρεις αν χρειάζεται να δίνεις κάθε φορά (μετά από κάθε boot) την εντολή "sudo ./wlan0up" (πάντα από τον υποκατάλογο rtl8187b-modified)? Τουλάχιστον αν δουλεύει έτσι να βρούμε καμιά πατέντα να το κάνει αυτόματα.

Αν όντως είναι έτσι και ανάβει το λαμπάκι δώσε την εντολή

$sudo iwconfig

για να δούμε ότι την βλέπει κανονικά το σύστημα. Μπορεί απλά να χρειάζεται ρύθμιση.
...και για να μη μπλέξουμε πάλι με κονσόλα, πρέπει η διανομή σου να έχει κάποιο gui για ρύθμιση καρτών δικτύου.

Άλλη πρόταση: Μπορείς να δοκιμάσεις κι ένα liveCD του καινούργιου Ubuntu ή του PCLinuxOS (Το οποίο έχει έναν όμορφο wizard στην αρχή για δίκτυο) ή της Mandriva (υπάρχουν όλα στο DVD του περιοδικού ή τα κατεβάζεις) μήπως σε ποιο καινούργιες διανομές έχει εξαλειφθεί το πρόβλημα με την υποστήριξη της κάρτας σου.

Τώρα, αν δεν βγάλουμε άκρη και είσαι διατεθειμένος να ξοδέψεις κι άλλα, το συζητάμε

Για το video:

WiludrakeGR]Εκεί θα πάντε στην καρτέλα Video και θα αλλαξετε το Default Output Plugin: σε : "X Windows System(No Xv)"
Πατήστε και ενα Test για να σιγουρευτείτε οτι παίζει οk

Αν το 'χεις κάνει είδη αυτό δοκίμασε κανένα άλλο plugin ή auto αν έχει (δεν μπορώ να πω συγκεκριμένα γιατί δεν παίζω Gnome)

Εδώ καλύτερα να πει κάποιος κάτι που έχει παρόμοιο σύστημα με το δικό σου

για το wi-fi έδωσα sudo ..... και η απάντηση ειναι αυτή

[email protected]:~/rtl8187b-modified$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g linked ESSID:"Wireless"
Mode:Managed Channel=3 Access Point: 00:11:6B:14:60:A4
Bit Rate=54 Mb/s
Retry:on Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[email protected]:~/rtl8187b-modified$

για το video δοκιμασα και τα άλλα που εχει αλλα δεν έγινε τίποτα

Οπότε τη βλέπει την κάρτα σου το σύστημα !!
Απλά είναι αρρύθμιστη και δεν συνδέεται πουθενά.
Δώσε κι ένα:

$sudo iwlist scan

να δούμε θα βρει τίποτα ??

Δεν έχει η διανομή σου κανένα gui για ρύθμιση Wifi καρτών ??
Μη σε πήξω στην κονσόλα (ωραία αποφεύγω κάτι που δεν ξέρω καλά :-))

Η απάντηση ειναι αυτή.

Οπότε τη βλέπει την κάρτα σου το σύστημα !!
Απλά είναι αρρύθμιστη και δεν συνδέεται πουθενά.
Δώσε κι ένα:

$sudo iwlist scan

με την καρτα γραφικων τι να κάνω δεν παίζει video :-(

promitheas, ποια απάντηση; Απ' όσο βλέπω δεν έχεις γράψει κάτι. Εχεις επαναλάβει την ερώτηση του luckyb. Πλζ, διόρθωσε το σχόλιο σου.

--Stat rosa pristina nomine, nomina nuda tenemus

Συγνώμη άλλα η κεκτημένη ταχύτητα φταίει λοιπόν έδωσα sudo και η απάντηση είναι αυτή.

$ sudo iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:11:6B:14:60:A4
ESSID:"Wireless"
Protocol:IEEE 802.11bg
Mode:Master
Channel:3
Encryption key:off
Bit Rates:54 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 22 24 36 48 54
Quality:27 Signal level:0 Noise level:55
Extra: Last beacon: 530ms ago
Cell 02 - Address: 00:1D:7E:AC:F0:D8
ESSID:"glx poy petaei"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:54 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 22 24 36 48 54
Quality:11 Signal level:0 Noi

Κάποιοι φίλοι μου μου έιπαν να εγκαταστήσω την καινουργεια έκδοση εγκατέστησα λοιπών την καινούργια έκδοση Ubuntu 8.10 και δεν δουλεύει πάλι τίποτα με την κάρτα δικτύου, τι πρέπει να κάνω τώρα πάλι όλα αυτά από την αρχή. Συγνωμη εάν σε πρίζω.

Η αλήθεια είναι ότι είσαι λίγο πρήχτης :-p
(προσπάθεια για εκδήλωση κακής αίσθησης χιούμορ :-))

Η γενική φιλοσοφία είναι μια -> Δεν δουλεύει τίποτα σημαίνει ότι:

1. Το σύστημα δεν βλέπει καθόλου κάρτα wireless. Αυτό θα έρθει ως συμπέρασμα εάν με την εντολή iwconfig (ή και με την iwlist scan για να είμαστε σίγουροι) δεν βλέπουμε τίποτα. Σ'αυτήν την περίπτωση θα χρειαστεί να περάσεις με την ίδια διαδικασία τον driver.

2. Αν οι προαναφερθείσες εντολές σου λένε ότι υπάρχει κάρτα κι είναι έτσι κι έτσι και μπορεί και ψάχνει και βρίσκει δίκτυα, τότε δουλεύει μια χαρά και δεν χρειάζεσαι driver, απλά μερικές ρυθμίσεις για να συνδεθείς στο router σου.

Επειδή είναι realtek τπάρχει μεγάλη πιθανότητα το chip να είναι broadcom.

(ακριβώς όπως συμβαίνει σε μένα).

Η "Διαχείρηση οδηγών κλειστού κώδικα" (από Σύστημα > Διαχείρηση), τι λέει?

Αν είναι broadcom, γιά δες εδώ, κάτω κάτω.

http://www.linuxinsider.gr/forum/wifi-%CE%A0%CF%81%CE%BF%CE%B2%CE%BB%CE…

====

the hamster's is out there

http://hamster.tuxhost.gr/

Αχ τι να κάνω που δεν ειμαι καλλός μαθητής. για να δεις τι τραβάνε και οι εκπαιδευτικοί.

Έδωσα την εντολή iwconfig

η απάντηση ειναι αυτ'η

lo no wireless extensions.

eth0 no wireless extensions.

και με την εντολή iwlist scan

η απάντηση ειναι αυτή

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

χαίρε παίδες.
λοιπόν
έχω και εγώ την κάρτα

που με lsusb δίνει

Bus 007 Device 002: ID 0bda:8187 Realtek Semiconductor Corp.

με dmesg | grep rtl8187 δίνει

phy0: hwaddr 00:15:af:0d:b8:a2, rtl8187 V1 + rtl8225z2
usbcore: registered new interface driver rtl8187

Τώρα με iwlist wlan0 scan το βλέπει το δίκτυο.

μπορώ να κάνω ifconfig wlan0 up, or, ifconfig wlan0 down, με τις αναμενόμενες συνέπειες.

Ότι αποτελέσματα παίρνω από το σκανάρισμα τα περνάω σαν ρυθμίσεις με iwconfig, (όσα μπαίνουν τουλάχιστον),

αλλά παρ'ολα αυτα δεν παίρνω ip. Επίσης παίρνω αυτό το ενοχλητικό output απο dhclient

wmaster0: unknown hardware address type 801

δεν έχω κάνει προσπάθεια να μεταγλωτίσω τον οδηγό που δίνεται εδώ.

θα ήθελα να εξαντλήσω κάθε ενδοχόμενο πρώτα.

Καμία ιδέα; είναι θέμα driver;