CentOS 6.4

dsyrmalis | Κυρ, 03/10/2013 - 21:57 | 3' | 7

Η διανομή CentOS βασίζεται στα κομμάτια του πηγαίου κώδικα του Red Hat Enterpise Linux. Τον τελευταίο καιρό είχαν παρουσιαστεί καθυστερήσεις αλλά και προβλήματα και πολλοί είχαν αμφιβολίες ακόμα και για την ίδια την ύπαρξη της διανομής. Παρόλα αυτά η κοινότητα συνέχισε με αποτέλεσμα να φτάσουμε αισίως στην έκδοση 6.4.

Ο εγκαταστάτης της διανομής αν και ξεκινά κάπως απότομα σε περιβάλλον ncurses δεν πρέπει να μας τρομάξει αφού εξαφανίζεται αμέσως και τη θέση του παίρνει ο φιλικός Anaconda που διαθέτει περιβάλλον γραφικών. Σε περίπτωση που επιλέξουμε ελληνικά θα πρέπει να πατήσουμε ταυτόχρονα τα δύο shift του πληκτρολογίου μας όταν μας ζητηθεί ο κωδικός του υπερχρήστη (Root). Το σύστημα δεν δέχεται κωδικό στα ελληνικά οπότε με τα δύο shift αλλάζουμε το πληκτρολόγιο στα αγγλικά. Τα ίδια ισχύουν και για τον κωδικό του απλού χρήστη, Ανάμεσα στις πολλές δυνατότητες του εγκαταστάτη στις οποίες έχουμε αναφερθεί αρκετές φορές είναι και η προσθήκη απο την αρχή έξτρα αποθετηριων και η ενεργοποίηση του ntp server για τη σωστή απεικόνιση της ώρας. Το τελευταίο είναι κάτι που σας το συνιστούμε.

Το λογισμικό που θα βρούμε στο CentOS είναι σχεδόν πανομοιότυπο με αυτό του RHEL 6.4 και κατα συνέπεια αρκετά "συντηρητικό":

  • Gnome 2
  • Firefox 10.0.12 ESR
  • LibreOffice 3.4.5
  • Πυρήνας 2.6.32

Στις αναβαθμίσεις του συστήματος πάντως μας προτάθηκε για κατέβασμα ο Firefox 17. Επιπλεόν λογισμικό θα βρούμε στα έξτρα αποθετήρια τα οποία ενργοποιούνται με ένα απλό κλικ.
Σε γενικές γραμμές το CentOS 6.4 είναι μια καλή πρόταση για όσους επιθυμούν ένα ελαφρύ και σταθερό σύστημα και δεν τους ενδιαφέρει να έχουν "φρέσκο" λογισμικό στο σύστημα τους. Επιπλέον είναι μια καλή επιλογή για όσους επιθυμούν να στήσουν κάποιο server ή και πιο απλά για όσους νοσταλγούν το Gnome 2.

Tags
Δώσε αστέρια!
Σχόλια

Χθες δοκίμασα να εγκαταστήσω το Enlightenment στο CentoOS.
Αποτελέσματα [url=http://eiosifidis.blogspot.gr/2013/03/enlightenment-e17-centos-63.html]…]
Εν ολίγοις, προσθήκη αποθετηρίου ως admin (μια γραμμή)
yum-config-manager --add-repo
http://download.opensuse.org/repositories/X11:/Enlightenment:/Factory/C…
Αναζητάτε για E17 και επιλέγετε το Enlightenment Window Manager και το εγκαθιστάτε.
Αποτέλεσμα; Δείτε εικόνα (εδώ με 6.3 αλλάδουλεύει και με 6.4)
[img]http://dl.dropbox.com/u/20413076/opensuse/e17/centos-e17.jpg[/img]

Φίλε Diamond το Ε17 ανεβαίνει όλο και πιο ψηλά στην εκτίμηση μου.

Παιδιά ωραίο το φόρουμ σας, ακολούθησα τα βήματα, μου ζήτησε να χρησιμοποιήσω το

# yum update --skip-broken

, το έκανα αλλά στο

# yum --install 

πήρα ... τα παρακάτω:

 

# yum install e17.x86_64
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos.privatelayer.com
 * extras: centos.privatelayer.com
 * updates: centos.privatelayer.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package e17.x86_64 0:0.17.3-41.1 will be installed
--> Processing Dependency: e17-branding = 0.1 for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeio1 >= 1.7.8 for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: edje-utils >= 1.7.8 for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeina1 >= 1.7.8 for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: efreet >= 1.7.8 for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: e17-theme for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeeze.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libedje.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_file.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeet.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_input_evas.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libefreet_trash.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libevas.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_ipc.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeukit.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libedbus.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_imf_evas.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libehal.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeio.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libefreet.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_imf.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_x.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libenotify.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libeina.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_con.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_input.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libemotion.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libefreet_mime.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Processing Dependency: libecore_evas.so.1()(64bit) for package: e17-0.17.3-41.1.x86_64
--> Running transaction check
---> Package e-theme-default.x86_64 0:0.17.3-41.1 will be installed
---> Package e17.x86_64 0:0.17.3-41.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: e17-0.17.3-41.1.x86_64
---> Package e17-branding-upstream.x86_64 0:0.17.3-41.1 will be installed
---> Package edje-utils.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: edje = 1.7.8 for package: edje-utils-1.7.8-34.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: edje-utils-1.7.8-34.1.x86_64
---> Package efreet.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: efreet-1.7.8-25.1.x86_64
---> Package libecore1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: ecore for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libts-0.0.so.0()(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libXp.so.6()(64bit) for package: libecore1-1.7.8-35.1.x86_64
---> Package libedbus1.x86_64 0:1.7.8-29.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedbus1-1.7.8-29.1.x86_64
---> Package libedje1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedje1-1.7.8-34.1.x86_64
--> Processing Dependency: libembryo.so.1()(64bit) for package: libedje1-1.7.8-34.1.x86_64
---> Package libeet1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeet1-1.7.8-35.1.x86_64
---> Package libeeze1.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libmount.so.1(MOUNT_2.20)(64bit) for package: libeeze1-1.7.8-27.1.x86_64
---> Package libefreet1.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libefreet1-1.7.8-25.1.x86_64
---> Package libeina1.x86_64 0:1.7.8-39.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeina1-1.7.8-39.1.x86_64
---> Package libeio1.x86_64 0:1.7.8-26.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeio1-1.7.8-26.1.x86_64
---> Package libemotion1.x86_64 0:1.7.8-15.1 will be installed
--> Processing Dependency: emotion-module for package: libemotion1-1.7.8-15.1.x86_64
---> Package libevas1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: evas-modules for package: libevas1-1.7.8-34.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Running transaction check
---> Package e17.x86_64 0:0.17.3-41.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: e17-0.17.3-41.1.x86_64
---> Package ecore.x86_64 0:1.7.8-35.1 will be installed
---> Package edje.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: embryo for package: edje-1.7.8-34.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: edje-1.7.8-34.1.x86_64
---> Package edje-utils.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: edje-utils-1.7.8-34.1.x86_64
---> Package efreet.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: efreet-1.7.8-25.1.x86_64
---> Package emotion-module.x86_64 0:1.7.8-15.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: emotion-module-1.7.8-15.1.x86_64
--> Processing Dependency: libxine.so.1()(64bit) for package: emotion-module-1.7.8-15.1.x86_64
---> Package evas-modules.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: evas-modules-1.7.8-34.1.x86_64
---> Package libXp.x86_64 0:1.0.0-15.1.el6 will be installed
---> Package libecore1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libts-0.0.so.0()(64bit) for package: libecore1-1.7.8-35.1.x86_64
---> Package libedbus1.x86_64 0:1.7.8-29.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedbus1-1.7.8-29.1.x86_64
---> Package libedje1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedje1-1.7.8-34.1.x86_64
---> Package libeet1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeet1-1.7.8-35.1.x86_64
---> Package libeeze1.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libmount.so.1(MOUNT_2.20)(64bit) for package: libeeze1-1.7.8-27.1.x86_64
---> Package libefreet1.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libefreet1-1.7.8-25.1.x86_64
---> Package libeina1.x86_64 0:1.7.8-39.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeina1-1.7.8-39.1.x86_64
---> Package libeio1.x86_64 0:1.7.8-26.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeio1-1.7.8-26.1.x86_64
---> Package libembryo1.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libembryo1-1.7.8-27.1.x86_64
---> Package libevas1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Running transaction check
---> Package e17.x86_64 0:0.17.3-41.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: e17-0.17.3-41.1.x86_64
---> Package edje.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: edje-1.7.8-34.1.x86_64
---> Package edje-utils.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: edje-utils-1.7.8-34.1.x86_64
---> Package efreet.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: efreet-1.7.8-25.1.x86_64
---> Package embryo.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: embryo-1.7.8-27.1.x86_64
---> Package emotion-module.x86_64 0:1.7.8-15.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: emotion-module-1.7.8-15.1.x86_64
--> Processing Dependency: libxine.so.1()(64bit) for package: emotion-module-1.7.8-15.1.x86_64
---> Package evas-modules.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: evas-modules-1.7.8-34.1.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: evas-modules-1.7.8-34.1.x86_64
---> Package libecore1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libecore1-1.7.8-35.1.x86_64
--> Processing Dependency: libts-0.0.so.0()(64bit) for package: libecore1-1.7.8-35.1.x86_64
---> Package libedbus1.x86_64 0:1.7.8-29.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedbus1-1.7.8-29.1.x86_64
---> Package libedje1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libedje1-1.7.8-34.1.x86_64
---> Package libeet1.x86_64 0:1.7.8-35.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeet1-1.7.8-35.1.x86_64
---> Package libeeze1.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libmount.so.1(MOUNT_2.20)(64bit) for package: libeeze1-1.7.8-27.1.x86_64
---> Package libefreet1.x86_64 0:1.7.8-25.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libefreet1-1.7.8-25.1.x86_64
---> Package libeina1.x86_64 0:1.7.8-39.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeina1-1.7.8-39.1.x86_64
---> Package libeio1.x86_64 0:1.7.8-26.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libeio1-1.7.8-26.1.x86_64
---> Package libembryo1.x86_64 0:1.7.8-27.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libembryo1-1.7.8-27.1.x86_64
---> Package libevas1.x86_64 0:1.7.8-34.1 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: libevas1-1.7.8-34.1.x86_64
--> Finished Dependency Resolution
Error: Package: libedbus1-1.7.8-29.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: evas-modules-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libfribidi.so.0()(64bit)
Error: Package: libecore1-1.7.8-35.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libevas1-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libfribidi.so.0()(64bit)
Error: Package: evas-modules-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: edje-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libecore1-1.7.8-35.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: efreet-1.7.8-25.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libeeze1-1.7.8-27.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libmount.so.1(MOUNT_2.20)(64bit)
Error: Package: embryo-1.7.8-27.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libeet1-1.7.8-35.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: emotion-module-1.7.8-15.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libecore1-1.7.8-35.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libts-0.0.so.0()(64bit)
Error: Package: e17-0.17.3-41.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: evas-modules-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libpng15.so.15()(64bit)
Error: Package: libembryo1-1.7.8-27.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libefreet1-1.7.8-25.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libevas1-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: emotion-module-1.7.8-15.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libxine.so.1()(64bit)
Error: Package: evas-modules-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libeina1-1.7.8-39.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libedje1-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libeio1-1.7.8-26.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: edje-utils-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

archwndas]

Παιδιά ωραίο το φόρουμ σας, ακολούθησα τα βήματα, μου ζήτησε να χρησιμοποιήσω το

# yum update --skip-broken

, το έκανα αλλά στο

# yum --install 

πήρα ... τα παρακάτω:

 

# yum install e17.x86_64
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos.privatelayer.com
 * extras: centos.privatelayer.com
 * updates: centos.privatelayer.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package e17.x86_64 0:0.17.3-41.1 will be installed
--> Processing Dependency: e17-branding = 0.1 for package: e17-0.17.3-41.1.x86_64
....
Error: Package: libeina1-1.7.8-39.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libedje1-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libeio1-1.7.8-26.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: edje-utils-1.7.8-34.1.x86_64 (X11_Enlightenment_Factory)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Καλησπέρα φίλε και καλωσήλθες.

Το πρόβλημα που βλέπω ότι έχεις είναι ότι προσπαθείς να εγκαταστήσεις το E17 αλλά το yum παραπονιέται ότι δεν βρίσκει την βιβλιοθήκη της C έκδοση 2.14.

Τι έκδοση του CentOS έχεις εγκατεστημένη;

Από ότι διαβάζω εδώ, το CentOS 6 έχει GLIBC 2.12 (και αυτό δεν πρόκειται να αναβαθμιστεί ποτέ). Στο link που σου δίνω, οι χρήστες του CentOS απαντάνε ότι το πρόβλημα δεν οφείλεται στη διανομή αλλά στο ότι υπήρχαν στο path ρυθμίσεις από άλλες διανομές. Μάλιστα, στη συγκεκριμένη περίπτωση ο χρήστης που είχε το ίδιο πρόβλημα με εσένα έκανε επανεγκατάσταση όλης της διανομής και το πακέτο εγκαταστάθηκε σωστά. Μήπως είναι κάτι τέτοιο το πρόβλημά σου; Μήπως στον ίδιο υπολογιστή και στο ίδιο home είχες εγκαταστήσει και άλλες διανομές;