προβλημα με ηχο και ασυρματο δικτυο σε linux mint 15 olivia>>>

artakias | Σάβ, 01/25/2014 - 22:30 | 1' | 38

καλησπερα σε ολους κ ολες μολις εγκατεστησα ενα linux mint 15 olivia σε ενα hp mini 2133 αλλα δεν εχω ηχο κ δεν εχω ουτε ασυρματο δικτυο!

τι μπορω να κανω?

ανοιξα ενα τερματικο κ πατησα alsamixer κ εβγαλα το mute που ειχε στο ενα κολωνακι.πατησα να παιξεις μετα αλλα δυστηχως ακομα δεν εχω ηχο.

για το ασυρματο δικτυο ομως δεν εχω ιδεα τι μπορω να κανω.

περιμενω την βοηθεια-συμβουλη σας για να λυσω το μικρο αυτο προβλημα.

σας ευχαριστω ολους κ ολες.

Φόρουμ
Δώσε αστέρια!
Σχόλια

το ασυρματο με μια μικρη βοηθεια απο καποιο παιδι απο εδω λυθηκε

αυτο που εκανα ηταν να γραψω σε ενα τερματικο

sudo apt-get install --reinstall b43-fwcutter firmware-b43-installer

μενει μονο ο ηχος....

Περιεργο να εχεις αυτα τα προβληματα με νεοτερη εκδοση.. σε παλιοτερη εκδοση λειτουργουσαν μια χαρα https://wiki.ubuntu.com/LaptopTestingTeam/HP2133

Καλο ειναι να αναφερεις και τι εκανες, σε περιπτωση που συναντησει και καποιος αλλος το ιδιο προβλημα, να δει τη λυση.

Για τον ηχο, εκτελεσε τις δυο παρακατω εντολες

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh
bash alsa-info.sh

ακολουθησε τις οδηγιες, επελεξε να ανεβασεις το αποτελεσμα, και δωσε μας το link του αποτελεσματος.

Εχεις τυποεγραφικο λαθος.

Αντι για alsa-info.sh εχεις γραψει alsa-imfo.sh

Artakia τα αποτελέσματα των εντολών μπορείς να τα κάνεις αντιγραφή-επικόλληση από το τερματικό δεν χρειάζεται να τα βγάζεις φώτο.

καλησπερα εχεις δικιο εκανα λαθος κ σε ευχαριστω.

πατησα λοιπν τα παρακατω

κατα την εντολη που μου ειπες την πρωτη δηλαδη
wget http://www.alsa-project.org/alsa-info.sh-0(μηδεν πατησα) alsa-info.sh

μου εβγαλε το παρακατω

[email protected]-HP-2133 ~ $ bash alsa-info.sh
alsa-info.sh: line 1: --2014-01-27: command not found
alsa-info.sh: line 2: syntax error near unexpected token `('
alsa-info.sh: line 2: `Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243'

και στην εντολη
bash alsa-info.sh

μου εβγαλε το παρακατω

bash alsa-info.sh
alsa-info.sh: line 1: --2014-01-27: command not found
alsa-info.sh: line 2: syntax error near unexpected token `('
alsa-info.sh: line 2: `Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243'

και επειδη δεν ημουν σιγουρος αν ηταν μηδεν ή ομικρον πατησα κ τα 2 και με εντολη
wget http://www.alsa-project.org/alsa-info.sh-Ο(ομικρον πατησα) alsa-info.sh

μου εβγαλε το παρακατω

wget http://www.alsa-project.org/alsa-info.sh-O alsa-info.sh
--2014-01-27 21:18:01--  http://www.alsa-project.org/alsa-info.sh-O
Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243
Connecting to www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-01-27 21:18:01 ERROR 404: Not Found.

--2014-01-27 21:18:01--  http://alsa-info.sh/
Resolving alsa-info.sh (alsa-info.sh)... failed: No such file or directory.
wget: unable to resolve host address ‘alsa-info.sh’

[email protected]-HP-2133 ~ $ cd/tmp
bash: cd/tmp: No such file or directory

[email protected]-HP-2133 ~ $ wget http://www.alsa-project.org/alsa-info.sh-O alsa-info.sh
--2014-01-27 23:48:49--  http://www.alsa-project.org/alsa-info.sh-O
Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243
Connecting to www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-01-27 23:48:49 ERROR 404: Not Found.

--2014-01-27 23:48:49--  http://alsa-info.sh/

Resolving alsa-info.sh (alsa-info.sh)... failed: No such file or directory.

wget: unable to resolve host address ‘alsa-info.sh’

[email protected]-HP-2133 ~ $ chmod 777 alsa-info.sh

[email protected]-HP-2133 ~ $ ./alsa-info.sh
./alsa-info.sh: line 1: --2014-01-27: command not found
./alsa-info.sh: line 2: syntax error near unexpected token `('
./alsa-info.sh: line 2: `Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243'

 

ελπιζω να το εκανα σωστα.

Δεν άφησες κενό μετά το cd. Δηλαδή έπρεπε να γράψεις cd  /tmp και όχι cd/tmp
Επίσης, τις αντολές μπορείς να τις κάνεις copy paste απο εδώ στο τερματικό σου.

οι αλλες εντολες ειναι ενταξει?

δεν μπαινω απο τον ιδιο υπολογιστη γι αυτο εβγαζα φωτο κ τωρα αυτο.

παω να το κανω κ σας λεω.

Όχι, δεν είναι εντάξει. Κάνε copy paste αυτά που σου έγραψε ο Slackware εδώ.
 

παμε να προσπαθησω ξανα.

[email protected]-HP-2133 /tmp $ cd /tmp
[email protected]-HP-2133 /tmp $ wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh
--2014-01-28 01:09:05--  http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243
Connecting to www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;hb=refs/hea… [following]
--2014-01-28 01:09:05--  http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;hb=refs/hea…
Resolving git.alsa-project.org (git.alsa-project.org)... 77.48.224.243
Connecting to git.alsa-project.org (git.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

    [ <=>                                   ] 27670       --.-K/s   in 0,1s    

2014-01-28 01:09:06 (223 KB/s) - ‘alsa-info.sh’ saved [27670]

 

και μετα το δευτερο μου εβγαλε αυτο με το link οποτε δειτε εδω>>>

http://www.alsa-project.org/db/?f=b733007edd23c711d54c41d3cac88cb85bc11…

 

καλημερα εχθες το βραδυ επρεπε να περασω ξανα την εκδοση linux mint 15 olivia στο μινι λαπτοπ που εχω.

εχω ομως παλι οπως κ την πρωτη φορα προβλημα στον ηχο κ στο ασυρματο.

στο ασυρματο παρολο που την πρωτη φορα πατησα την εντολη που σας ειπα κ πετυχε κ ειχα ασυρματο αυτη την φορα με την ιδια εντολη κ με τα ιδια αποτελεσματα οπως θα δειτε παρακατω δεν εχω ασυρματο.καμια ιδεα τι μπορω να κανω?

τα αποτελεσματα:

[email protected] ~ $ sudo apt-get install --reinstall b43-fwcutter firmware-b43-installer
[sudo] password for thunder:
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
0 αναβαθμίστηκαν, 0 νέο εγκατεστημένα, 2 επανεγκατεστημένα,0 θα αφαιρεθούν και 14 δεν αναβαθμίζονται.
Χρειάζεται να μεταφορτωθούν 0 B/22,5 kB από αρχεία.
Μετά από αυτή τη λειτουργία, θα χρησιμοποιηθούν 0 B χώρου από το δίσκο.
(Ανάγνωση βάσης δεδομένων ... 141679 files and directories currently installed.)
Προετοιμασία για αντικατάσταση b43-fwcutter 1:015-14 (χρησιμοποιώντας το .../b43-fwcutter_1%3a015-14_i386.deb) ...
Αποσυμπίεση του αντικαταστάτη b43-fwcutter ...
Προετοιμασία για αντικατάσταση firmware-b43-installer 1:015-14 (χρησιμοποιώντας το .../firmware-b43-installer_1%3a015-14_all.deb) ...
Αποσυμπίεση του αντικαταστάτη firmware-b43-installer ...
Επεξεργασία των trigger για man-db ...
Γίνεται εγκατάσταση b43-fwcutter (1:015-14) ...
Γίνεται εγκατάσταση firmware-b43-installer (1:015-14) ...
No chroot environment found. Starting normal installation
An unsupported BCM4312 Low-Power (LP-PHY) device was found.
Use b43 LP-PHY firmware (firmware-b43-lpphy-installer package) instead.
Aborting.

σας ευχαριστω ολους για την πολυτιμη βοηθεια,τις συμβουλες και τον χρονο σας.

Γιατι χρειαστηκε να κανεις παλι εγκατασταση ?

Γενικα, το Linux δεν ειναι οπως τα παραθυρα. Εγκαταασταση κανουμε μια φορα, και η επομενη γινεται οταν βγαλει προβλημα ο δισκος.

Τωρα, επειδη εχω μπερδευτει, και δεν εχω καταλαβει πιο ειναι ακριβως το προβλημα, για τον ηχο, αν εξακολουθεις να εχεις το προβλημα, δοκιμασε πρωτα αυτο εδω http://forums.linuxmint.com/viewtopic.php?f=49&t=146581

και αν δεν φτιαξει, βλεπουμε.

*Επισης, στις εντολες, κανε αντιγραφη-επικολληση*

Ακριβώς όπως το είπε ο Vagrale είναι. Δεν χρειάζεται η επανεγκατάσταση. Επίσης, δεν μπορώ να καταλάβω γιατί έβαλες Mint 15 και όχι 16. Νομίζω πως και στο Mint 15 Τέλειωσε η υποστήριξη. Διορθώστε με αν κάνω λάθος.

Vagrale μπορεί να κάνω και λάθος αλλά έχω την εντύπωση πως ίσως να είναι muted η ένταση του ήχου του.

dsyrmalis]

vagrale μπορεί να κάνω και λάθος αλλά έχω την εντύπωση πως ίσως να είναι muted η ένταση του ήχου του.

Ειναι και αυτο πιθανο, αν και μια αναζητηση που εκανα, ειδα οτι αρκετοι χρηστες εχουν προβλημα με την συγκεκριμενη καρτα, σε νεοτερες εκδοσεις. Ωστοσο, εχουν δωθει αρκετες λυσεις, οποτε καποια θα κανει και για τον artakias. smiley

καλησπερα κ συγνωμη που αργησα να σας απαντησω.

vagrale13 χρειαστηκε να κανω εγκατασταση παλι γιατι αθελα μου ή ισως απο υπερβολικη βιασινη εκανα κατατμηση χωρου με αποτελεσμα να εχω ενα μερος που ειναι 20gb κ εχω μεσα τα windows xp,50 linux mint 15 olivia και ενα ακομα 50 που δεν ειχε μεσα τπτ κ ετσι μη γνωριζοντας(αν λυνεται καπως αλλιως) ξανα περασα μεσα τα windows xp σε ολο το δισκο κ μολις τελειωσε αυτο περασα κ το linux mint 15 olivia και εκανα σωστα την κατατμηση χωρου(αν το λεω σωστα).

προβλημα εχω μονο στον ηχο κ στο ασυρματο δυστηχως κ με την εντολη που εκανα εχθες δεν πιανει δεν ξερω ομως το γιατι.

dsyrmalis κατεβασα την εκδοση που μου ειχες πει σε μνμ linux mint 16 μα οταν εκανα την εγκατασταση αυτη σταματουσε στο σημειο με την ασυρματη καρτα δικτυου κ δεν προχωρουσε.μετα ειδα οτι κ απο εκει που βρηκα της εκδοσης που εδωσα σε αλλο θεμα εδω ελεγε για linux mint 15 olivia κ θεωρησα οτι ηταν το σωστο να την περασα,ασχετα αν πραγματικα εκανα το πειραμα μου ταυτοχρωνα,εβαλα μεσα την εκδοση mint 15 κ λειτουργησε κανονικα με το μονο προβλημα να ερχετε στον ηχο κ στην καρτα ασυρματου δικτυου οπου το προβλημα αυτο το ειχα κ με αλλα λειτουργικα ubuntu,lubuntu κτλ.

οσο για το muted που ειπατε ανοιξα ενα τερματικο κ πατησα

alsamixer και το αποτελεσμα ειναι

http://prntscr.com/2nfood

υ.γ. πλεον κανω αντιγραφη επικολληση της εντολες οπως μου το γραφετε.

αυτα σας ευχαριστω κ τους 2 που μου αφιερωσατε τον χρονο σας.

παω να πατησω την εντολη που μου εδωσες τωρα για τον ηχο.

 

[email protected] ~ $ sudo apt-get remove oem-audio-hda-daily-dkms
[sudo] password for thunder:
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
E: Αδυναμία εντοπισμού του πακέτου oem-audio-hda-daily-dkms
[email protected] ~ $

το αποτελεσμα της εντολης απο εκει που μου ειπες.

Την εγκατασταση πως την εχεις κανει, κανονικα ή μεσα απο τα παραθυρα (με το wubi) ?

Εκτελεσε τις δυο εντολες,

killall pulseaudio
sudo alsa force-reload

και δες αν εχεις ηχο μετα.

δεν ξερω τι ειναι τα παραθυρα που λες :( με ρωτησε για κατατμηση κ εγω πατησα ναι κ εκανα ομως 3 μεροι γι αυτο.οκ θα δωσω τις εντολες αφου περασω πρωτα την 16 petra πανω.

οι εντολες που μου εδωσες ισχυουν στο petra mint 16 η οχι?

Εννοω αν εκανες την εγκατασταση μεσα απο τα windows, με το wubi, ή κανονικη εγκατασταση. Η κανονικη εγκατασταση ειναι να τοποθετησεις το cd/dvd ή usb, να κανεις επανεκκινηση, να επιλεξεις να κανει boot απο εκει, και να κανεις την εγκατασταση.

Οι εντολες ισχυουν και σε αυτη την εκδοση, ναι.

το δευτερο εκανα πατησα f9 κ μετα boot απο το usb dvd player που εχω κ το εκανε.

οκ μολις τελειωσει θα στειλω μνμ να σας πω αν τα καταφερα η οχι.

προσπαθησα να βαλω την εκδοση linux mint 16 petra εφτασε μεχρι το σημειο που μου ελεγε οτι εχει προβλημα η καρτα ασυρματου δικτυου κ μετα απο εκει μου εβγαλε ενα σημα κατι για τον x-server πατησα οκ κ ξανα μετα οκ κ μετα εβγαλε μια μαυρη οθονη με μι παυλα να αναβοσβηνει εδω κ περιπου 20λεπτα χωρις να κανει ομως τπτ παραπανω ουτε ο driver τρεχει.

παω να βαλω την εκδοση του mint 15 olivia

μολις εκανα εγκατασταση το mint 15 olivia χωρις να σταματησει πουθενα κ εκανε κ τις ενημερωσεις που ειχε τωρα παω να εκτελεσω την εντολη για το ασυρματο πρωτα κ επειτα για τον ηχο.

 

[email protected] ~ $ sudo apt-get install --reinstall b43-fwcutter firmware-b43-installer
[sudo] password for thunder:
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Τα ακόλουθα ΝΕΑ πακέτα θα εγκατασταθούν:
  b43-fwcutter firmware-b43-installer
0 αναβαθμίστηκαν, 2 νέο εγκατεστημένα, 0 θα αφαιρεθούν και 14 δεν αναβαθμίζονται.
Χρειάζεται να μεταφορτωθούν 22,5 kB από αρχεία.
Μετά από αυτή τη λειτουργία, θα χρησιμοποιηθούν 111 kB χώρου από το δίσκο.
Φέρε:1 http://archive.ubuntu.com/ubuntu/ raring/main b43-fwcutter i386 1:015-14 [18,9 kB]
Φέρε:2 http://archive.ubuntu.com/ubuntu/ raring/multiverse firmware-b43-installer all 1:015-14 [3532 B]
Μεταφορτώθηκαν 22,5 kB σε 0s (33,2 kB/s)    
Selecting previously unselected package b43-fwcutter.
(Ανάγνωση βάσης δεδομένων ... 141668 files and directories currently installed.)
Γίνεται αποσυμπίεση b43-fwcutter (από .../b43-fwcutter_1%3a015-14_i386.deb) ...
Selecting previously unselected package firmware-b43-installer.
Γίνεται αποσυμπίεση firmware-b43-installer (από .../firmware-b43-installer_1%3a015-14_all.deb) ...
Επεξεργασία των trigger για man-db ...
Γίνεται εγκατάσταση b43-fwcutter (1:015-14) ...
Γίνεται εγκατάσταση firmware-b43-installer (1:015-14) ...
No chroot environment found. Starting normal installation
An unsupported BCM4312 Low-Power (LP-PHY) device was found.
Use b43 LP-PHY firmware (firmware-b43-lpphy-installer package) instead.
Aborting.
[email protected] ~ $

εδω ειναι τα αποτελεσματα απο την πρωτη μου εντολη για το ασυρματο δικτυο κ τωρα θα κανω επανεκκινηση κ σας λεω το αποτελεσμα.

το ασυρματο μεχρι στιγμης δεν λειτουργει κ δεν επιασε η εντολη οποτε περιμενω την βοηθεια σας η καποια αλλη εντολη.
 

[email protected] ~ $ killall pulseaudio
[email protected] ~ $ sudo alsa force-reload
[sudo] password for thunder:
Unloading ALSA sound driver modules: snd-hda-codec-analog snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-analog snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
Loading ALSA sound driver modules: snd-hda-codec-analog snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
[email protected] ~ $

 

και τα αποτελεσματα απο τις αλλες 2 εντολες που μου ειπατε αλλα ηχο παλι δεν εχω.

vagrale13]

Περιεργο να εχεις αυτα τα προβληματα με νεοτερη εκδοση.. σε παλιοτερη εκδοση λειτουργουσαν μια χαρα https://wiki.ubuntu.com/LaptopTestingTeam/HP2133

Καλο ειναι να αναφερεις και τι εκανες, σε περιπτωση που συναντησει και καποιος αλλος το ιδιο προβλημα, να δει τη λυση.

Για τον ηχο, εκτελεσε τις δυο παρακατω εντολες

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh
bash alsa-info.sh

ακολουθησε τις οδηγιες, επελεξε να ανεβασεις το αποτελεσμα, και δωσε μας το link του αποτελεσματος.

http://www.alsa-project.org/db/?f=e9c71e4a6ac255679d05f2312050cdef50b11…

δεν αφησα καμια εντολη σας που να μην την εκανα εβαλα ολα τα αποτελεσματα που βγηκαν ελπιζω να σας βοηθησουν να μου πειτε τι να κανω.
 

1) Μην κανεις πολλα post, αλλα ενα, γιατι γινετε δυσαναγνωστο το θεμα.

2) Ειδα πως εκανες και παλι εγκατασταση, αν καταλαβα καλα, τοτε καλο ειναι να καταλαβεις πως δεν χρειαζεται να κανεις ξανα εγκατασταση. Το μονο που θα καταφερεις με τις συνεχομενες εγκαταστασεις, ειναι να δημιουργησεις καποια στιγμη προβλημα στον δισκο. Αν καταλαβα λαθος, αγνοησε το.

3) Εκτελεσε την εντολη

sudo gedit /etc/modprobe.d/alsa-base.conf

και στο αρχειο που θα ανοιξει, στο τελος προσθεσε αυτο

options snd-hda-intel position_fix=1

πατησε Αποθηκευση - κλεισε το αρχειο - κανε επανεκκινηση, και δες αν εχεις ηχο.

Αν δεν εχεις ηχο, εκτελεσε και παλι την παραπανω εντολη, και σβησε τη γραμμη που προσθεσες - πατησε Αποθηκευση - κλεισε το αρχειο - κανε επανεκκινηση.

Μην αλλαξεις κατι αλλο στο αρχειο.enlightened

 

3) Κατεβασε την εκδοση Mint 13 - μπες με το liveusb - και δες αν εχεις ηχο εκει.

Μην κανεις εγκατασταση, απλα επελεξε δοκιμη χωρις αλλαγη στο μενου.

 

κανε αυτα, και πες το αποτελεσμα.

καλησπερα σας φιλε vagrale13 εκανα αυτο που μου ειπες ακριβως αλλα κ παλι ηχο δεν ειχα.

δοκιμασα κ το mint 13 maya που μου ειπες κ εκει στο δοκιμαστικο ειχα ηχο.

τι αλλο μπορω να κανω?

Αν θελεις να ασχοληθεις να διορθωσεις το προβλημα του ηχου, κανε το παρακατω, αν παλι δεν θελεις, μπορεις απλα να εγκαταστησεις την εκδοση Mint 13.

Μπες με το live cd στην εκδοση Mint 13, και εκει εκτελεσε τις δυο παρακατω εντολες

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh
bash alsa-info.sh

ακολουθησε τις οδηγιες, επελεξε να ανεβασεις το αποτελεσμα, και δωσε μας το link του αποτελεσματος, αυτο απο την εκδοση Mint 13 με το livecd.

καλησπερα θα το κανω αυτο που μου ειπες κ θα ανεβασω το link αλλα μου βγαζει οταν παω να κανω εγκατασταση του mint 13 maya ενα μνμ

δεν εχει οριστει βασικο συστημα αρχειων!

τι πρεπει να κανω για να μου δεχτει να να κανω την εγκατασταση?

οποιος ξερει ας μου πει να πατησω να κανω εγκατασταση το mint 13 maya να ηρεμησω λιγο.

καλησπερα σας φιλε vagrale13 εγκατεστησα την εκδοση linux mint 13 maya ηχο εχω κανονικα το μονο που δεν εχω ειναι το ασυρματο δικτυο.

η εντολη για το ασυρματο που ειχα γραψει ειναι η ιδια για ολες τις εκδοσεις η πρεπει να πατησω κατι αλλο?

περιμενω τις γνωμες σας για να ολοκληρωσω επιτελους το mini laptop μου με επιτυχια.

σας ευχαριστω ολους για ολα οσα μου εχετε γραψει κ με εχετε συμβουλευσει.