Dreamweaver CS4

kokeroulis | Παρ, 02/13/2009 - 23:40 | 1' | 22

Καλησπέρα

Στον υπολογιστή μου έχω 2 λειτουργικά συστήματα.Τα windows xp και το suse 11.1.Στα windows xp έχω εγκαταστήσει το dreamweaver cs4 και επειδή μου άρεσε θέλω να το εγκαταστήσω και στο suse.Το θέμα είναι όμως ότι το suse από μόνο του δεν υποστειρίζει προγράμματα των windows xp.Τι είναι καλύτερο να κάνω?Να χρησιμοποιώ το dreamweaver cs4 μέσα από τα windows ή εγκαταστήσω ένα virtual box στο suse και να το χρησιμοποιώ από εκεί.

Φόρουμ
Δώσε αστέρια!
Σχόλια

Σήμερα προσπάθησα να εγκαταστήσω το dreamweaver (επειδή φέτος γράφω πανελλίνιες δεν έχω πολύ ελεύθερο χρόνο) αλλά το suse δεν βλέπει να αρχεία εγκατάστασης (όλα όχι μονο τα exe).Ξέρεται τι φταίει?

Εντάξη βρήκα για ποιό λόγο δεν έβλεπα το περιεχόμενο.Αλλά ακόμα έχω πρόβλημα.Όταν τρέχω το αρχείο exe για την εγκατάσταση δεν κάνει τπτ.Ούτε error ούτε τπτ.Ξέρεται τι φταίει?

δώσε στην κονσόλα:

wine path/to/dreamweaver.exe

και πέρασε εδώ τα αποτελέσματα. Ίσως καταλάβεις και μόνος σου τι φταίει.

Σε κάθε περίπτωση, από τις ρυθμίσεις του WineConfigure δοκίμασε να βάλεις συμβατότητα με κάποια άλλη άλλη έκδοση των windows πολλές φορές αυτό δουλεύει...

Έκανα ότι είπες αλλά το dreamweaver κολάει στην εγκατάσταση.Αυτή είναι η μοναδικι εικόνα που διχνει.Στο δεύτερο αρχείο έχω βάλει τις γραμές που γράφει η κονσόλα αό μόνη της.(Το ανέβασα στο rs γτ είναι πάρα πολλές οι σειρές.)

http://i41.tinypic.com/2ueqy6g.png

http://rapidshare.com/files/201241085/dreamweaver

Δεν επιστρέφει κάποιο σφάλμα, οπότε τρέχει κανονικά.

Από την πρώτη εικόνα που έστειλες, φαίνεται ότι είναι το κλασσικό πρόβλημα με τις ελληνικές γραμματοσειρές, μιάς και τα windows επιμένουν σε iso-8859-7 (και συνεπώς το ίδιο οι εφαρμογές που αναπτύσσονται ή προορίζονται για αυτά).

Υποθέτοντας ότι έχεις εγκαταστήσει το charset αυτό [ως root: locale-gen el_GR.ISO-8859-7] τρέξε το πρόγραμμα εγκατάστασης ως εξής:

LC_ALL=el_GR.ISO-8859-7 wine /path/to/setup.exe

και δες αν τρέχει...

Τα fixme δεν είναι σφάλματα που θα μπορούσαν να κολλήσουν εγκατάσταση (δεν είναι καν σφάλματα για την ακρίβεια). Οπότε θα συμφωνήσω με τον apkoutsou

Έχεις δοκιμάσει να περάσεις αυτά που λέει το http://appdb.winehq.org/objectManager.php?sClass=version&iId=14343 ??

"Simply had to use winetricks to install gdiplus, msxml3, corefonts and ie6.
Would not work with version 1.1.9 which was what was installed as standard on my linux distribution. Simply upgraded to latest version and it all worked fine."

Δες και τα υπόλοιπα 4 (πχ http://appdb.winehq.org/objectManager.php?sClass=version&iId=14343&iTes…

apkoutsou]Δεν επιστρέφει κάποιο σφάλμα, οπότε τρέχει κανονικά.

Από την πρώτη εικόνα που έστειλες, φαίνεται ότι είναι το κλασσικό πρόβλημα με τις ελληνικές γραμματοσειρές, μιάς και τα windows επιμένουν σε iso-8859-7 (και συνεπώς το ίδιο οι εφαρμογές που αναπτύσσονται ή προορίζονται για αυτά).

Υποθέτοντας ότι έχεις εγκαταστήσει το charset αυτό [ως root: locale-gen el_GR.ISO-8859-7] τρέξε το πρόγραμμα εγκατάστασης ως εξής:

LC_ALL=el_GR.ISO-8859-7 wine /path/to/setup.exe

και δες αν τρέχει...

Όταν χρησιμοποιώ την εντολή locale-gen el_GR.ISO-8859-7 μέσα στην κονσόλα μου βγάζει το παρακάτω σφάλμα.Εψαξα μέσα στο yast και δεν υπάρχει αυτό το πακέτο.Τι πρέπει να κάνω για να το βρώ?

dhcppc0:/home/kokeroulis # locale-gen el_GR.ISO-8859-7]
bash: locale-gen: command not found

Τα άλλα τα έχεις δοκιμάσει?
(Στα suse μου δεν υπάρχει η εντολή locale-gen. Για κοίτα τι κάνει, αν είναι η ίδια, η locale.)

Teddy]Τα άλλα τα έχεις δοκιμάσει?
(Στα suse μου δεν υπάρχει η εντολή locale-gen. Για κοίτα τι κάνει, αν είναι η ίδια, η locale.)

Η locale μου βγάζει το εξης μήνυμα

[email protected]:~> locale
LANG=el_GR.UTF-8
LC_CTYPE="el_GR.UTF-8"
LC_NUMERIC="el_GR.UTF-8"
LC_TIME="el_GR.UTF-8"
LC_COLLATE="el_GR.UTF-8"
LC_MONETARY="el_GR.UTF-8"
LC_MESSAGES="el_GR.UTF-8"
LC_PAPER="el_GR.UTF-8"
LC_NAME="el_GR.UTF-8"
LC_ADDRESS="el_GR.UTF-8"
LC_TELEPHONE="el_GR.UTF-8"
LC_MEASUREMENT="el_GR.UTF-8"
LC_IDENTIFICATION="el_GR.UTF-8"
LC_ALL=

Ενώ όταν έτρεξα την εντολή locale el_GR.ISO-8859-7 με su δεν έκανε τπτ.Ούτε σφάλμα ούτε τπτ άλλο

...Τι να σου πω, δεν ξέρω απ'αυτά.. Τα άλλα που σου είπα τα δοκίμασες?

Καταρχάς συγγνώμη διότι δεν είδα ότι έχεις SuSE και έτσι KDE εξορισμού.

Η εντολή locale σου επσιτρέφει τις ρυθμίσεις εντοπιότητας.

Έτρεξες καθόλου την εντολή:

LC_ALL=el_GR.ISO-8859-7 wine /path/to/setup.exe

να δεις αν τρέχει σωστά ή προσπάθησες κατευθείαν να εγκταστήσεις το locale??? Η παραπάνω εντολή εξαναγκάζει το σύστημα να χρησιμοποιήσει ως locale το el_GR.ISO-8859-7 και όχι αυτό που σου επιστρέφει η εντολή locale.

Με το KDE έχω πραγματικά πολύ καιρό να ασχολήθώ και δεν θυμάμαι τπτ...Εδώ θα πρέπει κάποιος άλλος να βοηθήσει...

apkoutsou]Καταρχάς συγγνώμη διότι δεν είδα ότι έχεις SuSE και έτσι KDE εξορισμού..

Δυο διορθωσούλες: Η πρώτη έιναι οτι το suse σου δίνει την επιλογή KDE-Gnome-Xfce κ.ά, ή όλα μαζί.

Δεύτερον δεν είναι "εξορισμού" αλλα εξ'ορισμού. Όχι τίποτε άλλο θα σε παρεξηγήσουμε (καλά κι εσύ σήμερα βρήκες?) :p

Παιδια εντάξει τώρα εμφανίζονται τα γράμματα αλλά πάνω στην εγκατάσταση κολάει και δεν φορτονει η μπαρα.Η κονσόλα γράφει το παρα κάτω σφάλμα

fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub
fixme:seh:_abnormal_termination (void)stub

Τα fixme δεν είναι σφάλματα απο οτι ξέρω. Τα υπόλοιπα τα έχεις εγκαταστήσει?

Teddy]

apkoutsou]Καταρχάς συγγνώμη διότι δεν είδα ότι έχεις SuSE και έτσι KDE εξορισμού..

Δυο διορθωσούλες: Η πρώτη έιναι οτι το suse σου δίνει την επιλογή KDE-Gnome-Xfce κ.ά, ή όλα μαζί.

Δεύτερον δεν είναι "εξορισμού" αλλα εξ'ορισμού. Όχι τίποτε άλλο θα σε παρεξηγήσουμε (καλά κι εσύ σήμερα βρήκες?) :p

OK! Η τελευταία έκδοση του SuSE που έχω δει ήταν η 9.2 Pro, Την είχα αγοράσει μάλιστα από τον Παπασωτηρίου 75 ολόκληρα ευρώ το 2004!!! Ήθελα να έχω όλα τα CDs και φυσικά το ΤΕΡΑΣΤΙΟ εγχειρίδιο, από το οποίο έμαθα και λίγα που ήξερα που ήξερα για το linux και την consol, μέχρι να ασχοληθώ πιο σοβαρά τον τελευταίο 1,5 χρόνο... Η έκδοση αυτή εγκαθιστούσε εξ ορισμού KDE 3.3 (γιατί και εσύ λάθος το έγγραψες... τι δουλειά έχει η απόστροφος??? είναι η πρόθεση 'εκ' που συντάσσεται με γενική και το ουσιαστικό 'ορισμός'.... το δικό μου λάθος είναι ότι έπρεπε να γράψω "... και έτσι το KDE εξορκισμού ..." για να έρθω και στα λεγόμενά σου στο ποστ που ανέφερες... ;-) )

Παντώς, ναι! πολύ καμμενιά.... LoL LoL

Λοιπόν, στο θέμα μας τώρα:

Ήταν τελικά θέμα localization??

Εδώ (όπως επισήμανε και ο καμμένος) λέει ότι μπορείς να το τρέξεις κανονικά σε OpenSuSE 11.1, απλά πρέπει πρώτα να εγκαταστήσεις την τελευταία έκδοση του wine (οδηγίες αρχικά εδώ και μετά εδώ) και μετά το winetricks με κάποια extra! Συνεπώς, αφού εγκαταστήσεις την τελευταία έκδοση του wine, δίνεις σε κονσόλα:

$ wget http://www.kegel.com/wine/winetricks; sh winetricks corefonts ie6 gdiplus msxml3
$ LC_ALL=el_GR.ISO-8859-7 wine /path/to/setup.exe

και πρέπει  να είσαι ΟΚ σε όλα...

Υ.Γ.: Τελικά με έκανες GRIGRIS να δω δύο φορές το μήνυμα μπας και έχω λάθη... LoL LoL!!!!

apkoutsou]

Teddy]

apkoutsou]Καταρχάς συγγνώμη διότι δεν είδα ότι έχεις SuSE και έτσι KDE εξορισμού..

Δυο διορθωσούλες: Η πρώτη έιναι οτι το suse σου δίνει την επιλογή KDE-Gnome-Xfce κ.ά, ή όλα μαζί.

Δεύτερον δεν είναι "εξορισμού" αλλα εξ'ορισμού. Όχι τίποτε άλλο θα σε παρεξηγήσουμε (καλά κι εσύ σήμερα βρήκες?) :p

OK! Η τελευταία έκδοση του SuSE που έχω δει ήταν η 9.2 Pro, Την είχα αγοράσει μάλιστα από τον Παπασωτηρίου 75 ολόκληρα ευρώ το 2004!!! Ήθελα να έχω όλα τα CDs και φυσικά το ΤΕΡΑΣΤΙΟ εγχειρίδιο, από το οποίο έμαθα και λίγα που ήξερα που ήξερα για το linux και την consol, μέχρι να ασχοληθώ πιο σοβαρά τον τελευταίο 1,5 χρόνο... Η έκδοση αυτή εγκαθιστούσε εξ ορισμού KDE 3.3 (γιατί και εσύ λάθος το έγγραψες... τι δουλειά έχει η απόστροφος??? είναι η πρόθεση 'εκ' που συντάσσεται με γενική και το ουσιαστικό 'ορισμός'.... το δικό μου λάθος είναι ότι έπρεπε να γράψω "... και έτσι το KDE εξορκισμού ..." για να έρθω και στα λεγόμενά σου στο ποστ που ανέφερες... ;-) )

Παντώς, ναι! πολύ καμμενιά.... LoL LoL

Λοιπόν, στο θέμα μας τώρα:

Ήταν τελικά θέμα localization??

Εδώ (όπως επισήμανε και ο καμμένος) λέει ότι μπορείς να το τρέξεις κανονικά σε OpenSuSE 11.1, απλά πρέπει πρώτα να εγκαταστήσεις την τελευταία έκδοση του wine (οδηγίες αρχικά εδώ και μετά εδώ) και μετά το winetricks με κάποια extra! Συνεπώς, αφού εγκαταστήσεις την τελευταία έκδοση του wine, δίνεις σε κονσόλα:

$ wget http://www.kegel.com/wine/winetricks; sh winetricks corefonts ie6 gdiplus msxml3
$ LC_ALL=el_GR.ISO-8859-7 wine /path/to/setup.exe

και πρέπει  να είσαι ΟΚ σε όλα...

Υ.Γ.: Τελικά με έκανες GRIGRIS να δω δύο φορές το μήνυμα μπας και έχω λάθη... LoL LoL!!!!

τα έκανα όλα.Αλλά πάλι κολάει στην εγκατάσταση....

Βασική ερώτηση: έχεις το wine το 0.9xx που είναι στο επίσημο repo ή το wine που θα βρείς στα community repositories? Βάλε το δεύτερο (έκδοση 1.15 ή 1.16). Το βάζεις απο YAST-->Πηγές Λογισμικού--->Προσθήκη-->community repositories και το βρίσκεις εκεί (Wine CVS Builds). Μετά θα το βρεις στην προσθαφαίρεση προγραμμάτων