προβλημα με pacman -Syu

ditsikts | Κυρ, 10/12/2008 - 11:19 | 1' | 10

φτάνω στο σημείο να δώσω την εντολή pacman -Syu έχωντας ακολουθήσει τις οδηγίες του περιοδικού,

και μου βγάζει αυτο το μήνυμα:

error failed to init transaction (unable to lock database)

if you are sure a package manager is not already running,

you can remove /var/lib/pacman/db.lck.

δοκίμασα να σβήσω το db.lck με rm /var/lib/pacman/db.lck και μου λέει ότι δεν υπάρχει.

Φόρουμ
Δώσε αστέρια!
Σχόλια

Tην έτρεξες την εντολή ως root ; Μπορεί να μην δούλεψε επειδή έτρεχε ήδη ο pacman ...

--------------------
happy_linux_downloads

ως root την έτρεξα.
Το μήνυμα λέει ότι ίσως τρέχει ήδη ο pacman.
Με το που έκανα login ως root γίνετε να ξεκινήσει μόνος του να τρέχει;
πως θα δω αν τρέχει ήδη ο pacman και πως μπορώ να τον σταματήσω;

Όχι αν δεν τον τρέξεις εσύ δεν ξεκινάει μόνος του ο pacman.Ακούγεται και περίεργο γιατί σου βγάζει το πρόβλημα και δεν γνωρίζω αν υπάρχει άλλη λύση,εκτός από αυτήν που αναφέρει.

Nα φανταστώ αυτό το βγάζει σε ότι και αν πας να κάνεις με τον pacman.Για δες στο αρχείο /var/log/pacman.log μπας και βγάζει κάποιο σφάλμα πριν το παραπάνω μήνυμα ;

--------------------
happy_linux_downloads

Ευχαριστώ για το ενδιαφέρον αλλά το έσβησα το arch και έβαλα να δοκιμάσω το super ubuntu, μόνο με το ubuntu και τα παράγωγά του τα πάω καλά. Του arch θα του ξαναδώσω ευκαιρία κάποια στιγμή.

ok μια άλλη φορά :)

Πάντως αν ψάχνεσαι για διανομή ρίξε μια ματιά στη mandriva :D

--------------------
happy_linux_downloads

πήγα να τη δοκιμάσω αλλά μου κολούσε στο boot αφου μου εμφάνιζε 2 γραμμές που ξεκινούσαν με audit.
λες να τη ξανακατεβάσω μηήπως είχε κάποιο σφάλμα στην εγγραφή του cd ή το isο;

bash-3.2# pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
adslgr32 is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace cairo with adslgr32/cairo-cleartype? [Y/n] Υ
:: Replace freetype2 with adslgr32/freetype2-cleartype? [Y/n] Υ
:: Replace libxft with adslgr32/libxft-cleartype? [Y/n] Υ
:: Replace mplayer with adslgr32/mplayer-svn? [Y/n] Υ
:: Replace smplayer with adslgr32/smplayer-svn? [Y/n] Υ
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: ipw3945: requires kernel26<2.6.27
bash-3.2#

τι ειναι ?

είμαι καινούργιος με το arch αλλα δεν τα παραταω

πρεπει να αναβαθμισεις τον πυρηνα σου ,με βαση αυτα που λεει. Δοκιμασε ενα pacman -Su kernel

[[email protected]]$uname -r|awk '{print $1}'

bash-3.2# pacman -Su kernel
:: Starting full system upgrade...
:: Replace cairo with adslgr32/cairo-cleartype? [Y/n] n
:: Replace freetype2 with adslgr32/freetype2-cleartype? [Y/n] n
:: Replace libxft with adslgr32/libxft-cleartype? [Y/n] n
:: Replace mplayer with adslgr32/mplayer-svn? [Y/n] n
:: Replace smplayer with adslgr32/smplayer-svn? [Y/n] n
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: ipw3945: requires kernel26<2.6.27
bash-3.2# pacman -Suy
:: Synchronizing package databases...
core                      31,7K   12,5K/s 00:00:03 [#####################] 100%
extra                    413,8K   12,3K/s 00:00:34 [#####################] 100%
community                358,2K   15,2K/s 00:00:23 [#####################] 100%
adslgr32                  20,5K   50,3K/s 00:00:00 [#####################] 100%
archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace cairo with adslgr32/cairo-cleartype? [Y/n] y
:: Replace freetype2 with adslgr32/freetype2-cleartype? [Y/n] y
:: Replace libxft with adslgr32/libxft-cleartype? [Y/n] y
:: Replace mplayer with adslgr32/mplayer-svn? [Y/n] y
:: Replace smplayer with adslgr32/smplayer-svn? [Y/n] y
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: ipw3945: requires kernel26<2.6.27
bash-3.2#

[[email protected]]$uname -r|awk '{print $1}'  ----- ti ειναι ??


Βγάζει αυτό το πρόβλημα επειδή πλέον δεν υποστηρίζεται ο ipw3945 από τον νέο kernel αλλά έχει αντικατασταθεί από το iwl3945 (η είδηση)

Τώρα για να λυθεί το πρόβλημα (από εδώ) θα πρέπει να κάνεις εγκατάσταση το iwlwifi-3945-ucode (ως root) με:

pacman -S iwlwifi-3945-ucode

Και για να ξεκινάει και στο boot πρόσθεσε το iwl3945 στα Modules,για ευκολία:

gedit /etc/rc.conf

θα ανοίξει ένα αρχείο και θα δεις μια γραμμή με modules,πρόσθεσε το--αν έχεις KDE βάλε kwrite ή kate αντί για gedit :).

Αφού κάνεις αυτά πλέον θα μπορέσεις να κάνεις αναβάθμιση το πισί σου με:

pacman -Syu

Για οποιαδήποτε άλλη απορία εδώ είμαστε :) :)
--------------------
happy_linux_downloads