Suse 10.2 Xgl

gregoryx | Κυρ, 01/13/2008 - 23:05 | 1' | 10

Θα ηθελα οδηγιες για το πως μπορω να εργοποιησω το Xgl αλλα και πως να το απενεργοποιησω. Εχω βαλει οδηγους για την καρτα γραφικων. (με τα αγγλικα δεν τα παω καλα, εναν οδηγο οπως ειχατε στο περιοδικο για το 10,1 θα βοηθουσε)

Φόρουμ
Δώσε αστέρια!
Σχόλια

Το tutorial που πρέπει να ακολουθήσεις είναι αυτό:
http://en.opensuse.org/Beryl

Χοντρικά πρέπει:

1) Να έχεις nVidia ή ATi με εγκατεστημένους τους drivers.
Αν δεν τους έχεις εγκαταστήσεις δες εδώ και εδώ για το πως εγκαθιστάς τα αποθετήρια.

2) Να εγκαταστήσεις τα αποθετήρια για τα πακέτα του Beryl/Xgl.
Αν χρησιμοποιείς το zypper/rug, άνοιξε μια κονσόλα και δώσε:

zypper sa  http://ftp.skynet.be/pub/software.opensuse.org/X11:/XGL/open SUSE_10.2/ xgl
ή
rug sa http://ftp.skynet.be/pub/software.opensuse.org/X11:/XGL/open SUSE_10.2/ xgl

Ενώ αν χρησιμοποιείς το Add Sources του YaST, δώσε τα ξής στο Add Source:
Είδος: rpm-md/repomd
Πρωτόκολλο: HTTP
Όνομα διακομιστή: software.opensuse.org
Φάκελος: /download/X11:/XGL/openSUSE_10.2/


3) Μετά εγκατέστησε τα παρακάτω πακέτα
(Αυτό γίνεται μέσω YaST ή rug/zypper από την κονσόλα):

  • xgl
  • beryl-core-snapshot
  • beryl-plugins-snapshot
  • emerald-snapshot : window decorator
  • emerald-themes-snapshot
  • aquamarine-snapshot
  • beryl-settings-snapshot
  • beryl-manager-snapshot
  • compiz


4) Ένεργοποίησε το Xgl.
Ανοιξε μια κονσόλα και δώσε:

su
gnome-xgl-switch --enable-xgl

(άσχετα αν έχεις KDE ή Gnome) και μετά δώσε:

su
rcxdm restart

Θα ξαναξεκινήσει ο Χ Server οπότε δίνεις:

beryl-manager

και τρέχεις το Beryl/Xgl.



linuxformat2007-3-2 10:26:6

Τα παραπάνω είναι για Beryl με Xgl.

Όμως μπορείς ίσως να τρέξεις το Beryl πάνω σε AIGLX.
Σε αυτή την περίπτωση όμως θα πρέπει να έχεις είτε nVidia (Geforce 4>) είτε παλιότερη ATi (Radeon 7000 μέχρι X850)

Εγκαθιστάς τους drivers

και δίνεις

su
gnome-xgl-settings --disable-xgl

για να απενεργοποιήσεις, αν χρειάζεται το Xgl. Μετά κάνε ένα backup στο /etc/X11/xorg.conf:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

και άνοιξε το με ένα κειμενογράφο (για KDE):

kdesu kate /etc/X11/xorg.conf

ή για Gnome:
gksu gedit /etc/X11/xorg.conf

Στο νέο παράθυρο βρες το Section "ServerLayout", και πρόσθεσε (αν δεν υπάρχει):

Option "AIGLX" "true"

Βρες μετά το Section "DRI", και πρόσθεσε (αν δεν υπάρχει):

Group 0
Mode 0666

Ενώ στο  Section "Device", γράψε:

Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"

Τέλος πρέπει να φτιάξεις ένα νέο Section που θα λέει τα εξής:

Section "Extensions"

    Option "Composite" "Enable"

EndSection


Τελικά το xorg.conf θα πρέπει να είναι κάπως έτσι:
Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Option "AIGLX" "true"
Screen "Screen[0]"
EndSection

Section "Device"
BoardName "915 GM"
BusID "0:2:0"
Driver "i810"
Identifier "Device[0]"
Option "NoDDC"
VendorName "Intel"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
EndSection



Στη συνέχεια πάτα Ctrl+S, κλεισε το παράθυρο και δώσε

su
rcxdm restart

Και τρέξε το Beryl:

beryl-manager





Σε κάθε περίπτωση θα πρέπει να δίνεις
beryl-manager

για να τρέχεις το beryl μετά από κάθε reboot.

Για να το τρέχεις αυτόματα, κάνε τα εξής ανάλογα με το γραφικό περιβάλλον που έχεις:

KDE

Από μια κονσόλα (όχι ως root) δώσε τις εντολές:

ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager
ln -s /usr/bin/beryl ~/.kde/Autostart/beryl


Gnome

Πήγαινε στο Κέντρο Ελέγχου του Gnome, βρες το Sessions και στη τελευταία καρτέλα "Startup Programs", πρόσθεσε τα εξής δύο προγράμματα στη λίστα με όσα θα ξεκινούν αυτόματα:

beryl-manager
beryl




linuxformat2007-3-2 10:24:36

Για να μην παιδεύεσαι, κατέβασε το scriptάκι

http://l2knet.awardspace.com/scripts/postinstall.sh

(δεξί κλικ > Save As, σώσε το στο Desktop). Μετά άνοιξε μια κονσόλα και δώσε:

cd ~/Desktop
sudo sh ./postinstall.sh

Θα σου εγκατάστήσει Adobe Flash, Java, και 3D desktop.

μετα απο ολα αυτα δεν ανοιγει η επιφανεισ εργασιασ και συνεχιζει σε γραμμη εντολων. ακολουθησα την πρωτη διαδικασια με καρτα τησ ατι 9550 256 mb

το σκρυπτακι δεν υπερχει σε αυτην την διευθινση

γειά σας κι απο μένα.
Έχω 2 pc και στο 1 έχω περάσει το opensuse 10.2.
Το θέμα που έχω με το beryl είναι το εξής:
Έχω περάσει το repository στο yast, εγκατέστησα μετά ένα πρόγραμμα που υποτίθεται πως αναλάμβανε να διαχειριστεί την όλη διαδικασία με έναν φιλικό προς τον χρήστη τρόπο.
Το πρόγραμμα αυτό εγκατέστησε κι ενεργοποίησε το Beryl.
Μετα απο επανεκκίνηση είχα κανονικά Beryl αλλά μετά ενεργοποίησα ένα gconf το οποίο όπως έλεγε, έκανε overide το xgl-conf.
Ισως να είναι ιδέα μου αλλά απο τότε και μετά κάθε φορά που τρέχω το beryl βρίσκω προβλήματα.
Μετα την εκκίνηση , φορτώνει το Beryl-manager αλλα επιλέγει για window manager οχι το beryl/emerald αλλά ένα metacity? (εαν θυμάμαι καλά το όνομα).
Πρέπει κάθε φορά να επιλέγω χειροκίνητα το beryl window manager, κι όταν γίνεται αυτό, εξαφανίζεται η μπάρα που βρίσκονται τα κουμπιά εξόδου, μεγιστοποίησης/ελαχιστοποίησης στα παράθυρα.

Πρέπει να κάνω reload window manager αρκετές φορές για να λειτουργίσει σωστά το beryl.
Τελικά μήπως έχει πολλά bug ή έκανα εγώ κάτι λάθος;
----------------- Update
Τελικά νομίζω πως το διόρθωσα.
Διέγραψα το user account και το ξανα δημιούργησα.
Το μόνο πρόβλημα που αντιμετωπίζω είναι πως κάθε φορά που ξεκινά ο beryl-manager μου φορτώνει το Metacity window manager.
Πως θα ορίσω να φορτώνει πάντα το beryl window manager?
suselakos2007-6-26 22:54:52

Δε θυμαμαι, που ειναι στο suse, μα λογικα απο το Yast, θα πας καπου στις ρυθμισεις του hardware & καπου εκει θα βρεις την επιλογη που ειναι για τις αναλογες ρυθμισεις.

Πανω-κατω, κατι τετοιο:

(Προσοχη αυτο ειναι αλλη διανομη(PCLOS), πανω-κατω, ετσι θα ειναι & στο Suse)



Απο εκει θα μπεις στο μενου & θα επιλεξεις μονιμα το beryl manager

To προβλημα που λες, μαλλον, σου δημιουργηθηκε επειδη το παραφορτωσες. Αν θες να βλεπεις ολα τα εφε & καθε φορα διαφορετικο βαλε σα default το: Random

Aνοιξε το beryl. Θα σου ερθει στον πινακα, κατω. Δεξι κλικ, κανε οτι βλεπεις:



(με κλικ στην εικονα τη βλεπεις σε μεγαλο μεγεθος)

Mετα με δεξι κλικ, επελεξε beryl manager & κανε οτι ρυθμισεις θελεις. Το ιδιο & με το Emerald, διαλεξε οτι σου αρεσει. (εχω π.χ το ghost(λιγο τροποποιημενο,βεβαια)constantinos2007-6-28 22:30:37

Aν παντως τυχει & δε πιασει, που δε νομιζω, κανε κατι αλλο:

Ανοιξε κονσολα & δωσε:

ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager

ln -s /usr/bin/beryl ~/.kde/Autostart/beryl


Ετσι καθε φορα που ξεκινας, θα αρχιζει & το beryl!

ps: Αυτο θα το κανεις σαν χρηστης. Oxi σαν rootconstantinos2007-6-28 23:31:53