web cam

g.b | Πέμ, 04/03/2008 - 20:20 | 2' | 18

καλησπέρα,

πρώτα θα ευχαριστήσω ακόμα μια φορά για την βοήθεια που είχα στο θέμα του evolution mail,

(καλά έστειλα καμιά δεκαριά email έτσι για να το χαρώ),

τώρα θα ρωτήσω κάτι άλλο , είπαμε νιούφης είμαι και δεν ξέρω ,

έχω δύο web cams , μια microsoft LifeCam VX-1000 και

μια Creative (αγνώστων λοιπών στοιχείων , αλλά αν χρειαστει θα ανέβω στο πατάρι

για να βρω το κουτί της)

στα παραθύρια τις έβαζες , εγκατάσταση και τσουπ έβλεπες της φάτσα σου στην οθόνη,

εδώ τι γίνεται?

πως θα κάνω αυτές τις δύο ή έστω την μία @#[email protected]$#% συσκευές να δουλέψουν?

Φόρουμ
Δώσε αστέρια!
Σχόλια

Σύνδεσε τις κάμερες σου στον υπολογιστή και μετά από ένα τερματικό/κονσόλα γράψε

lsusb

και κάνε ένα copy/paste αυτά που θα βγάλει η εντολή.

-------------------

Η ΔΕΗ σας εύχεται Καλές Διακοπές !!!!

g.b. πρέπει να βρεις τι τσιπάκι φοράει η κάθε κάμερα (όπως σου έδειξε ο thanos) και έπειτα να ψάξεις για drivers. Πάντως, αν είσαι τυχερός, μπορεί ο πυρήνας να περιέχει ήδη drivers για κάποια από τις δύο. Απλά, τρέξε το Ekiga (στο μενού Internet του Ubuntu) και κάνε κλικ στο εικονίδιο της κάμερας. Αν δεις τη φάτσα σου, σημαίνει ότι υποστηρίζεται η webcam...:) Αν δεν υπάρχουν μέσα στον πυρήνα drivers, μπορεί να σε σώσει ο Γάλλος mxhaard που έχει φτιάξει ένα πακέτο (το gspca) που υποστηρίζει δεκάδες webcams. Για να δεις αν υποστηρίζει και κάποια από τις δικές σου, πρέπει να δώσεις την παραπάνω εντολή, sudo lsusb και θα σου απαντήσει κάτι σαν κι αυτό:

Bus 005 Device 001: ID 0000:0000
Bus 001 Device 006: ID 045e:072b Microsoft Corp.
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000

Τώρα πρέπει να αντιπαραβάλλεις το αποτέλεσμα (045e: 072b) με τον πίνακα που θα βρεις εδώ: http://mxhaard.free.fr/spca5xx.html Ψάχνεις για το ίδιο vendorid/product id με αυτά που σου έδωσε το lsusb και, αν τα βρεις, κοιτάς αν στην προτελευταία στήλη λέει Yes. Αυτό δηλώνει ότι υποστηρίζεται η webcam σου. Αν μία από τις δύο webcams υποστηρίζεται από το gspca, τότε για να το εγκαταστήσεις απευθείας βλέπεις αν υπάρχει binary module για τον πυρήνα σου:

apt-cache search gspca-`uname -r` 

- Αν υπάρχει, το εγκαθιστάς

sudo apt-get install gspca-`uname -r` 

Reboot και ξαναδοκιμή στο Ekiga. - Αν δεν υπάρχει binary module, κατεβάζεις τον κώδικα:

  sudo apt-get install gspca-source

και το κάνεις compile με το module-assistant:

  sudo m-a
 

Θα εμφανιστεί ένα μενού, όπου κάνεις κατά σειρά, UPDATE, PREPARE, και SELECT. Στο SELECT εμφανίζεται μια τεράστια λίστα, επιλέγεις (πατώντας Space) μόνο το gspca και μετά πατάς OK. Σε λίγο θα στο φτιάξει και θα κάνεις ξανά reboot και ξανά δοκιμή στο Ekiga.

αν και δεν κατάλαβα και πολλά (σχεδόν τίποτα) με αυτά τα sudo, apt

πρέπει να πω ότι είχε ενδιαφέρον.

κάτι έκανα , με είδα στην οθόνη ,

αλλά η εικόνα δεν ήταν καθαρή.

είναι νορμάλ αυτό ή μπορεί να γίνει κάτι παραπάνω?

(την βλέπω την δουλειά εγώ , έχω να κεράσω καφεδάκια

μέχρι να μάθω πέντε οκάδες linux, ουουου...)

Εκανες τη διαδικασία με το module-assistan έτσι;
Aμα είδες τη φάτσα σου είσαι ΟΚ. O driver εγκαταστάθηκε. Τώρα για το γιατί εμφανίζεται όπως εμφανίζεται η φάτσα σου...εεεε, εδώ δεν ξέρω. Μόνο με το Ekiga δοκίμασες;

Δημήτρη, έχω κάνει την ίδια διαδικασία με το Ekiga, αλλά το ανοίγω μέσω κονσόλας. Πώς μπορώ να το εμφανίσω στο Μενού του Ubuntu Ultimate μου; Δεν το βρίσκω κάπου.

------------------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

ΓΕΙΑ ΣΑΣ ΠΑΙΔΙΑ. ΕΙΜΑΙ ΚΑΙΝΟΥΡΓΙΟΣ ΧΡΗΣΤΗΣ ΤΟΥ LINUX UBUNTU 7.10 64bit ΚΑΙ ΓΙ' ΑΥΤΟ ΑΝΤΙΜΕΤΩΠΙΖΩ ΚΑΠΟΙΑ ΠΡΟΒΛΗΜΑΤΑ. ΕΧΩ ΕΓΚΑΤΑΣΤΗΣΕΙ ΤΟ SKYPE ΑΛΛΑ ΔΕΝ ΔΟΥΛΕΥΕΙ Η ΚΑΜΕΡΑ ΜΟΥ. ΤΟ ΜΙΚΡΟΦΩΝΟ ΟΜΩΣ ΔΟΥΛΕΥΕΙ. ΑΝΤΙΘΕΤΑ ΣΤΟ amsn ΔΟΥΛΕΥΕΙ Η ΚΑΜΕΡΑ ΑΛΛΑ ΔΕΝ ΔΟΥΛΕΥΕΙ ΤΟ ΜΙΚΡΟΦΩΝΟ. ΜΠΟΡΕΙΤΕ ΝΑ ΜΕ ΒΟΗΘΗΣΕΤΕ ΚΑΙ ΝΑ ΜΟΥ ΠΕΙΤΕ ΤΙ ΝΑ ΚΑΝΩ ΓΙΑΤΙ ΕΧΩ ΧΑΣΕΙ ΤΗΝ ΜΠΑΛΑ. ΣΑΣ ΕΥΧΑΡΙΣΤΩ.

Υ.Γ: ΠΑΝΤΩΣ ΕΙΜΑΙ ΠΟΛΥ ΕΥΧΑΡΙΣΤΗΜΕΝΟΣ ΣΕ ΓΕΝΙΚΕΣ ΓΡΑΜΜΕΣ ΜΕ ΤΟ LINUX. ΕΙΝΑΙ ΠΑΡΑ ΠΟΛΥ ΣΤΑΘΕΡΟ ΛΟΓΙΣΜΙΚΟ ΣΕ ΣΧΕΣΗ ΜΕ ΤΑ WINDOWS.

Πήγαινε στα options του προγράμματος και στα video devices και δες εκεί αν έχει στην μπάρα επιλογή για την κάμερα σου και πάτα και το test.

ΠΗΓΑ ΣΤΑ options ΤΟΥ skype. ΕΚΕΙ ΕΧΕΙ ΕΠΙΛΟΓΗ ΓΙΑ ΚΑΜΕΡΑ ΑΛΛΑ ΟΤΑΝ ΤΟ ΠΑΤΑΩ ΓΡΑΦΕΙ NO DEVICES FOUND. ΤΙ ΜΠΟΡΩ ΝΑ ΚΑΝΩ ΑΛΛΟ?

γειά σου gakis jedi. Δοκίμασες να ακολουθησεις τις οδηγίες στο post #2;
Εφόσον σου λέει "no devices found" δεν υπάρχουν drivers στη διανομή σου. Χρειάζεται να δεις αν υπάρχουν αλλού. Γι' αυτό πρέπει να ξέρεις το μοντέλο του chip της webcam σου. Αναλυτικά έχω γράψει γι' αυτό το ζήτημα στο #2 πόστ αυτού του thread.

dimitris ΤΟ ΕΚΑΝΑ ΑΥΤΟ ΠΟΥ ΜΟΥ ΕΙΠΕΣ. ΕΝΝΟΩ ΑΥΤΟ ΣΤΟ post#2 ΑΛΛΑ ΚΑΙ ΠΑΛΙ ΣΤΟ SKYPE ΔΕΝ ΕΧΕΙ ΚΑΜΕΡΑ. ΜΟΝΟ ΣΤΟ amsn ΛΕΙΤΟΥΡΓΕΙ. ΤΙ ΜΠΟΡΕΙ ΝΑ ΦΤΑΙΕΙ?

Εγκατέστησες δηλαδή τους gspca drivers και η κάμερα παίζει αλλά μόνο στο aMSN; Στο Ekiga παίζει;

Μήπως το Skype έχει κάποια τρελά κρυμμένη ρύθμιση για τον ποιον driver να χρησιμοποιεί;

ΝΑΙ ΣΤΟ Ekiga ΔΟΥΛΕΥΕΙ. ΑΝ ΥΠΑΡΧΕΙ ΑΥΤΗ Η ΤΡΕΛΑ ΚΡΥΜΜΕΝΗ ΡΥΘΜΙΣΗ, ΕΓΩ ΠΩΣ ΘΑ ΜΠΟΡΕΣΩ ΝΑ ΤΗΝ ΒΡΩ?

Αν δουλεύει στο Ekiga και στο aMSN, τότε το Linux δεν φταίει. Πρόκειται για βλακεία του Skype. Ψάξτε λίγο στις ρυθμίσεις του, αν υπάρχουν επιλογές για την webcam...προς το παρόν, δεν μπορώ να προσφέρω άλλη βοήθεια :(

Έχω suse 10.0 και μια web cam , creative PD1001

με lsusb παίρνω

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 005: ID 041e:400d Creative Technology, Ltd WebCam PD1001
Bus 002 Device 004: ID 15ca:00c3
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

προσπαθώ να βρω drivers να την εγκαταστήσω και κατέβασα από http://alpha.dyndns.org/ov511/download.html#2.xx το ov511-2.29.tar.bz2. Με αυτό τον τρόπο όμως δεν το κατάξερα. Έψαξα και από αυτόν το Γάλλο http://mxhaard.free.fr/spca5xx.html που το βλέπω παντού αλλά τπτ(δε βρίσκω το ID, 041e:400d ).Προσπαθώ να χρησιμοποιήσω την κάμερα μέσω amsn αλλά δεν τη βλέπει..
Επίσης δεν ξέρω και κάποιο πρόγραμμα μέσω του οποίου να μπορώ να τη χρησιμοποιήσω .. Υπάρχει καμμία πρόταση ?

Ευχαριστώ

Γεια σας!

ως νεος και εγω εχω τα προβληματα μου. λοιπον διαβαζοντας εδω το θεματακι θυμηθηκα οτι ακομα δεν δουλευει η καμερουλα μου... ή μαλλον δουλευει λαθος. πχ βλεπω στο ekiga καπως την φατσα μου αλλα εγω δουλευω skype το οποιο κανει φιλοτιμες προσπαθειες να με εμφανισει αλλα το μονο που καταφερα ηταν να με δω σε μια πρασινη οθονη και χωρις να ειμαι σιγουρος με δειχνει διπλό. τελος το amsn δεν ασχολειται με χαμηλης ποιοτητας εικονες μαλλον οποτε δειχνει απλα μια μαυρη εικονα. εχω δοκιμασει διαφορα ψαχνοντας αλλα το περισσοτερο που καταφερα ηταν αυτο. αντε να δουμε αν θα βρεθει καμια λυση.

παρεπιπτοντως εχω ενα acer aspire 5672wlmi και η καμερα λεει κατι για orbicam.

Υ.Γ. Απιθανο το ubuntu! και μονο οτι σερφαρα οση ωρα το εγκαθηστουσα... ενω στα win εκανα ενα πακετο τσιγαρα τα λεει ολα...

Φίλε Δημήτρη. Χρειὰζομαι την γνώμη σου διότι φαινεται να το κατέχεις το άθλημα που λέγεται Linux και ακολούθηασα τις οδηγίες σου που βρήκα στο forum. Σου περιγράφω τι έκανα και πες μου σε παρακαλώ έχω πρόβλημα στον Kernel? Συγνώμη αν γὶνω κουραστικός.
Είμαι αρχάριος χρὴστης σχετικά, του Linux και γράφτηκα μολις προχθές στο forum του περιοδικού. Αφορμή ήταν η αδυναμία να δουλέψω δύο web cameras που έχω.
1.Bus 002 Device 002: ID 046d:0920 Logitech, Inc. QuickCam Express
2.Bus 001 Device 003: ID 046d:0992 Logitech, Inc. QuickCam Communicate Deluxe
Η 1. υποστηρίζεται απ´ότι είδα στην σελίδα αυτού του μουσάτου Γάλλου που έφτιαξε τον driver "gspca", οπότε ακουλούθησα τις οδηγίες σου από το βήμα ´sudo apt-get install gspca-source´Αφού λοιπόν εφτασα να επιλεξω το gspca πατησα οκ και μετα build? σωστά? και η διαδικασία σταματησε με το παρακατω μηνυμα:Build of the package gspca-source failed! How do you wish too proceed?1.view, 2. continue, 3. stop. και πατησα στοπ.κατέβασα λοιπον το gspcav1-20071224.tar.gz απο την σελιδα αυτουνου του Γαλλου αποσημπίεσα μπηκα στο νεο καταλογο και διαβαζοντας το READ_AND_INSTALL, ακουκούθησα τις οδηγίες. εκτέλεσα λοιπον την εντολη make και πηρα μια σειρα απο λαθη.
Ψαχνοντας λοιπον βρηκα οτι υπαρχει και ο driver qc-usb-0.6.6.tar.gz. τα ιδια και εδω αποσημπίεσα μπηκα στο νεο καταλογο και διαβαζοντας τις οδηγιες απο την σελιδα εκτέλεσα την εντολη make all και δες τη εγινε:[email protected]-ubuntu:~/downloads/programs/QuickCam/qc-usb-0.6.6$ make all
make -C "/lib/modules/2.6.27-9-generic/build" SUBDIRS="/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6" modules V=1 USER_OPT="-DHAVE_UTSRELEASE_H=1"
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-9-generic'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
/bin/false)
mkdir -p /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/.tmp_versions ; rm -f /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/.tmp_versions/*
make -f scripts/Makefile.build obj=/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6
gcc -Wp,-MD,/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/.qc-driver.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.2/include -D__KERNEL__ -Iinclude -I/usr/src/linux-headers-2.6.27-9-generic/arch/x86/include -include include/linux/autoconf.h -Iubuntu/include -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -ffreestanding -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iinclude/asm-x86/mach-default -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -pg -Wdeclaration-after-statement -Wno-pointer-sign -DNOKERNEL -DHAVE_UTSRELEASE_H=1 -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(qc_driver)" -D"KBUILD_MODNAME=KBUILD_STR(quickcam)" -c -o /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/.tmp_qc-driver.o /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c
In file included from /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:47:
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/quickcam.h:129:1: warning: "BIT" redefined
In file included from include/linux/kernel.h:15,
from include/linux/cache.h:4,
from include/linux/time.h:7,
from include/linux/videodev2.h:60,
from include/linux/videodev.h:16,
from /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/quickcam.h:95,
from /home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:47:
include/linux/bitops.h:6:1: warning: this is the location of the previous definition
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c: In function ‘qc_i2c_init’:
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:824: error: ‘struct urb’ has no member named ‘lock’
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:825: warning: assignment from incompatible pointer type
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c: In function ‘qc_isoc_start’:
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:1867: warning: assignment from incompatible pointer type
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c: In function ‘qc_v4l_ioctl’:
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:2529: error: ‘struct video_device’ has no member named ‘type’
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c: At top level:
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:3008: error: unknown field ‘type’ specified in initializer
/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.c:3009: error: unknown field ‘hardware’ specified in initializer
make[2]: *** [/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6/qc-driver.o] Error 1
make[1]: *** [_module_/home/spyros/downloads/programs/QuickCam/qc-usb-0.6.6] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic'
make: *** [quickcam.ko] Error 2

με ανησηχουν στις πρωτες γραμμες εκεινα τα echo και τις εντολές που πρεπει να δωσω για να επιδιορθωθεί ο Kernel? αν καταλαβα καλα?
Με την δεύτερη κάμερα είχα εικόνα στο vlc προτού κάνω όλα αυτά.??

Ευχαριστὼ, περιμὲνω απὰντησὴ σου.

εχω την microsoft vx-3000 αλλα υποστηριζιε αυτο gspcav1 οχι το gspca τελικα τι φταιε?ι? και δεν φαινεται ουτε στο synaptic to gspca εγκατασταθηκε κανονικα αλλα δεν εβγαλα ακρη με το τερματικο