πως βάζω τους drivers σε ubuntu ?

Ανώνυμος (χωρίς επαλήθευση) | Κυρ, 01/13/2008 - 23:05 | 1' | 8

εχω το ubuntu 7.04-feisty.εξερετικη εκδοση ασχετα αν ειναι ακομη λιγο beta.επιδει προτη φορα ασχολουμε με ubuntu που βρισκο deb πακετο η οτιδιποτε περνει με drivers για nvidia GeForce 6200 κ πανο απο ολλα ποσ τουσ εγκαθιστο αφου δεν μπορο να βγω απο τον Χ με το init 3.

Φόρουμ
Δώσε αστέρια!
Σχόλια

κανενασ δεν μπορει να μου απαντισει?

Σημείωση: Στο Feisty αρκεί να εγκαταστήσετε το πακέτο nvidia-glx ή nvidia-glx-legacy για να εγκαταστήσετε τους drivers της nVidia. Δεν χρειάζεται καμία από τις παρακάτω αλλαγές. Οι οδηγίες αφορούσαν παλιότερη alpha έκδοση του Feisty.


Τα παρακάτω ισχύουν για το edgy. Λογικά (αλλά καθόλου σίγουρα) αν αλλάξεις τη λέξη edgy σε feisty στα αποθετήρια τότε ίίσως να κάνεις τη δουλειά σου. Το Feisty είναι beta και μπορεί να μην έχουν φτιάξει ακόμα πακέτα drivers (ούτε καν αποθετήρια). Τέσπα, δοκίμασε.

BHMA 1: ΑΠΟΘΕΤΗΡΙΑ

Ανοίξτε μια κονσόλα και κάντε ένα αντίγραφο του αρχείου, για παν ενδεχόμενο:
sudo cp -p /etc/apt/sources.list /etc/apt/sources.list_backup

Μετά ανοίξτε το αρχείο sources.list με την εντολή:
sudo gedit /etc/apt/sources.list

Αντικαταστήστε το περιεχόμενό του με τις παρακάτω γραμμές:

## Add comments (##) in front of any line to remove it from being checked.   
## Use the following sources.list at your own risk.

deb http://gr.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://gr.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

deb http://gr.archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://gr.archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://gr.archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://gr.archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb-src http://gr.archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

## PLF REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://packages.freecontrib.org/plf edgy-plf free non-free
deb-src http://packages.freecontrib.org/plf edgy-plf free non-free

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.)
deb http://archive.canonical.com/ubuntu edgy-commercial main

## Listen
#deb http://theli.free.fr/packages/ edgy listen



Αποθηκεύστε το με Ctrl+S και κλείστε το παράθυρο.


BHMA 2: ΕΓΚΑΤΑΣΤΑΣΗ DRIVERS

Μετά από το τερματικό δώστε:


sudo apt-get install nvidia-glx nvidia-kernel-common

sudo nvidia-xconfig

Στη συνέχεια δώσε:

sudo gedit /etc/X11/xorg.conf

και τσέκαρε ότι ο Driver είναι ο "nvidia" και όχι o "nv"
Αν όχι άλλαξε τον. Σώσε το αρχείο και κλείστο.

Μετά πάτησε Ctrl+Alt+del για να κάνεις reboot τον X.


dimitris2007-4-18 1:5:53

Δημητρη εισαι κορυφη.επιασε.μπεικαν οι drivers.ποσ ρυθμιζω ομοσ αναληση οθονησ?

Δεν είμαι σίγουρος αν έχω καταλάβει.

Υπάρχει επιλογή στο μενού Συστημα > Προτιμήσεις > Ανάλυση οθόνης. Δοκίμασε από εκεί να δεις τι επιλογές σου δίνει. Αμα δεν κάνεις προκοπή, πρέπει να σκαλίσεις λίγο το αρχείο ρυθμίσεων του X11.

Από το τερματικό δώσε (copy/paste):

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.b

Μετά
sudo gedit /etc/X11/xorg.conf

Στο νέο παράθυρο, ψάξε για κάτι σαν κι αυτό (εσένα θα λέει nVidia, λογικά):

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon 9100 A5 (R200 IGP)"
        Monitor         "AOC Spectrum"
        DefaultDepth    24
        SubSection "Display"
                 Depth          1
                 Modes        "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                 Depth         4
                 Modes          "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                 Depth          8
                 Modes          "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                 Depth          15
                 Modes         "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                 Depth          16
                 Modes         "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                 Depth         24
                 Modes         "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


Εκεί σε ενδιαφέρουν οι τιμές των modes. Βάλε 1024x768 (μπροστά από το "800x600", σώσε το αρχείο και κάνε restart τον X server να δεις αμα παίζει. Αμα δεν...κάνε το αντίστροφο copy για να επανέλθεις στις αρχικές ρυθμίσεις, δηλαδή δώσε:

sudo cp /etc/X11/xorg.conf.b /etc/X11/xorg.conf

Και κάνε restart.


good luck

dimitris2007-4-18 0:56:7

Αλλάζεις το xorg.conf ή ακόμα καλύτερα χρησιμοποιείς το nvidia-settings.
Από το τερματικό δίνεις
nvidia-settings

και στο παράθυρο των ρυθμίσεων που θα εμφανιστεί, κάνεις κλικ στο X Server Display Configuration. Δεξιά θα εμφανιστεί ένα mini-μενού "Resolution". Κάνεις κλικ, επιλέγεις ανάλυση, πατάς Apply.



Τέλος.