ATi drivers στο Ubuntu και το Kubuntu - Οδηγίες εγκατάστασης με χειροκίνητο τρόπο

Ανώνυμος (χωρίς επαλήθευση) | Σάβ, 02/16/2008 - 23:19 | 8' | 45

Ο παρακάτω οδηγός είναι παλιός. Για εγκατάσταση των drivers στο Ubuntu δείτε το νεότερο οδηγό: Πως εγκαθιστώ drivers για την κάρτα γραφικών μου στο Linux


Ο παρακάτω οδηγός ειναι για την εγκατάσταση των ATi drivers 8.04 στο Ubuntu και τo Kubuntu. Οι drivers αυτοί υποστηρίζουν μόνο τα εξής τσιπάκια: Radeon HD 2900, HD 2400, HD 2600, X1900, X1800, X1600 , X1300, X800/X850, X700, X600, X550/X300, 9800, 9700, 9600, 9550, 9500, και Xpress1200, Xpress 200, Xpress 1100, αλλά και τις αντίστοιχες Mobility. Προσοχή κάποιες AGP κάρτες HD2x00 δεν υποστηρίζονται - δείτε στο Troubleshooting στο τέλος! Οι οδηγίες δοκιμάστηκαν με μια ΑΤi X300, σε Kubuntu 7.10 με πυρήνα 2.6.22-14-generic. Προέρχονται από τον 2ο τρόπο που είναι δημοσιευμένος στο [1] (δείτε στο τέλος). Για αυτόματη εγκατάσταση σε Debian, δείτε στο [2]. Το ίδιο σκριπτάκι ίσως μπορείτε να το χρησιμοποιήσετε και στο Ubuntu...

KATEΒΑΣΤΕ ΤΟΥΣ

Τους drivers μπορείτε να τους κατεβάσετε απευθείας από εδώ (έκδοση 8.5):

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-5-x86.x86_64.run

Η' από εδώ (για νεότερες εκδόσεις): http://ati.amd.com/support/drivers/linux/linux-radeon.html

Κατεβάστε το .run αρχείο και σώστε το στο home σας, όχι στην επιφάνεια εργασίας.

ΠΡΟΑΠΑΙΤΟΥΜΕΝΑ ΠΑΚΕΤΑ

Για την εγκατάσταση των drivers θα πρέπει να έχετε εγκαταστήσει το πακέτο build-essential, καθώς και αρκετά πακέτα ανάπτυξης (debhelper, fakeroot, κλπ).

Επίσης θα πρέπει να έχετε ενεργοποιήσει τα αποθετήρια multiverse και universe.

Για τα προαπαιτούμενα πακέτα, δίνετε τις εντολές: sudo apt-get install build-essential debhelper fakeroot dkms gawk sudo apt-get install dh-make debconf libstdc++5 dkms sudo aptitude install linux-headers-`uname -r`

ΕΓΚΑΤΑΣΤΑΣΗ

Κατόπιν για να δημιουργήσετε τα πακέτα .deb από το .run που έχετε κατεβάσει, δίνετε: sudo sh ./ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/7.10 Η παραπάνω εντολή είναι για Gutsy. Για Hardy δίνετε:

sudo sh ./ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/Hardy

Και μετά τα εγκαθιστάτε με την εντολή: sudo dpkg -i *.deb Τώρα προσοχή! Κάντε reboot για να φορτωθεί το module και ύστερα δώστε: sudo aticonfig --initial sudo aticonfig --overlay-type=Xv Μετά ξανακάντε reboot.

ΠΩΣ ΚΑΤΑΛΑΒΑΙΝΩ ΟΤΙ ΟΛΑ ΕΙΝΑΙ ΟΚ; Δώστε την εντολή fglrxinfo και θα πρέπει να δείτε κάτι σαν κι αυτό:

[email protected]:~$ fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: Radeon X300/X550/X1050 Series OpenGL version string: 2.1.7281 Release

Επίσης, αν τρέξετε το fgl_glxgears θα πρέπει να δείτε τους κύβους με τα γρανάζια και τα FPS στην κονσόλα. Σε εμένα βγάζει 450FPS, αν αναρωτιέστε :)

Επίσης με την εντολή: glxinfo | grep rendering

θα πρέπει να παίρνετε την απάντηση direct rendering: Yes

TROUBLESHOOTING

Πρώτα απ' όλα βεβαιωθείτε ότι η κάρτας σας υποστηρίζεται από τους drivers. Διαβάστε τα release notes από το site της ATi

A. Αν έχετε 64bit Ubuntu, και μετά την εγκατάσταση των drivers βλέπετε τέτοια μηνύματα: glxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

πρέπει να προσθέσετε έναν ψευτοσύνδεσμο: sudo ln -s /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1

B. Στην περίπτωση που δείτε μαύρη οθόνη, καντε reboot και μπείτε σε recovery mode. Θα είστε root. Τότε δώστε: cp /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default sh ati-driver-installer-8-02-x86.x86_64.run --extract ati sudo cp ati/common/etc/ati/{control,signature} /etc/ati/ και ξανακάντε reboot.

Γ. Αν δεν βλέπετε προκοπή, ξαναδοκιμάστε. Αφαιρέστε τα πακέτα: dpkg -r fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx xorg-driver-fglrx-dev και από το φάκελο με τα deb ξαναδώστε sudo dpkg -i *.deb

Δ. Αν δεν πιάσει ούτε αυτό cat /var/log/Xorg.0.log και κάντε copy/paste τις τελευταίες 20 γραμμές του log εδώ.

Ε. Υπάρχει ένα script για Debian Εtch στο [2] που όμως έχει αναφερθεί ότι τρέχει και στο Ubuntu. Κατεβάστε το, πατήστε Ctrl+Alt+f1 και τρέξτε το με sudo install-fglrx-debian.sh και κάντε το σταυρό σας...

Ζ. Μήπως έχετε την ATI Radeon HD 2600 XT σε AGP; Τότε μπορεί απλά να έχετε ρυθμίσει λάθος το BIOS. Δείτε εδώ πόσο εύκολα έλυσε (τελικά) το πρόβλημα ένας χρήστης με αυτήν την κάρτα, με αλλαγή στο BIOS.

OK. ΕΓΚΑΤΕΣΤΗΣΑ ΤΟΥΣ DRIVERS ME 3D ΕΠΙΤΑΧΥΝΣΗ. ΤΩΡΑ ΠΩΣ ΕΝΕΡΓΟΠΟΙΩ ΤA 3D ΕΦΕ ΤΟΥ COMPIZ;

Στο επίσημο forum του Compiz-Fusion, υπάρχει ένα αναλυτικό tutorial για την ενεργοποίηση των εφέ σε νεότερες ATi κάρτες. Τυπικά, πρέπει να κάνετε τις εξής αλλαγές στο xorg.conf:

Στο Section "ServerLayout" να έχετε: Option "AIGLX" "on"

Στο Section "DRI" να γράφει:

Mode 0666

Και στο Section "Extensions" Option "RENDER" "Enable" Option "DAMAGE" "Enable" Option "Composite" "Enable" Option "XVideo" "Enable"

Δείτε περισσότερες ρυθμίσεις στο [3].

ΠΑΡΑΠΟΜΠΕΣ [1] http://wiki.cchtml.com/index.php/Ubuntu_Gutsy_Installation_Guide#Method_1:_Install_the_Driver_the_Ubuntu_Way

[2] Για Debian Etch, κατεβάστε και τρέξτε αυτό το script http://kanotix.com/files/install-fglrx-debian.sh

[3] Οδηγίες ενεργοποίησης 3D εφέ με το Compiz Fusion http://forum.compiz-fusion.org/showthread.php?s=291578a711162972167e4069c89311ee&t=6008

-- Any fool knows a dog needs a home, A shelter from pigs on the wing.

Φόρουμ
Δώσε αστέρια!

MO: 5 (ψήφοι: 1)

Σχόλια

Αυτές είναι οι τελευταίες 20 γραμμές:

(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: drmOpenMinor returns 8
drmOpenByBusid: drmGetBusid reports PCI:1:0:0

Προσωπικά πάντως δεν βλέπω κάτι λάθος (γενικά σε όλο το αρχείο), αν είναι πές μου να σου το στείλω όλο...

orea emena mou t grafi ola afta kai exo 650fps exo tin ati 1600, omos otan pao na energopioiso ta visual effect mou grafi oti de mporoun na energopoiithoun "Desktop effects could not be enabled" ti mporo na kano?

Σημείωση: αυτό το thread δεν είναι για εφέ. Αλλά για εγκατάσταση drivers. UPDATE: Δείετ το αρχικό post όμως, όπου προσθέσαμε ένα χρήσιμο link στο τέλος

Αν τα εφέ δεν λειτουργούν παρότι εγκαταστήσατε drivers, πρέπει να ξέρετε ότι κάποιες κάρτες ATi είναι blacklisted από το ίδιο το Compiz. Κοίταξτε εδώ:

http://wiki.compiz-fusion.org/Hardware/Blacklist

και ιδιαίτερα τα PCI IDs. Mετά από ένα τερματικό δώστε:

lspci -nn | grep VGA

θα σας πει π.χ.

4:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)] [1002:5b60]

Συγκρινετε τον αριθμό στην αγκύλη στο τέλος με τους αριθμούς της 2ης στήλης του πίνακα μήπως η κάρτα σας είναι blacklisted μέσα στο Compiz Fusion.

Αν είναι blacklisted, δοκιμάστε να φορτώσετε το Compiz με την παράμετρο SKIP_CHECKS=yes compiz-manager όπως γράφει στο πρώτο URL. Δηλαδή:

SKIP_CHECKS=yes compiz --replace ccp &

(ή compiz-manager, ανάλογα με τη διανομή).

ΥΓ: Καλό είναι να λέτε, και ποια ακριβώς κάρτα έχετε (με lspci -vv | grep VGA).
ΥΓ2"apkoutsou, δες το pciid της κάρτας σου. Υποστηρίζεται από τους 8.2 drivers; Κοίταξες το release notes στο site της ATi;

--
Any fool knows a dog needs a home,
A shelter from pigs on the wing.

Λοιπόν, το lspci μου δίνει την εξής απάντηση:

01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 94c4

και αυτός είναι εξάλλου και ο λόγος (unknown device) που ο Διαχειριστής Οδηγών Κλειστού Κώδικα, το Automatix κ.ά. δεν μου βγάζουν επιλογή για εγκατάσταση οδηγών της ATi.
Τις release notes των νέων Catalyst τις είχα δει και υποστηρίζουν την HD2400Pro!Αλλά το Ubuntu αρνείται να την αναγνωρίσει...
Εκείνο που φοβάμαι είναι μήπως δεν υποστηρίζεται η AGP, αλλά μόνο η PCIe...Κάτι τέτοιο δεν προκείπτει από το site τηξς ATi, αλλά ποτέ δεν ξέρεις...

Edit: Πάντως το Envy την αναγνώρισε κανονικά, για να κάνει τον έλεγχο συμβατότητας με τους drivers που θα κατέβαζε...(το είδα από την κοσνόλα που άνοιξε το Envy...

Edit: Ξανακοιτούσα το Xorg.0.log και είδα ότι αναγνωρίζει το chipset ως HD2400Pro (αλλά με 256ΜΒ RAM) και την κάρτα ως τρίτου κατασκευαστή (και όντως έτσι είναι - είναι GeCube και στο site της η GeCube δεν έχει linux οδηγούς παραπέμποντας στο site της ΑΤi, ενώ οι windows οδηγοί είναι οι προηγούμενοι) και AGP κάνοντας κανονικά την εκκίνηση... δεν μπορώ να καταλάβω τι συμβαίνει...Στo log file φαίνονται όλα μια χαρά...Μήπως πρέπει να το αναρτήσω εδώ για να δείτε και εσείς?

Είσαι γκαντέμης....AGP είναι η κάρτα; Απλά δεν υποστηρίζεται. Κοίτα εδώ που το λέει ο τύπος:

http://www.phoronix.com/forums/showpost.php?s=c53430389705f54e56525c48d…

Γενικά, στο thread αυτό διαβάζω ότι ο ATi driver υποστηρίζει μόνο PCe και όχι AGP στις HD2x00 κάρτες

--
Any fool knows a dog needs a home,
A shelter from pigs on the wing.

Και όμως δουλεύει και με AGP!
Μόλις σήμερα εγκατέστησα την τελευταία εκδοση fglrx και δούλεψε για πρώτη φορά το Compiz+AIGLX+HD2600 AGP!Είμαι πολύ χαρούμενος!

Ποιαν έκδοση; Την 8.02; Πως την εγκατέστησες; Δεν τα γράφεις εδώ αναλυτικά να μην παιδευονται οι υπόλοιποι που δεν τα έχουν καταφέρει;;

--
Any fool knows a dog needs a home,
A shelter from pigs on the wing.

Η έκδοση είναι αυτή οπως τη κατέβασα από την homepage της ati: ati-driver-installer-8-02-x86.x86_64.run
Η διαδικασία εγκατάστασης είναι αυτή που περιγράφεται εδώ.
Είναι καλό να απεγκαθηστά κανείς ότι προηγούμενο driver έχει. Στη περίπτωση του fglrx σιγουρυτείτε οτι εχετε κανει rm και το directory /etc/ati.
Στο xorg.conf να φαίνεται στο device μονο το fglrx και τίποτα άλλο!! Ούτε extensions ούτε άλλα (τουλάχιστον έτσι δούλεψε σε μένα)
Μετά δίνετε στο terminal: SKIP_CHECKS=yes compiz & (εννοείτε ότι έχετε εγκαταστήση το compiz και ότι σχέση έχει με αυτό)
Happy compiz!! :)

Μου έδωσεες νέες ελπίδες...Θα επιχειρήσω άλλη μια φορά μπας και τα καταφέρω...

Οπότε:
1. Επεγκαθιστώ όλους τους drivers καρτών γραφικών από το Synaptic (xserver-xorg-video-*),
2. Αφαιρώ /etc/ati,
3. Εγκαθιστώ τους drivers (θα το κάνω από την κονσόλα, αν είναι σε recovery mode), ακολουθώντας την ίδια διαδικασία

Και ο Θεός βοηθός, μπας και δούμε καμιά "κυβική" μέρα (οτιδήποτε, βέβαια, αρκεί να μην είναι μαύρη πάλι όπως η οθόνη μετά από την εγκατάσταση...)

Ρε παιδιά έχω μια απορία...Τι είναι καλύτερο για κάρτες avi; Το fglrx που είναι κλειστού κώδικα ή το open source ati;

Εννοείς για κάρτες ATi. Μην ρωτάς "τι είναι καλύτερο" αλλά "τι υποστηρίζεται". Ο ανοικτού κώδικα ati driver υποστηρίζει τις παλιές GPU (π.χ. X300, κλπ) και με 3D επιτάχυνση, ενώ ο fglrx αυτές που αναφέρουμε στο πρώτο post. Άρα ανάλογα με το ποια κάρτα έχεις, πορεύεσαι. Σπίτι έχω X300 - ποτέ δεν έβαλα fglrx εκτός από μία φορά που μου χρειάστηκε για να στήσω το Xgl. Στο γραφείο έχω IGP - ποτέ δεν έβαλα fglrx. Σε κάτι άλλα PCs με νεότερες κάρτες ATi, η επιλογή fglrx είναι μονόδρομος αν παίζεις games και θες 3D εφέ.

εγω έχω μια ati Radeon X700. Είχα εγκαταστήσει το fgrlx και όλα δούλευαν μια χαρά εκτός απο τα παιχνίδια. Εδώ και 2 εβδομαδες άρχιδε να δημιουργεί προβλήματα στην χρήση video,google earth και στο WoW που εγκατέστησα.Τότε έκανα το λάθος να βγάλω απο το restricted manager τα drivers...Δεν ξανακατάφερα να μπώ στο gnome. Μπήκα σε κατάσταση ασφαλείας και έκανα κάποια back up και ξανά εγκατάσταση!(ούτε με dpkg-reconfigure-xserver-xorg δεν έγινε κάτι).

Τώρα που ξανα έκανa εγκατάσταση το Ubuntu επέλεξα το ati accelarated graphics driver απο system->administrator->restricted drivers manager και δουλεύει καλά. Δεν χρειάζεται να ακολουθήσω τον παραπάνω οδηγό, έτσι;

Όχι, εφόσον παίζουν όλα, μην πειράξεις τίποτε.

--
Any fool knows a dog needs a home,
A shelter from pigs on the wing.

Δημήτρη μιλάς για όλες τις κάρτες AGP ότι δεν υποστηριζεται ή για κάποιες συγκεκριμένες?
Η δικιά μου κάρτα είναι η Ati radeon x1950Pro(AGP). Εγκαθιστώ τον διαθέσιμο driver(μέσω envy), συγκεκριμένα τον 8.42.3.
Πατώντας fglrxinfo παίρνω:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.0.6958 Release
που νομίζω πως είναι σωστό.

Πατώντας fgl_glxgears παίρνω:
Using GLX_SGIX_pbuffer
8246 frames in 5.0 seconds = 1649.200 FPS
9019 frames in 5.0 seconds = 1803.800 FPS
6986 frames in 5.0 seconds = 1397.200 FPS
9075 frames in 5.0 seconds = 1815.000 FPS
7968 frames in 5.0 seconds = 1593.600 FPS
και ανοίγει και ένα άλλο παράθυρο το οποίο ειναι κενό(δηλαδή φαίνεται μέσα απο αυτό η σελίδα που είναι από πίσω)

Πατώντας glxinfo | grep rendering παίρνω yes όπως λες παραπάνω.

Προφανώς κάτι δε πάει καλά καθως το παράθυρο στο οποίο πρέπει να βλέπω τα γρανάζια εμένα μου εμφανίζεται κενό. Όπως καταλαβαίνετε όλοι σας δεν έχω και 3D effects.

p.s Έχω kubuntu 7.10

Στο παραπάνω url που έδινα, υπήρχε ένας developer της AMD/ATi που έλεγε ότι η τότε έκδοση των drivers δεν υποστήριζε AGP. Εκτοτε όμως βγήκε νέα έκδοση. Οπότε πιθανόν να υποστηρίζονται (κάποιες). Πρέπει να δεις τα release notes και να ψάξεις για τη δική σου κάρτα τι γίνεται...

--
They say you're beautiful
And they'll always let you in
But doors are never open
To the child without a trace of sin

Sail away

aggelos7, δες εγκατέστησε τους νέους drivers χειροκίνητα όπως γράφει στο πρώτο post (βγάλε τους παλιούς που έχεις βάλει με το Envy) και μετά κάνε επανεκκίνηση. Επειτα, τροποποίησε το xorg.conf:

Στο Section "ServerLayout" να έχεις:

Option "AIGLX" "on"

Στο Section "DRI" να γράφει:

Mode 0666

Και στο Section "Extensions"

Option "RENDER" "Enable"
Option "DAMAGE" "Enable"
Option "Composite" "Enable"
Option "XVideo" "Enable"

Δείτε περισσότερες ρυθμίσεις στο [3] του πρώτου post.

giati na kaneis ola ayta pleon afou o alberto milone ekane to envy?

kai pleon i nea ekdosi tou exei epilogi na aferesei ton driver...

opote de nomizo pos kapoios pleon zorizete na valeis driver, to mono pou exei na kanei einai na pros8esei merikes grammes ston xorg tou.

kknhht3]

giati na kaneis ola ayta pleon afou o alberto milone ekane to envy?

kai pleon i nea ekdosi tou exei epilogi na aferesei ton driver...

opote de nomizo pos kapoios pleon zorizete na valeis driver, to mono pou exei na kanei einai na pros8esei merikes grammes ston xorg tou.

Σωστή παρατήρηση. Υπάρχει και το Envy για όσους προτιμούν ένα εργαλείο να κάνει όλη τη δουλειά.

BTW, αν δεν έχεις πρόβλημα, θα προτιμούσαμε να γράφεις και συ με Ελληνικούς χαρακτήρες για να είναι κατανοητά σε όλους.

Λοιπόν .. Το envy έχει τρόπο να εγκαθιστά και να απεγκαθιστά τους drivers αλλά στην περίπτωση μου δεν δούλεψε γιατί δεν μπόρεσα μετά την εγκατάσταση των drivers με το Envy να τρέξω το compiz.

Λοιπόν.. Έχω μία κάρτα ΑΤΙ Radeon Xpress 200.
Βρήκα τον κατάλληλο driver σύμφωνα με τις οδηγίες που ανέφερες εδώ Δημήτρη τον κατέβασα και τον μετέτρεψα σε πακέτο .deb ( θα γίνει εγκατάσταση στο Mint Daryna που πατάει πάνω στο Gutsy ok.. ).

O driver τώρα είναι ο ati-driver-installer-8-3-x86.x86_64.run

Τα θέματα τώρα είναι τα εξής:

Να προχωρήσω σε εκ νέου εγκατάσταση από το envy;;;
Πως μπορώ να ξέρω ποιον driver κατεβάζει το envy για να δω αν φέρνει κάτω τον σωστό ( που είπαμε όμως ότι δεν μου δούλεψε με το compiz αλλά δεν κόβω και το λαιμό μου ότι φταίει ο driver ή η εγκατάσταση του compiz).

Αν κάνω χειροκίνητη εγκατάσταση ( από το πακέτο deb που όπως είπαμε έφτιαξα) πως θα τον απεγκαταστήσω αν κάτι δεν πάει καλά;

Και όπως και να έχει μπορεί κάποιος να μου επιβεβαιώσει εδώ ότι κατέβασα τον σωστό driver;;;

Τώρα ο υπολογιστής μου έχει τα εξής χαρακτηριστικά ( τα αναφέρω εδώ μήπως και έχουν κάποια σημασία για το θέμα)


00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc 4379 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
08:0a.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
08:0a.2 Generic system peripheral [0805]: O2 Micro, Inc. Integrated MMC/SD Controller (rev 01)
08:0a.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
08:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

***** @ kknhht3
Προσπαθούμε να γράφουμε σε ελληνικά και όχι σε greeklish ή κεφαλαία γιατί αν δεν το κάνουμε αυτό δεν θα δουλεύει η αναζήτηση όταν ψάχνουμε κάτι μέσα στο φόρουμ αφού είναι ρυθμισμένη να "διαβάζει" μόνο ελληνικά ή μόνο αγγλικά. (τι να κάνουμε .. τα greeklish και τα γρικλις δεν είναι επίσημες γλώσσες :) )
Για αυτό παρακαλούμε πολύ να γράφετε ελληνικά χωρίς να είναι και αυτά μόνο σε κεφαλαία γιατί φανταστείτε μετά να ψάχνετε κάποια απάντηση σε ένα θέμα και να μην την βγάζει γιατί πχ κάποιος στον τίτλο αντί να γράψει envy έγραψε ενβι ή αντί να γράψει επεξεργαστής κειμένου έγραψε epexergastis keimenou ( χάλια δεν είναι;; )
Tώρα ... όσοι έχετε γράψει κατά καιρούς μηνύματα σε greeklish ή τίτλους από topics και αυτά σε greeklish παρακαλούμε να τα κάνετε edit και να τα περάσετε εκ νέου στα ελληνικά.

Χεχε marlene το ίδιο πισι έχουμε τι γίνεται;;; Και γω αυτήν την "κάρτα" έχω και δεν ασχολήθηκα και αρκετά με τους drivers της οπότε καιρός να γίνει...

Marlene, αφού λες ότι με το Envy δεν έκανες δουλειά προσπάθησε και τον χειροκίνητο τρόπο.
O driver είναι ο σωστός.
Μετά η απεγκατάσταση γίνεται με δύο εντολές σαν κι αυτές:

suspect=`sudo dpkg -l | grep flgrx | awk '{print $2}'`
sudo apt-get remove $suspect

Η πρώτη αποθηκεύει στη μτβλτή suspect το αποτέλεσμα της αναζήτης με το dpkg -l για ολα τα εγκατεστημένα πακέτα που έχουν στο όνομα τους το fgrlx.
Η δεύτερη τα αφαιρεί.
Πριν κάνεις reboot/restart τον Χ, επαναφέρεις το παλιό σου xorg.conf με Driver "ati" ή "vesa".

Αυτά για την εγκατάσταση των drivers. Για ενεργοποίηση του AIGLX, που υποτίθεται ότι υποστηρίζουν οι εν λόγω drivers (8.02+), και κατ' επέκτασην ενεργοποίηση Compiz Fusion, οι απόψεις διίστανται ;). Έχει παίξει σε laptops με νεότατες Ati Radeon, αλλά με απογοητεύει σε παλιότερες. Λογικά είναι θέμα συγχρονισμού των πλανητών ή ρυθμίσεων, ή blacklisted chip (δες #3ο σχόλιο).

Βασικά με το Envy δεν έκανα δουλειά γιατί παρόλο που ο x δούλεψε κανονικά το compiz δεν έτρεξε. Μου έλεγε κάτι για κάποιο module που του έλειπε, αλλά δεδομένης της ώρας και του χρόνου που έχει περάσει από τότε δεν το θυμάμαι.
Βασικά δεν ασχολήθηκα την δεδομένη στιγμή με το compiz γιατί δεν είχα χρόνο, αλλά τώρα με αφορμή αυτές τις οδηγίες είπα να δω τι τρέχει με την περίπτωση.
Θα επαναλάβω την εγκατάσταση με το Envy για να σας πω ακριβώς τι παίζει με τους drivers αυτούς.
Τώρα όσον αφορά την χειροποίητη (!) εγκατάσταση δεν είμαι βέβαιη αν πρέπει να την κάνω αφού δεν ξέρω αν στην περίπτωση με το envy έφταιγαν οι drivers ( πάντως προβλήματα δεν είχα του στυλ να βλέπω μαύρη οθόνη κτλ) ή το compiz που κάπου έχανε λάδια..

@thanos Μη μου πεις ότι έχεις και εσύ Peppe υπολογιστή γιατί δεν θα το πιστέψω.. ( Peppe είναι το μικράκι που έχω εδώ -12 άρι είναι το καημένο- που είναι μάρκα Pepper αλλά εγώ τον έβγαλα Peppe..! :D )

Μου φαίνεται ότι όλα τα σουρεαλιστικά σε μένα συμβαίνουν. ΔΕΝ ΕΧΩ ΕΓΚΑΤΑΣΤΗΣΕΙ ΑΚΟΜΑ ΤΙΠΟΤΑ (το μελετάω το πράγμα.. ) Κοίταξα όμως να δω τι γίνεται με τους υπάρχοντες drivers και τι είδα;;;
Λοιπόν δείτε τι μου βγάζει η κονσόλα
[email protected]-laptop2:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon Xpress Series
OpenGL version string: 2.0.6473 (8.37.6)
[email protected]-laptop2:~$ glxinfo | grep rendering
direct rendering: Yes
[email protected]-laptop2:~$
και το κερασάκι στην τούρτα;;

Eπανεγκατέστησα το compiz ( κομπλέ ) και μόλις του είπα να τρέξει τα 3d μου έβγαλε το εξής:
The Composite extension is not available ( που θέλει να πει τι?????? )
Λοιπόν τα έχω όλα εδώ έτοιμα και το ερώτημα είναι το εξής:
Θέλει ή δεν θέλει drivers;;

ΕΝΗΜΕΡΩΣΗ: ( για να μην πάει χαμένο το ξενύχτι και  να μαθαίνουμε όλοι)

Kαι τελικά η απάντηση ήταν η εξής:

Δεν ήθελε drivers αλλά ήθελε πείραγμα το xorg.conf

που στο

EndSection
Section "Extensions"
Option "Composite" "0"
EndSection

έπρεπε να είναι

EndSection
Section "Extensions"
Option "Composite" "1"
EndSection

ενώ έπρεπε να εγκατασταθεί και το πακέτο

xserver-xgl

δηλαδή

sudo apt-get install xserver-xgl

Μετά από αυτό δούλεψε κανονικά ( βέβαια ακόμα δεν βρήκα τον κύβο αλλά πήγε αργά και βαριέμαι πλέον)

και χωρίς να έχω εγκαταστήσει τους  drivers από το envy.

Αυτάαα.. πάμε να φύγουμε τώρα γιατί έχουμε και δουλειές να κάνουμε.!

Ουσιαστικά παίζεις με το Xgl τώρα και όχι με το AIGLX. Αυτό κάνει το πακέτο xserver-xgl που εγκατέστησες...

Επιπλέον, στάθηκες και τυχερή γιατί έχεις chipάκι γραφικών που υποστηρίζεται (ως προς την 3D επιτάχυνση) και από τον ανοικτού κώδικα driver "ati" του Linux. Ίδια ακριβώς περίπτωση έχω και εγώ με μια X300. Το περίεργο είναι όμως ότι εγώ έχω 3D επιτάχυνση και με AIGLX. Και αναρωτιέμαι γιατί δεν δούλεψε και σε εσένα εξαρχής.

--Hey you!
don't help them to burry the light
don't give in without a fight.

Χα χα.. Λοιπόν επειδή παιδάκια είμαστε και παίζουμε έκανα κάτι και δεν δουλεύει τίποτα τώρα.
Λοιπόν μετά που έκανα το τελευταίο ποστ δοκίμασα να εγκαταστήσω τους drivers μέσα από το envy. ( η περιέργεια σκότωσε την γάτα. ) Μου έκανε την εγκατάσταση κανονικά αλλά εκεί πάει την χάσαμε την επιτάχυνση. Μου έδωσε τότε μήνυμα ότι οι drivers δεν του envy δεν λειτουργούν σωστά, βέβαια με είχε βάλει σε γραφικό περιβάλλον αλλά δεν δούλευε καλά.
Τότε του είπα να τους απεγκαταστήσει ( αφού σου δίνει και τέτοιο option) Αυτό αν κατάλαβα καλά πριν τους βγάλει έκανε μόνο του backup το τελευταίο xorg.conf. και πέταξε έξω τα πάντα. Έτσι όταν πήγα να ξαναμπώ με άφησε χωρίς γραφικό περιβάλλον.

Πέταξε προφανώς όλα τα πακέτα που είχαν μέσα fgrlx. Aυτό μου έδωσε άλλωστε και ως μήνυμα στην κονσόλα ( εκτος γραφικού.)
Καλά λέω .. έτσι το έχεις;;;
Είχα έτοιμα τα πακέτα που είχα φτιάξει αφού είχα κατεβάσει τους άλλους drivers, για χειροποίητη εγκατάσταση, και τα εγκατέστησα! :D Οπότε ευκαιρία να δοκιμάσουμε και αυτούς τους drivers. Τώρα αυτοί ήταν άλλο μοντέλο από αυτούς που εγκαθιστά το envy.

Μπήκα σε γραφικό περιβάλλον μετά, και αυτοί επίσης δεν δούλευαν, τους απεγκατέστησα και επανέφερα το αρχικό μου xorg.conf ( προ πειραμάτων) και ενίοτε έστειλα και το compiz .
Όμως τώρα σέρνεται η οθόνη γιατί προφανώς του λείπουν κάποια πακέτα από τους drivers της ATI εκείνους που δίνει η διανομή μου. ( Mint Daryna) .. ή τουλάχιστον έτσι πιστεύω.
Πως τους ξανα εγκαθιστάμε τώρα αυτούς;;;

Marlene μία είναι η λύση,η τριχιά,το σαπούνι και κάτι άλλο δεν μου έρχεται στο μυαλό (αστειεύομαι)}:).Και γω σαν μικρό παιδάκι έπαιξα με τους drivers της ati (για 2η φορά) χωρίς αποτέλεσμα βέβαια,αλλά το χάρηκα χωρίς γραφικό περιβάλλον με την μαύρη κονσολίτσα gg είμαι.Εντάξη έγινε τώρα αλλά δεν έχω περίγραμμα παραθύρων :P...Που θα πάει θα το παλέψω και θα γίνει,any help καλοδεχούμενη.

Mαλλον σου έχει χτυπήσει ο metacity. Βγάλτον και ξανα εγκατέστησε τον.

Δες τι σου έβγαλε, Marlene και ξαναβάλτο:

sudo -i
cat /var/log/apt/term.log

--Hey you!
don't help them to burry the light
don't give in without a fight.

Eπειδή το πείραξα γενικότερα και το output είναι ένα κατεβατό στο έστειλα στο μειλ σου.
Για δες μήπως και βγάλουμε άκρη εδώ Πάντως το compiz το έστειλα . Θέλω να επαναφέρω τους αρχικούς drivers και ρυθμίσεις.

Kαλά θα κάνεις Marlene.Anyway κάτι παίζει με το metacity που είπες...Από κονσόλα τρέχει μια χαρούλα αλλά βγάζει το εξής:

[email protected]-desktop:~$ metacity
Προειδοποίηση διαχειριστή παραθύρων: Το "" που βρέθηκε στη βάση δεδομένων ρυθμίσεων δεν είναι μια έγκυρη τιμή για συνδυασμό πλήκτρων"toggle_shaded"

αλλά το περίγραμα φαίνεται μια χαρά,τώρα τι γίνεται δεν ξέρω.

thanos]Kαλά θα κάνεις Marlene.Anyway κάτι παίζει με το metacity που είπες...Από κονσόλα τρέχει μια χαρούλα αλλά βγάζει το εξής:

[email protected]-desktop:~$ metacity
Προειδοποίηση διαχειριστή παραθύρων: Το "" που βρέθηκε στη βάση δεδομένων ρυθμίσεων δεν είναι μια έγκυρη τιμή για συνδυασμό πλήκτρων"toggle_shaded"

αλλά το περίγραμα φαίνεται μια χαρά,τώρα τι γίνεται δεν ξέρω.

Περί μπερδεμένων drivers:

Το έφτιαξα. Εγκατέστησα εκ νέου το σύστημα είχα και όλα τα προγράμματα μου στο "apt get on cd" τα πέρασα μέσα του έκανα και ένα upgrade και μερικές εγκαταστάσεις στα γρήγορα και συνήλθε σε ένα τέταρτο ( τελικά αυτό έπρεπε να κάνω από την αρχή από το να κάθομαι και να παιδεύομαι. )

Έτσι και αλλιώς το σύστημα το έχω σε χωριστό partition και του έχω και μπόλικο χώρο γιατί μου αρέσει να αλλάζω λειτουργικά και έτσι έχω βρει κόλπο και δεν κουράζομαι ιδιαίτερα να τα στήνω ειδικά τα debian οειδή με gnome.

Για τον metacity τώρα...

Κάνε του complete removal  και μετά εγκατέστησε τον εκ νέου ή γράψε από κονσόλα

sudo apt-get install metacity

Μια φορά την είχα πατήσει και εγώ έτσι.

Χαιρετώ όλους τους φίλους.
Είμαι νέος με το Linux αλλά με εμπειρία -πιστεύω -στους υπολογιστές. Η πρώτη μου επαφή ήταν τα πανεπιστημιακά χρόνια ( 1976) με τη fortran V.Σε καινούργιο μου PC με athlon 64x2 (5200+) και κάρτα γραφικών ati HD2400XT Εγκατέστησα ubuntu 7.1.
Έχω αρκετά ξενυχτίσει προσπαθόντας να κάνω να δουλέψουν τα εφε του Compiz-Fusion.Ακολούθησα την χειροκίνητη εγκατάσταση του dimitri και όλα πήγαν καλά. Οι κύβοι εμφανίστηκαν. Κατόπιν ακολούθησα την παραπομπή 3 στο ίδιο θέμα του dimitri. Δυστυχώς στο ΣΥΣΤΗΜΑ - ΠΡΟΤΙΜΗΣΕΙΣ - ΕΜΦΑΝΙΣΗ -VISUAL EFFECT -NORMAL έχω :Desktop effects could not be enabled. Μετά ακολούθησα την παραπομπή 1 αλλά και πάλι χωρίς αποτέλεσμα. Εδω όμως κατά την διαδικασία πήρα :
[email protected]:~$ sudo dpkg -i --force-overwrite xorg-driver-fglrx_8.471-0*.deb fglrx-kernel-source_8.471-0*.deb fglrx-amdcccle_8.471-0*.deb
dpkg: σφάλμα στην επεξεργασία του xorg-driver-fglrx_8.471-0*.deb (--install):
αδύνατη η πρόσβαση στην αρχειοθήκη: No such file or directory
dpkg: σφάλμα στην επεξεργασία του fglrx-kernel-source_8.471-0*.deb (--install):
αδύνατη η πρόσβαση στην αρχειοθήκη: No such file or directory
dpkg: σφάλμα στην επεξεργασία του fglrx-amdcccle_8.471-0*.deb (--install):
αδύνατη η πρόσβαση στην αρχειοθήκη: No such file or directory
Προέκυψαν σφάλματα κατά την επεξεργασία του:
xorg-driver-fglrx_8.471-0*.deb
fglrx-kernel-source_8.471-0*.deb
fglrx-amdcccle_8.471-0*.deb
[email protected]:~$

Παρακάτω δίνω το αρχείο μου xorg.conf

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
screen 0 "aticonfig-Screen[0]" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Option "AIGLX" "on"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,gr"
Option "XkbVariant" ","
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "L194W"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "[email protected]" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "[email protected]" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "[email protected]" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "[email protected]" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "[email protected]" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "[email protected]" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "[email protected]" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
modeline "[email protected]" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
modeline "[email protected]" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "[email protected]" 136.49 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
modeline "[email protected]" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "[email protected]" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "[email protected]" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
modeline "[email protected]" 188.07 1680 1800 1984 2288 1050 1051 1054 1096 -hsync +vsync
modeline "[email protected]" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
Gamma 1.0
EndSection

Section "Device"
Identifier "ATI Technologies Inc ATI Default Card"
Driver "vesa"
Busid "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Boardname "ati"
Busid "PCI:1:0:0"
Driver "fglrx"
Screen 0
# .............................

Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "TexturedVideo" "on"
Option "Textured2D" "on"
Option "TexturedXrender" "on"
Option "UseFastTLS" "1"
Option "BackingStore" "on"
Option "MaxGARTSize" "256"
Option "XAANoOffscreenPixmaps" "on"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc ATI Default Card"
Monitor "L194W"
Defaultdepth 24
SubSection "Display"
Modes "1440x1440" "1440x900" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1920 1200
Modes "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "RENDER" "Enable"
Option "DAMAGE" "Enable"
Option "Composite" "Enable"
Option "XVideo" "Enable"
EndSection

Section "ServerFlags"
EndSection

Ευχαριστώ εκ των προτέρων όσους με βοηθήσουν.

Χαιρετώ όλους τους φίλους και σας εύχομαι να περάσετε καλά τις ημέρες αυτές.
Σήμερα έκανα αναβάθμιση στο 8.04 και φυσικά εγκατέστησα τους ΝΕΟΥΣ drivers της ati που υπάρχουν στο http://ati.amd.com/support/driver.html.
Αν και έχω :ΣΥΣΤΗΜΑ - ΠΡΟΤΙΜΗΣΕΙΣ - ΕΜΦΑΝΙΣΗ -VISUAL EFFECT -NORMAL :Desktop effects could not be enabled με ctrl alt + αριστερό κλικ βλέπω το desktop σε κύβο να περιστρεφεται. Αυτά προς το παρόν.
ΚΑΛΟ ΠΑΣΧΑ.

ακολούθησες τον χειροκίνητο τρόπο του πρώτου post; Αν ναι, τότε είναι τα κουλά των ATi drivers. Εσύ έχεις εφέ, αλλά το Ubuntu δεν το ξέρει! :(

--Hey you!
don't help them to bury the light
don't give in without a fight.

ναι και εμένα μου το έκανε αυτό η νέα έκδοση...άσε που κάνει το σύστημα να πηγαίνε ισαν χελώνα (γα κάπιο λόγο υπερφορτώνει τον επεξεργαστή...)

Το ίδιο παρατήρησα και εγώ πιστεύοντας ότι το "φόρτωμα" οφειλόταν στην ενεργοποίηση των εφφέ,
Ακόμη
1.- Στο grub εμφανίστηκαν και Ubuntu 8.04, kernel 2.6.24-16-generic και Ubuntu 8.04, kernel 2.6.22-14-generic με τα recovery mode τους φυσικά. ΕΡΩΤΗΣΗ Εχουν καποια χρησιμότητα τα kernel 2.6.22-14.Μπορώ να επέμβω στο /boot/grub/menu.lst ακυρώνοντας τα.Τέλος μπορώ να κερδίσω χώρο στο δίσκο απεγκαθιστόντας τα.
2.- Στο παράθυρο εισόδου έχω χαμηλή ανάλυση μάλλον και δεν το βλέπω ολόκληρο.
ΑΥΤΑ ΠΡΟΣ ΤΟ ΠΑΡΟΝ ΚΑΙ ΚΑΛΟ ΠΑΣΧΑ ΣΕ ΟΛΟΥΣ.

Το φόρτωμα αυτό το έχω με μόνη την χρήση των fglrx χωρίς ενεργοποίηση εφε...

1. Όσο οναφορα το grub, το ίδιο είχα με την έκδοση 7.10 και απλά με τον grub editor αφαίρεσα τις επιλογές αυτές χωρίς πρόβλημα...

Επίσης και ΚΑΛΗ ΑΝΑΣΤΑΣΗ!!!!

Τους έβαλα εγώ. Παίζουν σε ATI X300 (όπου σημειωτέον δεν χρειάζεστε drivers για να δείτε τρισδιάστατα εφέ και OpenGL), αλλά με προβλήματα.

--Stat rosa pristina nomine, nomina nuda tenemus

Κατ' αρχήν ΚΑΛΟ ΚΑΛΟΚΑΙΡΙ.
Ακολουθώντας ένα παραπάνω σχόλιο του mitsaras77 έκανα rm το φάκελο /ati/ και επανεγκατέστησα τους νέους drivers της ati ati-driver-installer-8-6-x86.x86_64.run.
Έχω όμως το εξης πρόβλημα όταν εισέρχομαι σε μια συνεδρεία έχω
"Η συνεδρία σας διάρκεσε λιγότερο από 10 δευτερόλεπτα .......
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
Προβολή λεπτομερειών (~/xsession-errors file) /etc/gdm/xsession: Beginning session setup....
.:20:can't open /etc/ati/ati-fglrx.sh.
Ευχαριστώ εκ των προτέρων όποιον με βοηθήσει.
ΦΙΛΙΚΑ ΤΑΣΟΣ

Είναι πλέον Σαββατόβραδο έχω επανεγκαταστήσει το ubuntu 804 lts amd x64

από το iso που εδωσε το ram. Ακολουθόντας υστερα από "πολλά" πάλι τη μεθοδο

του  dimitri στη εντολή "sudo sh ./ati-driver-installer-8-6-x86.x86_64.run --buildpkg Ubuntu/Hardy

πηρα

Generating package: Ubuntu/Hardy
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Removing temporary directory: fglrx-install.O28871
ΚΑΛΟ ΣΑΒΒΑΤΟΒΡΑΔΟ

και εγώ έχω εγκαταστήσει το Ubuntu 8.04 και έχω την ATI 9200.
Οταν κάνω fglrxinfo παίρνω αυτό που σημαίνει ότι μάλλον δεν είναι εγκατεστημενοι drivers:
display: :0.0 screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 4x x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.0.3-rc2

Όταν δοκιμάζω να κάνω εγκατάσταση με το Envyng η κονσόλα του μου βγάζει το ακόλουθο μήνυμα

Your Graphics Card has been detected as ATI Radeon 9250(ok για 50 θα κάνουμε έτσι)

your graphic card is supported by the legacy driver
EnvyNG Error: ATI's legacy driver does not support your operating system

Δηλαδή φταίει το Ubuntu?

Εχω μια απορεια. Οταν λετε οτι εχετε 3D εφε και ειστε οκ. Ενοειτε οτι σε ολα ειστε οκ????? Γιατι και εγω εχω ATI HD 3650 OZI 512MB και π.χ τα αποτελεσματα fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3600 Series
OpenGL version string: 2.1.7659 Release

glxinfo | grep rendering
direct rendering: Yes

[email protected]-desktop:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
294 frames in 5.0 seconds = 58.800 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 60.000 FPS
299 frames in 5.0 seconds = 59.800 FPS
299 frames in 5.0 seconds = 59.800 FPS
300 frames in 5.0 seconds = 60.000 FPS
299 frames in 5.0 seconds = 59.800 FPS

sudo gedit /etc/X11/xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Driver "fglrx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,gr"
Option "XkbVariant" ","
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Σα να φενεται οτι ολα ειναι οκ. Οταν ομως εχω περιβαλον 3D εφε και παω να τρεξω καποια 3D εφαρμογη οπως googleaerth. η καποιο game Ανοιγουν η εφαρμογες αλλα αναβοσβηνη η εικονα τους συνεχεια. και τοτε βγαζω το 3D περιβαλων και ειναι ολα οκ.Οταν λετε οτι ειστε οκ τη ενοειτε????Και συμφονα με τα αποτελεσματα που ανεβασα βρισκετε κατι λαθος???? ευχαριστω εκ των προτερων.

μετα απο πολυ καιρο ειπα να ξανασχοληθω με τα λινουξ.εβαλλα τα 11,10 .εχω athlon 2800+,hd 2600 xt 
βαζω τους τελευταιους   και ενω μου λενε πως δεν εχουν εγκατασταθει σωστα οταν δινω fglrxinfo  παιρνω σωστες πληροφοριες το μονο σοβαρο προβλημμα οτι μετα απο καποια λεπτα το συστημα κρασαρει και πρεπει να κανω restart.......πιστευω πως κατι θα θελει και το xorg.conf μου.....:(

@veneton

Με την καρτα που εχεις, πρεπει να χρησιμοποιειησεις τον ανοιχτο οδηγο,
δες και εδω Εγκατάσταση - Αναβάθμιση οδηγών κάρτας γραφικών (ATI - NVIDIA - INTEL - SIS)

Αν εχεις προβλημα και δεν μπορεις να μπεις σε γραφικο, ανοιξε ενα νεο θεμα να το φτιαξουμε.