Προβλημα ηχου στο Ubuntu 7.10 [Λύθηκε]

johnsid | Κυρ, 01/13/2008 - 23:30 | 1' | 20

Γεια σε ολους!

Αντιμετωπιζω ενα ενοχλητικο προβληματακι με τον ηχο.

Συγκεκριμενα σε καθε εκκινηση ακουγεται ενα ενοχλητικο σφυριγμα με την εισαγωγη username & password,σταματαει βεβαια με την εισαγωγη και των δυο αλλα το συνεχιζει κατα την αναπαραγωγη audio,video.

Εχω δοκιμασει διαφορες ρυθμισεις στην κονσολα του ηχου αλλα δεν εχω βρει καποια λυση.

Help!

Φόρουμ
Δώσε αστέρια!

MO: (ψήφοι: 0)

Σχόλια

Το πρόβλημα ξεκίνησε αμέσως μετά την εγκατάσταση της διανομής; Και από πού ακούγεται το σφύριγμα; Από τα ηχεία ή τη μητρική;   

Το προβλημα εχει ξεκινησει μετα την εγκατασταση και ακουγεται απο τα ηχεια.johnsid2007-12-10 11:1:3

Ποιά κάρτα ήχου έχεις για να δούμε αν έχει αναφερθεί παρόμοιο πρόβλημα.Αν δεν την ξέρεις δώσε σε κονσόλα
lspci
και γράψε εδώ τι θα σου εμφανίσει.

Μου βγαζει τα εξης:
[email protected]:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. PT894 I/O APIC Interrupt Controller
00:00.7 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. PT890 PCI to PCI Bridge Controller
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
02:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
03:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
04:04.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
04:05.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
04:05.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
04:05.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
04:05.3 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
04:06.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

Διαβασα σε καποιο forum οτι με την συκεκριμενη mobo (Asus P5VDC-X)
ισως χρειαζεται εγκατασταση απο το Alternate CD ισχυει κατι τετοιο;
Παρεπιπτοντως εχω κανει εγκατασταση με γνησιο cd(παραγγελια απο shipit).

johnsid2007-12-12 17:10:41

Ευχαριστω για τα παραπανω link.

Ψαχνοντας βρηκα τον παρακατω audio driver για Linux απο το επισημο site της Asus αλλα δεν ξερω πως να τον κανω εγκατασταση.

http://dlsvr02.asus.com/pub/ASUS/mb/socket775/P5VDC-X/LinuxA UDIO.zip

Υπαρχει καποιο on-line manual για Ubuntu η καποιο βιβλιο που θα μπορουσα να βρω για εξτρα βοηθεια;

johnsid2007-12-12 22:52:10

Να πω κάτι που ίσως να σου φανεί κάπως πριν κάνεις εγκατάσταση κάποιου audio driver.
¶νοιξε μία κονσόλα αφού μπεις στο σύστημα και γράψε alsamixer.
Αφού μπεις εκεί πάτα τα βελάκια ( δεξιά και αριστερά) και το Μ και πήγαινε και κλείσε ή χαμήλωσε την ένταση σε όλα τα μικρόφωνα.
Αν έχεις laptop ( κάτι τέτοιο εικάζω αν κάνω λάθος τότε συγγνώμη)  απλά έχεις ανοιχτό το μικρόφωνο του και με το που πάει να μπει παίρνει τον ήχο από τον ήχο έναρξης και μικροφωνίζει.
Το ίδιο και για την αναπαραγωγή αρχείων που περιέχουν ήχο.

Το ίδιο μπορείς να κάνεις φυσικά και χωρίς τo alsa mixer από το εικονάκι όπου ρυθμίζεις τον ήχο με δεξί κλίκ επάνω σε αυτό.
Αν δεν ισχύει αυτό που σου λέω ακολούθησε τότε ότι οδηγίες σου δίνει εδώ ο alfisti.

Καθε βοηθεια δεκτη και δεν παρεξηγω τιποτα.Ευχαριστω πολυ αν και το προβλημα απεκτησε αλλη μορφη.
Δοκιμασα τον Alsamixer  και το σφυριγμα χαθηκε προς το παρον (εκανα τρια-τεσσερα reboot και ακουγεται μια χαρα) ομως...
οταν πηγα να ρυθμισω την ενταση απο το tray ο ηχος χαθηκε αποτομα.
το ιδιο και απο τα κουμπια του πληκτρολογιου!!!
Σαν το γεφυρι της Αρτας... περιπου.

Ξεχασα να αναφερω οτι προκειται για ενα desktop pc,Intel Celeron D,2GB DDR2 στο οποιο συζουν Windows XP & Ubuntu 7.10.

johnsid2007-12-13 18:11:0


Λοιπόν... καταρχάς να κάνω μία παρατήρηση εδώ γενικότερου ενδιαφέροντος.
Ένα πρόβλημα μπορεί να οφείλεται σε διάφορους λόγους αλλά πρώτα πρέπει να σκεφτόμαστε τον πιο απλό και αυτονόητο.
Δηλαδή καταρχάς ελέγχουμε αν έχουμε κάνει μία λάθος ρύθμιση και μετά πρέπει να πάει το μυαλό μας στα χειρότερα.
Όντας φοιτήτρια ανθρωπιστικών σπουδών, είμαι μεγάλη fun του δόγματος "ξυράφι του Όκκαμ" δηλαδή ότι η πιο απλή λύση είναι και η πιο πιθανή.

Τώρα για το πρόβλημα που έχεις τώρα:
Προφανώς έκλεισες τον ήχο εντελώς!
Πρόσεξε εδώ. Το alsamixer είναι το κεντρικό μενού όπου ανοιγοκλέινουμε τον ήχο. Το tray είναι αυτό στο οποίο τον ρυθμίζουμε από το desktop.
Αν κάτι το έχεις κάνει εντελώς mute στο alsa μην περιμένεις να στο δώσει πάνω στο desktop. Μ και αφού κάνεις umute έχεις διαθέσιμη την  επιλογή στο tray.
Επίσης το τι θα έχει το tray πάνω για να το ρυθμίζεις εξαρτάται από τα δικά του preferences ( μπορείς να το διαλέξεις αυτό.) Επέλεξε αυτά που χρησιμοποιείς, χαμήλωσε και μούγκανε εντελώς αυτά που δε χρειάζεσαι καθόλου και επίσης βγάλε τα εντελώς από το tray.

Για να κάνεις λοιπόν σωστά τις ρυθμίσεις σου και να μην νιώθεις ότι έχεις μπλέξει στης ¶ρτας το γεφύρι, πήγαινε εδώ
http://forum.hellug.gr/hardware/t288/msg2042/#msg2042
όπου στο συγκεκριμένο μήνυμα έχω απαντήσει σε μία σχετική απορία για την ρύθμιση του ήχου στο ubuntu.
Επίσης την ώρα που κάνεις τις ρυθμίσεις, από οπουδήποτε και αν τις κάνεις αυτές, είτε από το alsa είτε από το tray, έχε ένα αρχείο ήχου να παίζει, γιατί γενικότερα στα desktops έχει πολλές διαφορετικές εξόδους και εισόδους ήχου.
¶νοιξε ένα αρχείο ήχου λοιπόν να παίζει και άρχισε να κάνεις κάποια από αυτά που αναφέρω στο λινκ που σου δίνω και φυσικά δοκίμασε και άλλα πράγματα για να βρεις που είναι τι.

Ο υπολογιστής δεν έχει πρόβλημα. Πρέπει να βρεις τις ρυθμίσεις και να ενεργοποιήσεις τις κατάλληλες εξόδους ήχου για να ακούς από εκεί που έχεις συνδεμένα τα ηχεία σου.

Τα μικρόφωνα όταν δεν τα χρησιμοποιείς φροντίζεις με δεξί κλίκ από το tray να τα έχεις πάντα κλειστά. Όταν τα χρειάζεσαι τότε με δεξί κλικ πάς στο fader του μικροφώνου το δυναμώνεις μέχρι την μέση το πολύ κάνεις την δουλειά σου και μετά πάντα δεν ξεχνάς να το κλείνεις.

Αυτά για την ώρα. αν έχεις κάποια άλλη απορία μη διστάσεις να ρωτήσεις ξανά εδώ.

¶ντε καλή συνέχεια!


Μηπως βιαζεσαι λιγακι Marlene?

Δεν εχω αναφερει κατι για mute η muting.

Τσεκαρισα τα παντα η τουλαχιστον οσα γνωριζω τον λιγο καιρο που ασχολουμαι συν αυτα που μου υποδειξες και ολα τα βρηκα μια χαρα(η ετσι φαινονται τουλαχιστον)

Ο ηχος επανερχεται μονο μετα απο reboot και παραδοξως οι ρυθμισεις ειναι ακριβως εκει που τις εχω αφησει.

Αναπαραγει κανονικα τα παντα μονο που αν προσπαθησεις να αυξησεις η να μειωσεις την ενταση ηχος τελος.

Καμμια αλλη ιδεα?

(Marlene γιατι τοση εμμονη με τα μικροφωνα?Δεν εχω κι ουτε σκεφτομαι να βαλω,για την ωρα)johnsid2007-12-13 19:16:56

Γιατί αυτό που περιέγραφες ήταν κάτι που έμοιαζε με μικρόφωνο που δεν λειτουργεί σωστά. Και όπως μου είπες όταν πείραξες το alsa mixer αυτό σταμάτησε να γίνεται. Οπότε κατέληξα να συμπεράνω είτε ότι είχες κάποιο μικρόφωνο επάνω που έπαιρνε τον ήχο από τα ηχεία είτε κάποιες από τις ρυθμίσεις ήχου ήταν πιο δυνατά από ότι έπρεπε.

Τώρα από ότι κατάλαβα ρυθμίζεις τον ήχο από το tray.
Οπότε προφανώς έχεις βάλει το tray να χαμηλώνει τον ήχο στο master του υπολογιστή πράγμα που σημαίνει ότι μόλις πας να χαμηλώσεις λίγο το ήχο στα κλείνει όλα.

Στο reboot παίρνει τις ρυθμίσεις από την αρχή.
Anyway.
Πάμε μία τις ρυθμίσεις από την αρχή.
Αλλάζω υπολογιστή για να μπω από το desktop όπου οι ρυθμίσεις πρέπει να είναι παρόμοιες και θα σου τις δείξω σε καινούργιο ποστ μαζί με screenshot..
Επανέρχομαι λοιπόν..

Λοιπόν το alsamixer πρέπει να σου παρουσιάζει και τέτοιο.
Η πρώτη φωτο είναι ότι βλέπεις στην αρχή και η δεύτερη είναι τι βλέπεις στα δεξιά.
Ρύθμισε τα έτσι λοιπόν.




Πάμε τώρα στο tray.
Εκεί είναι λίγο πιο tricky τα πράγματα.

Καταρχάς χρήσιμο είναι να βλέπεις με δεξί κλικ στο open volume control τα ακόλουθα που είναι και τα απολύτως απαραίτητα.



Ότι άλλο θες, και ανάλογα με τις ανάγκες σου το τικάρεις για να ενεργοποιηθεί από το μενού edit/prefernces. Θα σου δώσει ένα παράθυρο που έχει αυτά που βλέπεις παρακάτω. Για να δεις τι έχω ενεργοποιήσει εγώ και τι είναι αυτό που βλέπω στο screenshot που σου έδιξα πιο πάνω το έκανα μεγάλο.



τώρα με δεξί κλικ πάνω στo tray πας στο τρίτο από πάνω εκεί που λέει preferences και το πατάς.
Σε αυτο δίνεις να δυναμώνει χαμηλώνει η ένταση στο pcm διότι αν το δώσεις στο master τότε ανοιγοκλείνει η ένταση ΓΙΑ ΌΛΑ ταυτόχρονα και έτσι ο υπολογιστής χάνει τον ήχο του.



Δες εδώ πως πρέπει να το κάνεις.

Κάνε αυτές τις ρυθμίσεις . Αν πάλι σου παρουσιάζει το ίδιο πρόβλημα και εξαφανίζεται ο ήχος κοιτάμε το ενδεχόμενο να κολλάει η κάρτα ήχου σου από κάποια εφαρμογή που τρέχεις και το ψάχνουμε εναλλακτικά.




Μαλλον το πειραζει η υγρασια...
Χθες επαιξε ταινια,σημερα παλι σφυριζει τι αλλο μπορω να κανω?

johnsid2007-12-27 17:47:48

Κοιτα να δεις.Πανω που ειχα αρχισει να απογοητευομαι απο το Ubuntu

επεσα κατα τυχη στο :

http://ubuntuforums.org/showthread.php?t=231032&highlight=High+pitched+…

Τελικα βρηκα την λυση (προς το παρον λειτουργει αψογα) κατα τυχη....:-)

Και μ' αρεσει πολυ...

johnsid]

Κοιτα να δεις.Πανω που ειχα αρχισει να απογοητευομαι απο το Ubuntu

επεσα κατα τυχη στο :

http://ubuntuforums.org/showthread.php?t=231032&highlight=High+pitched+…

Τελικα βρηκα την λυση (προς το παρον λειτουργει αψογα) κατα τυχη....:-)

Και μ' αρεσει πολυ...

Problem Solved

johnsid, η marlene έκανε τόση προσπάθεια να σε βοηθήσει.
Γράψε κι εσύ με απλά λόγια τι έκανες ώστε να βοηθήσεις τους υπόλοιπους που μπορεί να μην καταλαβαίνουν.

Administrator ειναι αληθεια οτι το αμελησα λιγακι και ζητω συγγνωμη απο τους υπολοιπους.
Ακολουθησα τις οδηγιες απο το παραπανω link και ανοιξα με εναν επεξεργαστη κειμενου απο το filesystem/etc/modprob.d το αρχειο options δηλαδη : sudo gedit /etc/modprobe.d/options και εκανα επικοληση στην τελευταια σειρα το εξης:
options snd-hda-intel position_fix=1 model=3stack
Κατοπιν αφου εσωσα το options και το εκλεισα, ετρεξα στο τερματικο sudo update-modules και εκανα reboot.

Ελπιζω τα παραπανω να βοηθησουν οποιον εχει παρομοιο προβλημα(high pitched noise at startup).