Kernel Panic on slackware 12.0

Ανώνυμος (χωρίς επαλήθευση) | Κυρ, 01/13/2008 - 23:30 | 3' | 1

Καλησπέρα,
πήγα να εγκαταστήσω τοην κάρτα δυκτίου μου (Intel 3945ABG) και συγκεκριμένα το mac80211 subsystem package

ακολούθησα τις οδηγίες εγκατάστασης απο το readme
σας το παραθέτω εδώ

Quick steps

If you're a user that just wants to try and get up and running
as quickly as possible, here are the simplest steps we have so
far:

% make patch_kernel

The above, if it succeeds, should patch your current running
kernel source tree to contain the mac80211 subsystem sources. Now
you need to configure your kernel build to build the mac80211
modules:

% cd /lib/modules/$(uname -r)/build
% make menuconfig

You will want to set the following to <M>:

CONFIG_MAC80211=m

Networking --->
Generic IEEE 802.11 Networking Stack (dscape)

You can turn on the sub-options for that subsystem if you want.

Select 'Exit' until it prompts to save your kernel configuration
and select 'Yes'. Now you can build the module:

% make modules
% make modules_install

//ΕΔΩ ΕΙΝΑΙ ΤΟ ΠΡΟΒΛΗΜΑ!!!!!!!!!!!!!!!!!!!!!!!!!!1
NOTE: As of mac80211-2.0.0 you must also enable CONFIG_CFG80211 and
rebuild your main kernel image. This is because the latest mac80211
changes re-implement the kernel built-in from net/core/wireless.c as
part of the net/wireless/ sources.

% make all
% make install

You will then need to reboot into the new kernel (vs. just loading the
new 80211 modules)

έκανα make modules, make modules_install,
και μετά

make all
make install

κάνω reboot,
και εμφανίζετε kernel panic!!!

'No filesystem could mount root, tried:'
'Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,5)'

είμαι σχετικά νέος,
plz help! :)

Δώσε αστέρια!
Σχόλια

PROBLEM SOLVED,

Boot with slackware dvd, choose your installation folder, and run the kernel source again :P