Εχω σύνδεση DSL με modem/router και κάρτα δικτύου, αλλά δεν μπορώ να δω ιστοσελίδες! Τι φταίει;

Άνοιξε ένα τερματικό και δώσε την εντολή

/sbin/ifconfig

Θα εμφανίσει κάτι σαν κι αυτό:

[email protected]:~$ /sbin/ifconfig 
enp0s31f6 Link encap:Ethernet  HWaddr 4c:cc:6a:b7:27:41  
          inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::8195:da60:6dce:55ab/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27426958 errors:0 dropped:9 overruns:0 frame:0
          TX packets:39592994 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3484684740 (3.4 GB)  TX bytes:42414830529 (42.4 GB)
          Interrupt:16 Memory:df100000-df120000 

Στο παράδειγμά μας η enp0s31f6 είναι η (πρώτη) κάρτα δικτύου μας. Αν έχεις περισσότερες κάρτες (ή θύρες στον υπολογιστή) θα δεις και άλλες τέτοιες καταχωρίσεις. Ενώ αν έχεις wireless, θα δεις wlan0 ή κάτι παρόμοιο.

Αυτό που μας ενδιαφέρει είναι αν στα παραπάνω αποτελέσματα, έχεις μια διεύθυνση της μορφής inet addr 192.168.1.ΧΧ ή ότι άλλο χρησιμοποιεί ο router σου (δες τα έντονα γράμματα!). Αν ναι, τότε μπορείς να κάνεις ping στον router; Π.χ. δίνοντας:

ping 192.168.1.1

θα πρέπει να απαντήσει o router σου:

PING 192.168.1.1 () 56(84) bytes of data.
64 bytes from 10.1.2.1: icmp_seq=1 ttl=128 time=0.145 ms
...

Αν απαντήσει σωστά, τότε μάλλον έχεις προβλήματα με DNS servers.

Πως διαπιστώνω και πως λύνω προβλήματα με DNS server;

Κάθε server, κάθε ιστοσελίδα και και κάθε ιστότοπος στο διαδίκτυο (π.χ. www.linuxinsider.gr) έχουν μια IP διεύθυνση του τύπου ΧΧΧ.ΧΧΧ.ΧΧΧ.ΧΧΧ.

Οι υπολογιστές μας όμως δεν μπορούν να ξέρουν την IP της κάθε ιστοσελίδας. Οταν π.χ. βάζουμε στο Firefox http://www.linuxinsider.gr, ο υπολογιστής μας πρέπει να ζητήσει από κάποιον να του "μεταφράσει" το όνομα που βάλαμε στην αντίστοιχη διεύθυνση IP. Αυτή τη "μετάφραση" την κάνει ένας DNS server (ή nameserver).

Με άλλα λόγια, αν δεν μπορείς να μπεις σε ιστοσελίδες με τον Firefox αλλά δίνοντας απευθείας μια IP, π.χ.

http://216.58.209.174

βλέπεις τη σελίδα της google, τότε 99%  το πρόβλημά σου είναι θέμα DNS. Δηλαδή ο υπολογιστής σου 

  • είτε δεν ξέρει που να βρει έναν DNS server για να ζητήσει μετάφραση του ονόματος που του δίνεις σε διεύθυνση IP,
  • είτε ξέρει τον DNS server, αλλά ο server αυτός είναι down

Οτι απο τα δύο κι αν συμβαίνει, ο υπολογιστής σου καταλαβαίνει την IP, γι' αυτό σε πηγαίνει απευθείας στη σελίδα της google.

Οι διευθύνσεις των DNS servers διαφέρουν ανάλογα με τον πάροχο Internet που έχεις και στο Linux καθορίζονται στο αρχείο /etc/resolv.conf.

Το αρχείο αυτό στις περισσότερες διανομές δεν πρέπει να το ανοίξεις γιατί ρυθμίζεται αυτόματα από ένα πρόγραμμα που λέγεται NetworkManager - και συνήθως εκεί μπαίνει η IP του router σου, καθώς το router αναλαμβάνει να παίξει το ρόλο του DNS server για το τοπικό δίκτυο σου (παίρνει DNS servers από τον πάροχό σου).

Για να λύσεις προβλήματα με DNS, μπορείς  να βάλεις "καρφωτά" κάποιους "παγκόσμιους" dns servers (π.χ. τον 8.8.8.8 της Google ή τον 1.1.1.1 της Cloudflare) για να μιλάει το Linux σου απευθείας με αυτούς αντί να ζητάει τη βοήθεια του router ή του παρόχου σου. Για να το κάνεις αυτό σε Ubuntu, πάτα Alt+F2 και γράψε:

gedit admin:///etc/resolvconf/resolv.conf.d/base

ή από ένα τερματικό γράψε

sudo nano /etc/resolvconf/resolv.conf.d/base

Αυτό το αρχείο πρέπει να έχει αυτήν την μορφή:

nameserver 8.8.8.8
nameserver 1.1.1.1

 

Οι παραπάνω δύο DNS είναι της google και της Cloudflare. Με αυτούς θα κάνετε τη δουλειά σας, μια και σπάνια έχουν downtime.

Αποθηκεύστε το αρχείο (Ctrl+S αν είστε στο Gedit ή Ctrl+X αν είστε στο nano) και κάντε επανεκκίνηση...

Σημείωση: Αν θέλετε να βάλετε τους DNS servers των παρόχων Internet στην Ελλάδα, να μια λίστα:

OTENET
195.170.0.1
195.170.2.2

Forthnet
194.219.227.2
193.92.150.3
193.92.110.1 Για Β. Ελλάδα
193.92.30.19 Για Κρήτη

HOL
194.30.220.114
194.30.220.117

Tellas
62.169.194.17
62.169.194.18

 

 

Δώσε αστέρια!

MO: 5 (ψήφοι: 2)

Comments

Παιδιά καλησπέρα. Είναι η πρώτη μου επαφή με Linux, κ για την ακρίβεια εγγατέστησα πριν δύο μέρες το Ubuntu 8.04 .Έχω σύνδεση Conex με modem/ruter Sagem fast 800, κατέβασα ένα προγραμματάκι για το Sagem Fast 800 με τις οδηγίες του περιοδικού σας, εγκατέστησα το sagem fast 800, συνδέεται στο δίκτυο αλλά δεν μου εμφανίζει σελίδες. Έγραψα μια IP δ/νση και δεν μου εμφάνισε τίποτα. Άνοιξα το αρχείο /etc/resolv.conf. και έγραψα τους nameservers της ΟΤΕΝΕΤ αλλά κ πάλι τίποτα.Τι μπορώ να κάνω;

χαιρεται...εχω ενα προβλημα με το ubuntu: οταν πληκτρολογο το username & password με βγαζει σε μια πορτοκαλη οθονη και δεν μου ανοιγει το desktop...καμια συμβουλη?

 Γεια σας και από 'μένα... Είμαι τελείως νέος χρήστης του linux, τώρα κάνω τα πρώτα - πρώτα βήματά μου.

Μόλις εγκατέστησα στον υπολογιστή μου το Ubuntu 8.04 (αγόρασα το σχετικό περιοδικό LINUX format). Το έχω σε dual boot με τα Windows XP SP3.

Σε ό,τι αφορά το διαδίκτυο, παρουσιάζεται αδυναμία πρόσβασης. Δηλαδή πάνω δεξιά μου δείχνει τις δύο οθονούλες με ένα κόκκινο Χ. 

Ο εξοπλισμός που χρησιμοποιώ για την πρόσβασή μου στο internet είναι ο εξής :

Baudtec T263R1U @ 8Mbps (modem από την cosmote)

Netgear Wireless-G USB 2.0 Adapter WG111v3 @ 54 Mbps (το εξάρτημα αυτό συνδέεται με τον υπολογιστή μέσω USB σύνδεσης)

Netgear Wireless-G Router WGR614v9 @ 54Mbps (το σήμα φτάνει σε αυτόν τον δρομολογητή. Κατόπιν μέσω καλωδίου ethernet συνδέεται με το παραπάνω modem και από εκεί φεύγει το τηλεφωνικό καλώδιο για την πρίζα.)

 

Υπάρχει κάποια λύση;

Ubuntu 8.04? Είσαι σίγουρος; Η καινούρια έκδοση του Ubuntu είναι η 10.04!

Για άνοιξε τερματικό (κονσόλα) και γράψε

lsusb

να δούμε αν βλέπει το USB εξάρτημα.

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

Γεια σας και πάλι.

Αυτή την εντολή δεν μου την αναγνωρίζει. Ανοίγω το τερματικό (είναι στον home κατάλογο, έτσι δεν είναι; ) και πληκτρολογώ susb.

Μου βγάζει το μήνυμα μη αναγνώρισης της εντολής. Αν χρησιμοποιήσω το σύμβολο "/", μου βγάζει ότι δεν αναγνωρίζει τον κατάλογο.

Η έκδοση που έχω είναι η 8.04. Αγόρασα το περιοδικό LINUX format με το σχετικό DVD, το οποίο βρήκα σ' ένα supermarket ΜΑΣΟΥΤΗΣ (Νικήτη Χαλκιδικής). 

 

Με την εντολή ifconfig μου βγάζει δύο κείμενα. Το πρώτο ξεκινά με την λέξη eth0 και αφορά μάλλον την onboard κάρτα ethernet της μητρικής μου. Λέει κάτι για πακέτα δεδομένων, συγκρούσεις κ.τ.λ.

Στο δεύτερο κείμενο γράφει lo και μετά lοοpback (ή κάτι τέτοιο) και γράφει τ' αντίστοιχα χαρακτηριστικά. Η διαφορά είναι ότι σε αυτή την ενότητα γράφει ότι ανταλλάχθηκαν περίπου 89 Kb δεδομένων (εκεί που λέει για τα πακέτα).

Τα ίδια δεδομένα μπόρεσα να εμφανίσω και μέσω του γραφικού περιβάλλοντος.

 

Βασικά τώρα γράφω από τα windows. Κάνω boot με το linux, κάνω ό,τι είναι να κάνω και μετά ξανά boot με windows, ώστε να στείλω αυτά τα μηνύματα.

Γι' αυτό και δεν μπορώ ν' αποδώσω πλήρως αυτά που συμβαίνουν. Άμα δεν βγει άκρη θα κάνω το ίδιο, αλλά θα πάρω φωτογραφία το τερματικό (με την αντίστοιχη εφαρμογή) και θα αναεβάσω το αρχείο ώστε να το δείτε.

 

Κατ' αρχήν, η έκδοση που έχεις, είναι ήδη ξεπερασμένη και σου συστήνω να κατεβάσεις το νέο Ubuntu από εδώ. Ή εναλλακτικά να πας εδώ και να το κατεβάσεις με την επιλογή torrent, όπου είναι πιο σίγουρη.

Το αρχείο είναι σε μορφή .iso. Θα πρέπει να κατέβει σωστά (γι' αυτό θεωρώ πιο ασφαλές το torrent) και στη συνέχεια -από τα Windows- θα το κάψεις σε CD με την επιλογή του Nero "Burn Image".  Όταν τελειώσεις, θα μπουτάρεις τον υπολογιστή σου από το CD όπως έκανες και με το 8.04. Κάνεις την εγκατάσταση και μας λες αν παραμένει το πρόβλημα. Παίζει ρόλο η κάθε έκδοση λειτουργικού, γιατί υπάρχουν νέοι πυρήνες (kernels) και νέες ενημερώσεις για hardware. Η 8.04 θεωρείται "προϊστορική" πλέον!

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

Δημήτριος Μαυρομάτης]

Aυτή την εντολή δεν μου την αναγνωρίζει. Ανοίγω το τερματικό (είναι στον home κατάλογο, έτσι δεν είναι; ) και πληκτρολογώ susb.

Μου βγάζει το μήνυμα μη αναγνώρισης της εντολής. Αν χρησιμοποιήσω το σύμβολο "/", μου βγάζει ότι δεν αναγνωρίζει τον κατάλογο.
 

Η εντολή είναι (εσύ γράψτο με μικρά) LSUSB . Δείχνει την λίστα (ls) των συσκευών usb. Αντίστοιχα υπάρχουν εντολές lspci που δείχνουν τις pci συσκευές, η lsmod που δείχνει τα modules που τρέχουν, η απλή ls που σου δείχνει τα περιεχόμενα του τρέχοντος καταλόγου και πιθανώς αρκετές ακόμα. 

Α, μπράβο, δεν το είχα προσέξει! Την έγραψε λάθος την εντολή. Πάντως, θα επιμείνω να κατεβάσει την πρόσφατη έκδοση. Η 8.04 είναι πολύ παλιά.

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

Παιδιά ευχαριστώ για τις απαντήσεις σας!

Θα κατεβάσω την πρόσφατη έκδοση και θα ενημερώσω αμέσως μετά!!!

 Πάντως το Linux βλέπει μια χαρά τον USB πομπό-δέκτη της Netgear, όπως και όλες τις άλλες συσκευές. 

Χθες έκανα κλικ στις δύο οθονούλες του desktop και επέλεξα την εντολή manual configuration. Αμέσως εμφανίστηκε ένα παράθυρο όπου είχε δύο επιλογές, την ενσύρματη σύνδεση και την σημείο προς σημείο. Έκανα κλικ στην ενσύρματη και στις ιδιότητες πάτησα "αυτόματη ρύθμιση". Μετά πρόσθεσα και τα IP των DNS servers της ΟΤΕΝΕΤ, αλλά εξακολουθεί να μην μπαίνει.

Μήπως οι οδηγοί που εγκατέστησε το linux για την συσκευή αυτή δεν είναι κατάλληλοι; Μήπως και ο router (επίσης της Netgear) θέλει κάποιο πρόγραμμα;

Πάντως, όταν φορτώνω τον Mozilla, μετά από αρκετή ώρα μου βγάζει σφάλμα σύνδεσης, ενώ πριν μου το έβγαζε αμέσως!

Παιδιά εκπέμπω SOS!!

Ήθελα να εγκαταστήσω την έκδοση 10.4 και έτσι αποφάσισα να διγράψω πρώτα την 8.04. Επειδή δεν ήξερα πως να το κάνω αυτό, πήγα μέσω του Paragon partition manager στα Windows να διαγράψω τ' αντίστοιχα partitions (ένα για τα δεδομένα και ένα για την εικονική μνήμη). Έτσι λοιπόν, τα διέγραψα (και τα δεδομένα καταστράφηκαν).

Επιπρόσθετα ήθελα να αλλάξω τα μεγέθη των partitions, ώστε με την νέα εγκατάσταση να υπάρχει περισσότερος διαθέσιμος χώρος για το linux. Έτσι έκανα και διαφοροποιήσεις στο μέγεθος  του διαμερίσματος C. Το πρόγραμμα αυτό μου ζήτησε επανεκκίνηση, ώστε να μπορέσει να εφαρμόσει τις αλλαγές.

Όμως διαπίστωσα ότι το πρόγραμμα GRUB (αυτό που διαλέγεις με ποιο λειτουργικό να ξεκινήσεις και ενεργοποιείται πριν την φόρτωση κάποιου λειτουργικού κάθε φορά που ενεργοποιείται ο Η/Υ) δεν μπορούσε να δουλέψει (error 22). Ο υπολογιστής πλέον δεν μπορεί να κάνει τίποτε. Ξεκινά μόνο με δισκέτα εκκίνησης ή με κάποιο DVD/CD.

 

Τι να κάνω;;;; Υπάρχει περίπτωση ν' αποφύγω το format;; Υπάρχει λύση;;;

Απαντήστε σας παρακαλώ, γιατί καίγομαι!!!

Μου φαίνεται οτι αν εγκαταστήσεις το 10.04 θα μπουτάρεις κανονικά και στα δυο λειτουργικά. Τα δεδομένα που σβήστηκαν μάλλον περιείχαν και το /boot οπότε ο grub πάει να φορτώσει και δεν βρίσκει τίποτα.

Μια μικρή παρατήρηση όμως, το πρόβλημά σου είναι άσχετο με το θέμα...

 

 

Προσοχή στη διαφορά, πάντως! H 8.04 χρησιμοποιούσε Grub, ενώ η 10.4 χρησιμοποιεί Grub2.

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

Το ξέρω ότι είναι άσχετο το πρόβλημά μου με το θέμα.

Το τελευταίο που θ' αναφέρω είναι ότι προσπάθησα να εγκαταστήσω εκ νέου το 8.04, αλλά μου έβγαλε μήνυμα ότι το πρόγραμμα GRUB δεν μπορούσε να εγκατασταθεί (μήνυμα : "αυτό είναι κρίσιμο σφάλμα"). Προσπάθησα πρώτα με την 10.4, αλλά το CD δεν δούλεψε.

Ευτυχώς που έχω και τα δεδομένα μου σε back-up.

Τέλος πάντων, το κλείνω εδώ το θέμα, για να μην ξεφύγει.

 

 

 Παιδιά γεια σας και πάλι...

Εγκατέστησα την 10.04 έκδοση, η οποία, όντως δεν έχει καμιά σχέση με την 8.04! (Έκανα format όλο τον δίσκο πρώτα, στάθηκε αδύνατο να ξεπεράσω το πρόβλημα με το GRUB)

Όμως εξακολουθώ να μην μπορώ να συνδεθώ στο διαδίκτυο. Το λειτουργικό βλέπει τον USB πομπό-δέκτη της NETGEAR (W111v3), αλλά δεν μπαίνει.

Επισκέφθηκα διάφορες ιστοσελίδες μέσω Google, για να κατεβάσω οδηγούς (για linux), αλλά δεν βρήκα κάτι. Τι να κάνω;

Μάλλον χρειάζεσαι δύο πακέτα. τα  ndiswrapper-common και ndiswrapper-utils. Για ψάξε αν υπάρχουν εγκατεστημένα ή κατέβασέ τα μέσω synaptic.

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

Χωρίς να θέλω να σε στεναχωρήσω (ή απογοητεύσω), η συσκευή έχει πρόβλημα συμβατότητας με το linux, γενικότερα! Να τι βρήκα στην παρακάτω σελίδα που ασχολείται με το θέμα:

Netgear USB network adapter W111V3

Linux Compatible: No

The ndiswrapper driver does configure the network card. However, it refuses to connect to any Wi-Fi hotspots due to the missing firmware files not supplied on the vendor CD. **Avoid this for Linux use **

------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

 Βασικά είχα μάθει χθες γι' αυτά από το ψάξιμό μου στο διαδίκτυο. Πάτησα την αναζήτηση χθες στο ubuntu και μου έβγαλε 4 αποτελέσματα. 2 αρχεία (ένα ndiswrapper*.ko - μεταφρασμένος κώδικας-, ένα αρχείο header με την ίδια ονομασία) και τους 2 αντίστοιχους φακέλους.

Για να τα κατεβάσω από synaptic πρέπει να βρω έναν άλλο υπολογιστή με linux, αφού ο δικός μου δεν συνδέεται.

Μήπως, λέω μήπως, μπορώ ν' αλλάξω μόνο τον πομπό-δέκτη (να βάλω της Linksys) και ν' αφήσω ίδιο τον δρομολογητή (της NETGEAR);

Το ότι αρνείται να συνδεθεί σε Wi-Fi spots, τι σημαίνει για ένα ακίνητο desktop; Εγώ απλά θέλω τον adapter προκειμένου να γλιτώσω το καλώδιο που συνέδεε το απομακρυσμένο modem μου με τον υπολογιστή (και σκόνταφτα συνέχεια πάνω του, αφού περνούσε από το χωλ του σπιτιού). Θα μπορώ στο μέλλον να φτιάξω δίκτυο υπολογιστών μέσω του ίδιου δρομολογητή; Λογικά ναι, αφού του adapter είναι το πρόβλημα, όχι του δρομολογητή, ε;;;

 

Παιδιά έχω ευχάριστα νέα!!!!

Τελικά ο USB πομποδέκτης, που έχω, φοράει πάνω ένα chipάκι της REALTEK (το RTL8187B). Αυτό το chipάκι υποστηρίζεται μια χαρά από τον kernel 2.6.27 (ή νεότερο) του linux. Για του λόγου το αληθές δείτε εδώ (παρμένο από άλλο thread του φόρουμ τούτου). Μάλιστα υποστηρίζει πολλά chipάκια της REALTEK...

Ο λόγος που δεν μπορούσα να μπω τόσο καιρό; Απλά έδινα λάθος συνθηματικό...

Γι' αυτό και στο σηματάκι πάνω δεξιά (το σύμβολο ")))))" στραμμένο κατά 90 μοίρες αριστερόστροφα) αναβόσβηνε για πολύ ώρα, πριν μου ξαναβγάλει το παράθυρο διαλόγου με το όνομα, το επιζητούμενο επίπεδο ασφάλειας και το συνθηματικό...

 

ΟΥΦ! Τέλος καλό, όλα καλά!

Παιδιά, ωραία, βλέπω τις ιστοσελίδες, αλλά στην αρχή δεν μπορούσα να δω βιντέακια.

Για τον σκοπό αυτό απαιτείται το πρόγραμμα Adobe Flash Player. Έτσι λοιπόν κατέβασα το deb (εκτελέσιμο) πακέτο και το εγκατέστησα με την προεπιλεγμένη εφαρμογή GDebi. To deb πακέτο εγκαταστάθηκε, το έβλεπα στο σύστημα synaptic εγκατεστημένο στην κατηγορία "Εγκατεστημένα (τοπικά ή ξεπερασμένα)".

Αυτό γιατί συμβαίνει; Τι σημαίνει αυτό;

Στην αρχή δεν μπορούσα να δω βιντεάκια στο facebook. Μετά όμως από μια επανεκκίνηση, έστρωσε...