Ubuntu 8.04 - ATi Proprietary Drivers

109 posts / 0 new
Τελευταία καταχώριση
Εικόνα: apkoutsou
apkoutsou
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1825
Ubuntu 8.04 - ATi Proprietary Drivers

Το Ubuntu 8.04 ήρθε με λυμένο πλέον το γνωστό πρόβλημα με την αναγνώριση των καρτών AGP της ATi!!!

Πριν από λίγες ώρες το κατέβασα και ασχολούμαι αποκλειστικά με αυτό... Το ευτυχές είναι ότι ΑΜΕΣΩΣ μετά την εγκατάσταση το λειτουργικό αναγνώριζε την κάρτα γραφικών στον "Οοδηγό Υλικού" (τέως "Διαχείρηση οδηγών κλειστού κώδικα"), οπότε εγκατέστησα το EnvyNG (το οποίο με την σειρά του εγκατέστησε του ΤΕΛΕΥΤΑΙΟΥΣ παρακαλώ drivers για την ATi) και για πρώτη φορά έχω επιτελους εφε...!!!!

ΟΜΩΣ (καθότι ο γολγοθάς συνεχίζεται) όταν χρησιμοποιείται ο fglrx driver ο επεξεργαστής κτυπά κυριολεκτικά κόκκινο: σουλεύει συνεχώς στο 90-100%, με αποτέλσμα το σύστημα να είναι πολύ αργό ακόμα και για να ανοίξει το τερματικό (!!!), ενώ η παρακολούθηση συστήματος τα δείχνει όλα φυσιολογικά...Το πρόβλημα δεν υπάρχει όταν χρησιμοποιώ vesa drivers, ούτε υπήρχε όταν είχα μια σχετικά παλιά NVidia, οπότε κάτι τρέχει με τους fglrx...

Καμία ιδέα για το τι μπορεί να προκαλεί όλο αυτό τον φόρτο στον καημένο μου επεξεργαστή...???

Edit: Έχω μια μικρή αίσθηση ότι η υπερφόρτωση οφείλεται στο gDesklets...Θα το ερευνήσω, αλλά ας καταθέσει και κανείς άλλος την γνώμη του...

__________________

--------------------------------------------------------------------

LawyersVoice.gr - To forum των νέων δικηγόρων

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

καλημερα εμενα το ενβυ δεν δουλεψε γιατι ηταν παλια εκδοση.τους εγκαταστησα με το χερι αλλα μετα ειχα οθονη ασπρη.
σε παρακαλω μπορεις να μου πεις
1 μολις εκανες φορματ εβαλλες ενβυ
2 περασες τον οδηγο
3εκανες ρεσταρτ
και ετσι δουλεψε?
ευχαριστω

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τελικα εβαλλα τους ντριβερσ με το ενβυ ετρεξα και τον οδηγο και οταν κανω επανεκινιση εχω μια ασπρη οθονη.οταν ξανακανω επανεκινιση εμφανιζει για κλασματα δευτερολεπτου τιν οθονη κανονικα και κλεινει...

Εικόνα: dimitris
dimitris (not verified)

Οι ATi drivers έχουν ακόμα πρόβλημα με τις AGP κάρτες. Το έχουμε πει, ότι οι ίδιοι οι developers λένε ότι δεν υποστηρίζονται επισημα οι AGP κάρτες. Μην το παλεύετε άδικα και χαλάτε το Ubuntu σας. Εμένα θα με πείραζε πολύ το να βάλω drivers που γονατίζουν το σύστημα. Θα έπαιρνα μια nvidia ή θα έπαιζα με τον vesa drivers μέχρι νεοτέρας.

--Stat rosa pristina nomine, nomina nuda tenemus

Εικόνα: chek2fire
chek2fire
Απουσιάζω!
Registered User
Μέλος από: 1 Ιαν 1970
Πόντοι: 1500

veneton ποιά κάρτα γραφικών έχεις?

__________________

[url="http://ubuntu.opengr.net/"][="#8B0000"]Ubuntu-gr Forum[/][/url]

Εικόνα: apkoutsou
apkoutsou
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1825

Παράθεση από dimitris:

Εμένα θα με πείραζε πολύ το να βάλω drivers που γονατίζουν το σύστημα. Θα έπαιρνα μια nvidia ή θα έπαιζα με τον vesa drivers μέχρι νεοτέρας.

Για εκεί το βλέπω τώρα...Έχω κάποιες υποψίες για το τι μπορεί να προκαλεί την υπερφόρτωση, αλλά αν δεν βγουν αληθινές τότε μάλλον θα αγοράσω καμιά nVidia για να τελειώνω και με αυτό το θέμα επιτέλους...

@venton: ναι αυτή την διαδικασία ακολούθησα, αλλά όπως λέει και ο dimitris οι drivers έχουν πρόβλημα και είμαστε σε συνεχή αναμονή... Εμένα δεν τρέχαν καθόλου στην 7.10 και τώρα γονατίζουν κυριολεκτικά το σύστημα... Η CPU εργάζεται στο 100%... Τώρα είμαι πάλι με vesa και μετά το φαγητό θα κάνω μερικές δοκιμές και μετά κατευθείαν αγορά μιας nVidia...Ίσως και σήμερα ακόμη...

__________________

--------------------------------------------------------------------

LawyersVoice.gr - To forum των νέων δικηγόρων

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

hd 2600 xt agp sta 256 αλλα μαλλον που πρεπει να ξεχασω το θεμα ε?

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

εγω παιδια την αγορασα περισσοτερο για να βλεπω δορυφορικη τηλεοραση hd,αφου παιχνιδια δεν παιζω.... αλλα αποτι φαινεται πρεπει να γυρισω στα windows.... η στην αγορα καποιας αλλης καρτας και να φανταστειτε την αγορασα τον δεκεμβριο 110 ευρω.....

αυτο που με εξοργιζει ειναι πως καποιος τα καταφερε με αναλογη καρτα αλλα προ με 512 και εγω παιδευομαι ακομα.....

Εικόνα: cordobans
cordobans
Απουσιάζω!
Registered User
Μέλος από: 29 Απρ 2008
Πόντοι: 0

μην αγχωνεσαι εγώαγορασα προ4 ημερών μια x1650pro και δεν μου την αναγνωριζει με κανέναν τροπο,εχω εγκαταστησει και απεγκαταστησει το ubuntu 8.04 περιπου18 φορες κοντευω να κρασαρω τον δισκο.

 

Εικόνα: chek2fire
chek2fire
Απουσιάζω!
Registered User
Μέλος από: 1 Ιαν 1970
Πόντοι: 1500

Yπάρχει πρόβλημα με τους driver της ati και ορισμένες agp κάρτες. Η τελευταία λύση εγκατάστασης των driver είναι μέσω του εργαλείου envyng που θα βρείτε στο synaptic. Aν δεν εγκατασταθούν από εκεί τότε δεν έχετε παρά να περιμένετε για κάποιο update.

__________________

[url="http://ubuntu.opengr.net/"][="#8B0000"]Ubuntu-gr Forum[/][/url]

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

καλα αυτο θα μου γινει μαθημα πλεον, σε λιγο καιρο θα κανω αναβαθμιση στο συστημα μου και ενα ειναι σιγουρο ποτε πια ατι!!!!!!

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Θα ήθελα απλώς να υπενθυμίσω ότι είναι στα σκαριά και ο opensource driver radeonhd, που ακόμα δεν υποστιρίζει 3D, αλλά σε λίγο καιρό θα γίνει και αυτό. Στην τελευταία έκδοση υπάρχει υποστήριξη για 2D accelaration κτλ. Πιστεύω στην επόμενη θα δούμε και 3D!! :) Και θα υποστιρίζει και τις καρτες ati agp. ;) Πάντως αυτή η κάρτα hd 2600 xt agp σε μένα δουλεύει με fglrx σε debian sid. Δεν μπορώ να καταλάβω γιατί όχι στο Ubuntu... :?

Εικόνα: chek2fire
chek2fire
Απουσιάζω!
Registered User
Μέλος από: 1 Ιαν 1970
Πόντοι: 1500

veneton για δοκίμασε την εγκατάσταση των driver μέσω του envyng. Το envyng θα το βρεις μέσω synaptic.

__________________

[url="http://ubuntu.opengr.net/"][="#8B0000"]Ubuntu-gr Forum[/][/url]

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

δυστηχως το εκανα και αυτο, πηγα στο σιτε και εκανα εγκατασταση περασα μετα τους ντριβερσ και εκει ειχα ενα αλλο παραξενο.Ενω ολοι οι αλλοι εχουν μαυρη εικονα εγω εχω ασπρη τελειως!!!ειναι κανονικα σαν να δουλευει αφου πατησα τον κωδικο μου αλλα μετα δεν μπορουσα να το επαναφερω και εκανα εγκατασταση καινουργια στα λινουξ.
σαν ασχετος θα ηθελα σε οποιον μπορει να μου εξηγησει αυτο που γραφει ο μιτσαρας<Πάντως αυτή η κάρτα hd 2600 xt agp σε μένα δουλεύει με fglrx σε debian sid.>
τι ειναι το debian sid?ευχαριστω παρα πολυ ολους σας......

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Εγώ έχω τη Sapphire(δεν κάνω διαφήμιση, απλώς για ενημέρωση) hd 2600 xt agp και ο κλειστού κώδικα οδηγός πάντα την αναγνώρισε την κάρτα στο linux χωρίς προβλήματα. Τον κύβο και τα άλλα του compiz-fusion βέβαια τα είδα μόνο με τις 2-3 τελευταίες εκδόσεις του οδηγού. Οι άσπρες και μαύρες οθόνες, κατά τη γνώμη μου, είναι πιό πολύ θέμα σωστής ρύθμισης του monitor στο xorg.conf,

Section "Monitor"
Identifier "Μοντέλο monitor"
HorizSync "Τιμές από το manual του monitor°
VertRefresh "Τιμές από το manual του monitor°
Mode °man xorg.conf(στη χειρότερη περίπτωση θα χρειαστεί να οριστούν και αυτά)"
Option "DPMS"
EndSection

'Οσο για το debian είναι το λειτουργικό σύστημα στο οποίο βασίζονται πολλές διανομές και μέσα σε αυτές είναι και το Ubuntu. Το Sid είναι η κωδική ονομασία της unstable εκδοσης του debian(στην οποία βασίζεται και το Ubuntu). Οι άλλες δύο είναι η stable και testing. Περισσότερα στο www.debian.org . Χρησιμοποιώ τον fglrx που έρχεται έτοιμος στα non-free repositories του sid.

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

καταρχην ενα μεγαλο ευχαριστω που απαντησες,ακριβως την ιδια καρτα εχω με τη διαφορα που η δικη μου ειναι 256μβ.
οποτε μαλλον οτι ειμαι ασχετος γιαυτο και δεν μπορω να περασω τους ντριβερσ και να τους λειτουργησω σωστα....
αν μπορεις να μου πεις ακριβως την διαδικασια που τα εκανες ισως καταφερω να δω και εγω....αν φυσικα ειναι κουραστηκο να τα γραψεις δεν πειραζει ....
και παλι ευχαριστω

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

μιτσαρα ειχες δικιο οτι κατι δεν παει καλα στο xorg.conf,.
μετα που εγκατεστησα παλι τους ντριβερσ ειδα ασπρη οθονη οποτε δεν αντεξα και εκανα παλι φορματ,κατευθειαν πηγα να δω το αρχειο και ειδα πως δεν εχει αναγνωρισει τιποτα.
επειδη ειμαι ασχετος τελειος πως μπορω να βαλλω τα στοιχεια π.χ της οθονης με καποιο προγραμμα η τα βαζω εγω .ευχαριστω....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Κοίτα, ο dimitris(ο admin δηλαδή του φορουμ) έχει κάνει ένα tutorial πάνω στην εγκατάσταση του οδηγού ati σε ubuntu που εγώ καλύτερα δεν θα μπορούσα να το κάνω. 'Ασε που δεν έχω τρέξει ποτέ το Ubuntu.. Αλλά όπως εξήγησα και πρίν το Ubuntu είναι βασισμένο σε μια μίξη του debian sid/testing, δηλαδή ότι τρέχω και γω στο pc μου. http://www.linuxinsider.gr/?q=forum/ati-drivers-%CF%83%CF%84%CE%BF-ubuntu-%CE%BA%CE%B1%CE%B9-%CF%84%CE%BF-kubuntu-%CE%9F%CE%B4%CE%B7%CE%B3%CE%AF%CE%B5%CF%82-%CE%B5%CE%B3%CE%BA%CE%B1%CF%84%CE%AC%CF%83%CF%84%CE%B1%CF%83%CE%B7%CF%82-%CE%BC%CE%B5-%CF%87%CE%B5%CE%B9%CF%81%CE%BF%CE%BA%CE%AF%CE%BD%CE%B7%CF%84%CE%BF-%CF%84%CF%81%CF%8C%CF%80%CE%BF Με τη μόνη διαφορά, πριν αρχίσεις να κάνεις αυτά που λέει ο dimitris, φόρτωσε τον vesa driver, κάνε reboot για τρέχεις το σύστημα με vesa, και βγάλε ότι driver fglrx, ή πακέτα που σχετίζονται με αυτό, έχεις στο σύστημά σου. Επιπλέον άνοιξε μια κονσόλα και γράψε

sudo rm -rf /etc/ati

Μετά, ακολούθησε πιστά τα βήματά που περιγράφει ο dimitris και είμαι σίγουρος ότι θα τα καταφέρεις. Για τις ρυθμίσεις του μόνιτορ πρέπει να συμβουλευτείς το manual του monitor. Πάντως αν έχεις monitor που δουλεύει με λυχνία και όχι τις επίπεδες, τότε ίσως πρέπει να δώσεις τις παραμέτρους που ανέφερα πριν, δηλαδή HorizSync και VertRefresh στο xorg. Αν έχεις τις καινούργιες, λυπάμαι αλλά δεν γνωρίζω την τύφλα μου :)

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Παράθεση από veneton:

επειδη ειμαι ασχετος τελειος πως μπορω να βαλλω τα στοιχεια π.χ της οθονης με καποιο προγραμμα η τα βαζω εγω .ευχαριστω...

Δεν ξέρω αν υπάρχει κάποιο πρόγραμμα που ρυθμίζει το monitor, που σίγουρα θα υπάρχει, αλλά απ'ότι φαίνεται ως τώρα έχει αποτύχει. Γι'αυτό εγώ θα δοκίμαζα την κονσόλα(ή τερματικό). 'Ανοιξε ένα και δώσε

 sudo gedit /etc/X11/xorg.conf

Βρες το κομμάτι που αναφέρεται στο monitor δηλαδή

Section "Monitor"
Identifier "Μοντέλο monitor"
HorizSync "Τιμές από το manual του monitor°
VertRefresh "Τιμές από το manual του monitor°
Option "DPMS"
EndSection

και πρόσθεσε τα HorizSync και VertRefresh με τις κατάλληλες τιμές. Αυτά για monitor με λυχνία.

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

εκανα το φορματ και το xorg.conf μοθ ειναι>
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

εχω μια οθονη lg 710S
οποτε πρεπει να βαλλω αυτα
Section "Monitor"
Identifier "lg 710S"
HorizSync 30 - 71 kHz °
VertRefresh "50 - 160 Hz°
Option "DPMS"

πρεπει να συμπληρωσω τιποτα αλλο εσυ οπως βλεπεις το αρχειο?
σευχαριστω παρα πολυ....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Ναι, αν είναι οι τιμές που προτείνει ο κατασκευαστής. Επιπλέον, αν το Section "Monitor" είναι αυτό που βλέπω τότε και στο Section "Screen", η γραμμή Monitor "Configured Monitor" θα πρέπει να γίνει Monitor "lg 710S". Το πιασες? Δηληδη , ότι υπαρχει στο Identifier από Section "Device" και Section "Monitor" θα πρέπει να είναι ίδιο, αντίστοιχα, και στις γραμμές Device "Configured Video Device" και Monitor "Default Screen" του Section "Screen". Δηλαδή κάπως έτσι

Section "Device"
Identifier "'Οτι βάλεις εδώ θα μπεί και στο Device του Section "Screen". Π.χ HD 2600 XT AGP"
Driver "Μην ξεχάσεις το όνομα driver, για αρχή vesa, και μετά fglrx"
EndSection

Section "Monitor"
Identifier "lg 710S"
....
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "lg 710S"
Device "HD 2600 XT AGP"
EndSection

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τωρα μολις κανω αυτα μετα βαζω ενβυ για τους ντριβερσ και τιποτα αλλο και κανω επανεκινηση?
η πρεπει να βαλω και τον οδηγο κλειστου λειτουργηκου?

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Ολη η εγκατάσταση του fglrx να γίνει με τον X server σε vesa! Σημαντικό

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

αυτο πως το καθοριζω στο 8,04?

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Απλό, το

Section "Device"
Identifier "HD 2600 XT AGP"
Driver "vesa"
EndSection

να φαίνεται έτσι. Κάνε reboot και μετά βουρ για εγκατάσταση fglrx! Καλή επιτυχία!!!

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

οταν λες εγκατασταση του fglrx εννοεις του ενβυ και ντριβερσ μην κανω καμια βλακεια.....χιλια ευχαριστω......

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Ναι, αμα σε βολεύει το envy(εγώ δεν το γνωρίζω πως λειτουργεί)

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

δυστηχως απτην αρχη τα σκουρα εκανα επανεκινιση και δεν μπορουσε να μπει και ετσι ξαναφτιαξε καινουργιο αρχειο αυτο

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:2:0:0"
Driver "vesa"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "LG Electronics Inc."
Modelname "LG 701S"
Horizsync 30.0-70.0
Vertrefresh 50.0-160.0

modeline "[email protected]" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "[email protected]" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "[email protected]" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "[email protected]" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "[email protected]" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "[email protected]" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "[email protected]" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "[email protected]" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "[email protected]" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1400 1050
Modes "[email protected]"..."[email protected]"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection

θα αλλαξω μονο την καρτα γραφικων και θα κανω επανεκινιση....για να δουμε....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Χμμμ.. Το υποψιαζόμουν ότι το Ubuntu κάνει τα δικά του.. Τέσπα δεν είναι άσχημο το αρχείο(αν και μερικες τιμές μου φαίνονται λίγο εξωπραγματικές), απλώς τα modeline δεν θα δουλέψουν για fglrx.. Εκτός αν το Ubuntu τα φτιάξει μόνο του...

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τα πραγματα πηγαν χειροτερα αποτι φανταζομουν γιατι μετα την επανεκινηση ειχα χαλια οθονη,σκεφτηκα για καλη μου τυχη να μπω με λαιβ σιντι και αλλαξα το εξηςVirtual 1400 1050 σε 800 600 και ως θαυματος μια χαρα μπηκα....
μα δεν εχω καταλαβει εσυ τι λειτουργηκο χρησιμοποιεις αφου δεν εχεις ουμπουντου?
σευχαριστω παρα μα παρα πολυ.....

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

περασα τουσ ντριβερσ και το αρχειο ειναι αυτο πλεον
ection "Screen"
Identifier "Default Screen"
Device "HD 2600 XT AGP"
Monitor "Configured Monitor"
SubSection "Display"
Depth 24
Virtual 800 600
Modes "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
EndSubSection
Defaultdepth 24
EndSection

Section "Device"
Identifier "HD 2600 XT AGP"
Boardname "vesa"
Busid "PCI:2:0:0"
Driver "fglrx"
Screen 0
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "LG Electronics Inc."
Modelname "LG 701S"
Horizsync 30.0-70.0
Vertrefresh 50.0-160.0
modeline "[email protected]" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "[email protected]" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "[email protected]" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "[email protected]" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "[email protected]" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "[email protected]" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "[email protected]" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "[email protected]" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "[email protected]" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "[email protected]" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "[email protected]" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "[email protected]" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "[email protected]" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "[email protected]" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "[email protected]" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "[email protected]" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "[email protected]" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "[email protected]" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "[email protected]" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

τωρα τι θα γινει στην επανεκινηση θα δειξει....

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τελικα μαυρη εικονα δεν μπαινει......
τωρα απο το αρχειο το τελευταιο βρισκεις κατι που πρεπει να αλλαχθει?
και κατι αλλο νομιζω πως περασε τους 8,3 και οχι τους τελευταιους που ειναι οι 8,4,
καμια συμβουλη....ευχαριστω....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Σε γενικές γραμμές καλό είναι. Είχα πει και πριν ότι υπάρχουν κάποιες εξωπραγματικές τιμές στα modeline όπως για παράδειγμα αυτές

modeline "[email protected]" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "[email protected]" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "[email protected]" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "[email protected]" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync

Πριν κάνεις ότιδήποτε σου πώ από εδώ και κάτω πάρε αντίγραφα ασφαλείας Δηλαδή το αρχείο xorg.conf στο /etc/X11 αντέγραψέ το κάπου αλλού. Σε ένα ασφαλές μέρος! Δεν νομίζω ότι το monitor σου μπορεί να δουλέψει σε τέτοιες αναλύσεις. Επίσης το virtual βάλτο 1024 768. Βασικά θα σου πρότεινα το Section "Monitor" να γίνει κάπως έτσι

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "LG Electronics Inc."
Modelname "LG 701S"
Horizsync 30.0-70.0
Vertrefresh 50.0-160.0
modeline "[email protected]" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "[email protected]" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "[email protected]" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "[email protected]" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "[email protected]" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "[email protected]" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "[email protected]" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "[email protected]" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "[email protected]" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "[email protected]" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
Gamma 1.0
EndSection

Επίσης το Section "Screen" κάπως έτσι

Section "Screen"
Identifier "Default Screen"
Device "HD 2600 XT AGP"
Monitor "Configured Monitor"
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "[email protected]" .. "[email protected]"
EndSubSection
Defaultdepth 24
EndSection

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Και για πες. δουλεύει τελικά? Το fglrxinfo αμα το δώσεις στην κονσόλα τι σου βγάζει?

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

καλημερα και καλο μηνα σε ολους.
λοιπον χθες στην επανεκινηση με Virtual 800 600 η μπαρα γεμισε και μετα μαυρη οθονη και νεκρο πληκτρολογιο δηλαδη δεν μπορεσα ουτε το ονομα να γραψω.
σημερα μετα τις συμβουλες σου αλλαγη Virtual 1024 768 και τις υπολοιπες επανεκινηση και εμφανιζει λεει προβλημμα και μου λεει να ξεκινισει με χαμηλη αναλυση που εφτιαξα εγω.
δηλαδη χαλια εκει που δεν παει....
μα εσυ ποιο λειτουργηκο χρησιμοποιεις?
σευχαριστω....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Σβήσε τα modelines!! Σου παραθέτω το δικό μου xorg.conf που δουλεύει για να πάρεις μια ιδέα

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,gr,it"
Option "XkbOptions" "grp:alt_shift_toggle"
Option "XkbVariant" ",extended"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "SAMTRON"
EndSection

Section "Device"
Identifier "Γενική Κάρτα Γραφικών"
Driver "fglrx"
Option "TexturedVideo" "on"
Option "XAANoOffscreenPixmaps" "on"
Option "Textured2D" "on"
Option "TexturedXrender" "on"
Option "TexturedVideoSync" "True"
Option "BackingStore" "on"
Option "UseFastTLS" "1"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Γενική Κάρτα Γραφικών"
Monitor "SAMTRON"
DefaultDepth 24
SubSection "Display"
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Μην το αντιγράψεις!!! Απλώς να πάρεις μια άποψη. Τρέχω debian, όπως ανέφερα και παραπάνω.

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τελικα διεγραψα τα modelines εκανα επανεκινηση και μου λεει πως δεν βρεθηκε καρτα γραφικων και οθονης!!!
απελπιστηκα ισως καποια στιγμη να δοκιμασω να βαλλω και εγω δεβιαν.
σευχαριστω παρα πολυ .
μαλλον ειναι αποκλειστηκο προβλημμα των ντριβερε τι να πω...καλο σου μηνα.....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Δεν νομίζω ότι φταίνε οι drivers. Κατά την ταπεινή μου γνώμη, μάλλον το Ubuntu έχει κάποιο προβληματάκι..Πάντως σε βοήθησα όσο μπορούσα. 'Οτι σου είπα τα έχω εφαρμόσει στο δικό μου και πάντα είχα επιτυχία. Πάντως έτσι μου έρχεται να κάνω εγκατάσταση το Ubuntu για να δω τι συμβαίνει.

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

Εννοειτε και με βοηθησες αν δεν ησουν εσυ δεν θα ειχα καταλαβει πολλα πραγματα.
δεν πειραζει ομως καποια στιγμη ας ελπισω πως θα βγει η κανενα update η το λινουξ να κανει κατι.
και παλι ευχαριστω....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Δε μ'αρεσει έτσι. Πρέπει να δουλέψει... Θα κάνω εγκατάσταση το Ubuntu να δω τι γίνει... Περίμενε νέα μου

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

μην σε βαζω τωρα να κανεις εγκατασταση κριμα ειναι που εχεις φτιαξει το συστημα σου να κανεις τωρα φορματ.
δεν εχω λογια να εκφρασω τις ευχαριστιες μου εισαι απτα λιγα ατομα που δινουν τοση βοηθεια....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Οπως σου υποσχέθηκα, γύρισα. fglrx+compiz σε HD2600 AGP στο ubuntu. Είσαι έτοιμος? Βασικά απο clean εγκατάσταση τι έκανα? Απλό, μόλις τελείωσε η εγκατάσταση (από το live-cd έγινε η όλη δουλειά και μπορώ να πω τάχυστα), ρύθμισα την ανάλυση από το Σύστημα-Προτιμήσεις-Ανάλυση οθόνης και έβαλα 1024x768 στα 85Hz(το δικό σου με το δικό μου μόνιτορ έχουν ίσες δυνατότητες), άνοιξα το synaptic και εγκατέστησα το fglrx-control. Το module του fglrx ήταν ήδη εγκατάσταστημένο, δηλαδή το πακέτο linux-restricted-modules-2.6.24-16-generic. Μετά πήγα στο Σύστημα-Διαχείριση συστήματος-Οδηγοί υλικού και ενεργοποίασα το fglrx. Μια επανεκκίνηση και τελείωσα. Τρέχω το avant-window-navigator, το οποίο δουλεύει μόνο άμα υπάρχει ενεργομποιημένο το compiz. Τώρα, τον κύβο δεν τον είδα ακόμη, αλλά μάλλον κάτι μου διαφεύγει.. Ιδίως το μενού ρύθμισης του compiz :sick: ... Αλλά αυτό το βρίσκεις εύκολα με λίγο ψάξιμο(όχι εγώ, γιατί βαριέμαι..). Σορρυ για την προηγούμενη ταλαιπωρία, νιώθω αρκετά ένοχος, το πάθημα θα μου γίνει μάθημα...Ζητάω χίλια συγνώμη..

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

δηλαδη αν καταλαβα καλα με αυτα που εκανες εχεις κανονικα τους ντριβερς.
1>εγκατασταση ουμπουντου
2)εγκατέστησες το fglrx-control
3)Σύστημα-Διαχείριση συστήματος-Οδηγοί υλικού και ενεργοποίασες το fglrx
δεν καταλαβα ομως το λογο που νιωθεις ενοχος αφου εσυ με βοηθησες...

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

τελικα εκανα αυτα που εγραψες αλλα παλι μαυρη εικονα χωρις να μπορω να μπω,οποτε εγω κανω κατι λαθος.....
θα εγκαταλειψω την ιδεα του ουμπουντου....
σευχαριστω....

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

μηπως παιζει καμια ασυμβατοτητα του συστηματος μου αραγε?
athlon 2800+
asus a7n8x-x me nvidia chip
hd 2600 xt agp

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

Παράθεση από veneton:

1>εγκατασταση ουμπουντου
2)εγκατέστησες το fglrx-control
3)Σύστημα-Διαχείριση συστήματος-Οδηγοί υλικού και ενεργοποίασες το fglrx

Ακριβώς. Τo πακέτο linux-restricted-modules ήταν σε σένα εγκατεστημένο? Σε μένα ήταν από την αρχή χωρίς να το εγκαταστήσω. Εμένα πάντως μου έκανε έκπλήξη ότι ενώ έτρεχα το livecd, χωρίς να έχω κάνει εγκατάσταση, στα log παρατήρησα ότι μου είχε αναγνωρίσει την κάρτα!!

Παράθεση από veneton:

μηπως παιζει καμια ασυμβατοτητα του συστηματος μου αραγε?

Τι να πω.. Σηκώνω τα χερια

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

telika ekana egkatastash apthn arxh akolouthontas ta bhmata sou alla mataia afou i othoni kai pali meta thn mpara fortosis einai mauri.to xorg.conf pou dimioutgithike einai>
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

den ksero ti na po....

Εικόνα: mitsaras77
mitsaras77
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 1735

:( :( :( :(

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

ναι ηταν εγκατεστημενο το linux-restricted-modules !!!
ναι την καρτα μαλλον την εχει αναγνωριση αφου απο εκει περασε τους ντριβερσ....
και εβαλλε και το καταλιστ...
μαλλον που ο δικος μου υπολογιστης δεν θελει....
ΣΕΥΧΑΡΙΣΤΩ δεν ξερω τι αλλο να σου πω γιαυτα που εκανες για να το λειτουργησουμε.....

Εικόνα: veneton
veneton
Απουσιάζω!
Registered User
Μέλος από: 14 Απρ 2008
Πόντοι: 5

Καραρχην ενα μεγαλο ΕΥΧΑΡΙΣΤΩ στο ΜΙΤΣΑΡΑΣ77 *λογικα Δημητρης* για τις πολυτιμες συμβουλες του...
τελικα δουλευει μια χαρα η καρτα στα λινουξ> fglrxinfo
display: :0.0 screen: 0
OpenGL endor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL version string: 2.1.7415 Release

[email protected]:~$ glxinfo | grep "direct rendering"
direct rendering: Yes
η επιλυση οσο και αν φαινεται παραλογη ηρθε απτο βιος του κομπιουτερ!στην καρτα γραφικων επρεπε να διαλεξω
vga και ΟΧΙ AGP!!!!