Τονισμός σε κειμενογράφους για LaTeX

10 posts / 0 new
Τελευταία καταχώριση
Εικόνα: geotsalakos
geotsalakos
Απουσιάζω!
Registered User
Μέλος από: 26 Νοε 2009
Πόντοι: 20
Τονισμός σε κειμενογράφους για LaTeX

Φίλοι μου γεια σας.

Κατ' αρχήν θα ήθελα να σας ευχαριστήσω γιατί μέσα από το Forum βρήκα λύσεις σε διάφορα προβλήματα που είχα (λόγω απειρίας) με το Ubuntu.

Επίσης να ζητήσω συγνώμη γιατί ίσως αναφέρω πιο πολλές πληροφορίες απ' ότι χρειάζεται για να εξηγήσω το πρόβλημα που αντιμετωπίζω. Είναι, όμως, το πρώτο μου στο Forum (και γενικά σε οποιοδήποτε Forum)

Είμαι καθηγητής φυσικήςστη Μέση Εκπαίδευση στην Κύπρο  και για την προετοιμασία φύλλων εργασίας, σχημάτων διαγωνισμάτων και άλλων φυλλαδίων χρησιμοποιώ αποκλειστικά το LaTex. Στον υπολογιστή μου (IBM Thinkpad A31)  έχω σε dual boot WindowsXP Professional και Ubuntu 9.04. Στα Windows δουλεύω με το MikTeX και το TexnicCentet ή το Texmaker και το TeXworks (για xetex). Στο Ubuntu είχα εγκαταστήσεις το texlive και για LaTeX editor χρησιμοποιούσα το Kile ή το Texmaker ή το Texworks χωρίς πρόβλημα.

Μετά την κυκλοφορία του Ubuntu 9.10 προσπάθησα να κάνω αναβάθμιση από 9.04 σε 9.10 χωρίς επιτυχία αφού μετά την αναβάθμιση όταν προσπαθούσα να άνοίξω κάποια εφαρμογή ο υπολογιστής πάγωνε και δεν γινόταν τίποτα (αυτό όμως είναι άλλο θέμα).

Επανεγκατέστησα το 9.04 από το DVD του περιοδικού και εγκατέστησα τα πακέτα του texlive (texlive, texlive-xetex, texlive-lang-greek) και τους editors Kile, Texmaker και Lyx.

Το πρόβλημα που έχω είναι ότι σ' αυτούς τους κειμενογράφους όταν γράφω ελληνικά δεν εμφανίζονται καθόλου τόνοι. Σε άλλους κειμενογράφους (abiword, gedit, openoffice write) οι τόνοι εμφανίζονται κανονικά.

Έψαξα στα διάφορα fora αλλά δεν βρήκα κάτι που να επιλύει το πρόβλημα.

Υπάρχει κάποια ιδέα για την επίλυση του προβλήματος; Δεν θέλω να μείνω στα Windows.

__________________

Γιώργος Τσαλακός

Εικόνα: Constantinos
Constantinos
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 4560

Δεν εχω ασχοληθει & ιδιατερα με το Latex, παρ' ολ' αυτα, πριν καμια 10αρια μερες στη δουλεια, αντιμετωπισανε ενα ιδιο με σενα προβλημα.

Οπως σου ειπα δεν ειναι το αντικειμενο μου, ωστε να ενημερωθω το γιατι ακριβως, μου ειπαν ομως οτι βρηκαν τη λυση, στις τελευταιες σελιδες του Help pdf, του Latex

Π.Σ.Π.Α

 

 

Εικόνα: Qbric
Qbric
Απουσιάζω!
Registered User
Μέλος από: 8 Οκτ 2008
Πόντοι: 405

 Καλημερα, τι εννοεις δεν εμφανιζονται οι τόνοι? Στον κειμενογράφο (editor) ή στο pdf? 

Γραψε ποιο πακετο χρησιμοποιεις για τα ελληνικα (greektex, babel κλτ)

Επίσης οταν γραφεις τη λεξη τονούμενη εμφανιζεται αυτο ---> (τονισμ'ος και οχι τονισμός)

 

Εικόνα: geotsalakos
geotsalakos
Απουσιάζω!
Registered User
Μέλος από: 26 Νοε 2009
Πόντοι: 20

Καλήμερα. Ευχαριστώ για την ανταπόκριση. Το πρόβλημα δεν είναι με το LaTeX αλλά με τον κειμενογράφο. Δεν εμφανίζονται καθόλου τόνοι όταν γράφω ελληνικά στους κειμενογράφους για LaTeX (Kile, Texmaker, Lyx, Texworks).  Γράφοντας τον κώδικα tex σε άλλο κεμενογράφο (π.χ. gedit (στον οποίο οι τόνοι εμφανίζονται κανονικά)) και επικολλώντας τον στο Kile οι τόνοι υπάρχουν. Το πρόβλημα είναι ότι δεν μπορώ να βάλω τόνους όταν γράφω στους κειμενογράφους για LaTex.

Γιώργος Τσαλακός

__________________

Γιώργος Τσαλακός

Εικόνα: Qbric
Qbric
Απουσιάζω!
Registered User
Μέλος από: 8 Οκτ 2008
Πόντοι: 405

Πραγματικα δεν μπορω να σκεφτω κατι για το οποιο φταιει, εκτος αν εχεις πειραξει καμια επιλογη για πληκτρολογιο-γλωσσα, αλλα αφου λες οτι στο gedit δουλευει...

Εγω θα ξαναεγκαταστουσα τους κειμενογραφους αλλα πριν το κανεις αυτο υπαρχει και αλλος τροπος λιγο πλαγιος βεβαια.

Στο  texmaker υπαρχει η επιλογη για ορθογραφικο ελεγχο και στα ελληνικα. Αν μια λεξη δεν ειναι τονισμενη την διορθωνει. Δεν ξερω κατα ποσο σε βολευει αυτο.

Εικόνα: Qbric
Qbric
Απουσιάζω!
Registered User
Μέλος από: 8 Οκτ 2008
Πόντοι: 405

Καλησπερα και παλι. Για το προβλημα θα ηθελα να μου δωσεις την εξης διευκρινιση:

Η λεξη που θελεις να τονισεις (εστω η λεξη τονισμος) εμφανιζεται ετσι " τονισμος" ή "τονισμ'ος"?

Γιατι για το πρωτο πραγματικα δε ξερω πρωτη φορα το βλεπω, για το δευτερο μου συμβαινει και μενα (και σε πολλους αλλους απο οτι ξερω) και υπαρχουν τρεις λυσεις:

1)Απλα κανεις ιρθογραφικο ελεγχο μετα απο καθε συγγραφη κειμενου και ησυχαζεις.

2)Αν ελαχιστοποιησεις το παραθυρο του editor ή περιμενεις 2-3 λεπτα το προβλημα φτιαχνει (μη με ρωτατε πως και γιατι δεν ξερω)

3)Αυτο τον τροπο δεν τον εχω δοκιμασει. Αφου κανεις backup το αρχειο el_GR που βρισκεται στο φακελο ~./xinput.d να το σβησεις. Το επαναλαμβανω δεν το εχω δοκιμασει να δω τι συμβαινει.

 

Εχεις δοκιμασει το Geany, αλλος ενας πολυ καλος editor, απλως χωρις συντομευσεις.

Εικόνα: geotsalakos
geotsalakos
Απουσιάζω!
Registered User
Μέλος από: 26 Νοε 2009
Πόντοι: 20

Καλησπέρα. Η λέξη «τονισμός» εμφανίζεται σαν «τονισμος». Είναι όντως πολύ περίεργο γιατί πριν την προσπάθεια αναβάθμισης σε 9.10 δεν είχα τέτοιο πρόβλημα. Πάντως θα δοκιμάσω την τρίτη λύση που προτείνεις. Το Geany δεν το ξέρω, είναι LaTeX editor?

Γιώργος Τσαλακός

__________________

Γιώργος Τσαλακός

Εικόνα: Qbric
Qbric
Απουσιάζω!
Registered User
Μέλος από: 8 Οκτ 2008
Πόντοι: 405

Ναι αλλα οχι μονο. Δοκιμασε πρωτα ομως τον ορθογραφικο ελεγχο να δεις αν δουλευει.

Εικόνα: dimitris
dimitris (not verified)

Λοιπόν, αυτό το πρόβλημα μου θυμίζει ένα που είχα αντιμετωπίσει παλιότερα με το Lyx, όπου δεν έμπαιναν τόνοι. Αν θυμάμαι καλά, το πρόβλημα ήταν στις βιβλιοθήκες του ...Qt (όπου βασίζεται το Lyx).

Δεν θυμαμαι όμως τι είχα κάνει...ούτε μπορώ να βρω αναφορές στο gg. :(

 

Εικόνα: geotsalakos
geotsalakos
Απουσιάζω!
Registered User
Μέλος από: 26 Νοε 2009
Πόντοι: 20

Φίλοι μου γεια σας. Στο διάστημα που μεσολάβησε από το τελευταίο μου μήνυμα δοκίμασα διάφορα για να λύσω το πρόβλημα χωρίς αποτέλεσμα. Τελικά το πρόβλημα με τον τονισμό σε κειμενογράφους LaTeX λύθηκε με την επανεγκατάσταση του Ubuntu 8.10. Κατέβασα το iso της διανομής από το διαδίκτυο και έκανα την εγκατάσταση. Μετά εγκατέστησα το TeXLive 2009 και το TeXWorks. Τώρα στο TeXWorks οι τόνοι εμφανίζονται κανονικά. 

Στην προηγούμενη εγκατάσταση του Ubuntu είχα δηλώσει για τον καθορισμό της ζώνης ώρας τη Λευκωσία (Ασία/Λευκωσία), ενώ στην εγκατάσταση που έχω τώρα δήλωσα Ευρώπη/Αθήνα. Δεν ξέρω αν αυτό επηρεάζει τα πακέτα του Smart Common Input Method (SCIM) που εγκαθίστανται και τις ρυθμίσεις τους.

Ευχαριστώ παιδιά για το ενδιαφέρον.

Γιώργος Τσαλακός

__________________

Γιώργος Τσαλακός