Ελληνικοί υπότιτλοι στο Ubuntu

27 posts / 0 new
Τελευταία καταχώριση
Εικόνα: Anonymous
Anonymous
Ελληνικοί υπότιτλοι στο Ubuntu

καλησπέρα!

έχω κάποιες ταινίες μαζί με τα .srt τους [υπότιτλοι]
το πρόβλημα είναι ότι οι υπότιτλοι αυτοί είναι σε ακαταλαβίστικη μορφή
[αλαμπουρνέζικα] όχι μονο όταν βλέπω το dvd αλλα και μέσα στο αρχείο .srt!

απλά να αναφέρω πως μπορώ να γράφω ελληνικά στα [ενα δυο? :P]
άρα τι πρόβλημα μπορεί να παίζει? Και ποια είναι η λύση του?

Εικόνα: Anonymous
dimitris (not verified)

Το πρόβλημα με τους υπότιτλους είναι ότι τα αρχεία srt είναι συνήθως encoded σε IS08859-7 ενώ εσύ (κι εμείς) έχουμε διανομές Linux με UTF8. Αρα για να δεις τους Ελληνικούς υπότιτλους θα πρέπει να το πεις στο player σου ότι το srt είναι ISO8859-7.

Στο VLC, απλά ανοίγεις με File > Open το AVI και από κάτω κάνεις κλικ στο "Use a Subtitles File". Δίπλα του υπάρχει ένα κουμπάκι "Αdvanced Settings". Κάνεις κλικ σε αυτό, αλλάζεις το encoding σε UTF8 (ή ISO-8859-7, ανάλογα με τους υπότιτλους!), πατάς ΟΚ και όταν επιστρέψεις στον προηγούμενο διάλογο κάνεις κλικ στο Browse για να επιλέξεις το .srt. Μετά OK και βλέπετε την ταινία...

Στο Mplayer πρέπει να προσθέσεις τη γραμμή:
subfont-encoding=iso-8859-7

στο αρχείο ρυθμίσεων του mplayer, το ~/.mplayer/config.

Δες και το FAQ.

Εικόνα: Anonymous
n1k0z (not verified)

οκ το προβλημα το ελυσα με την εντολη
iconv -fiso-8859-7 -tutf8 5.srt >7.srt :)
[δεν δουλευε το trick με τα advanced options tou player]
ευχαριστω πολυ παντως!

[τωρα για τα greeklish, το θεωρεις αγένεια να γραφει καποιος ετσι?
δλδ το θεμα ειναι να καταλαβαινομαστε, το μεσο δεν εχει τοση σημασια..
ισως ειναι θεμα ηλικιας -δε ξερω τι ηλικια εχεις-, ισως εξοικιωσης -εννοω οτι ποσο εισαι εξοικιωμενος beyond the user level- ισως και οικοιοτητας με τα αγγλικα -δε ξερω τι οικιοτητα εχεις.]

thanx a lot tho!:)


n1k0z2007-6-28 12:50:45

Εικόνα: katsaplias
katsaplias
Απουσιάζω!
Registered User
Μέλος από: 1 Ιαν 1970
Πόντοι: 5

"Στο VLC  π.χ. απλά 
ανοίγω με File > Open το AVI και από κάτω κάνω κλικ
στο "Use a Subtitles File" και δίπλα του υπάρχει ένα
κουμπάκι "Αdvanced Settings". Κάνω κλικ σε αυτό, αλλάζω 
το encoding σε UTF8, πατάω ΟΚ και στον προηγούμενο 
διάλογο κάνω κλικ στο Browse για να επιλέξω το .srt. 
Μετά OK και βλέπω την ταινία...:)"

Στον VLC λειτουργεί μια χαρά αυτό που έγραψε ο φίλος dimitris απλα στο encoding πρέπει να βάλεις IS08859-7 και όχι UTF8.To δοκίμασα και εγω και αρχικά δεν λειτουργούσε αλλά όταν το άλλαξα στο encoding που είναι το αρχείο των υπότιτλων έπαιξε μια χαρά σε όσες ταινίες δοκίμασα.

Εικόνα: maggnetis
maggnetis
Απουσιάζω!
Registered User
Μέλος από: 1 Ιαν 1970
Πόντοι: 0

Να προτείνω και εγώ μια λύση για να φαίνονται οι λέξεις στο srt αρχείο;;;
Με δεξί κλικ επιλέγεις να το ανοίξεις με Openoffice και θα σου προτείνει να επιλέξεις την κωδικοποίηση για να το ανοίξει. Συνήθως το επιλέγει αυτόματα σωστά...Θα φαίνονται τα γράμματα...Αν θες να το τραβήξεις παραπέρα κανεις save as και επιλέγεις text document. Τώρα θα τα βλέπεις όλα κανονικά με έναν απλό κειμενογράφο

__________________

Just be Open-source

[link=Foss Uoa]http://foss.di.uoa.gr[link]

[link=Foss Uoa forum]http://foss.di.uoa.gr/forum[link]

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

συγνώμη βρε παιδιά...
εγώ δεν μπορώ να το καταλάβω , μάλλον είμαι μπουμπούνας...
κατέβηκαν δύο αρχεία
το ένα είναι το avi και το άλλο είναι το srt.
πως γίνεται και τα βάζουμε αυτά τα δύο μαζι , και μάλιστα να παίζει το ένα μέσα στο άλλο...?
και κάτι ακόμα το srt αρχείο είναι ακαταλαβίστικα , αλλά μάλλον αυτό είναι η κωδικοποίηση που διάβασα πιο πάνω..
πείτε και σε μένα βρε παιδιά , γιατί κατέβασα ένα εργάκι και θα ήθελα να το δω , αλλά....
έχω στην διαθεσή μου τον vlc και τον kaffeine player , αλλά αν χρειαστεί και άλλος πείτε μου....

Εικόνα: rpil
rpil
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 4485

Άνοιξε το VLC.
Θα βρεις κάποιες επιλογές. Πήγαινε File --> Open File.
Θα σου ανοίξει νέο παράθυρο όπου θα πας στο Browse του Open. Με διπλό κλικ άνοιξε το αρχείο της ταινίας (.avi)
Μετά κατέβα σημάδεψε το Use a subtitles file και άνοιξε το Advanced Settings: Επέλεξε το ISO-8859-7 Greek από το Enconding.
Πήγαινε στο κάτω Browse του File και επέλεξε το αρχείο με τους υπότιτλους (.srt).
Πάτησε το play στο VLC και είσαι έτοιμος!

------------------------------------------------------------------------------------------------

"Όταν βλέπεις τον πιγκουίνο, ξέρεις τι πρέπει να κάνεις": ΒΑΖΕΙΣ LINUX!

__________________

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

vlc

επιλεγεις open file

με browse, το αρχειο avi

απο κατω υπαρχει επιλοφη για υποτιτλους.
προσθετεις τους υποτιτλους και απο το advanse επιλεγεις κωδικοποιηση iso 8859-7.

καλη διασκεδαση :)

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

καλα. μαζι τα γραφαμε.

ο πρωτος κερδιζει παντα.

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

σας ευχαριστώ πολύ βρε παιδιά....
το μόνο πρόβλημα είναι ότι οι υπότιτλοι εξακολουθούν να είναι ακαταλαβίστικα...
έπαιξα λίγο με αυτά τα iso έβαλα όλη την γκάμα από το 1 μέχρι το 16 , δοκίμασα όλες τις γλώσσες αλλά τίποτα μάλλον φταίει το
srt αρχείο...
το δοκίμασα σε δύο ταινίες...θα το δοκιμάσω και σε καμιά άλλη διανομή μήπως και φταίει αυτό και θα δούμε...

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

για ανοιξε το srt με open office (η επεξεργαστη κειμενου) επιλεγοντας κωδικοποιηση iso 8859-7

λογικα πρεπει να ειναι ελληνικα.

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

ναι , αυτο το μετατρέπει σε ελληνικά , τι κάνω τώρα..???

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

κατι κανεις λαθος λοιπον στο vlc.

(εστω ομως: δοκιμασε με το oo να το σωσεις σαν text iso 8859-7 και μετα αλλαξε την καταληξη σε srt. νομιζω πιανει
-παντως κατι δεν κανεις καλα στο vlc).

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

θα το ψάξω αύριο , φίλε alfisti σε ευχαριστώ...

υποχρεώσεις με καλούν .....

Εικόνα: Anonymous
dimitris (not verified)

Παράθεση από g.b:

συγνώμη βρε παιδιά...
εγώ δεν μπορώ να το καταλάβω , μάλλον είμαι μπουμπούνας...
κατέβηκαν δύο αρχεία
το ένα είναι το avi και το άλλο είναι το srt.
πως γίνεται και τα βάζουμε αυτά τα δύο μαζι , και μάλιστα να παίζει το ένα μέσα στο άλλο...?
και κάτι ακόμα το srt αρχείο είναι ακαταλαβίστικα , αλλά μάλλον αυτό είναι η κωδικοποίηση που διάβασα πιο πάνω..
πείτε και σε μένα βρε παιδιά , γιατί κατέβασα ένα εργάκι και θα ήθελα να το δω , αλλά....
έχω στην διαθεσή μου τον vlc και τον kaffeine player , αλλά αν χρειαστεί και άλλος πείτε μου....

Για τα ερωτήματά σου, υπάρχει μια εξήγηση στο FAQ (και οδηγίες για ελληνικά αρχεία υποτίτλων .srt στο τέλος):


">Πως βάζω ελληνικούς υπότιτλους στο MPlayer (ή το VLC)

--Stat rosa pristina nomine, nomina nuda tenemus

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

καλησπέρα...
και είδικά στον alfisti γιατί πριν από δύο βράδια προσπαθούσε να μου δείξει πως δουλεύουν οι υπότιτλοι στον vlc player
αυτός μου έλεγε εγώ έκανα...
αυτός το έλεγε σωστά εγώ δεν μπορούσα..
σταμάτησα με την εντύπωση ότι ή εγώ είμαι γκαου μπιου ή το pc μου τα έπαιξε...
τελικά τίποτα από όλα αυτά δεν ίσχυαν...
το μόνο πράγμα που έφταιγε ήταν ότι ΕΓΩ προσπαθούσα να το κάνω με mandriva....
(τι με έπιασε και μένα...)
μόλις μπήκα πάλι στο πρώτο μου το βαρκάκι νάτο , ούτε κυματάκια , ούτε ακαταλαβίστικοι υπότιτλοι , ούτε τίποτα..
κάτι για μια ψηφοφορία για το ποια διανομή θεωρείται καλύτερη αν θυμάμαι καλά.....
ε , φιλαράκια , για μένα το θέμα είναι πλέον απλό ubuntu και τέλος....

Εικόνα: luckyb
luckyb
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 2510

Για την τιμή των όπλων και ως γνήσιος υποστηρικτής του Kaffeine και ορκισμένος εχθρός του Ubuntu και του Gnome ( }:) ) έφτιαξα μερικά απλά βηματάκια για να βλέπουμε Ελληνικούς υπότιτλους σε Xine:
http://www.linuxinsider.gr/?q=forum/%CE%B5%CE%BB%CE%BB%CE%B7%CE%BD%CE%B9%CE%BA%CE%BF%CE%AF-%CF%85%CF%80%CF%8C%CF%84%CE%B9%CF%84%CE%BB%CE%BF%CE%B9-%CF%83%CF%84%CE%BF-xine-kaffeine

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

sorry, αλλά μην μπλέξουμε τα πράγματα.
ο vlc (ή kaffeine) δουλεύουν το ίδιο οπουδήποτε.

το να λέω λοιπόν γιά vlc καί κάποιος να το κάνει σε kaffeine, να το δεχτώ σαν λάθος συνενόηση.
το να λέω γιά vlc από ubuntu καί κάποιος να το κάνει σε mandriva... ε καί?

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

όχι βρε alfisti ,

δεν κατάλαβες το σκηνικό , χιούμορ έκανα ....

όταν κάτι δεν δουλεύει , δεν λέμε ότι φταίνε όλα τα άλλα εκτός από εμάς....

ε, 'ετσι και εγώ....

προφανώς κάποια πατατιά έκανα με το vlc και δεν μπορούσα να το βάλω να δουλέψει...

3 καφέδες και 2 τοστ μετά τα κατάφερα...

Εικόνα: luckyb
luckyb
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 2510

Καταρχήν οφείλω να ζητήσω μια συγγνώμη από όλους για το κακόγουστο σχόλιο περί Ubuntu και Gnome.
Ήταν μια άκαρπη προσπάθεια για χιούμορ (μου συμβαίνει συχνά τελευταία, πρέπει να το κοιτάξω !!)
(δεν μου την είπε κανένας, απλά το ξαναδιάβασα και δεν μ' άρεσε)

VLC για να πω την αλήθεια δεν έχω χρησιμοποιήσει ποτέ (απλά το δοκίμασα).
κόλλησα με το kaffeine λόγω gui (ο καθένας με τα γούστα του :-))

Το παράδοξο εδώ είναι ότι ενώ και τα δυο χρησιμοποιούν μηχανή xine και φαίνεται ότι στο vlc αρκεί μια απλή επιλογή του encoding σε Ελληνικό iso, στο Kaffeine αυτό δεν δουλεύει(σ' εμένα τουλάχιστον). Ήθελε και εγκατάσταση πρόσθετων γραμματοσειρών. Τι να πω ??

Εικόνα: alfisti
alfisti
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 5260

Στην αρχη σκεφτηκα να απαντησω με κατι για gnome (με χαμογελο παντα -σε αυτο το φορουμ, ετσι,?), αλλα το απεφυγα.
Παντως τωρα μια και το ανεφερες μονος σου, ε ναι ηταν απλα ατοπο.

Εκανα απλη διευκρινηση ετσι?
Οτι τουλαχιστον τα συγκεκριμενα προγραμματα σηκωνουν τις ιδιες ρυθμισεις ασχετα απο διανομη.

Παντως η ευκολια και το οτι παιζει τα παντα ειναι αυτο που με βολεψε στο vlc.

====

the hamster's is out there

http://hamster.tuxhost.gr/

__________________

====

http://alfistigr-photo.blogspot.com/

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

καλησπέρα...

εγκατέστησα το ubuntu και όπως πάντα δυο τρία πράγματα είναι στάνταρ διαδικασία

το firestarter είναι ένα από αυτά και το άλλο είναι το vlc player...και εδώ είναι το ερώτημα:

άλλαξε κάτι στο vlc? γιατί όσο και να προσπάθησα δεν μπόρεσα να βρω την διαδικασία

open file

use subtitle file

και τέλος παίξιμο του αρχείου...

τώρα ή εγώ δεν κατάλαβα τι έγινε ή κάτι παίχτηκε και το χάσαμε....

αν ξέρει κανείς πως ανοίγουμε πλέον αρχεία με τον vlc και το κυριότερο πως βάζουμε υπότιτλους

(ξαναλέω μέχρι τώρα μπορούσα, αλλά μάλλον κάτι άλλαξε)

Εικόνα: g.b
g.b
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Απρ 2008
Πόντοι: 2130

καμιά ιδέα κανένας?

Εικόνα: marlene
marlene
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 4645

Έλα...Που κολλάς;

Κάνε δεξί κλικ στο είδος αρχείου που θες να σου ανοίγει ο vlc και πήγαινε εκεί που λέει open with. Εκεί βάλε του σαν επιλογή να ανοίγει με τον vlc.
( όταν λέω στο είδος αρχείου εννοώ ότι θα διαλέξεις ποια είδη αρχείων θέλεις να σου ανοίγει ο vlc. avi wmv κτλ. Θα κάνεις την επιλογή σε ένα και αυτός θα το πάρει ως default για όλα του ιδίου είδους.)

Τους υπότιτλους τώρα: Το αρχείο των υπότιτλων πρέπει να έχει το ίδιο όνομα με το αρχείο που θες να δεις.
Δηλαδή αν η ταινία σου είναι mitsos.avi οι υπότιτλοι θα είναι mitsos.str. το extension θα είναι διαφορετικό.
Μετά θα πας στο settings/preferences/video/subtitleOSD και εκεί που λέει use subtitle file θα πατήσεις browse και θα του δώσεις το αρχείο με τους υπότιτλους που αντιστοιχούν στην ταινία που θέλεις να δεις.
Θα ξεκινήσεις την ταινία και αυτός θα αρχίσει να τους τρέχει κανονικά. Από τις υπόλοιπες ρυθμίσεις των υποτίτλων επιλέγεις το μέγεθος και το είδος των γραμμάτων που θες να φαίνονται οι υπότιτλοι σου.

Μην ξεχάσεις φυσικά στο τέλος να σώσεις τις ρυθμίσεις σου.

Αν κάνεις αλλαγές εν τω μέσω της ταινίας πρέπει να την ξεκινήσεις από την αρχή για να πάρει τις αλλαγές.

Εικόνα: Anonymous
sakis (not verified)

ναι αλλα δεν εχει πουθενα να αλλαξεις τη κωδικοποιηση σε ελληνικους χαρακτηρες....

Εικόνα: Azzurro
Azzurro
Απουσιάζω!
Registered User
Μέλος από: 21 Ιαν 2008
Πόντοι: 35

Παιδιά για μένα πιο εύκολο είναι με τον totem (σε gnome πάντα): από το Edit>Preferences και στο επόμενο παράθυρο αλλάζω το Encoding σε Greek (ISO-8859-7). Επίλέγω και το κουτάκι "Automatically load subtitle files when movie is loaded" και είμαστε έτοιμοι. Τώρα αρκεί ο υπότιτλος και το αρχείο avi να έχουν το ίδιο όνομα και με το άνοιγμα του avi φορτώνεται αυτομάτως και ο υπότιτλος.

Εικόνα: thanos
thanos
Απουσιάζω!
Registered UserΣυχνός σχολιαστήςModeratorEditor-Blogger
Μέλος από: 1 Ιαν 1970
Πόντοι: 3050

Παράθεση από sakis:

ναι αλλα δεν εχει πουθενα να αλλαξεις τη κωδικοποιηση σε ελληνικους χαρακτηρες....

Για τον vlc από το Tools>Προτιμήσεις στην κατηγορία subtitles&OSD βάλε τα εξής:

--------------------
happy_linux_downloads